Форум: X Window & GUI
Тема: widescreen 1680x1050
Автор: mcwolf

Мнение от mcwolf пуснато на Февруари 19 2008, 10:57
тормози ме един много дразнещ проблем - борбата е да се накара системата да се стартира в 1680x1050

на теория всичко е ток GDM/KDM зареждат коректно с желаната резолюция но при стартиране на графичната среда (kde3/4/gnome) резолюцията пада на 1280x1024 и се налага да се променя ръчно (след което няма никакви проблеми)

ето и лог файлът при стартиран < http://sg-fitness.com/~mcwolf/Xorg.0.log >
това е при стартирана < http://sg-fitness.com/~mcwolf/Xorg.0.log.1 >
а това след < http://sg-fitness.com/~mcwolf/Xorg.0.log.2 > на резолюцията

ето и < http://sg-fitness.com/~mcwolf/xorg.conf >

просто нямам време да го боря това затова разчитам на помощ  :P
Мнение от tolostoi пуснато на Февруари 19 2008, 11:17
Ако разкараш другите резолюции какво става?
Пробва ли да стартираш
Код: 
sudo nvidia-settings
от там да я зададеш и после save to xconfiguration file.

Сещам се и за друг вариант, но той работеше за рифреш рейта, има една опция която се грижи x-a да не прецака монитора, забелязъл съм, че се прави на много умна и само след като я спра, става това което искам. В Section "Monitor" се добавя
Код: 
Option "DDC" "false"

Мисля си, че при теб инструмента на нвидиа ще сработи.
Мнение от mcwolf пуснато на Февруари 19 2008, 11:23
nvidia-settings, dpkg-reconfigure -phigh xserver-xorg, dpkg-reconfigure xserver-xorg, разкарване на всички резолюции - ефектът е същия (при разкарана честота от 1680x1050 обаче нямам възможност ръчно да я задам)
последната опция на която попаднах е NoDFPNativeResolutionCheck от форумите на nvidia но за съжаление няма ефект

спирането на DDC-то не съм го тествал - ма това ще стане най рано довечера че това ми е личната машина - ако имате и други идеи ги давайте че вечер нямам никакво време да ровя из нетът и да търся решение
Мнение от Drakula пуснато на Февруари 19 2008, 21:47
Като заобикаляне на проблема бих ти предложил да разкараш всички ненужни разделитени способности (ръчно от xorg.conf) описани в секцията "Screen". Така ще-не ще X трябва да се стартира в посочената разделителна способност.

Аз така си реших проблем с честотата на опресняване...


Мнение от gosheto пуснато на Февруари 19 2008, 22:43
Аз пък на работния комютър имам обратния проблем. В xorg.conf съм махнал всички ненужни разделителни способности и съм оставил само 1024x768 и само един depth. Но всеки път кде-то ми се стартира на максималната разделителна способност (1450x1050). Проблема го заобиколих по следния начин - десен бутон Configure Desktop, от менюто disply си избирам желаната резделителна способност и слагам отметка на "Apply setting on kde startup"  :33;
Мнение от mcwolf пуснато на Февруари 20 2008, 09:42
gosheto горе долу и аз така съм решил проблемът но ме дразни така

Drakula тествал съм го това - логин мениджърите работят на правилната резолюция а графичната среда я променя (независимо коя - тествал съм с kde3/gnome и kde4 - ползвам него)

Option "DDC" "false" не помогна


-------
следващият опит е да променя точките на инч които поддържа мониторът - до сега работеше на 87x83 - а новата "резолюция" сега е 139x115 - довечера ще докладвам имало ли е ефект


Мнение от cdiem пуснато на Февруари 20 2008, 10:15
Тук < http://www.linuxsolutions.co.nz/sager9860wiki/index.php/X.org_setup > добавят някакъв ред ModeLine и опция dpms в xorg, за да изкарат 1680х1050. Не знам дали ще помогне. Тук < http://georgi.unixsol.org/diary/archive.php/2006-01-18 > опитват същото, не знам кой ред на modeline е правилният. Успех!
Мнение от mcwolf пуснато на Февруари 20 2008, 10:57
modeline-а влияе на честотата на мониторът и не би трябвало да има отношение към резолюцията (по скоро е обратното - честотата зависи от резолюцията)

ползваните < http://georgi.unixsol.org/diary/archive.php/2006-01-18 > стойности са за честоти съответно 59.62Hz(тая ме съмнява нещо), 60Hz, 75Hz, 85Hz, 100Hz

макар че и това ще пробвам де
Мнение от cdiem пуснато на Февруари 20 2008, 11:18
В < http://gentoo-wiki.com/HOWTO_Widescreen_Resolutions_(WSXGA) > съветват да се внимава с modeline, защото неправилно modeline можело да повреди монитора; трябвало да се използва EDID (или да се добави ignoreedid за modeline):
Цитат: 

Section "Device"
       Identifier  "Videocard0"
       Driver      "nvidia"
       VendorName  "NVIDIA"
       BoardName   "NVIDIA GeForce Go 6800"
       Option      "IgnoreEDID" "True"
EndSection

Друго, ако modeline не помогне, опитай с:
Цитат: 

Section "Device"
       Option "ModeValidation" "NoMaxPClkCheck"
       Identifier     "Card0"
...



Мнение от tolostoi пуснато на Февруари 20 2008, 12:05
За modeline генератор, аз съм ползвал този < http://xtiming.sourceforge.net/cgi-bin/xtiming.pl > иначе гугъл има повече предложения < http://www.google.com/search?hl=bg&amp;ie=UTF-8&amp;oe=UTF-8&amp;q=modeline+generator >
Мнение от mcwolf пуснато на Февруари 20 2008, 12:30
Код: 
mcwolf@mcwolf:~$ gtf 1680 1050 75

 # 1680x1050 @ 75.00 Hz (GTF) hsync: 82.20 kHz; pclk: 188.07 MHz
 Modeline "1680x1050_75.00"  188.07  1680 1800 1984 2288  1050 1051 1054 1096  -HSync +Vsync

зарежете честотата - тя не е проблем борбата е да накараме пущината да задържи 1680x1050 при зареждане на графичната среда без допълнителни шпагати
Мнение от mcwolf пуснато на Февруари 21 2008, 09:15
всичко предложено до тук не върши работа :29;
са се сещам - има ли значение това че ползвам цифровият вход а не аналоговоя ?


Мнение от tolostoi пуснато на Февруари 21 2008, 13:43
Може да пробваш, ма все ми се струва, че чакане му е майката, тоя новият X.Org X Server 1.4 си има собствено мнение за всичко, аз в една друга тема ти бях писал, че почти целият xorg.conf да разкараш, пак си бачка и секцията composite не му трябва, каква е картата, няма ли да тръгне с не-легаси драйвера? Може там да са по-напред нещата.
A сега намерих темата, ето го xorg-a с който всичко си работеше без грижи. Дори Option редовете в Section "InputDevice" после ги разкарах и пак всичко си беше ОК. Явно проблема идва като не сме на едно и също мение с него :), предполагам има някоя опция която може да го принуди да ползва това което искаш, но не съм я засичал :(
Код: 
# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
  Identifier   "Generic Keyboard"
  Driver      "kbd"
  Option      "XkbRules"   "xorg"
  Option      "XkbModel"   "pc105"
  Option      "XkbLayout"   "us"
EndSection

Section "InputDevice"
  Identifier   "Configured Mouse"
  Driver      "mouse"
  Option      "Emulate3Buttons"   "true"
EndSection

Section "Device"
  Identifier   "Configured Video Device"
EndSection

Section "Monitor"
  Identifier   "Configured Monitor"
EndSection

Section "Screen"
  Identifier   "Default Screen"
  Monitor      "Configured Monitor"
EndSection

Мнение от mcwolf пуснато на Февруари 22 2008, 09:09
и така съм пробвал (затова обърнах внимание че когато не съм задал 1680х1050 след това нямам възможност да мина ръчно на тази резолюция - така че трябва поне тя да е описана в конфиг файлът) - (драйверът които ползвам не е legacy)- тествал съм с nv и новия драйвер (100.*) - в момента си ползвам 96.43

проблемът малко вероятно да е в него - резолюцията си се разпознава коректно и Х-а се вдига именно на нея - зарежда логин мениджърът (пробвал съм с kdm и gdm) на желаната резолюция но при зареждане на графичната среда по неведоми пътища минава на 1280x1024_60 (при 60Hz) без да дава никакви обяснения защо (обърни внимание на краят на лог файловете от първият ми пост - това е един и същи файл но след всяко действие)

след ръчна промяна на резолюцията захапва съвсем културно на 1680x1050 при 75Hz (това са препоръчителните стойности за мониторът)

взех да си мисля да не би да се биииип дигиталния вход и повторих всички тестова на аналоговия - никаква промяна
Мнение от tolostoi пуснато на Февруари 22 2008, 10:18
С ubuntu подобни грижи имах, по същият начин се получаваш като при теб, оправи се след като влязох в приложението за настройка на резолюциите, те са две - едно юзърско и едно което си иска парола, та това което искаше парола стартирах (не помня на кубунту има ли ги тези мениджъри или са само за гнома) избрах си модела на монитора и резолюция и рифреш, след това ми каза, че трябва логаут за да влязат в сила (явно го прилага за всички потребители) логаутнах се веднага(без да правя нищо друго) и след това като влязох всичко беше както го бях задал. Иначе преди това, ги сменях(пак от същият мениджър), запазвах, рестартирах ръчно Х-а, че и машината - все нещо не беше както трябва, или резолюцията не беше същата или рифреша, дори ми пишеше някаква резолюция а аз я виждам, че не е такава (примерно пише 1280Х1024, а пък аз я виждам, че е 1024Х768, не съм се объркал, със сигурност, или рифреша пише един като проверя от менюто на монитора виждам, че не е същият) Звучи малко тъпо, но след като направих точно каквото си пишеше и стана (нали все знаем как става и много не им обръщаме внимание на тези надписи  :D ) Това беше на 7.10 ти си с Херон-а. А иначе драйвера си е легаси, ползвах го на geforce 2-ката, те сега са (ако не си обръщал внимание, един latest и 2 поколения легаси)
Цитат: 

Linux IA32
Latest Version: 169.07
Latest Legacy GPU version (1.0-71xx series): 71.86.04
Latest Legacy GPU version (1.0-96xx series): 96.43.05


#офтопик
Остана да пробваш и гнома (тъкмо ще видиш докъде се е развил)  :P
Мнение от mcwolf пуснато на Февруари 22 2008, 10:50
щом е толкова зле тоя драйвер мятам новия :)
а иначе съм пробвал и с gnome и kde3
Мнение от mcwolf пуснато на Март 07 2008, 20:26
и сега решението на проблемът
Код: 
rm -fr ~/.kde ~/.kde4

или казано по друг начин ресет на профила и работата заспа :P
Мнение от nikolavp пуснато на Март 12 2008, 16:19
Цитат: (mcwolf @ Февруари 20 2008, 10:57)

modeline-а влияе на честотата на мониторът и не би трябвало да има отношение към резолюцията (по скоро е обратното - честотата зависи от резолюцията)

ползваните < http://georgi.unixsol.org/diary/archive.php/2006-01-18 > стойности са за честоти съответно 59.62Hz(тая ме съмнява нещо), 60Hz, 75Hz, 85Hz, 100Hz

макар че и това ще пробвам де

Ела да го кажеш на моя Acer, който без modeline не може да тръгне на 1400x900 :). Настрой си modeline-a и би трябвало да потегли, само че внимавай както ти казаха по - нагоре  :21;
Мнение от mcwolf пуснато на Март 13 2008, 09:33
проблемът си се реши без никакви шпагати - единствено със задаване на желаната резолюция (след премахване на двете "конфигурационни директории" всичко си запали) след това просто сложих metamodes за да подкарам пущината на 75 херца (ползвам auto-select-а от предната страница - първият ми пост)

то беше видно от лог файловете че при вдигане на графичната среда се получаваше смяната на резолюцията - само не разбрах защо Gnome правеше същата мизерия като очевидно проблемът е бил в конфигурацията на едно от двете KDE-та :14;


Powered by ikonforums 1.0.0 © 2006 ikonforums