Форум: Networking
Тема: проблем с pppoe на ubuntu
Автор: omurtak

Мнение от omurtak пуснато на Юли 07 2006, 20:52
въпросът ми е следния: интернет връзката ми е PPPOE като напиша в конзолата pppoeconf си настройвам usser name i pass и нета тръгва но с много умрела скорост 6/7k на едно място намирих една тема в която пише че трябва да:
Изпълняваме командата:

pppoe -I eth0 -A

Тя претърсва мрежата на доставчика (чрез изпращане на PADI фреймове) за налични концентратори и сервизи. Това са тези логически точки, към които вие трябва да се включите. Тук трябва да видите този Service-Name, към които доставчикът ви е казал, че трябва да се включите та намерих Service-Name,към който да се включа.
Настройваме DNS сървърите на доставчика:

echo "nameserver XXX.XXX.XXX.YYY" > /etc/resolv.conf
echo "nameserver XXX.XXX.XXX.ZZZ" >> /etc/resolv.conf

Обърнете внимание на следното:
- Първата команда ще изтрие всичко във вашия файл resolv.conf.
- Втората команда наистина има два знака ">".

Добавяме потребителското си име и парола във файла pap-secrets, така че те да се вземат и използват при установяване на връзката.

echo "smalluser * smallpass" >> /etc/ppp/pap-secrets

Сега вече сме готови за най-важната част - установяване на връзката!

pppd pty 'pppoe -I eth0 -S abc' noipdefault defaultroute hide-password passive persist name smalluser

С опцията "-S" се задава параметърът Service-name, така че заменете abc с вашия. С опцията "name" се задава потребителското име. Заменете smalluser с вашето.
Забележка: нали правите разлика между тези два символа: ' и ` ?
но при мен стана следното juli@juli-desktop:~$ sudo -i
root@juli-desktop:~# pppoe -I eth0 -A
Access-Concentrator: cityconnect.netissat.bg
Service-Name: cityconnect
Got a cookie: 56 c4 85 e3 33 90 81 67 a6 95 ac d5 1d 2e 57 c0 25 04 00 00
AC-Ethernet-Address: 00:30:48:82:d6:e8
--------------------------------------------------
Access-Concentrator: cityconnect.netissat.bg
Service-Name: cityconnect
Got a cookie: a2 e1 75 3f 4e f4 34 c1 05 3c be f8 94 5b 38 9b 01 05 00 00
AC-Ethernet-Address: 00:30:48:55:c9:80
--------------------------------------------------
Access-Concentrator: cityconnect.netissat.bg
Service-Name: cityconnect
Got a cookie: 54 45 df 89 d2 44 57 b3 5b 61 42 43 f3 2c 3f 32 04 05 00 00
AC-Ethernet-Address: 00:30:48:55:96:68
--------------------------------------------------
root@juli-desktop:~# echo "nameserver XXX.XXX.XXX.YYY" > /etc/resolv.conf
root@juli-desktop:~# echo "XXX.XXX.XXX.ZZZ" >> /etc/resolv.conf
root@juli-desktop:~# echo "tnx 00525 * 2525" >> /etc/pap-secrets
root@juli-desktop:~# pppd pty 'pppoe -I eth0 -S abc' noipdefault defaultroute hide-password passive persist name smalluser
pppd: The remote system is required to authenticate itself
pppd: but I couldn't find any suitable secret (password) for it to use to do so.pppd: (None of the available passwords would let it use an IP address.)
root@juli-desktop:~# pppd pty 'pppoe -I eth0 -S abc' noipdefault defaultroute hide-2525 passive persist tnx 00525
pppd: unrecognized option 'hide-2525'
pppd version 2.4.4b1
Usage: pppd [ options ], where options are:
<device> Communicate over the named device
<speed> Set the baud rate to <speed>
<loc>:<rem> Set the local and/or remote interface IP
addresses. Either one may be omitted.
asyncmap <n> Set the desired async map to hex <n>
auth Require authentication from peer
connect <p> Invoke shell command <p> to set up the serial line
crtscts Use hardware RTS/CTS flow control
defaultroute Add default route through interface
file <f> Take options from file <f>
modem Use modem control lines
mru <n> Set MRU value to <n> for negotiation
See pppd(icon_cool.gif for more options.
root@juli-desktop:~# "-S"
-bash: -S: command not found
root@juli-desktop:~#

къде бъркам

Мнение от Red пуснато на Юли 07 2006, 22:08
Не си реален .....
Цитат:


root@juli-desktop:~# echo "nameserver XXX.XXX.XXX.YYY" > /etc/resolv.conf
root@juli-desktop:~# echo "XXX.XXX.XXX.ZZZ" >> /etc/resolv.conf
root@juli-desktop:~# echo "tnx 00525 * 2525" >> /etc/pap-secrets
root@juli-desktop:~# pppd pty 'pppoe -I eth0 -S abc' noipdefault defaultroute hide-password passive persist name smalluser

1. На мястото XXX ..... трябва да са ти IP-та за DNS-те
2. Човека ти е казал "С опцията "-S" се задава параметърът Service-name, така че заменете abc с вашия" ..... ти виждаш ли да си си задал service name ( при теб е Service-Name: cityconnect)
3. Човека пак ти е казал "..... С опцията "name" се задава потребителското име. Заменете smalluser с вашето...." .... смяаш ли, че usera-а ти за достъп до интернет се казва smalluser ( при теб tnx 00525 е smalluser и smallpass ти е 2525) ?!

Трябва отново да пуснеш pppoeconf и ако имаш забавяне, провери дали ти е пуснат firewall, покажи ping към някой сайт, както ifconfig pppoe. Обадил ли си се на ISP-та да видиш дали могат да ти помогнат, защото на това мерише .... нещо проблема май ще е при тях.

Мнение от omurtak пуснато на Юли 08 2006, 01:00
благодаря стана
:6;

Powered by ikonforums 1.0.0 © 2006 ikonforums