Форум: Общи Проблеми и Въпроси
Тема: Debian /testing/
Автор: MarineForce

Мнение от MarineForce пуснато на Май 15 2006, 22:14
1vo se izviniavam za latineca. Iskam samo da vi popitam kak moga da si opravia Debian-a, imam instalirani: x-window-system i x-server-xorg, gdm i gnome, no kato se opitam da pusna X-a izpisva slednata greshka:

Fake start-stop-daemon called, doing nothing


Ako mi pomognete shte sum vi blagodaren. :)

Мнение от MarineForce пуснато на Май 15 2006, 22:25
Syshto bih iskal da vi popitam, moga li da samo s 1-to CD na Debian Stable da instaliram operacionnata sistema i posle da si dobavia vsichkite neobhodimi mi paketi i syotvetno da upgrade-na do testing. (otnovo se izviniavam za latineca :) ).
Мнение от quintessence пуснато на Май 15 2006, 22:28
http://www.linux-index.org/cgi-bin/ib3/ikonboard.cgi?act=ST;f=39;t=1104

пакетите не са досататъчни; грешката ,която ти излиза не е заради проблем с конфигурирането на X-a
Код: 
mv /sbin/start-stop-daemon.REAL /sbin/start-stop-daemon


как стартираш X сесията ...
Код: 
startx


дай изхода от
Код: 
cat /var/log/messages/Xorg.0.log
изпълнено като супер потребител :)

Мнение от MarineForce пуснато на Май 15 2006, 23:05
А бих ли могъл с 1-то CD на Debian Sarge да инсталирам основната система и след това да си добавя графичната среда и кои пакети ще са ми необходими да я подкарам. А и мога ли да upgrade от stable до testing? :)

Благодаря :)...

Мнение от phantomlord пуснато на Май 15 2006, 23:10
И само първия диск ще ти свърши работа. Може да разгледаш и < http://www.debian.org/CD/netinst/ >. Само 180 МБ е, останалото се сваля от интернет. Има имиджи за теглене и на < http://www.debian.org/devel/debian-installer/ >.
Ако си с xorg, се пробвай да го реконфигурираш с:
Код: 
dpkg-reconfigure xserver-xorg

Ако си с xfree:
Код: 
dpkg-reconfigure xserver-xfree86



Мнение от MarineForce пуснато на Май 15 2006, 23:14
Цитат:  (phantomlord @ Май 15 2006,23:10)

И само първия диск ще ти свърши работа. Може да разгледаш и < http://www.debian.org/CD/netinst/ >. Само 180 МБ е, останалото се сваля от интернет. Има имиджи за теглене и на < http://www.debian.org/devel/debian-installer/ >.

Знам за Netinstall-а, но този вариант не за предпочитане с моя нет :), за това и попитах за инсталация само с 1-то CD на stable и дали мога да я upgrade до testing :)?

10x :).

Мнение от kalin пуснато на Май 15 2006, 23:17
от stable до testing може да пробваш като в файла
/etc/apt/sources.list в редовете,които имаш ще преправиш
stable на testing и след това правиш apt-get update
и apt-get dist-upgrade.
иначе и аз мисля,че пакетите само от първия диск няма да са
достатъчни

Мнение от MarineForce пуснато на Май 15 2006, 23:22
"няма да са достатъчи"?? о.О??? Е за инсталирането на base system не стига ли ? На мен ми трябва да инстална base system и полсе да си иснталирам графична среда ( и, ако кажете името на пакетите необходими за инсталацията на Х-са, ще сте златни ... ;) ).
Мнение от kalin пуснато на Май 15 2006, 23:45
ами действай само с първия диск и като приключиш
пробвай с командата
Код: 
tasksel
.
и ще можеш да избираш за инсталиране
различни категории софтуер:среда за работен плот и т.н.

Мнение от Red пуснато на Май 16 2006, 00:17
1. Аз си инсталирам Дебиан само от първият диск. Макар да имам и Netinstall и 14-те диска. Няма абс. никакъв проблем, защото както каза, качва само base system.
2. По принцип, ако си с pppoe, след като ти се ресне компа при качването на базисната система, ще те подкани за root парола, за обикновен потребител, паролата му и настройка на хранилището, т.е. sources.list. Aко си както споменах с pppoe, трябва да откажеш да прибавяш сървъри в хранилището и просто да избереш завършека на инсталацията. След това само даваш pppoeconf, настойваш си интернета и изпълняваш:
Код: 

apt-setup

Така ще си добавиш огледалните сървъри в sources.list. След това редактираш sources.list (vi /etc/apt/sources.list) като преписваш stable adress и заменяш думата stable с testing.
3. Aко си с статични насторйки при самото инсталиране, ще се опита да ти зареди мрежата po DHCP и след рестарт , след въвеждането на потребители и т.н. директно ще си заредиш огледалата, т.е. няма да илизаш , както е при pppoe.
4. По принцип за да си качиш графична среда, се дава
Код: 

#apt-get install x-windows-system xserver-xorg gdm gnome ( или kdm kdebase)



П.П. Аз лично имах проблем с зависимостите на gnome-core и ми се чупеше gnome. Начина по-който се преборих бе, вместо да дам gnome за инсталиране, дадох gnome-desktop-environment.
Също така ти препоръчвам да си инсталираш less, защото е мн. удачен инстурмент, когато ползваш конзола.
Ако търсиш нещо
Код: 

apt-cache search НИНДЖА | less

при изпълване на екрана, ще спре и ще чака да натиснеш enter  за да продължи с показването на резултатите.
Успех!

Edit : Ако ползваш моят начин, след като си инсталираш системата ще трябва да си качваш всички програми сам, т.е. ще бъдеш максимално начисто :44; . След това само даваш
Код: 

$su
#apt-get install synaptic

и вече ще плуваш в свой води. Знам го това, защото ако не се лъжа досега си бил на убубту :61;



Мнение от MarineForce пуснато на Май 16 2006, 06:11
Не се лъжеш :), на Убунту бях. Ще пробвам твоя начин като ми остане време и ще пиша, ако има проблеми ;).

Благодаря на всички  :43; !



Мнение от MarineForce пуснато на Май 18 2006, 13:08
Здравейте. Отново съм аз :). Значи инсталирахй си ново ядро 2.6.15 на Дебиан-а ми и си инсталирах xserver-xorg, но тъй като upgrade-нах от стабилната до тестовата версия на Дебиан, стабилната върви с xserver-xfree86, а аз искам да работя на xserver-xorg, но не мога да сменя да се стартира xorg. Някой ще помогне ли ;) ?
Мнение от Red пуснато на Май 18 2006, 13:23
# apt-get --reinstall install xserver-xorg

П.П. Само така и усех  :43;

Мнение от MarineForce пуснато на Май 18 2006, 13:42
Цитат:  (Red @ Май 18 2006,13:23)

# apt-get --reinstall install xserver-xorg

П.П. Само така и усех  :43;

Дам, но май няква грешка се получи .... :Т :


NY:/home/vanka# apt-get --reinstall install xserver-xorg
Reading package lists... Done
Building dependency tree... Done
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 438 not upgraded.
Need to get 0B/5920kB of archives.
After unpacking 0B of additional disk space will be used.
Do you want to continue [Y/n]? y
WARNING: The following packages cannot be authenticated!
 xserver-xorg
Install these packages without verification [y/N]?

Мнение от Red пуснато на Май 18 2006, 13:52
Цитат:


.........................
Install these packages without verification [y/N]?y

Мнение от MarineForce пуснато на Май 18 2006, 14:03
NY:/home/vanka# apt-get --reinstall install xserver-xorg
Reading package lists... Done
Building dependency tree... Done
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 438 not upgraded.
Need to get 0B/5920kB of archives.
After unpacking 0B of additional disk space will be used.
Do you want to continue [Y/n]? y
WARNING: The following packages cannot be authenticated!
 xserver-xorg
Install these packages without verification [y/N]? y
Preconfiguring packages ...
(Reading database ... 77669 files and directories currently installed.)
Preparing to replace xserver-xorg 6.9.0.dfsg.1-6 (using .../xserver-xorg_6.9.0.dfsg.1-6_i386.deb) ...
Unpacking replacement xserver-xorg ...
Setting up xserver-xorg (6.9.0.dfsg.1-6) ...
System startup links for /etc/init.d/xserver-xorg already exist.

Полсе как да пунса x-org :)?

Мнение от ... пуснато на Май 18 2006, 14:10
Цитат:


System startup links for /etc/init.d/xserver-xorg already exist.

Ама ти си го имаш. Какво става като дадеш
dpkg-reconfigure xserver-xorg ?

Мнение от MarineForce пуснато на Май 18 2006, 14:15
Цитат:  (Guest @ Май 18 2006,14:10)

Цитат:


System startup links for /etc/init.d/xserver-xorg already exist.

Ама ти си го имаш. Какво става като дадеш
dpkg-reconfigure xserver-xorg ?

NY:/home/vanka# dpkg-reconfigure xserver-xorg
xserver-xorg postinst warning: overwriting possibly-customised configuration
  file; backup in /etc/X11/xorg.conf.200605181406
System startup links for /etc/init.d/xserver-xorg already exist.

Конфигурирах го уж ;)......?

Мнение от MarineForce пуснато на Май 18 2006, 20:25
Здравейте пак ;).... Искам да ви попитам отново нещо свързано с Xorg, значи инстлаирам си го и го стартирам, но самият Х трябва да се конфигурира, но тъй като не си познавам до болка hardware-а и не мога да знам всичко за него (знам това-онова, но не всички детайли) и не мога да подкарам Х-а. Самият Х не може да намери директорията на мишката ми, независимо, че я създадох и ето такива проблемчета... Та въпросът ми е как да си конфигурирам Х-а, ако може автоматично :), та да ми тръгне и да ползвам Дебиан ми пълноценно :)....

Благодаря :)!



Мнение от yasnv пуснато на Май 18 2006, 20:45
бръкни в
Код: 
/etc/X11/xorg.conf

не гарантирам че ще стане,но все пак.

бтв,драйвери за видеото инсталирал ли си.не знам дали са излезнали драйвери за АТИ на xorg7.0 за последно като бях с дебиан имаше само за 6.9

Мнение от MarineForce пуснато на Май 18 2006, 20:54
Видео картата ми е nVidia GeForce FX5200, не Ati :). Мисълта ми беше няма ли някаква възможност самоят Х да се конфигурира автоматично за моя hardware и съответно да тръгне ;)?
Мнение от kalin пуснато на Май 18 2006, 22:29
относно "проблемчетата" дай да видим съдържанието на
/var/log/Xorg.0.log и на
/etc/X11/xorg.conf

Мнение от quintessence пуснато на Май 18 2006, 23:56
Цитат:  (MarineForce @ Май 18 2006,20:54)

Видео картата ми е nVidia GeForce FX5200, не Ati :). Мисълта ми беше няма ли някаква възможност самоят Х да се конфигурира автоматично за моя hardware и съответно да тръгне ;)?

цитат от линка,който ти предложих да погледнеш в първия ми пост :

Код: 
xorgsetup / xfree86setup - това са командите за автоматично конфигуриране на X Window System. Генерира се файл с минимална конфигурация, но достатъчна за успешно стартиране на X сесията .


има и друг вариант , ако горният те затрудни горния ...
Код: 
Xorg -configure / XFree86 -configure
- съответно за Xorg и XFree86; командата (~ите) генерират файл ( xorg.conf.new/XF86Config.new ) в /root директорията и имаш възможността да тестваш новата конфигурация ... съответно , ако те удовлетворява ( за basic config няма начин да не те ) трябва да преместиш този файл в /etc/X11 .. . и да го преименуваш от xorg.conf.new/XF86Config.new на xorg.conf/XF86Config ...

има и други начини за автоматично конфигуриране на X-a.



Мнение от Red пуснато на Май 19 2006, 00:17
xorgconfig :30;
Мнение от phantomlord пуснато на Май 19 2006, 01:56
Цитат:  (yasnv @ Май 18 2006,20:45)

...не знам дали са излезнали драйвери за АТИ на xorg7...

Излезнали са. В момента съм на Xorg 7.0 всичко е на 6.

@MarineForce: Колкото и както и да си конфигурираш xorg.conf, ако не си инсталираш драйверите за nVidia, все едно нищо не си направил. Има ги в хранилищата. Търси за nvidia-glx.

Цитат:

...Самият Х не може да намери директорията на мишката ми, независимо, че я създадох...

Какво те остави с това впечатение и какво означава:
Цитат:

независимо, че я създадох...
?!
Мишката ти би трябвало да е в /dev/input/mice.



Мнение от quintessence пуснато на Май 19 2006, 13:57
Цитат:  (Red @ Май 19 2006,00:17)

xorgconfig :30;

Колега ...
Код: 

xorgconfig / xf86config - това са tool-овете за фина настройка на X системата. Преминавайки през поставянето на различни видове опции, може да генерирате доста добър откъм използваемост X конфигурационен файл, но преди да използвате тези команди, трябва да знаете детайлите на хардуаерните компоненти на системата ви  
 ;)

Цитат:  (phantomlord @ Май 19 2006,01:56)

[quote=yasnv,Май 18 2006,20:45]@MarineForce: Колкото и както и да си конфигурираш xorg.conf, ако не си инсталираш драйверите за nVidia, все едно нищо не си направил. Има ги в хранилищата. Търси за nvidia-glx.
Може ли да попитам защо да инсталира драйвера?!Т.е какво общо има първоначалното конфигуриране на X-a с драйвера ?! (два реторични въпроса) ... преспокойно може да си кара и с nv драйвера,който си върви с ядрото ... виж ,вече има разлика дали автоматичното конфигуриране ще load-не glx модула ( да ,ще го по default ) ... :)



Мнение от Red пуснато на Май 19 2006, 23:12
Цитат:  (quintessence @ Май 18 2006,23:56)


..............................................................................

Код: 
xorgsetup / xfree86setup - това са командите за автоматично конфигуриране на X Window System. Генерира се файл с минимална конфигурация, но достатъчна за успешно стартиране на X сесията .

Код: 

debian:/home/red# xorgsetup
bash: xorgsetup: command not found
 :21;

Мнение от phantomlord пуснато на Май 20 2006, 00:27
Брях...
Цитат:

~$ sudo xorgsetup
sudo: xorgsetup: command not found

Цитат:

~$ sudo xorgconfig
sudo: xorgconfig: command not found

За Debian:
Код: 
dpkg-reconfigure xserver-xorg



Мнение от quintessence пуснато на Май 20 2006, 03:10
Код: 
whreis xorgsetup
;)

Мнение от Red пуснато на Май 20 2006, 03:15
Код: 

debian:/home/red# whereis xorgconfig
xorgconfig: /usr/X11R6/bin/xorgconfig /usr/bin/X11/xorgconfig
debian:/home/red# whereis xorgsetup
xorgsetup:
debian:/home/red#

Мнение от phantomlord пуснато на Май 20 2006, 03:55
А аз нямам нито едното, нито другото...
Мнение от quintessence пуснато на Май 20 2006, 10:46
Капризен Деби(?)ан , кво да го правиш  :D  :D  :D Не пречи да ползвате обаче
Код: 
 Xorg -configure / XFree86 -configure

Мнение от finley пуснато на Август 04 2006, 11:12
Днес реших да смемя Убунтуто с Дебиан инсталацията горе доло е еднаква. Инталирах КДЕ x-window-system xserver-xfree86(Red ми препоръча xserver-xorg но го нямаше в хранилището незнайно защо). Конфигурирането на Х-са ме затруднява. Не знам на някой от въпросите какво да напиша. < http://10stotinki.hit.bg/XFree86.0.log > с помоща на links2 качих лога ако може някой да погледне и да каже каде ми е грешката и как да я оправя.
Видеото ми е Nvidia RivaTNT2 32mb гледам в лога че има и нещо че не може да намери мишката, а тя е a4 tech на UBS но при мен е на PS/2 накрайник.



Мнение от Red пуснато на Август 04 2006, 11:37
Имаш проблем с мишката. Пробвай да смениш порта, т.е. даваш dpkg-reconfigure xserver-xfree86. Все някой ще иска ..... нямам пред себе си дебиан, за да ти кажа точно кой е. Също така, може да прегледаш и < http://www.linux-bg.org/cgi-bin/ib3/ikonboard.cgi?act=ST;f=6;t=15213;st=10 >

Успех

Мнение от finley пуснато на Август 04 2006, 11:40
сега ще пробвам да видим какво ще стане :12;
Мнение от finley пуснато на Август 04 2006, 11:54
Red vqrno problema be6e s mi6kata premestih q na USB porta i X-sa trygna se mislq da upgredna i posle da vidq za6to mi dava kradrat4eta na kilicata
Мнение от finley пуснато на Август 04 2006, 15:00
Sled kato go upgreinah pak mi dava vmesto kilica kradrat4eta. nakavi idei kak da gi oprawq
Мнение от Red пуснато на Август 04 2006, 15:49
Стартираш synaptic, търсиш и инсталираш cyrillic шрифтове.
Мнение от finley пуснато на Август 04 2006, 16:13
Цитат:  (Red @ Август 04 2006,15:49)

Стартираш synaptic, търсиш и инсталираш cyrillic шрифтове.

Златен си ей :24;
Мнение от Red пуснато на Август 04 2006, 16:46
Няма грижи. Радвам се, че съм успял да помогна с нещо.
Мнение от finley пуснато на Август 05 2006, 10:21
Май пак ще трябва да помагаш ;)
Сега пък няма саунд (не помнля дали от инсталацията до сега е имало) .
Интересното е че като инсталирах Медиа плейъра ми премахна алса драйвъра и инсталира осс. Махнах осс пак инсталирах алса и не става :6;



Мнение от Hawk_Eye пуснато на Август 05 2006, 11:02
Пробвай с alsaconf да си заредиш модула наново.Ако не стане си инсталирай alsa-utils.Така би трябвало да се оправи проблема. :43;
Мнение от finley пуснато на Август 05 2006, 11:27
Цитат:

Така би трябвало

не би трябвало а се оправи  :P

Мнение от MarineForce пуснато на Август 06 2006, 22:24
Цитат:  (finley @ Август 05 2006,11:27)

Цитат:

Така би трябвало

не би трябвало а се оправи  :P

Още един абонат на Дебиан :):):)...
Powered by ikonforums 1.0.0 © 2006 ikonforums