Форум: Applications
Тема: Инсталация на драйвер
Автор: bashi

Мнение от bashi пуснато на Януари 13 2008, 22:24
Привет на всички! Ползвам Убунту вече близо година и съм много доволен. За сега съм много доволен от системата с изключение на това, че не съм си инсталирал драйвер за видеокартата. Тя е GeForce FX 5500. Проблема е, че преди време се опитвах да инсталирам драйвери пак на Убунту и имаше доста ядове. При опит да пусна Х-а ми излизаше само един син екран с мого йероглифи. Въпроса ми е има ли начин да направя резервно копие на xorg.conf и как в спасителен режим бих могъл да го подкарам, понеже не ми се иска да преинсталирам всичко на ново? Също така трябва ли да се записва още нещо за да може да се възстанови системата? Предварително благодаря!
Мнение от phantomlord пуснато на Януари 13 2008, 22:57
Резервно копие можеш да си направиш много лесно:
cp /etc/X11/xorg.conf ~/xorg.conf.bak
После:
cp ~/xorg.conf.bak /etc/X11/xorg.conf

Мнение от tonitochev пуснато на Януари 14 2008, 07:24
Или след нестартиране на Х (поради неправилна версия на драйвера) в конзолен режим:
#nano /etc/X11/xorg.conf
Със стрелките се придвижваш до реда, където е описан драйвера:
Section "Device"
Identifier "Generic Video Card"
Driver "nvidia"
Е, nvidia поправяш на nv
Запазваш промените:
Cntr + o
Enter
Cntr + x
и startx , отново си в графична среда със обикновения драйвер за Х (без 3D)

Мнение от bashi пуснато на Януари 15 2008, 16:17
Много благодаря за съветите! Много ми помогнаха! Обаче сега се появи един по-голям проблем. Можете ли да помогнете малко за инсталирането на тези драйвери? Ето какво направих аз и какви проблеми се появиха. Първо си изтеглих драйвера от официалния сайт на nvividia и го сложих в хоум директорията. Опитах се да спра Х-а но нещо не се получи. Изчезна всичко и се появи черен екран като в конзола с разни надписи и долу мигащ курсор обаче каквото и да напиша не се случва нищо. Просто нямаше команден ред - явно нещо беше зациклило при изключването. Дадох му ctr+alt+del за да се ресне целия комп и влязох в спасителен режим. От там инсталирах всичко и му дадох да промени конфиг файла и успях дори да пусна графична среда- /etc/init.d/gdm/start .
До тук добре обаче при пускането ми се появи една грешка, която остана и при възтановяване на стария конф файл -
failed to initialize HAL!
Наложи ми се да ресна компа при което се появи големия проблем - при стартирането на X-a се появиха на син екран две съобщения -
Failed to start the X server. It is likely that it is not set un correctly would you like to view the X server output to diagnose the problem!
Другото беше
The X server is now disabled. Restart GDM when it is configured correcly
Това бяха съобщенията. Извинявам се ако нещо от тях съм объркал, но трябваше да ги препиша на ръка а и не съм на ти с ангрииския. Ето xorg.conf след инсталацията
Код: 
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder3)  Thu Dec 13 19:09:35 PST 2007

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf(5) manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
   Identifier     "Default Layout"
   Screen         "Default Screen" 0 0
   InputDevice    "Generic Keyboard"
   InputDevice    "Configured Mouse"
   InputDevice    "stylus" "SendCoreEvents"
   InputDevice    "cursor" "SendCoreEvents"
   InputDevice    "eraser" "SendCoreEvents"
EndSection

Section "Files"

# path to defoma fonts
   FontPath        "/usr/share/fonts/X11/misc"
   FontPath        "/usr/share/fonts/X11/cyrillic"
   FontPath        "/usr/share/fonts/X11/100dpi/:unscaled"
   FontPath        "/usr/share/fonts/X11/75dpi/:unscaled"
   FontPath        "/usr/share/fonts/X11/Type1"
   FontPath        "/usr/share/fonts/X11/100dpi"
   FontPath        "/usr/share/fonts/X11/75dpi"
   FontPath        "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
   Load           "i2c"
   Load           "bitmap"
   Load           "ddc"
   Load           "extmod"
   Load           "freetype"
   Load           "glx"
   Load           "int10"
   Load           "vbe"
EndSection

Section "InputDevice"
   Identifier     "Generic Keyboard"
   Driver         "kbd"
   Option         "CoreKeyboard"
   Option         "XkbRules" "xorg"
   Option         "XkbModel" "pc105"
   Option         "XkbLayout" "us,bg"
   Option         "XkbVariant" ","
   Option         "XkbOptions" "grp:alt_shift_toggle,grp_led:scroll"
EndSection

Section "InputDevice"
   Identifier     "Configured Mouse"
   Driver         "mouse"
   Option         "CorePointer"
   Option         "Device" "/dev/input/mice"
   Option         "Protocol" "ImPS/2"
   Option         "ZAxisMapping" "4 5"
   Option         "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
   Identifier     "stylus"
   Driver         "wacom"
   Option         "Device" "/dev/input/wacom"
   Option         "Type" "stylus"
   Option         "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
   Identifier     "eraser"
   Driver         "wacom"
   Option         "Device" "/dev/input/wacom"
   Option         "Type" "eraser"
   Option         "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
   Identifier     "cursor"
   Driver         "wacom"
   Option         "Device" "/dev/input/wacom"
   Option         "Type" "cursor"
   Option         "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "Monitor"
   Identifier     "Generic Monitor"
   HorizSync       28.0 - 51.0
   VertRefresh     43.0 - 60.0
   Option         "DPMS"
EndSection

Section "Device"
   Identifier     "nVidia Corporation NV34 [GeForce FX 5500]"
   Driver         "nvidia"
EndSection

Section "Screen"
   Identifier     "Default Screen"
   Device         "nVidia Corporation NV34 [GeForce FX 5500]"
   Monitor        "Generic Monitor"
   DefaultDepth    24
   SubSection     "Display"
       Depth       1
       Modes      "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection     "Display"
       Depth       4
       Modes      "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection     "Display"
       Depth       8
       Modes      "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection     "Display"
       Depth       15
       Modes      "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection     "Display"
       Depth       16
       Modes      "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection     "Display"
       Depth       24
       Modes      "1024x768" "800x600" "640x480"
   EndSubSection
EndSection
Къде бъркам?

Мнение от devik пуснато на Януари 17 2008, 11:39
На мен всичко ми изглежда наред,но явно не е?Нямаш ли копие на стария xorg.conf -ако имаш го върни или пробвай да деинсталираш nvidia-ta.
PS Би трябвало до се генерира копие в /etc/X11/xorg.conf.bak

Мнение от bashi пуснато на Януари 17 2008, 20:12
Проблема не във връщането - аз си бях направил резервно копие преди инсталацията. Проблема е да го подкарам да работи този драйвер
Мнение от bashi пуснато на Януари 17 2008, 20:20
Ето го стария файл

Код: 
# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf(5) manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
       FontPath        "/usr/share/fonts/X11/misc"
       FontPath        "/usr/share/fonts/X11/cyrillic"
       FontPath        "/usr/share/fonts/X11/100dpi/:unscaled"
       FontPath        "/usr/share/fonts/X11/75dpi/:unscaled"
       FontPath        "/usr/share/fonts/X11/Type1"
       FontPath        "/usr/share/fonts/X11/100dpi"
       FontPath        "/usr/share/fonts/X11/75dpi"
       # path to defoma fonts
       FontPath        "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
       Load    "i2c"
       Load    "bitmap"
       Load    "ddc"
       Load    "dri"
       Load    "extmod"
       Load    "freetype"
       Load    "glx"
       Load    "int10"
       Load    "vbe"
EndSection

Section "InputDevice"
       Identifier      "Generic Keyboard"
       Driver          "kbd"
       Option          "CoreKeyboard"
       Option          "XkbRules"      "xorg"
       Option          "XkbModel"      "pc105"
       Option          "XkbLayout"     "us,bg"
       Option          "XkbVariant"    ","
       Option          "XkbOptions"    "grp:alt_shift_toggle,grp_led:scroll"
EndSection

Section "InputDevice"
       Identifier      "Configured Mouse"
       Driver          "mouse"
       Option          "CorePointer"
       Option          "Device"                "/dev/input/mice"
       Option          "Protocol"              "ImPS/2"
       Option          "ZAxisMapping"          "4 5"
       Option          "Emulate3Buttons"       "true"
EndSection

Section "InputDevice"
       Driver          "wacom"
       Identifier      "stylus"
       Option          "Device"        "/dev/input/wacom"
       Option          "Type"          "stylus"
       Option          "ForceDevice"   "ISDV4"         # Tablet PC ONLY
EndSection

Section "InputDevice"
       Driver          "wacom"
       Identifier      "eraser"
       Option          "Device"        "/dev/input/wacom"
       Option          "Type"          "eraser"
       Option          "ForceDevice"   "ISDV4"         # Tablet PC ONLY
EndSection

Section "InputDevice"
       Driver          "wacom"
       Identifier      "cursor"
       Option          "Device"        "/dev/input/wacom"
       Option          "Type"          "cursor"
       Option          "ForceDevice"   "ISDV4"         # Tablet PC ONLY
EndSection

Section "Device"
       Identifier      "nVidia Corporation NV34 [GeForce FX 5500]"
       Driver          "nv"
       BusID           "PCI:1:0:0"
EndSection

Section "Monitor"
       Identifier      "Generic Monitor"
       Option          "DPMS"
       HorizSync       28-51
       VertRefresh     43-60
EndSection

Section "Screen"
       Identifier      "Default Screen"
       Device          "nVidia Corporation NV34 [GeForce FX 5500]"
       Monitor         "Generic Monitor"
       DefaultDepth    24
       SubSection "Display"
               Depth           1
               Modes           "1024x768" "800x600" "640x480"
       EndSubSection
       SubSection "Display"
               Depth           4
               Modes           "1024x768" "800x600" "640x480"
       EndSubSection
       SubSection "Display"
               Depth           8
               Modes           "1024x768" "800x600" "640x480"
       EndSubSection
       SubSection "Display"
               Depth           15
               Modes           "1024x768" "800x600" "640x480"
       EndSubSection
       SubSection "Display"
               Depth           16
               Modes           "1024x768" "800x600" "640x480"
       EndSubSection
       SubSection "Display"
               Depth           24
               Modes           "1024x768" "800x600" "640x480"
       EndSubSection
EndSection

Section "ServerLayout"
       Identifier      "Default Layout"
       Screen          "Default Screen"
       InputDevice     "Generic Keyboard"
       InputDevice     "Configured Mouse"
       InputDevice     "stylus"        "SendCoreEvents"
       InputDevice     "cursor"        "SendCoreEvents"
       InputDevice     "eraser"        "SendCoreEvents"
EndSection

Section "DRI"
       Mode    0666
EndSection

Възможно ли е проблема на новия драйвер да е в този ред
 BusID           "PCI:1:0:0" и какво ще стане ако му го добавя.

Мнение от devik пуснато на Януари 18 2008, 17:35
Наи-много да тръгне.Ако искаш виж  < http://myfreesoft.net/phpBB2/viewtopic.php?t=558 > статия на phantomlord - при мене работи без проблем.
Мнение от deke пуснато на Януари 18 2008, 18:50
Цитат:  (devik @ Януари 18 2008,17:35)

Наи-много да тръгне.Ако искаш виж  < http://myfreesoft.net/phpBB2/viewtopic.php?t=558 > статия на phantomlord - при мене работи без проблем.

Не, аз имам същата видеокарта - въпросната статия е перфектна при Дебиан, но при мен, при прилагане на Убунту не става. Дава ми, че не може да прекомпилира Кернела. bashi, пробвай следната статия / по - долу /, и по - точно поста на Tolostoi - при мен става перфектно. Само обърни внимание, че трябва да ПРЕМАХНЕШ всичко, което си инсталирал за nvidia до този момент.
< http://myfreesoft.net/phpBB2/viewtopic.php?t=68&highlight=nvidia >

Мнение от deke пуснато на Януари 18 2008, 18:56
Забравих да кажа - преди да приложиш описания начин, в Х - са промени драйвърите на vesa / не на nv /, защото тази карта след 2-3 кликвания, забива. При vesa - всичко е наред. Ще ти спести доста рестарта.
Powered by ikonforums 1.0.0 © 2006 ikonforums