Запомняне

» Здравейте
[ Вход :: Регистриране ]
 » Начало » Li Форуми » Help & Support » Инсталиране на Linux » Gentoo инсталиране чрез chroot
Тема: Gentoo инсталиране чрез chroot, въпроси и проблеми
Мнение #1 Skip to the next post in this topic.
Написано на: Февруари 20 2007, 19:20
Pivoto

No avatar chosen




Група: Li fans
Мнения: 191
Регистриран: Април 2006

Оценка: няма

Offline
Захванах се да си инсталирам Gentoo 2006.1 през мрежата, като компилирам всичко.

Добре, имам система с конзола. Компилирах КДЕ. И сега въпросите:


1.Понеже обаче ми се налага да правя доста конзолни конфигурации имам нужда от по-четима конзола (по-малък шрифт). Успях да пусна такава с Framebuffer на 1024 х 768.
Обаче с Framebuffer Х-а не желае да стартира. Та има ли начин да си пусна конзола с по-добра резолюция (за да чета по-дълги списъци) без да пускам FB ?

2. КДЕ ми стартира в режим 1400 х 1050 чрез startx скрипта. Странно, не ми се компилира KDM, може би е отделен пакет. Проблема е, че когато оправя резолюцията, тя не се запаметява и всеки път стартира на 1400х1050. Странно също е, че няма xorg.conf файл. Как тогава решава как да пусне X ? Хм, не съм гледал, може да има някой .Xsession в /root.

3. При инсталирането забравих да инсталирам едната си мрежова карта. Те се стартират при инит процеса. Имам готов стартъп скрипт, ама не знам как да го вържа със съответното устройство - (eth2)
Контакти:  Pivoto
WEB  
Мнение #2 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Февруари 20 2007, 19:44
nikolavp

Avatar




Група: Li maniacs
Мнения: 560
Регистриран: Юли 2006

Оценка: 4

Offline
Как си инсталирал X server-a? Следваше ли guide-a на Gentoo много е важно да си назовеш устройствата преди да започнеш да "имъргваш" този пакет погледни тук за конфигурацията на X server-a. За kdm каква грешка ти дава и най важното - кой пакет на kde инсталира(kde-meta, kde, kde-base?). Накрая за мрежовата карта трябва да изпълниш това ако наистина имаш *трета* мрежова карта защото eth2 е точно това влизаш като роот потребител и пишеш
Код: 
ln -s /etc/init.d/net.lo /etc/init.d/net.eth2 && rc-update add eth2 default && nano/vi/emacs(каквото ползваш) /etc/conf.d/net
Ако не знаеш какви опции да ползваш за /etc/conf.d/net опитай
Код: 
cat /etc/conf.d/net.example
или погледни тук
Добре дошъл в света на Gentoo, ще ти хареса, да не забравиш да отговориш за пакета на kde, който си инсталирал


Редактирано от nikolavp на Февруари 20 2007, 19:45

Контакти:  nikolavp

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #3 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Февруари 20 2007, 20:09
Pivoto

No avatar chosen




Група: Li fans
Мнения: 191
Регистриран: Април 2006

Оценка: няма

Offline
КДЕ пакета инсталирах.
Хайде, рестартирам уиндоуса и в конзолата.
Контакти:  Pivoto
WEB  
Мнение #4 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Февруари 20 2007, 20:29
nikolavp

Avatar




Група: Li maniacs
Мнения: 560
Регистриран: Юли 2006

Оценка: 4

Offline
Цитат:  (Pivoto @ Февруари 20 2007,20:09)

КДЕ пакета инсталирах.
Хайде, рестартирам уиндоуса и в конзолата.

Aз и разработчиците препоръчваме да го махнеш :).
Код: 
emerge gentoolkit(ако го нямаш) && emerge -Ca kde && emerge -a --depclean && revdep-rebuild
После инсталирай kde с това
Код: 
emerge kdebase-startkde kdm
това ще ти даде само стартова част на kde, след която ще трябва да си инсталираш всичко, което искаш konsole, amarok, и така нататък в зависимост от това какво ползваш. Можеш да инсталираш целия пакет както някои правят(kde-meta), но според няма смисъл и не познавам някого, който да ползва всички приложения включени в KDE. Казвай ако имаш други проблеми :). За повече информация защо не е препоръчително да използва kde, kde-base, и т. н. тук


Редактирано от nikolavp на Февруари 20 2007, 20:34

Контакти:  nikolavp

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #5 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Февруари 20 2007, 20:45
Pivoto

No avatar chosen




Група: Li fans
Мнения: 191
Регистриран: Април 2006

Оценка: няма

Offline
Sega pisha ot links prez konzolata.
Imam problem - imam 2 mrejovi karti, na danoto i PCI.
PCI mi a razpoznawa kato eth1 i si raboti perfektno.
Obache drugata ne jelae da se naglasi na 192.168.0.1 makar che sam dal nastroikite v /etc/conf.d/net
Probvah da ne bi da e eth2, no togava garmi skripta i kazva che takava karta nema !
Zagadka nekva ! Pri instalaciqta BTW mi beshe otkrilo 3 karti...
Контакти:  Pivoto
WEB  
Мнение #6 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Февруари 21 2007, 07:28
nikolavp

Avatar




Група: Li maniacs
Мнения: 560
Регистриран: Юли 2006

Оценка: 4

Offline
Цитат:  (Pivoto @ Февруари 20 2007,20:45)

Sega pisha ot links prez konzolata.
Imam problem - imam 2 mrejovi karti, na danoto i PCI.
PCI mi a razpoznawa kato eth1 i si raboti perfektno.
Obache drugata ne jelae da se naglasi na 192.168.0.1 makar che sam dal nastroikite v /etc/conf.d/net
Probvah da ne bi da e eth2, no togava garmi skripta i kazva che takava karta nema !
Zagadka nekva ! Pri instalaciqta BTW mi beshe otkrilo 3 karti...

Дай един изход от
Код: 
ifconfig -a
и
Код: 
lspci | grep Ether
и накрая
Код: 
ls -1 /etc/init.d/net*


Редактирано от nikolavp на Февруари 21 2007, 07:33

Контакти:  nikolavp

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #7 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Февруари 21 2007, 12:22
Pivoto

No avatar chosen




Група: Li fans
Мнения: 191
Регистриран: Април 2006

Оценка: няма

Offline
Стана тя каквато стана. С мрежата се оправих, просто кернела не ми поддържал гигабит Етернет на дъното.

За жалост като послушах съвета ти за триене на КДЕ, emerge е изтрило и важни части от системата и са се прецакали login, wget и други.

сега очевидно отново ще трябва да правя chroot и да създавам нова система. Хей поне /boot дяла ми е готов...

Ако имаш идеи по въпроса давай ги насам.
Контакти:  Pivoto
WEB  
Мнение #8 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Февруари 21 2007, 16:06
nikolavp

Avatar




Група: Li maniacs
Мнения: 560
Регистриран: Юли 2006

Оценка: 4

Offline
Цитат:  (Pivoto @ Февруари 21 2007,12:22)

Стана тя каквато стана. С мрежата се оправих, просто кернела не ми поддържал гигабит Етернет на дъното.

За жалост като послушах съвета ти за триене на КДЕ, emerge е изтрило и важни части от системата и са се прецакали login, wget и други.

сега очевидно отново ще трябва да правя chroot и да създавам нова система. Хей поне /boot дяла ми е готов...

Ако имаш идеи по въпроса давай ги насам.

А ти изпълни ли revdep-rebuild??Пробвай и един emerge -auND world. Едно нещо ще ти кажа :) Gentoo никога не се чупи непоправимо :). Каква е грешката на wget и login-a, за който говориш...


Редактирано от nikolavp на Февруари 21 2007, 16:07

Контакти:  nikolavp

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #9 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Февруари 23 2007, 12:59
Pivoto

No avatar chosen




Група: Li fans
Мнения: 191
Регистриран: Април 2006

Оценка: няма

Offline
Такаааа...

Имаме известен напредък...

Имам работеща Дженту система с инсталирано КДЕ и IP_masq и файъруол. Сложил съм и Koffice и amarok.

Проблеми:

1. КДМ продължава да стартира в режим 1400 х 1050. Нямам Xorg.conf файл и не знам какво го конфигурира така.

2. Инсталирал съм Алса но звук няма.

3. Под КДЕ не мога да намеря опции за инсталиране на различни клавиатурни подредби.

Идеи ?
Контакти:  Pivoto
WEB  
Мнение #10
Skip to the previous post in this topic. Написано на: Февруари 23 2007, 14:13
Pivoto

No avatar chosen




Група: Li fans
Мнения: 191
Регистриран: Април 2006

Оценка: няма

Offline
Problema s Alsa go uredih.

Sega ostavia da instaliram XKB.
BTW kade ima spisak na portage paketite i kakvo praviat ?

Както се вижда оправих и клавиатурата.


Редактирано от Pivoto на Февруари 23 2007, 14:14
Контакти:  Pivoto
WEB  
Общо 36 отговор(а) от Февруари 20 2007, 19:20 до сега
 » Начало » Li Форуми » Help & Support » Инсталиране на Linux » Gentoo инсталиране чрез chroot

© 2014 Linux Index Project
Powered by iF 1.0.0 © 2006 ikonForums