Запомняне

» Здравейте
[ Вход :: Регистриране ]
 » Начало » Li Форуми » Help & Support » X Window & GUI » Как да пусна Beryl?
Тема: Как да пусна Beryl?
Мнение #11 Skip to the next post in this topic.
Написано на: Септември 24 2007, 09:48
tolostoi

Avatar




Група: Li maniacs
Мнения: 869
Регистриран: Юли 2006

Оценка: 5

Offline
И как инсталира берил? Не всички хранилища работят на стабилният, по този начин още става на стабилният

http://forums.data.bg/viewtopic.php?p=8935959#8935959

инсталираш
Код: 
apt-get install libxcomposite1 mesa-utils
в xorg.conf правиш секция Extensions аз я слагам най-долу, и в нея
Код: 
Section "Extensions"

  Option "Composite" "Enable"

EndSection
в секция Device добавяш
Код: 
Option "AddARGBGLXVisuals"
ако нещо след това не сработи, пробвай в секция Device да сложиш тези опции
Код: 
Option "XAANoOffscreenPixmaps" "true"# Optional if NVIDIA drivers are used
Option "AddARGBGLXVisuals" "true" # see note below
Option "AllowGLXWithComposite" "true"  # not work without it on NVidia GForgeMX400 for me
после
Код: 
wget -O - http://debian.beryl-project.org/root@lupine.me.uk.gpg | sudo apt-key add -
в /etc/apt/sources.list file доавяш тези хранилища
Код: 
deb http://debian.beryl-project.org/ etch main

deb-src http://debian.beryl-project.org/ etch main
после
Код: 
apt-get update
apt-get install beryl beryl-core beryl-dev \
   beryl-manager beryl-plugins beryl-plugins-data \
   beryl-settings emerald emerald-themes
сложи и това (за КДЕ е, ако имаш)
Код: 
apt-get install aquamarine
рестартирай Х-а, после търси в менюто зеленият камък  :) за да го включиш.
Като знам какъв си бързак сигурно си го сложил вече, това е за берил с aiglx

Мнение #12 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Септември 24 2007, 11:09
iLife

No avatar chosen




Група: Li fans
Мнения: 28
Регистриран: Септември 2007

Оценка: няма

Offline
Ето като пробвах да го инсталирам по твоя начин какво ми излиза

Код: 
chris@debian:~$ su
Password:
debian:/home/chris# apt-get install libxcomposite1 mesa-utils
Reading package lists... Done
Building dependency tree... Done
libxcomposite1 is already the newest version.
mesa-utils is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 4 not upgraded.
W: Couldn't stat source package list http://www.linux.lk ./ Packages (/var/lib/apt/lists/www.linux.lk_%7eanuradha_beryl_etch_._Packages) - stat (2 No such file or directory)
W: You may want to run apt-get update to correct these problems
debian:/home/chris# gedit /etc/X11/xorg.conf

(gedit:3484): GnomeUI-WARNING **: While connecting to session manager:
Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed.
debian:/home/chris# wget -O - http://debian.beryl-project.org/root@lupine.me.uk.gpg | sudo apt-key add -
--11:01:38--  http://debian.beryl-project.org/root@lupine.me.uk.gpg
          => `-'
Resolving debian.beryl-project.org... 208.113.193.9, 82.140.42.54
Connecting to debian.beryl-project.org|208.113.193.9|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 2,415 (2.4K) [application/x-troff-me]

100%[====================================>] 2,415         --.--K/s

11:01:39 (113.92 MB/s) - `-' saved [2415/2415]

OK
debian:/home/chris# gedit /etc/apt/sources.list

(gedit:3548): GnomeUI-WARNING **: While connecting to session manager:
Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed.
debian:/home/chris# apt-get update
Get:1 http://debian.telecoms.bg stable Release.gpg [378B]
Hit http://debian.telecoms.bg stable Release
Ign http://debian.telecoms.bg stable/main Packages/DiffIndex
Ign http://debian.telecoms.bg stable/contrib Packages/DiffIndex
Ign http://debian.telecoms.bg stable/non-free Packages/DiffIndex
Ign http://debian.telecoms.bg stable/main Sources/DiffIndex
Ign http://debian.telecoms.bg stable/contrib Sources/DiffIndex
Ign http://debian.telecoms.bg stable/non-free Sources/DiffIndex
Hit http://debian.telecoms.bg stable/main Packages
Hit http://debian.telecoms.bg stable/contrib Packages
Get:2 http://www.debian-multimedia.org stable Release.gpg [189B]
Hit http://debian.telecoms.bg stable/non-free Packages
Hit http://debian.telecoms.bg stable/main Sources
Hit http://debian.telecoms.bg stable/contrib Sources
Hit http://debian.telecoms.bg stable/non-free Sources
Get:3 http://www.debian-multimedia.org stable Release [5535B]
Get:4 http://security.debian.org etch/updates Release.gpg [189B]
Get:5 http://security.debian.org etch/updates Release [22.5kB]
Ign http://www.debian-multimedia.org stable/main Packages/DiffIndex
Get:6 http://sidux.com sid Release.gpg [189B]
Get:7 http://debian.beryl-project.org etch Release.gpg [191B]
Ign http://download.skype.com stable Release.gpg
Hit http://sidux.com sid Release
Hit http://www.debian-multimedia.org stable/main Packages
Err http://sidux.com sid Release

Get:8 http://sidux.com sid Release [30.8kB]
Get:9 http://http.us.debian.org sarge Release.gpg [378B]
Ign http://security.debian.org etch/updates/main Packages/DiffIndex
Ign http://download.skype.com stable Release
Hit http://debian.beryl-project.org etch Release
Ign http://security.debian.org etch/updates/contrib Packages/DiffIndex
Ign http://security.debian.org etch/updates/main Sources/DiffIndex
Ign http://security.debian.org etch/updates/contrib Sources/DiffIndex
Hit http://security.debian.org etch/updates/main Packages
Hit http://security.debian.org etch/updates/contrib Packages
Hit http://security.debian.org etch/updates/main Sources
Hit http://http.us.debian.org sarge Release
Hit http://security.debian.org etch/updates/contrib Sources
Ign http://sidux.com sid Release
Ign http://download.skype.com stable/non-free Packages/DiffIndex
Ign http://sidux.com sid/main Packages/DiffIndex
Ign http://debian.beryl-project.org etch/main Packages/DiffIndex
Ign http://sidux.com sid/contrib Packages/DiffIndex
Ign http://sidux.com sid/non-free Packages/DiffIndex
Ign http://sidux.com sid/firmware Packages/DiffIndex
Ign http://sidux.com sid/fix.main Packages/DiffIndex
Ign http://sidux.com sid/fix.contrib Packages/DiffIndex
Ign http://sidux.com sid/fix.non-free Packages/DiffIndex
Hit http://sidux.com sid/main Packages
Hit http://sidux.com sid/contrib Packages
Hit http://sidux.com sid/non-free Packages
Hit http://sidux.com sid/firmware Packages
Hit http://sidux.com sid/fix.main Packages
Hit http://sidux.com sid/fix.contrib Packages
Hit http://download.skype.com stable/non-free Packages
Hit http://sidux.com sid/fix.non-free Packages
Ign http://debian.beryl-project.org etch/main Sources/DiffIndex
Ign http://http.us.debian.org sarge/main Packages/DiffIndex
Ign http://http.us.debian.org sarge/main Packages
Hit http://debian.beryl-project.org etch/main Packages
Hit http://http.us.debian.org sarge/main Packages
Hit http://debian.beryl-project.org etch/main Sources
Fetched 59.8kB in 1s (39.6kB/s)
Reading package lists... Done
W: GPG error: http://sidux.com sid Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 3916C431F80994F6
W: You may want to run apt-get update to correct these problems
debian:/home/chris# apt-get install beryl beryl-core beryl-dev \
>    beryl-manager beryl-plugins beryl-plugins-data \
>    beryl-settings emerald emerald-themes
Reading package lists... Done
Building dependency tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 beryl-core: Depends: libgl1-mesa-glx but it is not going to be installed or
                      libgl1
             Depends: libgl1 or
                      libgl1-mesa-glx but it is not going to be installed
 beryl-dev: Depends: libgl-dev
 xserver-xorg-input-all: Depends: xserver-xorg-input-evdev but it is not going to be installed
                         Depends: xserver-xorg-input-kbd but it is not going to be installed
                         Depends: xserver-xorg-input-mouse but it is not going to be installed
                         Depends: xserver-xorg-input-synaptics but it is not going to be installed
E: Broken packages
Контакти:  iLife
WEB  
Мнение #13 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Септември 24 2007, 11:44
tolostoi

Avatar




Група: Li maniacs
Мнения: 869
Регистриран: Юли 2006

Оценка: 5

Offline
Покажи си /etc/apt/sources.list и това ми се е получавало, когато си имал преди берил от друго хранилище и не съм махнал всичко от него. Та освен от sources.list-a дай да видя как си инсталирал предният път (линк или там каквото е)

Мнение #14 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Септември 24 2007, 11:56
iLife

No avatar chosen




Група: Li fans
Мнения: 28
Регистриран: Септември 2007

Оценка: няма

Offline
Ето го sources.list
Код: 
deb http://debian.telecoms.bg/debian/ stable main contrib non-free
deb-src http://debian.telecoms.bg/debian/ stable main contrib non-free
deb http://security.debian.org/ etch/updates main contrib
deb-src http://security.debian.org/ etch/updates main contrib
deb http://http.us.debian.org/debian/ sarge main
deb http://www.debian-multimedia.org stable main

deb http://download.skype.com/linux/repos/debian/ stable non-free

deb http://sidux.com/debian/ sid main contrib non-free firmware fix.main fix.contrib fix.non-free

deb http://debian.beryl-project.org/ etch main

deb-src http://debian.beryl-project.org/ etch main


Ето и линка дето от него инсталирах преди Beryl

http://aptgetanarchy.org/node/115
Контакти:  iLife
WEB  
Мнение #15 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Септември 24 2007, 12:00
tolostoi

Avatar




Група: Li maniacs
Мнения: 869
Регистриран: Юли 2006

Оценка: 5

Offline
Едит: Сега видях това, разкарай този ред от sources.list
Код: 
deb http://http.us.debian.org/debian/ sarge main
и дай един смислен отговор защо си го сложил?

Пробвай така
Код: 
aptitude purge beryl beryl-core beryl-manager beryl-plugins beryl-plugins-data beryl-settings emerald emerald-themes libberylsettings0 libemeraldengine0
aptitude update
aptitude upgrade
aptitude install beryl beryl-core beryl-dev \
  beryl-manager beryl-plugins beryl-plugins-data \
  beryl-settings emerald emerald-themes
и дай да видим какво казва грешки всичко.


Редактирано от tolostoi на Септември 24 2007, 12:11

Мнение #16 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Септември 24 2007, 12:15
iLife

No avatar chosen




Група: Li fans
Мнения: 28
Регистриран: Септември 2007

Оценка: няма

Offline
Код: 
chris@debian:~$ su
Password:
debian:/home/chris# aptitude purge beryl beryl-core beryl-manager beryl-plugins beryl-plugins-data beryl-settings emerald emerald-themes libberylsettings0 libemeraldengine0
Reading package lists... Done
Building dependency tree... Done
Reading extended state information
Initializing package states... Done
Writing extended state information... Done
Reading task descriptions... Done
Building tag database... Done
The following packages are unused and will be REMOVED:
 bug-buddy eog esound evince evolution-common fast-user-switch-applet
 file-roller gcalctool gconf-editor gdb gdm gedit gedit-common
 gnome-backgrounds gnome-cards-data gnome-core gnome-games
 gnome-games-data gnome-keyring-manager gnome-nettool gnome-system-tools
 gnome-themes gnome-volume-manager gstreamer0.10-gnomevfs gtkhtml3.8
 gucharmap guile-1.6-libs industrial-cursor-theme iso-codes libdjvulibre15
 libdmx1 libexchange-storage1.2-1 libgnome-pilot2 libgnomevfs2-bin
 libgtkhtml3.8-15 libguile-ltdl-1 libkpathsea4 libnm-glib0 libopal-2.2.0
 libosp5 libpisock9 libpisync0 libpoppler0c2-glib libpt-1.10.0
 libpt-plugins-alsa libpt-plugins-v4l libqthreads-12 pmount sound-juicer
 system-tools-backends vino w3c-dtd-xhtml xulrunner-gnome-support zenity
 zip
The following packages have been kept back:
 initscripts liblircclient0 sysvinit sysvinit-utils
0 packages upgraded, 0 newly installed, 55 to remove and 4 not upgraded.
Need to get 0B of archives. After unpacking 169MB will be freed.
Do you want to continue? [Y/n/?] y
Writing extended state information... Done
(Reading database ... 74738 files and directories currently installed.)
Removing gnome-core ...
Removing bug-buddy ...
Removing eog ...
Removing esound ...
Removing evince ...
Removing evolution-common ...
Removing fast-user-switch-applet ...
Removing file-roller ...
Removing gcalctool ...
Removing gconf-editor ...
Removing gdb ...
Removing gdm ...
Removing gedit ...
Removing gedit-common ...
Removing gnome-backgrounds ...
Removing gnome-games ...
Removing gnome-games-data ...
Removing gnome-cards-data ...
Removing gnome-keyring-manager ...
Removing gnome-nettool ...
Removing gnome-system-tools ...
Removing gnome-themes ...
Removing gnome-volume-manager ...
Removing sound-juicer ...
Removing gstreamer0.10-gnomevfs ...
Removing gtkhtml3.8 ...
Removing gucharmap ...
Removing guile-1.6-libs ...
Removing industrial-cursor-theme ...
Removing iso-codes ...
Removing libdjvulibre15 ...
Removing libdmx1 ...
Removing libexchange-storage1.2-1 ...
Removing libgnome-pilot2 ...
Removing libgnomevfs2-bin ...
Removing libgtkhtml3.8-15 ...
Removing libguile-ltdl-1 ...
Removing libkpathsea4 ...
Removing libnm-glib0 ...
Removing libopal-2.2.0 ...
Removing libosp5 ...
Removing libpisync0 ...
Removing libpisock9 ...
Removing libpoppler0c2-glib ...
Removing libpt-plugins-v4l ...
Removing libpt-plugins-alsa ...
Removing libpt-1.10.0 ...
Removing libqthreads-12 ...
Removing pmount ...
Removing system-tools-backends ...
Removing vino ...
Removing w3c-dtd-xhtml ...
Removing xulrunner-gnome-support ...
Removing zenity ...
Removing zip ...
debian:/home/chris# aptitude update
Get:1 http://www.debian-multimedia.org stable Release.gpg [189B]
Get:2 http://debian.telecoms.bg stable Release.gpg [378B]
Hit http://www.debian-multimedia.org stable Release
Hit http://debian.telecoms.bg stable Release
Get:3 http://sidux.com sid Release.gpg [189B]
Ign http://download.skype.com stable Release.gpg
Hit http://sidux.com sid Release
Ign http://debian.telecoms.bg stable/main Packages/DiffIndex
Ign http://www.debian-multimedia.org stable/main Packages/DiffIndex
Ign http://debian.telecoms.bg stable/contrib Packages/DiffIndex
Ign http://debian.telecoms.bg stable/non-free Packages/DiffIndex
Err http://sidux.com sid Release

Ign http://debian.telecoms.bg stable/main Sources/DiffIndex
Ign http://debian.telecoms.bg stable/contrib Sources/DiffIndex
Ign http://debian.telecoms.bg stable/non-free Sources/DiffIndex
Hit http://debian.telecoms.bg stable/main Packages
Hit http://debian.telecoms.bg stable/contrib Packages
Hit http://www.debian-multimedia.org stable/main Packages
Hit http://debian.telecoms.bg stable/non-free Packages
Hit http://debian.telecoms.bg stable/main Sources
Hit http://debian.telecoms.bg stable/contrib Sources
Hit http://debian.telecoms.bg stable/non-free Sources
Get:4 http://sidux.com sid Release [30.8kB]
Ign http://download.skype.com stable Release
Get:5 http://debian.beryl-project.org etch Release.gpg [191B]
Ign http://sidux.com sid Release
Ign http://download.skype.com stable/non-free Packages/DiffIndex
Ign http://sidux.com sid/main Packages/DiffIndex
Get:6 http://security.debian.org etch/updates Release.gpg [189B]
Ign http://sidux.com sid/contrib Packages/DiffIndex
Ign http://sidux.com sid/non-free Packages/DiffIndex
Ign http://sidux.com sid/firmware Packages/DiffIndex
Ign http://sidux.com sid/fix.main Packages/DiffIndex
Ign http://sidux.com sid/fix.contrib Packages/DiffIndex
Ign http://sidux.com sid/fix.non-free Packages/DiffIndex
Get:7 http://http.us.debian.org sarge Release.gpg [378B]
Hit http://sidux.com sid/main Packages
Hit http://sidux.com sid/contrib Packages
Hit http://sidux.com sid/non-free Packages
Hit http://sidux.com sid/firmware Packages
Hit http://sidux.com sid/fix.main Packages
Hit http://sidux.com sid/fix.contrib Packages
Hit http://debian.beryl-project.org etch Release
Hit http://security.debian.org etch/updates Release
Hit http://download.skype.com stable/non-free Packages
Hit http://sidux.com sid/fix.non-free Packages
Hit http://http.us.debian.org sarge Release
Ign http://security.debian.org etch/updates/main Packages/DiffIndex
Ign http://debian.beryl-project.org etch/main Packages/DiffIndex
Ign http://security.debian.org etch/updates/contrib Packages/DiffIndex
Ign http://security.debian.org etch/updates/main Sources/DiffIndex
Ign http://debian.beryl-project.org etch/main Sources/DiffIndex
Ign http://security.debian.org etch/updates/contrib Sources/DiffIndex
Hit http://security.debian.org etch/updates/main Packages
Hit http://security.debian.org etch/updates/contrib Packages
Ign http://http.us.debian.org sarge/main Packages/DiffIndex
Hit http://security.debian.org etch/updates/main Sources
Hit http://security.debian.org etch/updates/contrib Sources
Hit http://debian.beryl-project.org etch/main Packages
Ign http://http.us.debian.org sarge/main Packages
Hit http://http.us.debian.org sarge/main Packages
Hit http://debian.beryl-project.org etch/main Sources
Fetched 31.4kB in 1s (17.5kB/s)
Reading package lists... Done
W: GPG error: http://sidux.com sid Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 3916C431F80994F6
W: You may want to run apt-get update to correct these problems
debian:/home/chris# aptitude upgrade
Reading package lists... Done
Building dependency tree... Done
Reading extended state information
Initializing package states... Done
Writing extended state information... Done
Reading task descriptions... Done
Building tag database... Done
The following packages have been kept back:
 initscripts liblircclient0 sysvinit sysvinit-utils
0 packages upgraded, 0 newly installed, 0 to remove and 4 not upgraded.
Need to get 0B of archives. After unpacking 0B will be used.
Writing extended state information... Done
debian:/home/chris# aptitude install beryl beryl-core beryl-dev \
>   beryl-manager beryl-plugins beryl-plugins-data \
>   beryl-settings emerald emerald-themes
Reading package lists... Done
Building dependency tree... Done
Reading extended state information
Initializing package states... Done
Reading task descriptions... Done
Building tag database... Done
The following packages are BROKEN:
 libgl1-mesa-dri mesag-dev x11-common xorg
The following NEW packages will be automatically installed:
 beryl-settings-bindings libberylsettings-dev libberylsettings0
 libemeraldengine0 libfontenc-dev libfreetype6-dev libglib2.0-dev
 libice-dev libpng12-dev libsm-dev libstartup-notification0-dev libx11-dev
 libxau-dev libxcomposite-dev libxdamage-dev libxdmcp-dev libxext-dev
 libxfixes-dev libxfont-dev libxi-dev libxinerama-dev libxmu-dev
 libxmu-headers libxmuu-dev libxp-dev libxpm-dev libxrandr-dev
 libxrender-dev libxt-dev libxtrap-dev libxtst-dev libxv-dev mesag3 pm-dev
 x-dev x11proto-composite-dev x11proto-core-dev x11proto-damage-dev
 x11proto-fixes-dev x11proto-fonts-dev x11proto-gl-dev x11proto-input-dev
 x11proto-kb-dev x11proto-print-dev x11proto-randr-dev x11proto-record-dev
 x11proto-render-dev x11proto-trap-dev x11proto-video-dev
 x11proto-xext-dev x11proto-xinerama-dev xfree86-common xlibs-dev
 xlibs-static-dev xtrans-dev zlib1g-dev
The following packages will be automatically REMOVED:
 libgl1-mesa-glx
The following packages have been kept back:
 initscripts liblircclient0 sysvinit sysvinit-utils
The following NEW packages will be installed:
 beryl beryl-core beryl-dev beryl-manager beryl-plugins beryl-plugins-data
 beryl-settings beryl-settings-bindings emerald emerald-themes
 libberylsettings-dev libberylsettings0 libemeraldengine0 libfontenc-dev
 libfreetype6-dev libglib2.0-dev libice-dev libpng12-dev libsm-dev
 libstartup-notification0-dev libx11-dev libxau-dev libxcomposite-dev
 libxdamage-dev libxdmcp-dev libxext-dev libxfixes-dev libxfont-dev
 libxi-dev libxinerama-dev libxmu-dev libxmu-headers libxmuu-dev libxp-dev
 libxpm-dev libxrandr-dev libxrender-dev libxt-dev libxtrap-dev
 libxtst-dev libxv-dev mesag3 pm-dev x-dev x11proto-composite-dev
 x11proto-core-dev x11proto-damage-dev x11proto-fixes-dev
 x11proto-fonts-dev x11proto-gl-dev x11proto-input-dev x11proto-kb-dev
 x11proto-print-dev x11proto-randr-dev x11proto-record-dev
 x11proto-render-dev x11proto-trap-dev x11proto-video-dev
 x11proto-xext-dev x11proto-xinerama-dev xfree86-common xlibs-dev
 xlibs-static-dev xtrans-dev zlib1g-dev
The following packages will be REMOVED:
 libgl1-mesa-glx
0 packages upgraded, 66 newly installed, 1 to remove and 4 not upgraded.
Need to get 7450kB/12.7MB of archives. After unpacking 39.2MB will be used.
The following packages have unmet dependencies:
 mesag-dev: Depends: mesa-common-dev (= 5.0.0-5.1) but it is not installable
 libgl1-mesa-dri: Depends: libgl1-mesa-glx (= 6.5.1-0.6) but it is not installable
 x11-common: Conflicts: xfree86-common but 4.3.0.dfsg.1-14sarge3 is to be installed.
 xorg: Depends: libgl1-mesa-glx but it is not installable
Resolving dependencies...
The following actions will resolve these dependencies:

Install the following packages:
libgl1-mesa-dev [6.5.1-0.6 (stable)]
mesa-common-dev [6.5.1-0.6 (stable)]

Keep the following packages at their current version:
libgl1-mesa-glx [6.5.1-0.6 (stable, now)]
mesag-dev [Not Installed]
mesag3 [Not Installed]
pm-dev [Not Installed]
xfree86-common [Not Installed]
xlibs-dev [Not Installed]

Score is -26

Accept this solution? [Y/n/q/?] y
The following NEW packages will be automatically installed:
 beryl-settings-bindings libberylsettings-dev libberylsettings0
 libemeraldengine0 libgl1-mesa-dev libglib2.0-dev libpng12-dev
 libstartup-notification0-dev libx11-dev libxau-dev libxcomposite-dev
 libxdamage-dev libxdmcp-dev libxext-dev libxfixes-dev libxinerama-dev
 libxrandr-dev libxrender-dev mesa-common-dev x11proto-composite-dev
 x11proto-core-dev x11proto-damage-dev x11proto-fixes-dev x11proto-gl-dev
 x11proto-input-dev x11proto-kb-dev x11proto-randr-dev x11proto-render-dev
 x11proto-xext-dev x11proto-xinerama-dev xtrans-dev zlib1g-dev
The following packages have been kept back:
 initscripts liblircclient0 sysvinit sysvinit-utils
The following NEW packages will be installed:
 beryl beryl-core beryl-dev beryl-manager beryl-plugins beryl-plugins-data
 beryl-settings beryl-settings-bindings emerald emerald-themes
 libberylsettings-dev libberylsettings0 libemeraldengine0 libgl1-mesa-dev
 libglib2.0-dev libpng12-dev libstartup-notification0-dev libx11-dev
 libxau-dev libxcomposite-dev libxdamage-dev libxdmcp-dev libxext-dev
 libxfixes-dev libxinerama-dev libxrandr-dev libxrender-dev
 mesa-common-dev x11proto-composite-dev x11proto-core-dev
 x11proto-damage-dev x11proto-fixes-dev x11proto-gl-dev x11proto-input-dev
 x11proto-kb-dev x11proto-randr-dev x11proto-render-dev x11proto-xext-dev
 x11proto-xinerama-dev xtrans-dev zlib1g-dev
0 packages upgraded, 41 newly installed, 0 to remove and 4 not upgraded.
Need to get 3118kB/8407kB of archives. After unpacking 26.1MB will be used.
Do you want to continue? [Y/n/?] y
Writing extended state information... Done
Get:1 http://debian.telecoms.bg stable/main x11proto-core-dev 7.0.7-2 [78.4kB]
Get:2 http://debian.telecoms.bg stable/main libxau-dev 1:1.0.1-2 [10.8kB]
Get:3 http://debian.telecoms.bg stable/main libxdmcp-dev 1:1.0.1-2 [13.8kB]
Get:4 http://debian.telecoms.bg stable/main x11proto-input-dev 1.3.2-4 [14.6kB]
Get:5 http://debian.telecoms.bg stable/main x11proto-xext-dev 7.0.2-5 [41.7kB]
Get:6 http://debian.telecoms.bg stable/main libxext-dev 1:1.0.1-2 [74.9kB]
Get:7 http://debian.telecoms.bg stable/main x11proto-kb-dev 1.0.3-2 [26.8kB]
Get:8 http://debian.telecoms.bg stable/main xtrans-dev 1.0.1-3 [59.0kB]
Get:9 http://debian.telecoms.bg stable/main libx11-dev 2:1.0.3-7 [1269kB]
Get:10 http://debian.beryl-project.org etch/main libberylsettings-dev 0.2.0~0beryl1 [41.9kB]
Get:11 http://debian.telecoms.bg stable/main x11proto-fixes-dev 4.0-2 [5640B]
Get:12 http://debian.telecoms.bg stable/main libxfixes-dev 1:4.0.1-5 [11.8kB]
Get:13 http://debian.telecoms.bg stable/main x11proto-composite-dev 0.3.1-2 [4100B]
Get:14 http://debian.telecoms.bg stable/main libxcomposite-dev 1:0.3-3 [6194B]
Get:15 http://debian.telecoms.bg stable/main x11proto-damage-dev 1.0.3-4 [4028B]Get:16 http://debian.telecoms.bg stable/main libxdamage-dev 1:1.0.3-3 [6196B]
Get:17 http://debian.telecoms.bg stable/main x11proto-xinerama-dev 1.1.2-4 [5074B]
Get:18 http://debian.telecoms.bg stable/main libxinerama-dev 1:1.0.1-4.1 [5200B]Get:19 http://debian.telecoms.bg stable/main x11proto-randr-dev 1.1.2-4 [4726B]
Get:20 http://debian.telecoms.bg stable/main x11proto-render-dev 2:0.9.2-4 [6606B]
Get:21 http://debian.telecoms.bg stable/main libxrender-dev 1:0.9.1-3 [24.2kB]
Get:22 http://debian.telecoms.bg stable/main libxrandr-dev 2:1.1.0.2-5 [8542B]
Get:23 http://debian.beryl-project.org etch/main beryl-dev 0.2.0~0beryl1 [31.3kB]
Get:24 http://debian.telecoms.bg stable/main x11proto-gl-dev 1.4.8-1 [30.8kB]
Get:25 http://debian.telecoms.bg stable/main mesa-common-dev 6.5.1-0.6 [158kB]
Get:26 http://debian.telecoms.bg stable/main libgl1-mesa-dev 6.5.1-0.6 [32.4kB]
Get:27 http://debian.telecoms.bg stable/main libstartup-notification0-dev 0.8-2 [23.6kB]
Get:28 http://debian.telecoms.bg stable/main zlib1g-dev 1:1.2.3-13 [406kB]
Get:29 http://debian.telecoms.bg stable/main libpng12-dev 1.2.15~beta5-1 [172kB]Get:30 http://debian.telecoms.bg stable/main libglib2.0-dev 2.12.4-2 [540kB]
Fetched 3118kB in 1s (2096kB/s)
Extracting templates from packages: 100%
Selecting previously deselected package x11proto-core-dev.
(Reading database ... 69304 files and directories currently installed.)
Unpacking x11proto-core-dev (from .../x11proto-core-dev_7.0.7-2_all.deb) ...
Selecting previously deselected package libxau-dev.
Unpacking libxau-dev (from .../libxau-dev_1%3a1.0.1-2_i386.deb) ...
Selecting previously deselected package libxdmcp-dev.
Unpacking libxdmcp-dev (from .../libxdmcp-dev_1%3a1.0.1-2_i386.deb) ...
Selecting previously deselected package x11proto-input-dev.
Unpacking x11proto-input-dev (from .../x11proto-input-dev_1.3.2-4_all.deb) ...
Selecting previously deselected package x11proto-xext-dev.
Unpacking x11proto-xext-dev (from .../x11proto-xext-dev_7.0.2-5_all.deb) ...
Selecting previously deselected package libxext-dev.
Unpacking libxext-dev (from .../libxext-dev_1%3a1.0.1-2_i386.deb) ...
Selecting previously deselected package x11proto-kb-dev.
Unpacking x11proto-kb-dev (from .../x11proto-kb-dev_1.0.3-2_all.deb) ...
Selecting previously deselected package xtrans-dev.
Unpacking xtrans-dev (from .../xtrans-dev_1.0.1-3_all.deb) ...
Selecting previously deselected package libx11-dev.
Unpacking libx11-dev (from .../libx11-dev_2%3a1.0.3-7_i386.deb) ...
Selecting previously deselected package x11proto-fixes-dev.
Unpacking x11proto-fixes-dev (from .../x11proto-fixes-dev_4.0-2_all.deb) ...
Selecting previously deselected package libxfixes-dev.
Unpacking libxfixes-dev (from .../libxfixes-dev_1%3a4.0.1-5_i386.deb) ...
Selecting previously deselected package x11proto-composite-dev.
Unpacking x11proto-composite-dev (from .../x11proto-composite-dev_0.3.1-2_all.deb) ...
Selecting previously deselected package libxcomposite-dev.
Unpacking libxcomposite-dev (from .../libxcomposite-dev_1%3a0.3-3_i386.deb) ...
Selecting previously deselected package x11proto-damage-dev.
Unpacking x11proto-damage-dev (from .../x11proto-damage-dev_1.0.3-4_all.deb) ...Selecting previously deselected package libxdamage-dev.
Unpacking libxdamage-dev (from .../libxdamage-dev_1%3a1.0.3-3_i386.deb) ...
Selecting previously deselected package x11proto-xinerama-dev.
Unpacking x11proto-xinerama-dev (from .../x11proto-xinerama-dev_1.1.2-4_all.deb) ...
Selecting previously deselected package libxinerama-dev.
Unpacking libxinerama-dev (from .../libxinerama-dev_1%3a1.0.1-4.1_i386.deb) ...
Selecting previously deselected package x11proto-randr-dev.
Unpacking x11proto-randr-dev (from .../x11proto-randr-dev_1.1.2-4_all.deb) ...
Selecting previously deselected package x11proto-render-dev.
Unpacking x11proto-render-dev (from .../x11proto-render-dev_2%3a0.9.2-4_all.deb) ...
Selecting previously deselected package libxrender-dev.
Unpacking libxrender-dev (from .../libxrender-dev_1%3a0.9.1-3_i386.deb) ...
Selecting previously deselected package libxrandr-dev.
Unpacking libxrandr-dev (from .../libxrandr-dev_2%3a1.1.0.2-5_i386.deb) ...
Selecting previously deselected package libberylsettings0.
Unpacking libberylsettings0 (from .../libberylsettings0_0.2.0~0beryl1_i386.deb) ...
Selecting previously deselected package beryl-core.
Unpacking beryl-core (from .../beryl-core_0.2.0~0beryl1_i386.deb) ...
Selecting previously deselected package beryl-plugins-data.
Unpacking beryl-plugins-data (from .../beryl-plugins-data_0.2.0~0beryl1_all.deb) ...
Selecting previously deselected package beryl-plugins.
Unpacking beryl-plugins (from .../beryl-plugins_0.2.0~0beryl1_i386.deb) ...
Selecting previously deselected package beryl-settings-bindings.
Unpacking beryl-settings-bindings (from .../beryl-settings-bindings_0.2.0~0beryl1_i386.deb) ...
Selecting previously deselected package beryl-settings.
Unpacking beryl-settings (from .../beryl-settings_0.2.0~0beryl1_i386.deb) ...
Selecting previously deselected package libemeraldengine0.
Unpacking libemeraldengine0 (from .../libemeraldengine0_0.2.0~0beryl1_i386.deb) ...
Selecting previously deselected package emerald.
Unpacking emerald (from .../emerald_0.2.0~0beryl1_i386.deb) ...
Selecting previously deselected package beryl-manager.
Unpacking beryl-manager (from .../beryl-manager_0.2.0~0beryl1_i386.deb) ...
Selecting previously deselected package beryl.
Unpacking beryl (from .../beryl_0.2.0~0beryl1_i386.deb) ...
Selecting previously deselected package libberylsettings-dev.
Unpacking libberylsettings-dev (from .../libberylsettings-dev_0.2.0~0beryl1_i386.deb) ...
Selecting previously deselected package x11proto-gl-dev.
Unpacking x11proto-gl-dev (from .../x11proto-gl-dev_1.4.8-1_all.deb) ...
Selecting previously deselected package mesa-common-dev.
Unpacking mesa-common-dev (from .../mesa-common-dev_6.5.1-0.6_all.deb) ...
Selecting previously deselected package libgl1-mesa-dev.
Unpacking libgl1-mesa-dev (from .../libgl1-mesa-dev_6.5.1-0.6_i386.deb) ...
Selecting previously deselected package libstartup-notification0-dev.
Unpacking libstartup-notification0-dev (from .../libstartup-notification0-dev_0.8-2_i386.deb) ...
Selecting previously deselected package zlib1g-dev.
Unpacking zlib1g-dev (from .../zlib1g-dev_1%3a1.2.3-13_i386.deb) ...
Selecting previously deselected package libpng12-dev.
Unpacking libpng12-dev (from .../libpng12-dev_1.2.15~beta5-1_i386.deb) ...
Selecting previously deselected package libglib2.0-dev.
Unpacking libglib2.0-dev (from .../libglib2.0-dev_2.12.4-2_i386.deb) ...
Selecting previously deselected package beryl-dev.
Unpacking beryl-dev (from .../beryl-dev_0.2.0~0beryl1_i386.deb) ...
Selecting previously deselected package emerald-themes.
Unpacking emerald-themes (from .../emerald-themes_0.2.0~0beryl1_all.deb) ...
Setting up x11proto-core-dev (7.0.7-2) ...
Setting up libxau-dev (1.0.1-2) ...
Setting up libxdmcp-dev (1.0.1-2) ...
Setting up x11proto-input-dev (1.3.2-4) ...
Setting up x11proto-xext-dev (7.0.2-5) ...
Setting up x11proto-kb-dev (1.0.3-2) ...
Setting up xtrans-dev (1.0.1-3) ...
Setting up x11proto-fixes-dev (4.0-2) ...
Setting up x11proto-composite-dev (0.3.1-2) ...
Setting up x11proto-damage-dev (1.0.3-4) ...
Setting up x11proto-xinerama-dev (1.1.2-4) ...
Setting up x11proto-randr-dev (1.1.2-4) ...
Setting up x11proto-render-dev (0.9.2-4) ...
Setting up libberylsettings0 (0.2.0~0beryl1) ...

Setting up beryl-core (0.2.0~0beryl1) ...

Setting up beryl-plugins-data (0.2.0~0beryl1) ...
Setting up beryl-plugins (0.2.0~0beryl1) ...
Setting up beryl-settings-bindings (0.2.0~0beryl1) ...

Setting up beryl-settings (0.2.0~0beryl1) ...
Setting up libberylsettings-dev (0.2.0~0beryl1) ...
Setting up x11proto-gl-dev (1.4.8-1) ...
Setting up mesa-common-dev (6.5.1-0.6) ...
Setting up zlib1g-dev (1.2.3-13) ...
Setting up libpng12-dev (1.2.15~beta5-1) ...
Setting up libglib2.0-dev (2.12.4-2) ...
Setting up libemeraldengine0 (0.2.0~0beryl1) ...

Setting up beryl-manager (0.2.0~0beryl1) ...
Setting up libxext-dev (1.0.1-2) ...
Setting up emerald (0.2.0~0beryl1) ...

Setting up beryl (0.2.0~0beryl1) ...
Setting up emerald-themes (0.2.0~0beryl1) ...
Setting up libx11-dev (1.0.3-7) ...
Setting up libxfixes-dev (4.0.1-5) ...
Setting up libxcomposite-dev (0.3-3) ...
Setting up libxdamage-dev (1.0.3-3) ...
Setting up libxinerama-dev (1.0.1-4.1) ...
Setting up libxrender-dev (0.9.1-3) ...
Setting up libxrandr-dev (1.1.0.2-5) ...
Setting up libgl1-mesa-dev (6.5.1-0.6) ...
Setting up libstartup-notification0-dev (0.8-2) ...
Setting up beryl-dev (0.2.0~0beryl1) ...
debian:/home/chris#
Контакти:  iLife
WEB  
Мнение #17 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Септември 24 2007, 12:19
iLife

No avatar chosen




Група: Li fans
Мнения: 28
Регистриран: Септември 2007

Оценка: няма

Offline
Ама виж кои пакети ми изтри :
Код: 
bug-buddy eog esound evince evolution-common fast-user-switch-applet
file-roller gcalctool gconf-editor gdb gdm gedit gedit-common
gnome-backgrounds gnome-cards-data gnome-core gnome-games
gnome-games-data gnome-keyring-manager gnome-nettool gnome-system-tools
gnome-themes gnome-volume-manager gstreamer0.10-gnomevfs gtkhtml3.8
gucharmap guile-1.6-libs industrial-cursor-theme iso-codes libdjvulibre15
libdmx1 libexchange-storage1.2-1 libgnome-pilot2 libgnomevfs2-bin
libgtkhtml3.8-15 libguile-ltdl-1 libkpathsea4 libnm-glib0 libopal-2.2.0
libosp5 libpisock9 libpisync0 libpoppler0c2-glib libpt-1.10.0
libpt-plugins-alsa libpt-plugins-v4l libqthreads-12 pmount sound-juicer
system-tools-backends vino w3c-dtd-xhtml xulrunner-gnome-support zenity
zip

Според мене те ми трябват.. или само така си мисля :14; най-малкото поне gedit и gdm ???
Контакти:  iLife
WEB  
Мнение #18 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Септември 24 2007, 12:21
tolostoi

Avatar




Група: Li maniacs
Мнения: 869
Регистриран: Юли 2006

Оценка: 5

Offline
Ауу пич, виж едита в горният пост (махни реда с хранилището за sarge) и си инсталирай и пакета гноме
Код: 
aptitude install gnome
щото като гледам какво ти е махнало нема да може да ти тръгне машината, после дай пак
Код: 
aptitude update
aptitude upgrade
сега ще ги погледна нещата пак.

Даже махни и хранилището на sidux (то е за нестабилен дебиан, не знам какво има в него като ти потрябва по нататък пак можеш да го сложиш, за това говоря
Код: 
deb http://sidux.com/debian/ sid main contrib non-free firmware fix.main fix.contrib fix.non-free
значи първо си оправяш хранилищата, като махаш тези двете които ти посочих, после
Код: 
aptitude update
aptitude upgrade
aptitude install xorg gnome
и после пробвай да инсталираш берил, че се омаза системата :)


Редактирано от tolostoi на Септември 24 2007, 12:31

Мнение #19 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Септември 24 2007, 12:28
iLife

No avatar chosen




Група: Li fans
Мнения: 28
Регистриран: Септември 2007

Оценка: няма

Offline
Що къв е тоя sarge? Аз взех готов лист и си го пейстнах (не помня къде го гледах)
Контакти:  iLife
WEB  
Мнение #20
Skip to the previous post in this topic. Написано на: Септември 24 2007, 12:32
tolostoi

Avatar




Група: Li maniacs
Мнения: 869
Регистриран: Юли 2006

Оценка: 5

Offline
Цитат:  (iLife @ Септември 24 2007,12:28)

Що къв е тоя sarge? Аз взех готов лист и си го пейстнах (не помня къде го гледах)

sarge e по-стара версия на Дебиан виж горе какво ти писах.

Общо 31 отговор(а) от Септември 23 2007, 12:25 до сега
 » Начало » Li Форуми » Help & Support » X Window & GUI » Как да пусна Beryl?

© 2014 Linux Index Project
Powered by iF 1.0.0 © 2006 ikonForums