Запомняне

» Здравейте
[ Вход :: Регистриране ]
 » Начало » Li Форуми » Help & Support » X Window & GUI » widescreen 1680x1050
Тема: widescreen 1680x1050, честита ми първа тема :)
Мнение #11 Skip to the next post in this topic.
Написано на: Февруари 20 2008, 12:30

No avatar chosen




Група: Li gurus
Мнения: 1489
Регистриран: Април 2005

Оценка: 5

Offline
Код: 
mcwolf@mcwolf:~$ gtf 1680 1050 75

 # 1680x1050 @ 75.00 Hz (GTF) hsync: 82.20 kHz; pclk: 188.07 MHz
 Modeline "1680x1050_75.00"  188.07  1680 1800 1984 2288  1050 1051 1054 1096  -HSync +Vsync

зарежете честотата - тя не е проблем борбата е да накараме пущината да задържи 1680x1050 при зареждане на графичната среда без допълнителни шпагати
Контакти:  mcwolf

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #12 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Февруари 21 2008, 09:15

No avatar chosen




Група: Li gurus
Мнения: 1489
Регистриран: Април 2005

Оценка: 5

Offline
всичко предложено до тук не върши работа :29;
са се сещам - има ли значение това че ползвам цифровият вход а не аналоговоя ?

Редактирано от mcwolf на Февруари 21 2008, 10:26
Контакти:  mcwolf

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #13 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Февруари 21 2008, 13:43

Avatar




Група: Li maniacs
Мнения: 869
Регистриран: Юли 2006

Оценка: 5

Offline
Може да пробваш, ма все ми се струва, че чакане му е майката, тоя новият X.Org X Server 1.4 си има собствено мнение за всичко, аз в една друга тема ти бях писал, че почти целият xorg.conf да разкараш, пак си бачка и секцията composite не му трябва, каква е картата, няма ли да тръгне с не-легаси драйвера? Може там да са по-напред нещата.
A сега намерих темата, ето го xorg-a с който всичко си работеше без грижи. Дори Option редовете в Section "InputDevice" после ги разкарах и пак всичко си беше ОК. Явно проблема идва като не сме на едно и също мение с него :), предполагам има някоя опция която може да го принуди да ползва това което искаш, но не съм я засичал :(
Код: 
# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
  Identifier   "Generic Keyboard"
  Driver      "kbd"
  Option      "XkbRules"   "xorg"
  Option      "XkbModel"   "pc105"
  Option      "XkbLayout"   "us"
EndSection

Section "InputDevice"
  Identifier   "Configured Mouse"
  Driver      "mouse"
  Option      "Emulate3Buttons"   "true"
EndSection

Section "Device"
  Identifier   "Configured Video Device"
EndSection

Section "Monitor"
  Identifier   "Configured Monitor"
EndSection

Section "Screen"
  Identifier   "Default Screen"
  Monitor      "Configured Monitor"
EndSection

Мнение #14 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Февруари 22 2008, 09:09

No avatar chosen




Група: Li gurus
Мнения: 1489
Регистриран: Април 2005

Оценка: 5

Offline
и така съм пробвал (затова обърнах внимание че когато не съм задал 1680х1050 след това нямам възможност да мина ръчно на тази резолюция - така че трябва поне тя да е описана в конфиг файлът) - (драйверът които ползвам не е legacy)- тествал съм с nv и новия драйвер (100.*) - в момента си ползвам 96.43

проблемът малко вероятно да е в него - резолюцията си се разпознава коректно и Х-а се вдига именно на нея - зарежда логин мениджърът (пробвал съм с kdm и gdm) на желаната резолюция но при зареждане на графичната среда по неведоми пътища минава на 1280x1024_60 (при 60Hz) без да дава никакви обяснения защо (обърни внимание на краят на лог файловете от първият ми пост - това е един и същи файл но след всяко действие)

след ръчна промяна на резолюцията захапва съвсем културно на 1680x1050 при 75Hz (това са препоръчителните стойности за мониторът)

взех да си мисля да не би да се биииип дигиталния вход и повторих всички тестова на аналоговия - никаква промяна
Контакти:  mcwolf

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #15 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Февруари 22 2008, 10:18

Avatar




Група: Li maniacs
Мнения: 869
Регистриран: Юли 2006

Оценка: 5

Offline
С ubuntu подобни грижи имах, по същият начин се получаваш като при теб, оправи се след като влязох в приложението за настройка на резолюциите, те са две - едно юзърско и едно което си иска парола, та това което искаше парола стартирах (не помня на кубунту има ли ги тези мениджъри или са само за гнома) избрах си модела на монитора и резолюция и рифреш, след това ми каза, че трябва логаут за да влязат в сила (явно го прилага за всички потребители) логаутнах се веднага(без да правя нищо друго) и след това като влязох всичко беше както го бях задал. Иначе преди това, ги сменях(пак от същият мениджър), запазвах, рестартирах ръчно Х-а, че и машината - все нещо не беше както трябва, или резолюцията не беше същата или рифреша, дори ми пишеше някаква резолюция а аз я виждам, че не е такава (примерно пише 1280Х1024, а пък аз я виждам, че е 1024Х768, не съм се объркал, със сигурност, или рифреша пише един като проверя от менюто на монитора виждам, че не е същият) Звучи малко тъпо, но след като направих точно каквото си пишеше и стана (нали все знаем как става и много не им обръщаме внимание на тези надписи  :D ) Това беше на 7.10 ти си с Херон-а. А иначе драйвера си е легаси, ползвах го на geforce 2-ката, те сега са (ако не си обръщал внимание, един latest и 2 поколения легаси)
Цитат: 

Linux IA32
Latest Version: 169.07
Latest Legacy GPU version (1.0-71xx series): 71.86.04
Latest Legacy GPU version (1.0-96xx series): 96.43.05


#офтопик
Остана да пробваш и гнома (тъкмо ще видиш докъде се е развил)  :P

Мнение #16 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Февруари 22 2008, 10:50

No avatar chosen




Група: Li gurus
Мнения: 1489
Регистриран: Април 2005

Оценка: 5

Offline
щом е толкова зле тоя драйвер мятам новия :)
а иначе съм пробвал и с gnome и kde3
Контакти:  mcwolf

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #17 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Март 07 2008, 20:26

No avatar chosen




Група: Li gurus
Мнения: 1489
Регистриран: Април 2005

Оценка: 5

Offline
и сега решението на проблемът
Код: 
rm -fr ~/.kde ~/.kde4

или казано по друг начин ресет на профила и работата заспа :P
Контакти:  mcwolf

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #18 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Март 12 2008, 16:19

Avatar




Група: Li maniacs
Мнения: 560
Регистриран: Юли 2006

Оценка: 4

Offline
Цитат: (mcwolf @ Февруари 20 2008, 10:57)

modeline-а влияе на честотата на мониторът и не би трябвало да има отношение към резолюцията (по скоро е обратното - честотата зависи от резолюцията)

ползваните тук стойности са за честоти съответно 59.62Hz(тая ме съмнява нещо), 60Hz, 75Hz, 85Hz, 100Hz

макар че и това ще пробвам де

Ела да го кажеш на моя Acer, който без modeline не може да тръгне на 1400x900 :). Настрой си modeline-a и би трябвало да потегли, само че внимавай както ти казаха по - нагоре  :21;

Контакти:  nikolavp

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #19
Skip to the previous post in this topic. Написано на: Март 13 2008, 09:33

No avatar chosen




Група: Li gurus
Мнения: 1489
Регистриран: Април 2005

Оценка: 5

Offline
проблемът си се реши без никакви шпагати - единствено със задаване на желаната резолюция (след премахване на двете "конфигурационни директории" всичко си запали) след това просто сложих metamodes за да подкарам пущината на 75 херца (ползвам auto-select-а от предната страница - първият ми пост)

то беше видно от лог файловете че при вдигане на графичната среда се получаваше смяната на резолюцията - само не разбрах защо Gnome правеше същата мизерия като очевидно проблемът е бил в конфигурацията на едно от двете KDE-та :14;

Редактирано от mcwolf на Март 13 2008, 09:38
Контакти:  mcwolf

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Общо 18 отговор(а) от Февруари 19 2008, 10:57 до сега
 » Начало » Li Форуми » Help & Support » X Window & GUI » widescreen 1680x1050

© 2014 Linux Index Project
Powered by iF 1.0.0 © 2006 ikonForums