Запомняне

» Здравейте
[ Вход :: Регистриране ]
 » Начало » Li Форуми » Help & Support » X Window & GUI » проблем със старт на slackware 12
Тема: проблем със старт на slackware 12, проблем със старт na графична среда
Мнение #1 Skip to the next post in this topic.
Написано на: Март 02 2008, 18:52

No avatar chosen


Warn 1

Група: Li fans
Мнения: 9
Регистриран: Март 2008

Оценка: няма

Offline
Значи имам следният проблем току що си инсталирах слакуер 12 като зададох КДЕ да е дефаулт графична среда,инсталацията протече без проблеми но след като се логна пиша 'startx' и ми се изгася монитора.След това инсталнах слака на ново но шал същия проблем пак ми изписва на монитора "No signal detected" и пак се изгася.аз сум нов в слак и моля за вашето съдействие.Благодаря предварително
Контакти:  pennywise

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #2 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Март 03 2008, 13:21

Avatar




Група: Li fans
Мнения: 621
Регистриран: Декември 2006

Оценка: 5

Offline
Пробвай да влезеш в текстов режим /ctrl+alt+F2/ и погледни какво пише в xorg.conf - карта честота и т.н. ако нещо не е наред го промени.
edit Пробвай да смениш драйвъра на видеото оттам

Редактирано от devik на Март 03 2008, 13:22
Контакти:  devik
WEB  
Мнение #3 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Март 03 2008, 14:10

No avatar chosen


Warn 1

Група: Li fans
Мнения: 9
Регистриран: Март 2008

Оценка: няма

Offline
добре как точно да го оправя прегледах xorg-a сложих # HorizSync 28-50
# VertRefresh 43-75 и пак не става,а пък дори не съм бутал нищо просто ги инсталирах написах startx и до там монитора се изгася и нищо повече,картата ми е Nvidia mx 440 ,монитора Benq FP71G+, и после всеки ми хвали линукса че нямал никви бъгове и тн. нз ама под бозата не ми е ставало така може да има мноо недостатаци ама чак толкова големи бъгове няма.изтрих си целия хард само заради нямам боза и сичко свързано с нея и сеа инсталлнах слака и веднага нещо се преебава,нз закво го хвалите толкоз тоз линукс

Редактирано от pennywise на Март 03 2008, 14:13
Контакти:  pennywise

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #4 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Март 03 2008, 17:10

Avatar




Група: Li fans
Мнения: 398
Регистриран: Март 2006

Оценка: няма

Offline
Значи преди да бълваш гущери и жаби, не би било зле да попрочтеш нещо... В Линукс, ОСОБЕНО В ДИСТРИБУЦИЯТА SLACKWARE нищо не е предварително настроено и не се самонастройва... За това има грижата потребителя.Просто си прегледай спецификацията на монитора, и не само честотите ами и разделителната способност, с кой точно модул ще работи(драйвер му викат в бозата)...Не знам кой точно те е накарал да се спреш на Slackware, но тоова изобщо не е за тепърва прохождащи... Изтегли си UBUNTU, или Mandriva... може и openSUSE...

И пак повтарям - прочети тук примерно повече за настройка на xorg, има писано с тонове - използувай търсачката...

Направо звучиш смешно като употребяваш думата "бъгове" относно точно твоя проблем...

Успех !  :)

"Imagination is more important than knoledge" A.Einstein
Контакти:  delafer
Мнение #5 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Март 03 2008, 17:46

No avatar chosen


Warn 1

Група: Li fans
Мнения: 9
Регистриран: Март 2008

Оценка: няма

Offline
използвал съм Ubuntu и OpenSuse 10.3 с Gnome,Kde,Xfce,blackbox едновремменно и нямах никакви проблеми,а относно слак-а съм го инсталвал на лаптопа без никакви проблеми и ми се струва, че системата сама трябва да си разпознае основните компненти защото ако не ги разпознае то трябва да се конфигурира винаги след инсталация,и потребителя има грижата да си до-настрои  така както да върви оптимално и както му харесва и това с монитора си е чист "бъг" ти май само на теория си богат ама на практика си един "хлебар" направо много ми помогна и мислиш ли че преди да напиша тази тема не съм търсил във форума и намерих една подобна тема ,направих всичко по описанието и пак същата работа,така че исках помощ а не "Теория"

Редактирано от pennywise на Март 03 2008, 17:49
Контакти:  pennywise

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #6 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Март 03 2008, 20:03

Avatar




Група: Li fans
Мнения: 398
Регистриран: Март 2006

Оценка: няма

Offline
Вместо да сипеш епитети по пишещите по темата ти, да беше копирал тук текста на твоя xorg.conf...
Хлебари не знам дали сме (конкретно аз в случая), но със сигурност врачки не сме...
Аз не съм най-големия капацитет по Slackware тук, но със сигурност съм един от тези дето я използуват и до ден днешен...
И ще ти кажа само това - че е тръгнал X-а особено на лаптопа ти е било въпрос на чиста случайност...

Коректния начин в Slackware да си настроиш X-a е да си стартираш програмата xorgconfig - по принцип при нея се достига в крайна сметка до най-близки параметри до тези които са ти необходими... В общия случай не ти е необходимо да пипаш нищо повече... Внимателно чети какво те пита и попълвай каквото ти е необходимо. И пиши какво е станало.

Пак ще ти кажа, вероятността да става въпрос за бъг точно в твоя случай клони към нула...

Редактирано от delafer на Март 03 2008, 20:07

"Imagination is more important than knoledge" A.Einstein
Контакти:  delafer
Мнение #7 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Март 03 2008, 21:08

No avatar chosen


Warn 1

Група: Li fans
Мнения: 9
Регистриран: Март 2008

Оценка: няма

Offline
значи сега е било случайност да тръгне,незнам за какви случайности говориш ама една ОС не трябва да тръгва с проблеми и няма никакви случайности ако системата беше написана правилно нямаше да тругва с проблеми и това си е чист бъг,ако не беше бъг нямаше да има никакви проблеми и никога не съм говорил в множествено число чисто и просто ти казах че си "хлебар" ( ГЛУПАК,Fool,Moron,Hooker )!  и ми кажи как да го копирам тоз xorg??помисли малко,то ако беше всичко наред нямаше да пиша тази тема от другия комп. И ще ми кажеш ли тогава към къкво клони? това че ми дава проблем веднага след инсталацията без дори да съм пипал нещо какво е според теб "Перфектното функциониране на ОС-то" ли ? и единствения друг  който отговори по темата е devik за която му благодаря а не тръгна веднага кат теб с haterstvo

Редактирано от pennywise на Март 03 2008, 21:10
Контакти:  pennywise

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #8 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Март 03 2008, 21:33

Avatar




Група: Li fans
Мнения: 240
Регистриран: Август 2005

Оценка: няма

Offline
Сладур  :8;

Както вече ти казаха, в Slackware шанса да ти тръгне X-а нормално без да си барал нищичко е минимален (при мен поне така и никога не се и случи).

По темата:
След като нашишеш startx и ти угасне монитора, натисни Ctrl-Alt-Backspace (едновременно). Така ще убиеш X сървъра и ще излезеш обратно в конозлата. Загледай се в съобщенията изписани при стартирането на startx. Твърде вероятно е там да си пише какво го боли. Също така на последните редове ще ти пише къде се намира log файла. Доколкото си спомням файлът е /var/log/Xorg.0.log
За да го разгледаш, отвори го в тесктов редактор (под Slackware май има edit, който напомня донякъде на vi). Или пък го разгледай с някой листър, например less:
Код: 
less /var/log/Xorg.0.log

В less се скролира със стрелките нагоре-надолу и се излиза с копчето "q"

Едва ли можем да ти помогнем повече без да дадеш съдържанието на xorg.conf и споменатия лог файл.

Редактирано от Drakula на Март 03 2008, 21:33
Контакти:  Drakula
WEB  
Мнение #9 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Март 04 2008, 08:24

Avatar




Група: Li fans
Мнения: 398
Регистриран: Март 2006

Оценка: няма

Offline
Значи... ще ти отговоря само още 1 път.

1. убиваш X-а с едновременното натискане на ctrl+alt+backsp, въпреки че при теб няма какво да се убие... просто не се стартира
2. влизаш като root
3. изпълняваш xorgconfig
4. четеш и отговаряш най-прилежно на всичко което те пита... на english е... ако не го владееш просто се откажи да се занимаваш с Slackware... може би даже изобщо с какъвто и да е Linux
5.след като на последния въпрос си отговорил с Yes - питало те е да запише ли резултата в /etc/X11/xorg.conf като обикновен потребител изпълняваш startx
6.казваш тук какъв е резултата
7.като не знаеш как да си копираш съдържанието на монитора в текстов режим просто го препиши на хартия и след това тук... ще си упражниш английския правопис...

Успех !

Баща ми едно време казваше - сухо дупе риба не яде...
:33;

edit извън темата - ако мислиш да се държиш в този форум по този начин, той не е за теб, просто никой няма да ти отговаря на въпросите.

Редактирано от delafer на Март 04 2008, 08:54

"Imagination is more important than knoledge" A.Einstein
Контакти:  delafer
Мнение #10
Skip to the previous post in this topic. Написано на: Март 04 2008, 10:37

No avatar chosen




Група: Li fans
Мнения: 30
Регистриран: Ноември 2007

Оценка: 4

Offline
Въобще не става ясно дали му е инсталиран модула за нвидиата.
И да не забравяме че е доста важно да бъдат инсталирани
kernel-headers и kernel-modules за съответното ядро с което е инсталирана системата.В Слак 12 не знам на кой диск са съответните ядра. Значи на някой от дисковете има директории с гореописаните.
Вероятно са в 3-ти или 4-ти диск:
Code Sample: 

mount /mnt/cdrom
cd /mnt/cdrom
mc


И след това проверка на съдържанието в директориите.
Някъде там трябва да има kernel-headers и kernel-modules за ядрото което е инсталирано.После :
Code Sample: 

installpkg kernel-headers-2.6.XX.tgz
installpkg kernel-modules-2.6.XX.tgz
reboot

И би трябвало всичко да тръгне ... освен ако не се поддържа модула
точно за тази нвидиа .
Контакти:  asphyx
WEB  
Общо 17 отговор(а) от Март 02 2008, 18:52 до сега
 » Начало » Li Форуми » Help & Support » X Window & GUI » проблем със старт на slackware 12

© 2014 Linux Index Project
Powered by iF 1.0.0 © 2006 ikonForums