Запомняне

» Здравейте
[ Вход :: Регистриране ]
 » Начало » Li Форуми » Help & Support » Networking » eth0 - eth1 - проблемация с Дебиан
Тема: eth0 - eth1 - проблемация с Дебиан
Мнение #1 Skip to the next post in this topic.
Написано на: Ноември 27 2007, 12:43
Chaser

Avatar




Група: Li fans
Мнения: 18
Регистриран: Август 2005

Оценка: няма

Offline
1. Имам инсталиран Дебиан /последния/ като стандартна инсталация /с учебна цел - де /
2. Имам две мрежови карти едната с чипсет Риалтек 100 мегабита другата е с чипсет Davicom 100 мегабита /нарочно са две различни за да ги различавам - хах/
4. Когато изпълня ifconfig -излиза
debian:~# ifconfig
eth1      Link encap:Ethernet  HWaddr 00:0E:2E:32:4F:A9
         inet addr:172.16.43.18  Bcast:172.16.43.255  Mask:255.255.255.0
         inet6 addr: fe80::20e:2eff:fe32:4fa9/64 Scope:Link
         UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
         RX packets:560 errors:0 dropped:0 overruns:0 frame:0
         TX packets:654 errors:0 dropped:0 overruns:0 carrier:0
         collisions:0 txqueuelen:1000
         RX bytes:454798 (444.1 KiB)  TX bytes:451267 (440.6 KiB)
         Interrupt:3 Base address:0x6400

lo        Link encap:Local Loopback
         inet addr:127.0.0.1  Mask:255.0.0.0
         inet6 addr: ::1/128 Scope:Host
         UP LOOPBACK RUNNING  MTU:16436  Metric:1
         RX packets:8 errors:0 dropped:0 overruns:0 frame:0
         TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
         collisions:0 txqueuelen:0
         RX bytes:560 (560.0 b)  TX bytes:560 (560.0 b)

- т,е, eth0 въобще я няма

5. Редактирах и направих
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
#allow-hotplug eth1
#iface eth1 inet dhcp
auto eth1
iface eth1 inet static
       address 172.16.43.18
       netmask 255.255.255.0
       network 172.16.43.0
       broadcast 172.16.43.255
       gateway 172.16.43.1

iface eth0 inet static
       address 172.16.43.19
       netmask 255.255.255.0
       network 172.16.43.0
       broadcast 172.16.43.255
       gateway 172.16.43.1


- т,е. добавих реда с eth0

6. Но като дам рестарт на мрежовите интерфеиси eth0 липсва отново

ооооооооооооо pls Help me


P.S - Картата работи щото със ifup eth0 тръгва

7. Риалтека е разпознат като 10 мегабита - ааааааааааа

PLS HELP ME

8. ето го и със пуснат интерфеис

debian:~# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:08:A1:90:E2:ED
         inet addr:172.16.43.19  Bcast:172.16.43.255  Mask:255.255.255.0
         inet6 addr: fe80::208:a1ff:fe90:e2ed/64 Scope:Link
         UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
         RX packets:0 errors:0 dropped:0 overruns:0 frame:0
         TX packets:12 errors:0 dropped:0 overruns:0 carrier:0
         collisions:0 txqueuelen:1000
         RX bytes:0 (0.0 b)  TX bytes:328 (328.0 b)
         Interrupt:12 Base address:0x6000

eth1      Link encap:Ethernet  HWaddr 00:0E:2E:32:4F:A9
         inet addr:172.16.43.18  Bcast:172.16.43.255  Mask:255.255.255.0
         inet6 addr: fe80::20e:2eff:fe32:4fa9/64 Scope:Link
         UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
         RX packets:7561 errors:1 dropped:0 overruns:0 frame:0
         TX packets:8795 errors:0 dropped:0 overruns:0 carrier:0
         collisions:0 txqueuelen:1000
         RX bytes:6201066 (5.9 MiB)  TX bytes:6263865 (5.9 MiB)
         Interrupt:3 Base address:0x6400

lo        Link encap:Local Loopback
         inet addr:127.0.0.1  Mask:255.0.0.0
         inet6 addr: ::1/128 Scope:Host
         UP LOOPBACK RUNNING  MTU:16436  Metric:1
         RX packets:8 errors:0 dropped:0 overruns:0 frame:0
         TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
         collisions:0 txqueuelen:0
         RX bytes:560 (560.0 b)  TX bytes:560 (560.0 b)


Редактирано от Chaser на Ноември 27 2007, 12:49

Контакти:  Chaser
WEB  
Мнение #2
Skip to the previous post in this topic. Написано на: Ноември 27 2007, 13:17
Chaser

Avatar




Група: Li fans
Мнения: 18
Регистриран: Август 2005

Оценка: няма

Offline
открих решение на проблема

хах
nano /etc/network/interfaces

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
#allow-hotplug eth1
#iface eth1 inet dhcp
auto eth1
iface eth1 inet static
       address 172.16.43.18
       netmask 255.255.255.0
       network 172.16.43.0
       broadcast 172.16.43.255
       gateway 172.16.43.1

auto eth0
iface eth0 inet static
       address 172.16.43.19
       netmask 255.255.255.0
       network 172.16.43.0
       broadcast 172.16.43.255
       gateway 172.16.43.1

трябвало да има auto eth0 преди настоиките на интерфеиса



ама проблема с това че ги разпознава като 10 мегабитови стои  все още


Редактирано от Chaser на Ноември 27 2007, 13:18

Контакти:  Chaser
WEB  
Общо 1 отговор(а) от Ноември 27 2007, 12:43 до сега
 » Начало » Li Форуми » Help & Support » Networking » eth0 - eth1 - проблемация с Дебиан

© 2014 Linux Index Project
Powered by iF 1.0.0 © 2006 ikonForums