Запомняне

» Здравейте
[ Вход :: Регистриране ]
 » Начало » Li Форуми » Help & Support » Networking » Проблем с  pppoe Kubuntu
Тема: Проблем с  pppoe Kubuntu
Мнение #1 Skip to the next post in this topic.
Написано на: Август 22 2008, 15:22

No avatar chosen




Група: Li fans
Мнения: 2
Регистриран: Август 2008

Оценка: няма

Offline
Проблема е следният правя си настройте на интернета или pppoe-config или pppoeconf. Свързвам се без проблем. Но след известно време dns сърварите  който съм добавил в  /etc/resolv.conf се променят и нета спира тоест не спира, но трябва да въвеждам  сърварите наново. Как да спра обновяването на dns сърварите. Как мога да разбера дали са същите сървари тъй като съм си ги записвал преди година. Също така искам да попитам защо всички страници ми се отварят, а  страницата на hardwarebg.com  не иска да се отвори.
Мерси
Контакти:  rodger

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #2 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Август 23 2008, 11:15

Avatar




Група: Li fans
Мнения: 240
Регистриран: Август 2005

Оценка: няма

Offline
Цитат от man pppoe.conf:
Цитат: 


DNSTYPE
   One of NOCHANGE, SPECIFY or SERVER. If set to NOCHANGE, adsl-connect will not adjust the DNS setup in any way. If set to SPECIFY, it will re-write /etc/resolv.conf with the values of DNS1 and DNS2. If set to SERVER, it will supply the usepeerdns option to pppd, and make a symlink from /etc/resolv.conf to /etc/ppp/resolv.conf.


С други думи, когато dnstype = SERVER в pppoe.conf компютърът ти ще пита за DNS-ите от peer-а.
Може да разгледаш и man pppd
Контакти:  Drakula
WEB  
Мнение #3 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Август 23 2008, 13:23

Avatar




Група: Li fans
Мнения: 124
Регистриран: Юни 2008

Оценка: няма

Offline
ми да :) май е тай

Редактирано от boiko_tri на Август 23 2008, 14:04
Контакти:  boiko_tri

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #4
Skip to the previous post in this topic. Написано на: Август 23 2008, 15:42

No avatar chosen




Група: Li fans
Мнения: 2
Регистриран: Август 2008

Оценка: няма

Offline
дори да му дам specify или  nonchange  това не   оправя нещата.Последно редактирах
/etc/dhcp3/dhclient.conf

prepend domain-name-servers "сървар1","сървър2";
добавих си моите сървари и засега няма проблем.
Но защо не иска да отвори определени страници като hardwarebg.
Показвам съдържанието на /etc/network/interfaces
auto lo
iface lo inet loopback
address 127.0.0.1
netmask 255.0.0.0
auto eth0
iface eth0 inet dhcp

auto dsl-provider
iface dsl-provider inet ppp
pre-up /sbin/ifconfig eth0 up # line maintained by pppoeconf
provider dsl-provider



,/etc/ppp/peers/dsl-provider

pty "/usr/sbin/pppoe -I eth0 -T 80 -m 1452 -S fl1 -n -s"
noipdefault
defaultroute
replacedefaultroute
hide-password
#lcp-echo-interval 30
#lcp-echo-failure 4
noauth
persist
mtu 1450
#persist
#maxfail 0
#holdoff 20
plugin rp-pppoe.so rp_pppoe_service fl1  eth0
user rodger1
usepeerdns

Редактирано от rodger на Август 23 2008, 15:50
Контакти:  rodger

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Общо 3 отговор(а) от Август 22 2008, 15:22 до сега
 » Начало » Li Форуми » Help & Support » Networking » Проблем с  pppoe Kubuntu

© 2014 Linux Index Project
Powered by iF 1.0.0 © 2006 ikonForums