Запомняне

» Здравейте
[ Вход :: Регистриране ]
 » Начало » Li Форуми » Help & Support » Networking » Няма Интернет под Open Suse 11.0
Тема: Няма Интернет под Open Suse 11.0
Мнение #1 Skip to the next post in this topic.
Написано на: Февруари 20 2009, 21:49

No avatar chosen




Група: Li fans
Мнения: 24
Регистриран: Февруари 2009

Оценка: няма

Offline
Търся начин да пусна Интернет на компютър с инсталиран Open Suse 11.0 с KDE 3.5.9. Много ще съм благодарен ако някой ми помогне.
Контакти:  diti

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #2 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Февруари 20 2009, 22:31

Avatar




Група: Li fans
Мнения: 269
Регистриран: Май 2008

Оценка: 4.5

Offline
през "yast" отиваш на network -> network card -> edit, добавяш след това гейт и днс -> next -> finish
Контакти:  Str82DHeaD

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #3 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Февруари 22 2009, 15:31

No avatar chosen




Група: Li fans
Мнения: 24
Регистриран: Февруари 2009

Оценка: няма

Offline
Цитат: (Str82DHeaD @ Февруари 20 2009, 22:31)

през "yast" отиваш на network -> network card -> edit, добавяш след това гейт и днс -> next -> finish

Това го пробвах вече няколко пъти, но без резултат.

Редактирано от diti на Февруари 22 2009, 15:32
Контакти:  diti

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #4 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Февруари 22 2009, 21:29

Avatar




Група: Li fans
Мнения: 269
Регистриран: Май 2008

Оценка: 4.5

Offline
дай изхода от
Code Sample: 
# cat /etc/sysconfig/network/routes

# cat /etc/resolv.conf
# ifconfig

(за последното задължително като root)
и кажи какъв интернет ползваш. Т.е. със статично ip ли си или след рутер

Редактирано от Str82DHeaD на Февруари 22 2009, 21:30
Контакти:  Str82DHeaD

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #5 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Февруари 23 2009, 19:25

No avatar chosen




Група: Li fans
Мнения: 24
Регистриран: Февруари 2009

Оценка: няма

Offline
Цитат: (Str82DHeaD @ Февруари 22 2009, 21:29)

дай изхода от
Код: 
# cat /etc/sysconfig/network/routes

# cat /etc/resolv.conf
# ifconfig

(за последното задължително като root)
и кажи какъв интернет ползваш. Т.е. със статично ip ли си или след рутер

ето изхода:
linux-myzd:~ # cat /etc/sysconfig/network/routes
cat: /etc/sysconfig/network/routes: No such file or directory
linux-myzd:~ # cat /etc/resolv.conf
#
search site
linux-myzd:~ # ifconfig
eth0      Link encap:Ethernet  HWaddr 00:0F:EA:63:12:88
         inet6 addr: fe80::20f:eaff:fe63:1288/64 Scope:Link
         UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
         RX packets:0 errors:450 dropped:0 overruns:0 frame:0
         TX packets:436 errors:0 dropped:0 overruns:0 carrier:0
         collisions:0 txqueuelen:1000
         RX bytes:0 (0.0 b)  TX bytes:147528 (144.0 Kb)
         Interrupt:16 Base address:0xe000

lo        Link encap:Local Loopback
         inet addr:127.0.0.1  Mask:255.0.0.0
         inet6 addr: ::1/128 Scope:Host
         UP LOOPBACK RUNNING  MTU:16436  Metric:1
         RX packets:704 errors:0 dropped:0 overruns:0 frame:0
         TX packets:704 errors:0 dropped:0 overruns:0 carrier:0
         collisions:0 txqueuelen:0
         RX bytes:55416 (54.1 Kb)  TX bytes:55416 (54.1 Kb)



linux-myzd:~ # cat /etc/sysconfig/network/ifroute-lo
# Set an explicit route to the localnet, because there was a report (bug 34872)
# about performance problems in an oracle installation without that route.
# Normally it should not be necessary since kernel 2.4, but it does not harm.
127/8

Интернета ми идва от доставчика без да минава през рутер.
Контакти:  diti

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #6 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Февруари 26 2009, 08:06

Avatar




Група: Li fans
Мнения: 269
Регистриран: Май 2008

Оценка: 4.5

Offline
Трябва да имаш (дадени от доставчика) IP, Subnetmask, gateway, DNS. Ако ги нямаш - обади му се и си ги поискай. След като се сдобиеш с тях :
(да речем)
ip : xxx.xxx.xxx.xxx
Subnet : yyy.yyy.yyy.yyy.
gateway : zzz.zzz.zzz.zzz
DNS  :  bbb.bbb.bbb.bbb

1. от yast -> network devices -> network settings -> global options -> махаш отметката на "enable ipv6".
2. редактираш от файла следните редове (да изглеждат така):
# (едитор) /etc/sysconfig/network/ifcfg-eth0
Code Sample: 
BOOTPROTO='static'
....
IPADDR='xxx.xxx.xxx.xxx'
....
NETMASK='yyy.yyy.yyy.yyy'
....

3. създаваш файла /etc/sysconfig/network/routes, в него добавяш
Code Sample: 
default zzz.zzz.zzz.zzz - -

4. изпълняваш :
Code Sample: 
echo "nameserver bbb.bbb.bbb.bbb" > /etc/resolv.conf


след всичко това, рестартираш :
Code Sample: 
# init 6


Редактирано от Str82DHeaD на Февруари 26 2009, 08:14
Контакти:  Str82DHeaD

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #7 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Февруари 26 2009, 09:56

Avatar




Група: Li fans
Мнения: 763
Регистриран: Февруари 2008

Оценка: 5

Offline
init 6 не винаги рестартира, по - добре да ползва reboot, shutdown -r now

Контакти:  altoas

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
Мнение #8 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Февруари 26 2009, 21:46

Avatar




Група: Li fans
Мнения: 67
Регистриран: Май 2008

Оценка: няма

Offline
Смятате ли че горните напътствия ще вършат работа ако става дума за динамичен IP -PPPoE както е в повечето случай?
Контакти:  zubizabi

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #9 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Февруари 26 2009, 21:53

Avatar




Група: Li fans
Мнения: 269
Регистриран: Май 2008

Оценка: 4.5

Offline
ми по-нагоре, аз разбрах че има вече настройките, след като ги е правил през yasta и нищо не е станало... би трябвало да спомене че има юзър и парола? :14;
Контакти:  Str82DHeaD

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #10
Skip to the previous post in this topic. Написано на: Февруари 26 2009, 22:03

Avatar




Група: Li fans
Мнения: 67
Регистриран: Май 2008

Оценка: няма

Offline
това е един приятел на който не можах да помогна.Но да точно така е-PPPoE
Контакти:  zubizabi

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Общо 21 отговор(а) от Февруари 20 2009, 21:49 до сега
 » Начало » Li Форуми » Help & Support » Networking » Няма Интернет под Open Suse 11.0

© 2014 Linux Index Project
Powered by iF 1.0.0 © 2006 ikonForums