Запомняне

» Здравейте
[ Вход :: Регистриране ]
 » Начало » Li Форуми » Help & Support » Networking » Няма Интернет под Open Suse 11.0
Тема: Няма Интернет под Open Suse 11.0
Мнение #11 Skip to the next post in this topic.
Написано на: Февруари 26 2009, 22:35

Avatar




Група: Li fans
Мнения: 269
Регистриран: Май 2008

Оценка: 4.5

Offline
ми да си инсталира тогава rp-pppoe

после  в конзолата
Code Sample: 
# pppoe-setup
Контакти:  Str82DHeaD

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #12 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Февруари 26 2009, 22:40

No avatar chosen




Група: Li fans
Мнения: 24
Регистриран: Февруари 2009

Оценка: няма

Offline
Съжалявам, но може би съм заблудил участниците във форума. Консултирах се с един приятел и той ми каза, че ползвам динамично IP, a не статично. (Когато се свързвам под Windows ми са необходими само username и pasword) Не съм много наясно с тези термини. В такъв случай може би последните напътствия на Str82DHeaD са безсмислени за мен. Извинявам се още веднъж.
Контакти:  diti

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #13 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Февруари 26 2009, 22:55

Avatar




Група: Li fans
Мнения: 269
Регистриран: Май 2008

Оценка: 4.5

Offline
точно последното ти трябва. И няма проблем  ;)
Контакти:  Str82DHeaD

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #14 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Март 01 2009, 21:34

No avatar chosen




Група: Li fans
Мнения: 24
Регистриран: Февруари 2009

Оценка: няма

Offline
Инсталирах rp-pppoe-3.8-65.i586.rpm, след това изпълних # pppoe-setup, но отново не успях да се свържа. По-долу давам изхода:
linux-myzd:~ # pppoe-setup
Welcome to the Roaring Penguin PPPoE client setup.  First, I will run
some checks on your system to make sure the PPPoE client is installed
properly...

Looks good!  Now, please enter some information:

USER NAME

>>> Enter your PPPoE user name (default todorov_sl15):

INTERFACE

>>> Enter the Ethernet interface connected to the DSL modem
For Solaris, this is likely to be something like /dev/hme0.
For Linux, it will be ethn, where 'n' is a number.
(default eth0):

MODEM TYPE

We will try to detect if your modem is compliant with RFC 2516
or not. 3COM's 3CP4130 is *NOT* compliant, for instance.

Searching for a modem at interface eth0...

Not found, trying with 3COM's code...

Didn't find a modem at interface eth0, you can continue but
things might not work as you expect... :(
You might want to re-run this ****** and try a different interface.

Do you want the link to come up on demand, or stay up continuously?
If you want it to come up on demand, enter the idle time in seconds
after which the link should be dropped.  If you want the link to
stay up permanently, enter 'no' (two letters, lower-case.)
NOTE: Demand-activated links do not interact well with dynamic IP
addresses.  You may have some problems with demand-activated links.
>>> Enter the demand value (default no):

DNS

Please enter the IP address of your ISP's primary DNS server.
If your ISP claims that 'the server will provide DNS addresses',
enter 'server' (all lower-case) here.
If you just press enter, I will assume you know what you are
doing and not modify your DNS setup.
>>> Enter the DNS information here: server

PASSWORD

>>> Please enter your PPPoE password:
>>> Please re-enter your PPPoE password:

FIREWALLING

Please choose the firewall rules to use.  Note that these rules are
very basic.  You are strongly encouraged to use a more sophisticated
firewall setup; however, these will provide basic security.  If you
are running any servers on your machine, you must choose 'NONE' and
set up firewalling yourself.  Otherwise, the firewall rules will deny
access to all standard servers like Web, e-mail, ftp, etc.  If you
are using SSH, the rules will block outgoing SSH connections which
allocate a privileged source port.

The firewall choices are:
0 - NONE: This ****** will not set any firewall rules.  You are responsible
         for ensuring the security of your machine.  You are STRONGLY
         recommended to use some kind of firewall rules.
1 - STANDALONE: Appropriate for a basic stand-alone web-surfing workstation
2 - MASQUERADE: Appropriate for a machine acting as an Internet gateway
               for a LAN
>>> Choose a type of firewall (0-2): 1

** Summary of what you entered **

Ethernet Interface: eth0
User name:          todorov_sl15
Activate-on-demand: No
DNS addresses:      Supplied by ISP's server
Firewalling:        STANDALONE

>>> Accept these settings and adjust configuration files (y/n)? y
Adjusting /etc/ppp/pppoe.conf
Adjusting /etc/ppp/pap-secrets and /etc/ppp/chap-secrets
 (But first backing it up to /etc/ppp/pap-secrets-bak)
 (But first backing it up to /etc/ppp/chap-secrets-bak)



Congratulations, it should be all set up!

Type 'pppoe-start' to bring up your PPPoE link and 'pppoe-stop' to bring
it down.  Type 'pppoe-status' to see the link status.
linux-myzd:~ # pppoe-start
................TIMED OUT
/usr/sbin/pppoe-start: line 191:  4574 Terminated              $CONNECT "$@" > /dev/null 2>&1
linux-myzd:~ # pppoe-status
pppoe-status: Link is down (can't read pppoe PID file /var/run/pppoe.conf-pppoe.pid.pppoe)
linux-myzd:~ #


ПП: Там където има ****** всъщност стои думата СКРИПТ, само че на английски, но като пускам мнението излиза като ******, както и да е, не е голям проблем.

Редактирано от diti на Март 01 2009, 21:43
Контакти:  diti

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #15 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Март 04 2009, 16:28

No avatar chosen




Група: Li fans
Мнения: 24
Регистриран: Февруари 2009

Оценка: няма

Offline
Между другото сетих се, че когато настройвам мрежовата карта под Windows задължително трябва да извърша една настройка: Link Speed/Duplex Mode, тя трябва да бъде на стойност 10Mbps/Full Duplex. На другите няколко стойности не е възможно да се свържа. Дали има някакво значение това за настройките под Linux? Мрежовата карта, която ползвам е вградена - Realtek RTL8139/810x
Контакти:  diti

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #16 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Март 04 2009, 16:48

No avatar chosen




Група: Li gurus
Мнения: 1489
Регистриран: Април 2005

Оценка: 5

Offline
пусни pppoe-connect вместо pppoe-start - така ще имаш по подробна информация за това какво става

освен това провери мрежата си за налични "точки за достъп" pppoe -I eth0 -A
Контакти:  mcwolf

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #17 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Март 04 2009, 17:36

No avatar chosen




Група: Li fans
Мнения: 24
Регистриран: Февруари 2009

Оценка: няма

Offline
Цитат: (mcwolf @ Март 04 2009, 16:48)

пусни pppoe-connect вместо pppoe-start - така ще имаш по подробна информация за това какво става

освен това провери мрежата си за налични "точки за достъп" pppoe -I eth0 -A

Давам изхода след командата pppoe-connect:

linux-myzd:~ # pppoe-connect
Using interface ppp1
Connect: ppp1 <--> /dev/pts/6
pppoe: Timeout waiting for PADO packets
Modem hangup
Connection terminated.
****** /usr/sbin/pppoe -p /var/run/pppoe.conf-pppoe.pid.pppoe -I eth0 -T 80 -U  -m 1412    finished (pid 4244), status = 0x1
Using interface ppp1
Connect: ppp1 <--> /dev/pts/6
pppoe: Timeout waiting for PADO packets
Modem hangup
Connection terminated.
****** /usr/sbin/pppoe -p /var/run/pppoe.conf-pppoe.pid.pppoe -I eth0 -T 80 -U  -m 1412    finished (pid 4262), status = 0x1
Using interface ppp1
Connect: ppp1 <--> /dev/pts/6
pppoe: Timeout waiting for PADO packets
Modem hangup
Connection terminated.
****** /usr/sbin/pppoe -p /var/run/pppoe.conf-pppoe.pid.pppoe -I eth0 -T 80 -U  -m 1412    finished (pid 4280), status = 0x1

И така до безкрай...

Не знам как да проверя мрежата за налични "точки за достъп". Ако можеш да се ориентираш нещо по изхода който съм дал...
Контакти:  diti

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #18 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Март 04 2009, 17:57

Avatar




Група: Li fans
Мнения: 763
Регистриран: Февруари 2008

Оценка: 5

Offline
PADO са пакетите които идват от PPPoE комутатора, в отговор на твоите Search пакети.
което означава проблем на физическо ниво.
1) дефектна карта
2) дефектен кабел
3) дефектно оборудване от страна на доставчика
4) трябва да си настроиш скоростта на 10/half duplex
за повече инфо -> mii-tool, ifconfig
пробвай да смениш 1412 с 1492

Редактирано от altoas на Март 04 2009, 18:00

Контакти:  altoas

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
Мнение #19 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Март 04 2009, 21:47

No avatar chosen




Група: Li fans
Мнения: 24
Регистриран: Февруари 2009

Оценка: няма

Offline
Цитат: (altoas @ Март 04 2009, 17:57)

PADO са пакетите които идват от PPPoE комутатора, в отговор на твоите Search пакети.
което означава проблем на физическо ниво.
1) дефектна карта
2) дефектен кабел
3) дефектно оборудване от страна на доставчика
4) трябва да си настроиш скоростта на 10/half duplex
за повече инфо -> mii-tool, ifconfig
пробвай да смениш 1412 с 1492

Първите три точки са изключени тъй като под Windows всичко си върви перфектно. Може би наистина трябва да си настроя скоростта на 10/half duplex, но незнам как. 1412 и 1492 не ми са ясни за какво са. Командата mii-tool не тръгна, ifconfig даде инфо и в него пише MTU:1492, така че може би това 1492 си е настроено както трябва. По-надолу давам изхода от ifconfig:

linux-myzd:~ # ifconfig
eth0      Link encap:Ethernet  HWaddr 00:0F:EA:63:12:88
         UP BROADCAST RUNNING MULTICAST  MTU:1492  Metric:1
         RX packets:0 errors:13 dropped:0 overruns:0 frame:0
         TX packets:55 errors:0 dropped:0 overruns:0 carrier:0
         collisions:0 txqueuelen:1000
         RX bytes:0 (0.0 b)  TX bytes:18810 (18.3 Kb)
         Interrupt:16 Base address:0xe000

lo        Link encap:Local Loopback
         inet addr:127.0.0.1  Mask:255.0.0.0
         UP LOOPBACK RUNNING  MTU:16436  Metric:1
         RX packets:42 errors:0 dropped:0 overruns:0 frame:0
         TX packets:42 errors:0 dropped:0 overruns:0 carrier:0
         collisions:0 txqueuelen:0
         RX bytes:2708 (2.6 Kb)  TX bytes:2708 (2.6 Kb)
Контакти:  diti

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #20
Skip to the previous post in this topic. Написано на: Март 05 2009, 11:56

No avatar chosen




Група: Li gurus
Мнения: 1489
Регистриран: Април 2005

Оценка: 5

Offline
10x10 е антична техника - има вариант наистина картата ти да е дефектирала и за това да работи на толкова ниска скорост (масовите карти работят на 10х100 а новите на 10х1000)

man ifconfig ще ти даде отговорът как да пуснеш карата толкова бавно
Код: 
ifconfig eth0 media 10baseT


но това не е решение (дори да тръгне така) - просто няма начин съвременна мрежа да работи с такава скорост - моя съвет е да тестваш с друга карта

както ти казаха вече докато не почнеш да получаваш PADO пакетите няма смисъл да се мъчиш да се свързваш
самия тест става с командата pppoe както вече ти казах
Код: 
pppoe -I eth0 -A

тя или ще изреве също че няма PADO пакети или ще ти даде списък с точките за достъп (това е признак че мрежата е изправна на "физическо" ниво и вече можеш да пробваш да стартираш клентът)
Контакти:  mcwolf

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Общо 21 отговор(а) от Февруари 20 2009, 21:49 до сега
 » Начало » Li Форуми » Help & Support » Networking » Няма Интернет под Open Suse 11.0

© 2014 Linux Index Project
Powered by iF 1.0.0 © 2006 ikonForums