Запомняне

» Здравейте
[ Вход :: Регистриране ]
 » Начало » Li Форуми » Help & Support » Networking » Проблем с обхвата на Wi-fi
Тема: Проблем с обхвата на Wi-fi
Мнение #1 Skip to the next post in this topic.
Написано на: Март 31 2009, 13:46

Avatar




Група: Li fans
Мнения: 269
Регистриран: Май 2008

Оценка: 4.5

Offline
Здравейте. Купих си TOSHIBA Satellite L300-1A6. Качих му Open SuSE 11.1, намери си за всичко драйвъри (включително и за безжичната). До тук добре, ама виждам мрежата само в стаята с рутера... Като отида в другата стая - мрежа няма. Освен това понякога се разкачва сама. Въпроса ми е в кое е вината? нетуърк мениджъра или драйвърите на самата карта... Защото картата работи (поне под вистата, с която дойде). Рутера е наред - пуснал съм аванта на комшията ми над мен и казва че няма проблеми с връзката.
Контакти:  Str82DHeaD

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #2 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Март 31 2009, 16:56

Avatar




Група: Li fans
Мнения: 763
Регистриран: Февруари 2008

Оценка: 5

Offline
1. каква е картата
2. виж в dmesg за грешки
3. iwconfig
4. iwlist <iface> scanning

Контакти:  altoas

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
Мнение #3 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Март 31 2009, 22:37

Avatar




Група: Li fans
Мнения: 269
Регистриран: Май 2008

Оценка: 4.5

Offline
картата е realtek и я намира като rtl8187.
в dmesg няма грешки.
wiconfig
Quote: 

wmaster0  no wireless extensions.

wlan0     IEEE 802.11bg  ESSID:""
         Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated
         Tx-Power=27 dBm
         Retry min limit:7   RTS thr:off   Fragment thr=2352 B
         Encryption key:off
         Power Management:off
         Link Quality:0  Signal level:0  Noise level:0
         Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
         Tx excessive retries:0  Invalid misc:0   Missed beacon:0

iwlist
Quote: 

Cell 02 - Address: 00:1C:10:AB:04:0D
                   ESSID:""
                   Mode:Master
                   Channel:5
                   Frequency:2.432 GHz (Channel 5)
                   Quality=100/100  Signal level:-15 dBm
                   Encryption key:on
                   IE: WPA Version 1
                       Group Cipher : TKIP
                       Pairwise Ciphers (1) : TKIP
                       Authentication Suites (1) : PSK
                   Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                             12 Mb/s; 24 Mb/s; 36 Mb/s; 9 Mb/s; 18 Mb/s
                             48 Mb/s; 54 Mb/s
                   Extra:tsf=000000009870152b
                   Extra: Last beacon: 1448ms ago

lspci
Quote: 

00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 07)
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 03)
00:1c.4 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 5 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 03)
00:1d.3 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 93)
00:1f.0 ISA bridge: Intel Corporation ICH9M LPC Interface Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation ICH9M/M-E SATA AHCI Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 03)
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 02)


вижда още няколко мрежи,  но моята я хваща ето така. Сложил съм ssid и съм го оставил да е визибъл.
Взех офисния рутер да го тествам, данеби нещо линксиса ми да е сдал багажа(нн дали?) :) , но същата история отначалото :(. Понякога я вижда, понякога не. ако не я вижда и рестартирам цялата машина (само мрежите - не става) случайно се появява и то не всеки път!
едит : чух се със съседа и той каза, че се вижда на 80% при него

Редактирано от Str82DHeaD на Март 31 2009, 22:46
Контакти:  Str82DHeaD

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #4 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Април 01 2009, 00:03

Avatar




Група: Li fans
Мнения: 763
Регистриран: Февруари 2008

Оценка: 5

Offline
тоя драйвер е проблемен. наскоро четох из мандрива schedule-a че има бъгове в него. за версията в убунту нз, тъйкато нямам такава карта. най - вероятно не е от рутера ти

Контакти:  altoas

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
Мнение #5 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Април 01 2009, 10:30

No avatar chosen




Група: Li gurus
Мнения: 1489
Регистриран: Април 2005

Оценка: 5

Offline
"Сложил съм ssid и съм го оставил да е визибъл"
а защо тогава е празно полето при сканирането ?
Контакти:  mcwolf

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #6 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Април 01 2009, 20:55

Avatar




Група: Li fans
Мнения: 269
Регистриран: Май 2008

Оценка: 4.5

Offline
Quote: (mcwolf @ Apr. 01 2009, 10:30)

"Сложил съм ssid и съм го оставил да е визибъл"
а защо тогава е празно полето при сканирането ?

това се надявах някой от вас  да ми каже...  :(  през уин машини се вижда.
Едит : още един,освен altoas, обвини кадърността на драйвъра... но какво да правя?  :(

Редактирано от Str82DHeaD на Април 01 2009, 20:57
Контакти:  Str82DHeaD

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #7 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Април 01 2009, 21:44

Avatar




Група: Li fans
Мнения: 763
Регистриран: Февруари 2008

Оценка: 5

Offline
изтегли си от wireless.kernel.org
последната версия на compat-wireless
но имам впредвид последният дневен build
компилирай го, инсталирай го и чакаме feedback

отностно това, че не намира AP-то, обикновенно става, когато си с висок канал > 8, пробвай с 5-6 дали не е от това.

Редактирано от altoas на Април 01 2009, 21:44

Контакти:  altoas

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
Мнение #8 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Април 06 2009, 19:53

Avatar




Група: Li fans
Мнения: 269
Регистриран: Май 2008

Оценка: 4.5

Offline
аз не съм почитател на високите канали и първото което направих е да го сложа на 5-ти канал. Проблемът си остана...
така... свалих последният билд и ето какво казва :
Quote: 

linux-lhxb:/home/owner/Desktop/compat-wireless-2.6/compat-wireless-2009-04-05 # make
/bin/sh: line 0: test: -ge: unary operator expected
make -C /lib/modules/2.6.27.7-9-pae/build M=/home/owner/Desktop/compat-wireless-2.6/compat-wireless-2009-04-05 modules
make[1]: Entering directory `/usr/src/linux-2.6.27.7-9-obj/i386/pae'
make[1]: *** No rule to make target `modules'.  Stop.
make[1]: Leaving directory `/usr/src/linux-2.6.27.7-9-obj/i386/pae'
make: *** [modules] Error 2


Редактирано от Str82DHeaD на Април 06 2009, 20:20
Контакти:  Str82DHeaD

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #9 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Април 09 2009, 22:07

Avatar




Група: Li fans
Мнения: 621
Регистриран: Декември 2006

Оценка: 5

Offline
Мисля че ти трябват linux-headers и build-essential
Контакти:  devik
WEB  
Мнение #10
Skip to the previous post in this topic. Написано на: Април 11 2009, 01:43

Avatar




Група: Li fans
Мнения: 763
Регистриран: Февруари 2008

Оценка: 5

Offline
добре де, колко РАМ имаш, че си сложил PAE ядро?
пробвай с обикновенно ядро, виж и какъв е еквивалента от пакети в СУСЕ, който да покрие еквивалента на Убунту посочен от колегата по - горе

Контакти:  altoas

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
Общо 10 отговор(а) от Март 31 2009, 13:46 до сега
 » Начало » Li Форуми » Help & Support » Networking » Проблем с обхвата на Wi-fi

© 2014 Linux Index Project
Powered by iF 1.0.0 © 2006 ikonForums