Запомняне

» Здравейте
[ Вход :: Регистриране ]
Тема: Проблем с apt-get
Мнение #1 Skip to the next post in this topic.
Написано на: Юли 29 2006, 21:00
gosheto
 

Avatar




Група: Li fans
Мнения: 162
Регистриран: Април 2005

Оценка: 5

Offline
Бях решил да пробвам Enlightenment и трябваше да си го компилирам сам, преди phantomlord да ми покаже по - лесно решение (за което много му благодаря   :28; ) и в една статия пишеше, че трябва да си инсталирам тези пакети
Цитат:

$ apt-get install autoconf automake1.7 gettext libtool libfreetype6-dev
libjpeg62-dev libpng3-dev libtiff4-dev libungif4-dev libbz2-dev libltdl3-dev
pkg-config libxine-dev libgtk1.2-dev build-essential flex bison byacc

,но някой от тях не можахда да се инсталират поради зависомости и сега като напиша sudo apt-get upgrade ми дава това:
Цитат:

gosheto@debian:~$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree... Done
You might want to run `apt-get -f install' to correct these.
The following packages have unmet dependencies:
 xorg: Depends: libglu1-mesa but it is not installed
       Depends: xfonts-base (>= 1:1.0.0-1) but 6.9.0.dfsg.1-6 is installed
       Depends: xfonts-100dpi (>= 1:1.0.0-1) but 6.9.0.dfsg.1-6 is installed
       Depends: xfonts-75dpi (>= 1:1.0.0-1) but 6.9.0.dfsg.1-6 is installed
       Depends: xfonts-scalable (>= 1:1.0.0-1) but 6.9.0.dfsg.1-6 is installed
       Depends: xbase-clients (>= 1:1.0.1-1) but 6.9.0.dfsg.1-6 is installed
       Depends: xutils (>= 1:1.0.1-1) but 6.9.0.dfsg.1-6 is installed
 xserver-xorg-input-evdev: Depends: xserver-xorg-core (>= 1:0.99.0-1) but it is not installed
 xserver-xorg-input-mouse: Depends: xserver-xorg-core (>= 1:0.99.0-1) but it is not installed
 xserver-xorg-input-synaptics: Depends: xserver-xorg-core (>= 1.0.0) but it is not installed
 xserver-xorg-video-apm: Depends: xserver-xorg-core (>= 1:0.99.0-1) but it is not installed
 xserver-xorg-video-ark: Depends: xserver-xorg-core (>= 1:0.99.0-1) but it is not installed
 xserver-xorg-video-ati: Depends: xserver-xorg-core (>= 1:0.99.0-1) but it is not installed
 xserver-xorg-video-chips: Depends: xserver-xorg-core (>= 1:0.99.0-1) but it is not installed
 xserver-xorg-video-cirrus: Depends: xserver-xorg-core (>= 1:0.99.0-1) but it is not installed
 xserver-xorg-video-cyrix: Depends: xserver-xorg-core (>= 1:0.99.0-1) but it is not installed
 xserver-xorg-video-dummy: Depends: xserver-xorg-core (>= 1:0.99.0-1) but it is not installed
 xserver-xorg-video-fbdev: Depends: xserver-xorg-core (>= 1:0.99.0-1) but it is not installed
 xserver-xorg-video-glint: Depends: xserver-xorg-core (>= 1:0.99.0-1) but it is not installed
 xserver-xorg-video-i128: Depends: xserver-xorg-core (>= 1:0.99.0-1) but it is not installed
 xserver-xorg-video-i740: Depends: xserver-xorg-core (>= 1:0.99.0-1) but it is not installed
 xserver-xorg-video-i810: Depends: xserver-xorg-core (>= 1:0.99.0-1) but it is not installed
 xserver-xorg-video-imstt: Depends: xserver-xorg-core (>= 1:0.99.0-1) but it is not installed
 xserver-xorg-video-mga: Depends: xserver-xorg-core (>= 1:0.99.0-1) but it is not installed
 xserver-xorg-video-newport: Depends: xserver-xorg-core (>= 1:0.99.0-1) but it is not installed
 xserver-xorg-video-nsc: Depends: xserver-xorg-core (>= 1:0.99.0-1) but it is not installed
 xserver-xorg-video-nv: Depends: xserver-xorg-core (>= 1:0.99.0-1) but it is not installed
 xserver-xorg-video-rendition: Depends: xserver-xorg-core (>= 1:0.99.0-1) but it is not installed
 xserver-xorg-video-s3: Depends: xserver-xorg-core (>= 1:0.99.0-1) but it is not installed
 xserver-xorg-video-s3virge: Depends: xserver-xorg-core (>= 1:0.99.0-1) but it is not installed
 xserver-xorg-video-savage: Depends: xserver-xorg-core (>= 1:0.99.0-1) but it is not installed
 xserver-xorg-video-sis: Depends: xserver-xorg-core (>= 1:0.99.0-1) but it is not installed
 xserver-xorg-video-sisusb: Depends: xserver-xorg-core (>= 1:0.99.0-1) but it is not installed
 xserver-xorg-video-tdfx: Depends: xserver-xorg-core (>= 1:0.99.0-1) but it is not installed
 xserver-xorg-video-tga: Depends: xserver-xorg-core (>= 1:0.99.0-1) but it is not installed
 xserver-xorg-video-trident: Depends: xserver-xorg-core (>= 1:0.99.0-1) but it is not installed
 xserver-xorg-video-tseng: Depends: xserver-xorg-core (>= 1:0.99.0-1) but it is not installed
 xserver-xorg-video-v4l: Depends: xserver-xorg-core (>= 1:0.99.0-1) but it is not installed
 xserver-xorg-video-vesa: Depends: xserver-xorg-core (>= 1:0.99.0-1) but it is not installed
 xserver-xorg-video-vga: Depends: xserver-xorg-core (>= 1:0.99.0-1) but it is not installed
 xserver-xorg-video-via: Depends: xserver-xorg-core (>= 1:0.99.0-1) but it is not installed
 xserver-xorg-video-vmware: Depends: xserver-xorg-core (>= 1:0.99.0-1) but it is not installed
E: Unmet dependencies. Try using -f.


давам sudo apt-get install -f  и ми дава това:
Цитат:

gosheto@debian:~$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree... Done
Correcting dependencies... Done
The following extra packages will be installed:
 libglu1-mesa libglu1-xorg x11-common xbase-clients xfonts-100dpi xfonts-75dpi xfonts-base xfonts-encodings xfonts-scalable xfonts-utils xserver-xorg
 xserver-xorg-core xutils xutils-dev
Suggested packages:
 mesa-utils libglide2 pdksh
Recommended packages:
 discover
The following packages will be REMOVED:
 lbxproxy pm-dev proxymngr xdm xfs xfwp xprint xserver-common xvfb
The following NEW packages will be installed:
 libglu1-mesa xfonts-encodings xfonts-utils xserver-xorg-core xutils-dev
The following packages will be upgraded:
 libglu1-xorg x11-common xbase-clients xfonts-100dpi xfonts-75dpi xfonts-base xfonts-scalable xserver-xorg xutils
9 upgraded, 5 newly installed, 9 to remove and 93 not upgraded.
47 not fully installed or removed.
Need to get 0B/20.4MB of archives.
After unpacking 20.9MB disk space will be freed.
Do you want to continue [Y/n]?
Preconfiguring packages ...
(Reading database ... 76296 files and directories currently installed.)
Unpacking xserver-xorg-core (from .../xserver-xorg-core_1%3a1.0.2-9_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/xserver-xorg-core_1%3a1.0.2-9_i386.deb (--unpack):
unable to create `./usr/lib/xorg/modules/extensions/libglx.so': No such file or directory
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Errors were encountered while processing:
/var/cache/apt/archives/xserver-xorg-core_1%3a1.0.2-9_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


Ако някой знае как да го оправя ще съм му благодарен


Редактирано от gosheto на Юли 29 2006, 21:01
Контакти:  gosheto
WEB  
Мнение #2 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Юли 30 2006, 09:34
someone
 
Нерегистриран










Виж какво е положението с /usr/lib/xorg/modules/extensions/libglx.so
Контакти:  someone

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #3 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Юли 31 2006, 11:35
Red
 

Avatar


Warn 3

Група: Li fans
Мнения: 384
Регистриран: Април 2006

Оценка: няма

Offline
apt-get upgrade ?!:34;
Не е ли по-правилно apt-get update ?

red@debian:~$ sudo apt-build world
-----> Rebuilding the world! <-----
-----> Building package list <-----
Please read README.Debian first.
red@debian:~$
Контакти:  Red

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #4 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Юли 31 2006, 12:30
gosheto
 

Avatar




Група: Li fans
Мнения: 162
Регистриран: Април 2005

Оценка: 5

Offline
@someone  в /usr/lib/xorg/modules нямаше директория extensions и аз е създадох, но нещата пак останха така

@red  аз първо правя sudo apt-get update, което минава без проблмеми, но sudo apt-get upgrade дава резултата, който съм дал по нагоре

ако някой може да ми каже как да кажа на apt-get да не инстлира тези пакете: (libglu1-mesa xfonts-encodings xfonts-utils xserver-xorg-core xutils-dev) мисля, че нещата ще се оправят  :14;

в момента не мога да си инсталирам нищо и не мога да update-на пакетите, така че ще се радвам на всякаква помощ
Контакти:  gosheto
WEB  
Мнение #5 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Юли 31 2006, 12:41
Red
 

Avatar


Warn 3

Група: Li fans
Мнения: 384
Регистриран: Април 2006

Оценка: няма

Offline
Пробвай
Код: 

sudo apt-get autoclean
sudo apt-get dist-upgrade

Но не мога да разбера защо си тръгнал да инсталираш онези неща и с какво дистро си (версия) ?
Също така, покажи изхода от
Код: 

cat -n /etc/apt/sources.list

red@debian:~$ sudo apt-build world
-----> Rebuilding the world! <-----
-----> Building package list <-----
Please read README.Debian first.
red@debian:~$
Контакти:  Red

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #6 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Юли 31 2006, 12:57
gosheto
 

Avatar




Група: Li fans
Мнения: 162
Регистриран: Април 2005

Оценка: 5

Offline
Ето го изхода:
Код: 
gosheto@debian:~$ cat -n /etc/apt/sources.list
    1
    2  deb ftp://ftp.bg.debian.org/debian/ stable main contrib non-free
    3  deb ftp://ftp.bg.debian.org/debian/ testing main contrib non-free
    4  #deb ftp://ftp.bg.debian.org/debian/ unstable main contrib non-free
    5
    6  deb-src ftp://ftp.bg.debian.org/debian/ stable main contrib non-free
    7  deb-src ftp://ftp.bg.debian.org/debian/ testing main contrib non-free
    8  #deb-src ftp://ftp.bg.debian.org/debian/ unstable main contrib non-free
    9
   10  deb http://security.debian.org/ stable/updates main contrib non-free
   11  deb http://security.debian.org/ testing/updates main contrib non-free
   12
   13  deb ftp://debian.ludost.net/debian-non-US/ stable/non-US main contrib non-free
   14  deb ftp://debian.ludost.net/debian-non-US/ testing/non-US main contrib non-free
   15  #deb ftp://debian.ludost.net/debian-non-US/ unstable/non-US main contrib non-free
   16
   17  deb ftp://debian.ludost.net/debian/ proposed-updates main contrib non-free
   18  deb ftp://debian.ludost.net/debian/ testing-proposed-updates main contrib non-free
   19
   20  #deb ftp://ftp.logos-bg.net/debian-addons-bg/ ./
   21  #deb-src ftp://ftp.logos-bg.net/debian-addons-bg/ ./
   22
   23  #deb ftp://ftp.nerim.net/debian-marillat/ sarge main
   24  #deb ftp://ftp.nerim.net/debian-marillat/ etch main
   25  #deb ftp://ftp.nerim.net/debian-marillat/ sid main
   26
   27  deb ftp://ftp.uni-sofia.bg/debian-addons-bg/ ./
   28
   29  # Enlightenment
   30  deb http://gefechtsdienst.de/uman/files/ unstable main


коментирал съм unstable, защото мислех, че проблема може да е от там

Код: 
sudo apt-get autoclean
sudo apt-get dist-upgrade

не помогнаха

дистро debian testing/unstable
Контакти:  gosheto
WEB  
Мнение #7 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Юли 31 2006, 13:41
Red
 

Avatar


Warn 3

Група: Li fans
Мнения: 384
Регистриран: Април 2006

Оценка: няма

Offline
Ахааа наш човек, Дебиан user. Покажи ми какво ядро ползваш (uname -a)?

red@debian:~$ sudo apt-build world
-----> Rebuilding the world! <-----
-----> Building package list <-----
Please read README.Debian first.
red@debian:~$
Контакти:  Red

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #8 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Юли 31 2006, 13:44
gosheto
 

Avatar




Група: Li fans
Мнения: 162
Регистриран: Април 2005

Оценка: 5

Offline
Код: 
gosheto@debian:~$ uname -a
Linux debian 2.6.16-1-686 #2 Thu May 4 18:22:23 UTC 2006 i686 GNU/Linux
Контакти:  gosheto
WEB  
Мнение #9 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Юли 31 2006, 13:57
phantomlord
 
Phantom Lord
Avatar




Група: Li maniacs
Мнения: 665
Регистриран: Август 2005

Оценка: няма

Offline
Коя ти е версията на xserver-xorg?

Debian lenny/sid, 2.6.24-phantomlord, KDE 3.5.9
http://myfreesoft.net/phpBB2/index.php?c=7
The knowledge is to be shared...
Помогни си сам, за да ти помогне и Господ
Контакти:  phantomlord

  • AOL  AOL:
  • ICQ  ICQ: 322393169
  • MSN  MSN:
  • YIM  Yahoo IM:
Мнение #10
Skip to the previous post in this topic. Написано на: Юли 31 2006, 14:04
Red
 

Avatar


Warn 3

Група: Li fans
Мнения: 384
Регистриран: Април 2006

Оценка: няма

Offline
Също така я пробвай да сложиш # пред deb http://gefechtsdienst.de/uman/files/ unstable main и след това изпълни apt-get update и apt-get upgrade

red@debian:~$ sudo apt-build world
-----> Rebuilding the world! <-----
-----> Building package list <-----
Please read README.Debian first.
red@debian:~$
Контакти:  Red

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Общо 21 отговор(а) от Юли 29 2006, 21:00 до сега

© 2014 Linux Index Project
Powered by iF 1.0.0 © 2006 ikonForums