Запомняне

» Здравейте
[ Вход :: Регистриране ]
Тема: проблем с rmp-и
Мнение #1 Skip to the next post in this topic.
Написано на: Септември 27 2006, 10:31
suseuser

No avatar chosen




Група: Li fans
Мнения: 13
Регистриран: Септември 2006

Оценка: няма

Offline
Здравейте!
Имам следния проблем: Избирам някой rpm пакет - цъкам на Install s YaST и след няколко секунди чакане ми изписва съобщение, че не са намерени следните пакети - името на пакета, който искам да инсталирам. Само Опера успая да си кача от rpm.Пробвах с mplaer, win32codec  и не става. Моля за съвет.


Редактирано от suseuser на Септември 27 2006, 11:24
Контакти:  suseuser
WEB  
Мнение #2 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Септември 27 2006, 21:23
delafer

Avatar




Група: Li fans
Мнения: 398
Регистриран: Март 2006

Оценка: няма

Offline
Не, че не става и така, ама има и по- правилен начин... я попрочети ЕЙ ТУК

"Imagination is more important than knoledge" A.Einstein
Контакти:  delafer
Мнение #3 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Септември 28 2006, 08:50
suseuser

No avatar chosen




Група: Li fans
Мнения: 13
Регистриран: Септември 2006

Оценка: няма

Offline
Благодаря ти за отговора, който ще го приема като "здрасти".  :D

Там където ме пращаш да чета пише:
Цитат:

Once downloaded, navigate to where you saved the RPM and right-click on it. Go to "Actions -> Install with YaST". Most desktops will pop up a box asking you for your root password. At this point, one of three things is likely to happen:

Всичко това го правя, но не се получава и затова моля за съвет. Когато цъкна на rpm-пакета и дам "Install with YaST" ми излиза съобщение,че не е намерен пакета, който искам да инсталирам. Пак повтарям : цъкам направо върху rpm-пакета, така че е странно, че YaST не може да го открие.
Контакти:  suseuser
WEB  
Мнение #4 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Септември 28 2006, 21:21
delafer

Avatar




Група: Li fans
Мнения: 398
Регистриран: Март 2006

Оценка: няма

Offline
Разбира се, че можеш... :) моля да ме извиниш за пропуска.
 Значи, винаги е по-добре да инсталираш пакети със средствата на дистрибуцията - т.е. използуваш т.н. източници на софтуер в пакетния мениджър. В Сусе, обикновено това е YAST , но може да е и друг. Източниците - това са сайтове, фтп сървъри и изобщо места където, обикновено подредени по тип има програми, компилирани конкретно за дадената дистрибуция. Защо се препоръчва да се ползва точно този софтуер - защото той е тестван и компилиран именно с оглед наличния основен набор софтуер на дистрибуцията - това са ядрото, системните библиотеки, мултимедийни библиотеки и какво ли още не - не си мисли, че всичко това е идентично при Сусе, или при Федора, нищо че и двете ползуват един и същи формат за пакети - rpm.
Та по същество - как става това е друга тема... Но бих ти казал, че в този сайт има изобилие от информация по темата, просто трябва да я потърсиш. Специално за Сусе - двата най- популярни такива източници са : http://packman-test.links2linux.org/ и http://linux01.gwdg.de/~pbleser/ .
 Как да си ги добавиш в YAST, примерно би трябвало да знаеш...
 Освен, ако не ти трябва нещо съвсем екзотично, или рядко срещано, вероятността да се намира там това което търсиш клони към 99%.
 Специално пък за MPlayer - покрай него ти трябват доста допълнителни пакети - бях ги броил веднъж, 21 са...
  Успех :)

"Imagination is more important than knoledge" A.Einstein
Контакти:  delafer
Мнение #5 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Септември 29 2006, 13:41
suseuser

No avatar chosen




Група: Li fans
Мнения: 13
Регистриран: Септември 2006

Оценка: няма

Offline
Цитат:

Как да си ги добавиш в YAST, примерно би трябвало да знаеш...

Ами всъщност не знам  :14;  

Значи изтеглям даден пакет от  http://packman-test.links2linux.org/ . Например Mplayer, цъкам (както си пише) върху пакета и давам действие-> install with YaST. След няколко секунди излиза съобщение : "не са намерени следните пакети на носителя: Mplayer"
Странна работа.
Контакти:  suseuser
WEB  
Мнение #6 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Септември 29 2006, 19:34
saejoh

Avatar




Група: Li maniacs
Мнения: 449
Регистриран: Септември 2005

Оценка: няма

Offline
Цитат:  (suseuser @ Септември 29 2006,13:41)

Цитат:

Как да си ги добавиш в YAST, примерно би трябвало да знаеш...

Ами всъщност не знам  :14;
Добавяне на източници в YAST, всъщност.
Ако си инсталирал СУСЕ 10.1, виж това :43;

Ath XP 1700+, NVidia, Biostar M7NCG, Повече тук и тук
Контакти:  saejoh

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #7 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Септември 29 2006, 20:27
delafer

Avatar




Група: Li fans
Мнения: 398
Регистриран: Март 2006

Оценка: няма

Offline
Какво бих добавил - ти не се занимаваш със свалянето на конкретния пакет... Когато са направени тези настройки в YAST (добавянето на допълнителни източници) се отива в секцията YAST->"управление на софтуера" там в лентата "търсене" си пишеш това което ти трябва, примерно MPlayer натискаш enter и ти се появява един дълъг списък с пакети... Маркираш това което ти трябва кликваш на "приемане" и YAST върши останалото. Най-вероятно покрай основния пакет ще ти каже, че ти трябват и разни други за да се задоволят зависимостите, съгласяваш се и това е... Почва едно сваляне от нет, или ще ти се поиска инсталационния диск... Процесът понякога не е много бърз, зависи от нета ти и от количеството програми, които инсталираш.
 Надявам се обясних относително разбираемо за какво иде реч...
 Успех  :)


Редактирано от delafer на Септември 29 2006, 20:28

"Imagination is more important than knoledge" A.Einstein
Контакти:  delafer
Мнение #8 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Септември 30 2006, 12:58
suseuser

No avatar chosen




Група: Li fans
Мнения: 13
Регистриран: Септември 2006

Оценка: няма

Offline
Отново има някакъв проблем.Опитвам се да добавя източници за обновяване и излиза съобщение
"Възникнала е грешка при създаването на източник за инсталиране: ..." Опитах почти всички сървъри дадени в листата и не може да открие нито един.
Контакти:  suseuser
WEB  
Мнение #9 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Септември 30 2006, 14:18
saejoh

Avatar




Група: Li maniacs
Мнения: 449
Регистриран: Септември 2005

Оценка: няма

Offline
Цитат:  (suseuser @ Септември 30 2006,12:58)

Отново има някакъв проблем.Опитвам се да добавя източници за обновяване и излиза съобщение
"Възникнала е грешка при създаването на източник за инсталиране: ..." Опитах почти всички сървъри дадени в листата и не може да открие нито един.

Здравей,
1. Коя версия на СУСЕ бориш?
2. Как се опитваш да добавиш източници? Дай командите, които изпълняваш, но така, че да е ясно, че точно ти си този, който прави опити.
3. Изписвай пълните съобщения за грешки, без "..." (многоточие).
4. Кои сървъри не се откриват? Може би трябва да изчакаш, ако в момента са прекалено заети или се обновяват.
5. По интересуващите те въпроси има ли отговори, които си открил сам (като изключим дадените вече от delafer и мен в тази тема, не сме единствени, слава богу) ?
Успех!  :)

Ath XP 1700+, NVidia, Biostar M7NCG, Повече тук и тук
Контакти:  saejoh

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #10
Skip to the previous post in this topic. Написано на: Септември 30 2006, 17:30
suseuser

No avatar chosen




Група: Li fans
Мнения: 13
Регистриран: Септември 2006

Оценка: няма

Offline
Здравей, saejoh

Сусе 10.1 x86-64 ми е версията. Имам и по-стари.Даже си купих книгата СУСЕ Линукс 10.0. Още не съм я прочел цялата, но няма нищо полезно в нея.
Източниците ги добавям през YaST, а не с команди. Направо отварям YaST, промяна на източника на инсталация, (там имам по подразбиране dvd:///devices /dev/hda/ dev/hdb) , цъкам на "добавяне", излиза ми прозорец, в който давам отметка на ftp или http. копирам адреса от http://susewiki.org/index.php?title=Finding_RPMs в полето "директория на   сървъра", в полето "име на сървъра" не пиша нищо.На автентикация си стои отметка на "анонимен". И ми излиза съобщение "Възникнала е грешка при добавяне на източник на инсталиране от http://ftp.gwdg.de/pub/linux/misc/suser-scorot/suse100/" или там който и да е адрес, който съм въвел.
Най-странното е, че си инсталирах Опера от рпм пакет без проблем- цъкам върху пакета, давам "install with YaST" и готово. Но всички други рпм-и, които се опитвам да кача не стават. Излиза съобщение: "следните пакети не са намерени на носителя: името_на_пакета".
Готов съм да го преинсталирам, явно има нещо оплетено. Не съм съвсем начинаещ с Линуксите, но направо всяка една дистрибуция се опитва да ме откаже :34;  , обаче продължавам борбата  :29;   :6;
Контакти:  suseuser
WEB  
Общо 20 отговор(а) от Септември 27 2006, 10:31 до сега

© 2014 Linux Index Project
Powered by iF 1.0.0 © 2006 ikonForums