Запомняне

» Здравейте
[ Вход :: Регистриране ]
Тема: SUSE 10.0 python-gtk
Мнение #1 Skip to the next post in this topic.
Написано на: Октомври 02 2006, 15:42
hollow

Avatar




Група: Li fans
Мнения: 65
Регистриран: Януари 2006

Оценка: няма

Offline
Здравейте на всички.значи както се вижда от заглавието имам проблем.по конкретно проблема е с пакети който работят с python-gtk.значи уж всичко е инсталирано както трябва.всякакви зависимости са изпълнени но програмите нещо не тръгват.последния пример е : когато опитам да стартирам smart --gui ми излиза еи тва съобщение : "error: System has no support for gtk python interface"

това не е единствиния случай.например pitivi също не ми тръгва с подобно обяснение.някой да има някакви идеи?

Контакти:  hollow
WEB  
Мнение #2 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Октомври 02 2006, 17:20
saejoh

Avatar




Група: Li maniacs
Мнения: 449
Регистриран: Септември 2005

Оценка: няма

Offline
Цитат:  (hollow @ Октомври 02 2006,15:42)

Здравейте на всички.значи както се вижда от заглавието имам проблем.по конкретно проблема е с пакети който работят с python-gtk.значи уж всичко е инсталирано както трябва.всякакви зависимости са изпълнени но програмите нещо не тръгват.последния пример е : когато опитам да стартирам smart --gui ми излиза еи тва съобщение : "error: System has no support for gtk python interface"

това не е единствиния случай.например pitivi също не ми тръгва с подобно обяснение.някой да има някакви идеи?

Здравей,
Виж това, там някъде има пакет python-gtk-xyz... май като за твоята версия на СУСЕ.
Успех!  :)

Ath XP 1700+, NVidia, Biostar M7NCG, Повече тук и тук
Контакти:  saejoh

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #3 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Октомври 03 2006, 14:23
hollow

Avatar




Група: Li fans
Мнения: 65
Регистриран: Януари 2006

Оценка: няма

Offline
За съжаление и така няма да стане.не може да изпълни зависимостите , а иначе в yast съм вклучил всичко което се намира на
http://en.opensuse.org/Additional_YaST_Package_Repositories
иначе съм с KDE 3.5.4 release 78.1
чудя се ако се върна към 3.4.2 дали няма да се оправят нещата.май то беше включено в дистрото

Контакти:  hollow
WEB  
Мнение #4 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Октомври 03 2006, 19:16
saejoh

Avatar




Група: Li maniacs
Мнения: 449
Регистриран: Септември 2005

Оценка: няма

Offline
Цитат:  (hollow @ Октомври 03 2006,14:23)

За съжаление и така няма да стане.не може да изпълни зависимостите , а иначе в yast съм вклучил всичко което се намира на
http://en.opensuse.org/Additional_YaST_Package_Repositories

Здравей,
Кои зависимости не могат да бъдат изпълнени? Дай да видим какви съобщения ти се изписват! Не зарязвай нещата по средата. Помисли и за другите, които имат същия проблем. Иначе вярвам, че сам ще намериш начин да ги удовлетвориш.
Успех!

Ath XP 1700+, NVidia, Biostar M7NCG, Повече тук и тук
Контакти:  saejoh

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #5 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Октомври 03 2006, 21:17
saejoh

Avatar




Група: Li maniacs
Мнения: 449
Регистриран: Септември 2005

Оценка: няма

Offline
Здравей отново,
Такаа..., значи, за SMART явно доста е писано, но най-паче следва да разгледаш следните местенца:
1.този форум за СУСЕ
2.това Ръководство на потребителя
3.тези RPM-и
4.Wiki - SMART-Installation
Там са описани всички зависимости, от които се нуждаеш, и пакетите, които трябва да свалиш (основно smart и smart-gui).
чЕти и се не бОй! :43;

Ath XP 1700+, NVidia, Biostar M7NCG, Повече тук и тук
Контакти:  saejoh

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #6 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Октомври 03 2006, 22:31
hollow

Avatar




Група: Li fans
Мнения: 65
Регистриран: Януари 2006

Оценка: няма

Offline
Здрасти,
С Това започват неизпълнените зависимости.Продължават с това и надолу по същия начин за още няколко от рода на dbus,dbus-x11,dbus-1-gtk,gnome-vfs,hal,cairo и т.н.
Малко по надолу пък трябва да се downgrade-нат firefox,powersave и submount.
Прочетох статията за strace та това е изхода от strace -o smart_gui.txt -e trace=open,close smart --gui

Май забравих да кажа че мисля че проблема не е в smart.инсталирал съм го през yast та уж зависимостите трябва да са изпълнени.той си върви чудесно конзолно. а и проблема с python-gtk се появява и при pitivi,bittornado,bittorent по всяка вероятност това няма да е края на списъка.

надявам се някой да предложи някакво решение.

току що четох за някакъв човек със същия проблем само че при SUSE 10.2 alpha3.всичко се оправило като минал на alpha4


Редактирано от hollow на Октомври 03 2006, 23:07

Контакти:  hollow
WEB  
Мнение #7 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Октомври 03 2006, 23:11
saejoh

Avatar




Група: Li maniacs
Мнения: 449
Регистриран: Септември 2005

Оценка: няма

Offline
На python-а слагал ли си му devel-пакетите?

Ath XP 1700+, NVidia, Biostar M7NCG, Повече тук и тук
Контакти:  saejoh

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #8
Skip to the previous post in this topic. Написано на: Октомври 03 2006, 23:15
saejoh

Avatar




Група: Li maniacs
Мнения: 449
Регистриран: Септември 2005

Оценка: няма

Offline
Цитат:  (hollow @ Октомври 03 2006,22:31)

...
С Това започват неизпълнените зависимости.Продължават с това и надолу по същия начин за още няколко от рода на dbus,dbus-x11,dbus-1-gtk,gnome-vfs,hal,cairo и т.н.
...

А на споменатите dbus и останалите?

Ath XP 1700+, NVidia, Biostar M7NCG, Повече тук и тук
Контакти:  saejoh

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Общо 7 отговор(а) от Октомври 02 2006, 15:42 до сега

© 2014 Linux Index Project
Powered by iF 1.0.0 © 2006 ikonForums