Запомняне

» Здравейте
[ Вход :: Регистриране ]
 » Начало » Li Форуми » Help & Support » Общи Проблеми и Въпроси » сменяне на кирилицата
Тема: сменяне на кирилицата, openSUSE 10.2
Мнение #1 Skip to the next post in this topic.
Написано на: Юли 01 2007, 15:15
zerobrain

Avatar




Група: Li fans
Мнения: 26
Регистриран: Април 2007

Оценка: няма

Offline
Здравейте!

Имам един много досаден проблем.  :6;  С openSUSE 10.2 и KDE съм и всичко за сега си е наред и съм много доволен. Инсталирах си Bulgarian language support даже си извадих и layout в таскбара за да си сменям латиница-кирилица. До тук всичко е ОК, но не мога по никакъв начин да си конфигурирам да си сменям кирилицата с клафишна комбинация от клавиатурата.  :29;  Навремето с FlexType бях свикнал да си я сменям с левия Ctrl. Има ли начин да го направя и тук? Поразрових се в оmциите на KDE Keyboard Tool и от дадените обции си избрах модела клавиатура (макар, че моят модел не е точно този - моят е Logitech Black Internet Keyboard, а от списъка съм избрал Logitech Internet Keyboard).



И от Xkb options съм си го нагласил да ми сменя лейаутите само с левия контрол.



Но въпреки това не действа. :14;
Опитах да направя същото и от YAST Control Center -> Hardware -> Keyboard Layout, но пак без резултат. :6;  Тук във форума намерих тази тема - линк и направих всичко както е описано, но също не помогна.  :29;

Някакви идеи?  :21;

Сменям си кирилицата с мишката! :22; Мъка, мъка, мъка... :12;

POWERED by openSUSE 10.2
Контакти:  zerobrain
WEB  
Мнение #2 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Юли 01 2007, 19:34
quintessence

Avatar




Група: Li psychos
Мнения: 813
Регистриран: Август 2005

Offline
Спри keyboard layout-а на KDE и ползвай само метода с редактиране на xorg.conf
Контакти:  quintessence

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #3 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Юли 01 2007, 20:40
zerobrain

Avatar




Група: Li fans
Мнения: 26
Регистриран: Април 2007

Оценка: няма

Offline
Цитат:  (quintessence @ July 01 2007,19:34)

Спри keyboard layout-а на KDE и ползвай само метода с редактиране на xorg.conf

Спрях го и отново редактирах xorg.conf - ето какво съдържа в момнета:

Код: 
Section "InputDevice"
 Driver       "kbd"
 Identifier   "Keyboard[0]"
 Option       "Protocol" "Standard"
 Option       "XkbLayout" "us,bg"
 Option       "XkbVariant" ",bds"
 Option       "XkbModel" "logiik"
 Option       "XkbOptions" "grp:lctrl_toggle,grp:lwin_switch,grp_led:scroll"
 Option       "XkbRules" "xfree86"
 Option       "XkbVariant" "xfree86"
EndSection


Но пак не става! Да не би да е заради модела на клавиатурата?  :14;

POWERED by openSUSE 10.2
Контакти:  zerobrain
WEB  
Мнение #4 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Юли 01 2007, 21:16

No avatar chosen




Група: Li fans
Мнения: 34
Регистриран: Февруари 2007

Оценка: няма

Offline
Zerobrain, линка, който си дал, ми е сработвал само на Дебианските дистрота /без Mepis/. Пробвал съм го на различни не-Дебиански дистрота, но не се получава - крашва X - са. Явно нещо не правим както трябва. Иначе сменявах режима на layout при посочените дистрота от таскбара /панела/.
Ако някой знае нещо по въпроса,нека сподели-този проблем при мен стои  при Mepis, PCLinuxOS и Fedora 7. При положение, че layout /BG->US и обратно/ е изключен. :29;  :14;
Контакти:  deke
WEB  
Мнение #5 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Юли 01 2007, 23:28
quintessence

Avatar




Група: Li psychos
Мнения: 813
Регистриран: Август 2005

Offline
Ти с xorg или xfree86 си ?!

Щом даваш съдържанието на xorg.conf , следователно си с xorg . То тогава какво правят тези редове в конфигурационния ти файл

Код: 
Option       "XkbRules" "xfree86"
Option       "XkbVariant" "xfree86"


Редактирай ги на
Код: 
Option       "XkbRules" "xorg"
Option       "XkbVariant" "xorg"



Btw , ако от графична среда излизаш с left ctrl + някой alt + backspace , нямаш далавера да си сменяш клавиатурната подредба с left ctrl . Просто , защото ще се наложи излизането от графична среда да го правиш с десен ctrl + останалите бутони.

Пак подчертавам , избери си един от начините за смяна на kbd подредба . Или този на графичната среда , или този съответната X среда , или т.н.
Контакти:  quintessence

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #6 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Юли 03 2007, 02:31
phantomlord
Phantom Lord
Avatar




Група: Li maniacs
Мнения: 665
Регистриран: Август 2005

Оценка: няма

Offline
Цитат:  (deke @ Юли 01 2007,21:16)

Zerobrain, линка, който си дал, ми е сработвал само на Дебианските дистрота /без Mepis/.

Хъх... Странно защо при мен при мен е тръгвало включително под Mepis, Fedora, че дори и под FreeBSD...


Редактирано от phantomlord на Юли 03 2007, 02:45

Debian lenny/sid, 2.6.24-phantomlord, KDE 3.5.9
http://myfreesoft.net/phpBB2/index.php?c=7
The knowledge is to be shared...
Помогни си сам, за да ти помогне и Господ
Контакти:  phantomlord

  • AOL  AOL:
  • ICQ  ICQ: 322393169
  • MSN  MSN:
  • YIM  Yahoo IM:
Мнение #7
Skip to the previous post in this topic. Написано на: Юли 03 2007, 23:10
devik

Avatar




Група: Li fans
Мнения: 621
Регистриран: Декември 2006

Оценка: 5

Offline
Цитат:  (zerobrain @ Юли 01 2007,15:15)



И от Xkb options съм си го нагласил да ми сменя лейаутите само с левия контрол.



Но въпреки това не действа. :14;
Опитах да направя същото и от YAST Control Center -> Hardware -> Keyboard Layout, но пак без резултат. :6;  Тук във форума намерих тази тема - линк и направих всичко както е описано, но също не помогна.  :29;

Някакви идеи?  :21;

Сменям си кирилицата с мишката! :22; Мъка, мъка, мъка... :12;

Ако искаш да си нагласиш шорткъта от КДЕ влез в Control center>Regional&Accesability>Keyboard Shortcuts ,най-долното меню ти показва шорткъта,но за да работи в двете посоки трябва да е Ctrl+/ или нещо от този род и без букви/
поне аз друго не съм открил,след това може да го изтриеш от xorg-a
Option       "XkbOptions" "grp:lctrl_toggle,grp:lwin_switch,grp_led:scroll"
Контакти:  devik
WEB  
Общо 6 отговор(а) от Юли 01 2007, 15:15 до сега
 » Начало » Li Форуми » Help & Support » Общи Проблеми и Въпроси » сменяне на кирилицата

© 2014 Linux Index Project
Powered by iF 1.0.0 © 2006 ikonForums