Запомняне

» Здравейте
[ Вход :: Регистриране ]
 » Начало » Li Форуми » Help & Support » Общи Проблеми и Въпроси » Проблем с гледането на видео файлове
Тема: Проблем с гледането на видео файлове
Мнение #1 Skip to the next post in this topic.
Написано на: Юли 13 2010, 20:28

No avatar chosen




Група: Li fans
Мнения: 7
Регистриран: Юли 2010

Оценка: няма

Offline
Проблемът е, че картината ми "замръзва" докато гледам филми за около 10-20 сек. докато звука продължава да си върви. Няма значение какъв видео плеър използвам. Замръзва ми дори и на клипчета в youtube. Причината не е в хардуера, защото съм с уиндоус и линукс на компютъра, а под уиндоус нямам подобен проблем.
Това е вече трети форум, в който пиша... Досега са ми предлагали:
1. да сменя видео драйвера  - нямаше ефект, смених няколко
2. да бутам една отметка в gstreamer-properties - за видеото някакво х11 - без ефект

Ами това е... Ако някой може да помогне, ще съм му безкрайно благодарен.

П.П.
Съвсем отскоро използвам Линукс, не съм много в час, та ако може малко по-подробни обяснения.
Дистрибуцията е Линукс Минт:
Linux fiend-desktop 2.6.31-14-generic #48-Ubuntu SMP Fri Oct 16 14:04:26 UTC 2009 i686 GNU/Linux
Контакти:  Fiend

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #2 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Юли 14 2010, 08:49

No avatar chosen




Група: Li gurus
Мнения: 1489
Регистриран: Април 2005

Оценка: 5

Offline
подобни замръзвания обикновено се дължат на хардуерът - това че в windows ги няма не значи че хардуерът е в изправност (просто windows не го ползва пълноценно и пробелми които се появяват при натоварването му обикновено лъсват в linux)

но така или иначе не може да гадаем какъв е проблемът - трябва малко информация - пусни филм като стартираш плеърът в конзола (използвай mplayer) и когато картината замръзне го спри и дай изходът (това което е извел в конзолата - всичко)
освен това ще трябва и информация за системата (след като видеото спре)

dmesg | tail
cat /var/log/Xorg.0.log | tail
cat /var/log/Xorg.0.log | grep EE
cat /etc/X11/xorg.conf | grep Driver
lspci
Контакти:  mcwolf

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #3 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Юли 14 2010, 15:19

No avatar chosen




Група: Li fans
Мнения: 7
Регистриран: Юли 2010

Оценка: няма

Offline
Нещо подобно ли трябва да направя?
(Не съм го чакал да замръзне, защото ми се е случвало да изгледам цял филм без проблем, а друг път замръзва на 5 мин.)
Quote: 

fiend@fiend-desktop ~/Cinema/Angel-A $ mplayer Angel-A.avi
MPlayer SVN-r29237-4.4.1 © 2000-2009 MPlayer Team
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing Angel-A.avi.
AVI file format detected.
[aviheader] Video stream found, -vid 0
[aviheader] Audio stream found, -aid 1
VIDEO:  [XVID]  640x272  24bpp  25.000 fps  978.5 kbps (119.4 kbyte/s)
Clip info:
Software: Nandub v1.0rc2
SUB: Detected subtitle file format: subviewer
SUB: Read 1456 subtitles.
SUB: Added subtitle file (1): ./Angel-A.srt
open: No such file or directory
[MGA] Couldn't open: /dev/mga_vid
open: No such file or directory
[MGA] Couldn't open: /dev/mga_vid
[VO_TDFXFB] Can't open /dev/fb0: No such file or directory.
[VO_3DFX] Unable to open /dev/3dfx.
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffodivx] vfm: ffmpeg (FFmpeg MPEG-4)
==========================================================================
==========================================================================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
AUDIO: 48000 Hz, 2 ch, s16le, 128.0 kbit/8.33% (ratio: 16000->192000)
Selected audio codec: [mp3] afm: mp3lib (mp3lib MPEG layer-2, layer-3)
==========================================================================
[pulse] working around probably broken pause functionality,
       see http://www.pulseaudio.org/ticket/440
AO: [pulse] 48000Hz 2ch s16le (2 bytes per sample)
Starting playback...
[mpeg4 @ 0x25a7fe0]Invalid and inefficient vfw-avi packed B frames detected
VDec: vo config request - 640 x 272 (preferred colorspace: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 2.35:1 - prescaling to correct movie aspect.
VO: [xv] 640x272 => 640x272 Planar YV12
A: 574.1 V: 574.1 A-V:  0.001 ct:  0.103 14353/14353  5%  0%  0.9% 0 0
 =====  PAUSE  =====
Контакти:  Fiend

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #4 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Юли 14 2010, 16:34

Avatar




Група: Li fans
Мнения: 269
Регистриран: Май 2008

Оценка: 4.5

Offline
замръзва ли и на VLC player?
спомням си преди имах проблем с mplayer-a, но при мен направо затваряше филма. Пробвай как се държи с VLC.
Контакти:  Str82DHeaD

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #5 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Юли 14 2010, 17:01

No avatar chosen




Група: Li gurus
Мнения: 1489
Регистриран: Април 2005

Оценка: 5

Offline
Цитат: (Fiend @ Юли 14 2010, 12:19)

Нещо подобно ли трябва да направя?
(Не съм го чакал да замръзне, защото ми се е случвало да изгледам цял филм без проблем, а друг път замръзва на 5 мин.)

да точно това - както виждаш така има много подробна информация за това какво става - ако има проблем във филмът или кодеци (дори в самия плеър) ще има съобщение за грешката

другите неща ти ги искам за да видим дали проблемът не е случайно в самата ОС (или Х сървърът)
Контакти:  mcwolf

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #6 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Юли 14 2010, 18:51

No avatar chosen




Група: Li fans
Мнения: 7
Регистриран: Юли 2010

Оценка: няма

Offline
За другите неща, ще ми трябва помощ!
Представа си нямам как да изкарам информация за системата.
Освен това забелязах отскоро (като не пускам плейъра на цял екран), че цялият десктоп замръзва, не само филма и мога да движа единствено мишока.
Та ако чакам да замръзне, че за правя нещо, не знам какво ще стане...

Към Str82DHeaD:
Пробвал съм и с vlc...

Редактирано от Fiend на Юли 14 2010, 18:52
Контакти:  Fiend

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #7 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Юли 15 2010, 10:06

No avatar chosen




Група: Li gurus
Мнения: 1489
Регистриран: Април 2005

Оценка: 5

Offline
трябва да дадеш изходът от тея команди

Код: 
dmesg | tail
cat /var/log/Xorg.0.log | tail
cat /var/log/Xorg.0.log | grep EE
cat /etc/X11/xorg.conf | grep Driver
lspci


щом замръзва целия декстоп най вероятно проблемът е във видеокартата - свали я и прегледай дали няма издути кондензатори
Контакти:  mcwolf

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #8 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Юли 15 2010, 10:29

No avatar chosen




Група: Li fans
Мнения: 7
Регистриран: Юли 2010

Оценка: няма

Offline
Видео картата ми е вградена.
Code Sample: 
fiend@fiend-desktop ~ $ dmesg | tail
[   22.680587]    groups: 0-1 (__cpu_power = 2048)
[   23.355407] CPU0 attaching NULL sched-domain.
[   23.355415] CPU1 attaching NULL sched-domain.
[   23.368072] CPU0 attaching sched-domain:
[   23.368076]  domain 0: span 0-1 level MC
[   23.368078]   groups: 0 1
[   23.368082] CPU1 attaching sched-domain:
[   23.368084]  domain 0: span 0-1 level MC
[   23.368086]   groups: 1 0
[   83.240028] Clocksource tsc unstable (delta = -191914950 ns)
fiend@fiend-desktop ~ $ cat /var/log/Xorg.0.log | tail
(II) Macintosh mouse button emulation: Found x and y relative axes
(II) Macintosh mouse button emulation: Configuring as mouse
(**) Macintosh mouse button emulation: YAxisMapping: buttons 4 and 5
(**) Macintosh mouse button emulation: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
(II) XINPUT: Adding extended input device "Macintosh mouse button emulation" (type: MOUSE)
(**) Macintosh mouse button emulation: (accel) keeping acceleration scheme 1
(**) Macintosh mouse button emulation: (accel) filter chain progression: 2.00
(**) Macintosh mouse button emulation: (accel) filter stage 0: 20.00 ms
(**) Macintosh mouse button emulation: (accel) set acceleration profile 0
(II) Macintosh mouse button emulation: initialized for relative axes.
fiend@fiend-desktop ~ $ cat /var/log/Xorg.0.log | grep EE
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(II) Loading extension MIT-SCREEN-SAVER
fiend@fiend-desktop ~ $ cat /etc/X11/xorg.conf | grep Driver
   Driver         "mouse"
   Driver         "kbd"
   Driver         "nvidia"
fiend@fiend-desktop ~ $ lspci
00:00.0 RAM memory: nVidia Corporation MCP61 Memory Controller (rev a1)
00:01.0 ISA bridge: nVidia Corporation MCP61 LPC Bridge (rev a2)
00:01.1 SMBus: nVidia Corporation MCP61 SMBus (rev a2)
00:01.2 RAM memory: nVidia Corporation MCP61 Memory Controller (rev a2)
00:02.0 USB Controller: nVidia Corporation MCP61 USB Controller (rev a3)
00:02.1 USB Controller: nVidia Corporation MCP61 USB Controller (rev a3)
00:04.0 PCI bridge: nVidia Corporation MCP61 PCI bridge (rev a1)
00:05.0 Audio device: nVidia Corporation MCP61 High Definition Audio (rev a2)
00:06.0 IDE interface: nVidia Corporation MCP61 IDE (rev a2)
00:08.0 IDE interface: nVidia Corporation MCP61 SATA Controller (rev a2)
00:08.1 IDE interface: nVidia Corporation MCP61 SATA Controller (rev a2)
00:09.0 PCI bridge: nVidia Corporation MCP61 PCI Express bridge (rev a2)
00:0b.0 PCI bridge: nVidia Corporation MCP61 PCI Express bridge (rev a2)
00:0c.0 PCI bridge: nVidia Corporation MCP61 PCI Express bridge (rev a2)
00:0d.0 VGA compatible controller: nVidia Corporation C61 [GeForce 6150SE nForce 430] (rev a2)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:08.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
fiend@fiend-desktop ~ $
Контакти:  Fiend

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #9 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Юли 15 2010, 11:15

No avatar chosen




Група: Li gurus
Мнения: 1489
Регистриран: Април 2005

Оценка: 5

Offline
прегледай внимателно кондензаторите по самото дъно щом картата е вградена - ако има издути го занеси да ги сменят

иначе това трябва да дадеш но след като замръзне филмът (за да видим все пак какво е станало)
Контакти:  mcwolf

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #10
Skip to the previous post in this topic. Написано на: Юли 15 2010, 14:30

No avatar chosen




Група: Li fans
Мнения: 7
Регистриран: Юли 2010

Оценка: няма

Offline
Toва е след като замръзна...
от плейъра:
Code Sample: 

fiend@fiend-desktop ~/Cinema $ mplayer Clash.of.the.Titans.2010.FRENCH.DVDRip.XviD-FF.avi
MPlayer SVN-r29237-4.4.1 (C) 2000-2009 MPlayer Team
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing Clash.of.the.Titans.2010.FRENCH.DVDRip.XviD-FF.avi.
AVI file format detected.
[aviheader] Video stream found, -vid 0
[aviheader] Audio stream found, -aid 1
VIDEO:  [XVID]  640x256  24bpp  23.976 fps  764.8 kbps (93.4 kbyte/s)
Clip info:
Software: VirtualDubMod 1.5.10.2 (build 2542/release)
open: No such file or directory
[MGA] Couldn't open: /dev/mga_vid
open: No such file or directory
[MGA] Couldn't open: /dev/mga_vid
[VO_TDFXFB] Can't open /dev/fb0: No such file or directory.
[VO_3DFX] Unable to open /dev/3dfx.
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffodivx] vfm: ffmpeg (FFmpeg MPEG-4)
==========================================================================
==========================================================================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
AUDIO: 48000 Hz, 2 ch, s16le, 128.0 kbit/8.33% (ratio: 16000->192000)
Selected audio codec: [mp3] afm: mp3lib (mp3lib MPEG layer-2, layer-3)
==========================================================================
[pulse] working around probably broken pause functionality,
       see http://www.pulseaudio.org/ticket/440
AO: [pulse] 48000Hz 2ch s16le (2 bytes per sample)
Starting playback...
VDec: vo config request - 640 x 256 (preferred colorspace: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 2.50:1 - prescaling to correct movie aspect.
VO: [xv] 640x256 => 640x256 Planar YV12
A: 179.3 V: 179.3 A-V: -0.004 ct:  0.003 4301/4301  6%  0%  0.9% 0 0
 =====  PAUSE  =====

и другото...
Code Sample: 
fiend@fiend-desktop ~ $ dmesg | tail
[   23.655019] CPU0 attaching NULL sched-domain.
[   23.655026] CPU1 attaching NULL sched-domain.
[   23.672081] CPU0 attaching sched-domain:
[   23.672086]  domain 0: span 0-1 level MC
[   23.672088]   groups: 0 1
[   23.672094] CPU1 attaching sched-domain:
[   23.672096]  domain 0: span 0-1 level MC
[   23.672098]   groups: 1 0
[   83.740025] Clocksource tsc unstable (delta = -290223019 ns)
[  559.492034] TCP: Peer 0000:0000:0000:0000:0000:ffff:d5d1:a5a2:3438/6881 unexpectedly shrunk window 2358440021:2358444161 (repaired)
fiend@fiend-desktop ~ $ cat /var/log/Xorg.0.log | tail
(II) Macintosh mouse button emulation: Found x and y relative axes
(II) Macintosh mouse button emulation: Configuring as mouse
(**) Macintosh mouse button emulation: YAxisMapping: buttons 4 and 5
(**) Macintosh mouse button emulation: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
(II) XINPUT: Adding extended input device "Macintosh mouse button emulation" (type: MOUSE)
(**) Macintosh mouse button emulation: (accel) keeping acceleration scheme 1
(**) Macintosh mouse button emulation: (accel) filter chain progression: 2.00
(**) Macintosh mouse button emulation: (accel) filter stage 0: 20.00 ms
(**) Macintosh mouse button emulation: (accel) set acceleration profile 0
(II) Macintosh mouse button emulation: initialized for relative axes.
fiend@fiend-desktop ~ $ cat /var/log/Xorg.0.log | grep EE
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(II) Loading extension MIT-SCREEN-SAVER
fiend@fiend-desktop ~ $ cat /etc/X11/xorg.conf | grep Driver
   Driver         "mouse"
   Driver         "kbd"
   Driver         "nvidia"
fiend@fiend-desktop ~ $ lspci
00:00.0 RAM memory: nVidia Corporation MCP61 Memory Controller (rev a1)
00:01.0 ISA bridge: nVidia Corporation MCP61 LPC Bridge (rev a2)
00:01.1 SMBus: nVidia Corporation MCP61 SMBus (rev a2)
00:01.2 RAM memory: nVidia Corporation MCP61 Memory Controller (rev a2)
00:02.0 USB Controller: nVidia Corporation MCP61 USB Controller (rev a3)
00:02.1 USB Controller: nVidia Corporation MCP61 USB Controller (rev a3)
00:04.0 PCI bridge: nVidia Corporation MCP61 PCI bridge (rev a1)
00:05.0 Audio device: nVidia Corporation MCP61 High Definition Audio (rev a2)
00:06.0 IDE interface: nVidia Corporation MCP61 IDE (rev a2)
00:08.0 IDE interface: nVidia Corporation MCP61 SATA Controller (rev a2)
00:08.1 IDE interface: nVidia Corporation MCP61 SATA Controller (rev a2)
00:09.0 PCI bridge: nVidia Corporation MCP61 PCI Express bridge (rev a2)
00:0b.0 PCI bridge: nVidia Corporation MCP61 PCI Express bridge (rev a2)
00:0c.0 PCI bridge: nVidia Corporation MCP61 PCI Express bridge (rev a2)
00:0d.0 VGA compatible controller: nVidia Corporation C61 [GeForce 6150SE nForce 430] (rev a2)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:08.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
fiend@fiend-desktop ~ $
Контакти:  Fiend

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Общо 13 отговор(а) от Юли 13 2010, 20:28 до сега
 » Начало » Li Форуми » Help & Support » Общи Проблеми и Въпроси » Проблем с гледането на видео файлове

© 2014 Linux Index Project
Powered by iF 1.0.0 © 2006 ikonForums