Запомняне

» Здравейте
[ Вход :: Регистриране ]
Тема: ./configure проблеми
Мнение #1 Skip to the next post in this topic.
Написано на: Декември 21 2005, 17:38
yasnv

No avatar chosen




Група: Li fans
Мнения: 141
Регистриран: Август 2005

Оценка: няма

Offline
ми нещо хич не ми спори с инсталирането от сорс в Кубунту,Сусе-то май по-малко проблеми ми даваше.Общо взето пробелмите ми са два.

Да караме по ред:

Код: 
checking for Qt... configure: error: Qt (>= Qt 3.0 and < 4.0) (library qt-mt) not found. Please check your installation!
For more details about this problem, look at the end of config.log.
Make sure that you have compiled Qt with thread support!

знам че това Qt е свързано с КДЕ-то,обаче точно кой пакет иска,нямам представа и затова се обръщам към вас.

втория проблем се появява главно при инсталирането на плъгини за XMMS:

Код: 
checking for GLIB - version >= 1.2.2... no
*** The glib-config ###### installed by GLIB could not be found
*** If GLIB was installed in PREFIX, make sure PREFIX/bin is in
*** your path, or set the GLIB_CONFIG environment variable to the
*** full path to glib-config.
configure: error: *** GLIB >= 1.2.2 not installed - please install first ***

Тук пък какво иска? Гледам че имам инсталирани libglib пакети.

Знам че проблемите изглеждат лесно решими(и изобщо всички проблеми с тази команда)обаче пробвах с апт-гет инстал ,търсене на пакети с подобни имена,но не мога да открия точните.

След това мисля че имам проблем с make ама предлагам него после да го обсъдим.


Редактирано от yasnv на Декември 21 2005, 17:40

...иначе не е интересно.
have-tried list: Slax Slackware Mandriva SuSe Knoppix Debian Mepis PCLinuxOS Vector.Linux Ubuntu Kubuntu Tilix Xandros PC-BSD Frugalware rPath VLOS Fedora Gentoo
next-to-try:Korooa
Контакти:  yasnv
WEB  
Мнение #2 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Декември 21 2005, 18:40
PinkFloyd

Avatar




Група: Li fans
Мнения: 116
Регистриран: Април 2005

Оценка: няма

Offline
Няма да мога да помогна,но ще полюбопитствам какво се опитваш да инсталираш.Абе има някакви несъвместимости между Qt3.XX и Qt4.X та дали тук няма някакъв проблем.Съжалявам ако се обаждам неподготвен.
Контакти:  PinkFloyd
WEB  
Мнение #3 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Декември 21 2005, 19:31
saejoh

Avatar




Група: Li maniacs
Мнения: 449
Регистриран: Септември 2005

Оценка: няма

Offline
И аз като преждеговорившия, не се чувствам особено подготвен, и при положение, че не казваш какво точно си търсил, бих те посъветвал да потърсиш пакет започващ с qt-mt... - ако го намериш, да го инсталираш с thread-поддръжка. Второ - потърси пакет започващ с glib..., а след като го инсталираш, виж дали пременливата на обкръжението PATH съдържа директорията PREFIX/bin, където PREFIX е нещо от сорта на /usr/local/..., или задай на променливата на обкръжението GLIB_CONFIG пълния път до glib-config. Останалото е в твои ръце.
Айде успех!  :cool:

Ath XP 1700+, NVidia, Biostar M7NCG, Повече тук и тук
Контакти:  saejoh

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #4 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Декември 21 2005, 19:31
yasnv

No avatar chosen




Група: Li fans
Мнения: 141
Регистриран: Август 2005

Оценка: няма

Offline
специално този проблем се появява при инсталация на :
kmediafactory,kmencoder
първата със сигурност съм инсталирал на Сусе 10.0.
Много е хубава за DVD Authoring се разправя.

...иначе не е интересно.
have-tried list: Slax Slackware Mandriva SuSe Knoppix Debian Mepis PCLinuxOS Vector.Linux Ubuntu Kubuntu Tilix Xandros PC-BSD Frugalware rPath VLOS Fedora Gentoo
next-to-try:Korooa
Контакти:  yasnv
WEB  
Мнение #5 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Декември 21 2005, 19:34
yasnv

No avatar chosen




Група: Li fans
Мнения: 141
Регистриран: Август 2005

Оценка: няма

Offline
Цитат:  (saejoh @ Dec. 21 2005,19:31)

И аз като преждеговорившия, не се чувствам особено подготвен, и при положение, че не казваш какво точно си търсил, бих те посъветвал да потърсиш пакет започващ с qt-mt... - ако го намериш, да го инсталираш с thread-поддръжка. Второ - потърси пакет започващ с glib

това го пробвах още като за първи път се срещнах с проблемите.
относно thread подръжката - не съм чувал такъв метод,не знам за какво става въпрос.

имам инсталирани libqt3-headers ; libqt3-mt БЕЗ libqt3-mt-dev


Редактирано от yasnv на Декември 21 2005, 19:37

...иначе не е интересно.
have-tried list: Slax Slackware Mandriva SuSe Knoppix Debian Mepis PCLinuxOS Vector.Linux Ubuntu Kubuntu Tilix Xandros PC-BSD Frugalware rPath VLOS Fedora Gentoo
next-to-try:Korooa
Контакти:  yasnv
WEB  
Мнение #6 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Декември 31 2005, 08:36
scarface

No avatar chosen




Група: Li fans
Мнения: 40
Регистриран: Декември 2005

Оценка: няма

Offline
ne znaia kaktochno stana,no iavno popadnah na tochnoto miasto:),znachi Az sym svryh nov v linux no za smetka na tova sym i svryh entusiast:) niama koi da mipokaje kakvo da pravia a i trygnah syvsem sam ot nulata /e baia izchetoh v internet de/, trudnichko mi e i to dosta no sym i dosta tvyrdoglav... ta po temata
Az sym na Fedora Core 4 i kogato pusnah ./configure za xmms mi izpisa absoliutno sy6tata gre6ka-"install GLIB 1.2.2 first" potrudih se i namerih vyprosnia GLIB v net-a,dori ima6e versii do 1.2.10 i zapo4nah slednata procedura:
beshe tar.gzfile i go razarhivirah,sled tova startirah ./configure, posle make i make install. Ne vidiah niakakvi osobenosti a vsichko si prikliuchi mai dobre, obache kogato pak pusnah ./configure na xmms pak mi izpisa sy6tata greshka?!?!?!? MOLIA ako niakoi znae kak stava ili kakvo drugo triabva da napravia da pomaga!?!
Контакти:  scarface
WEB  
Мнение #7 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Декември 31 2005, 16:10
mcwolf

No avatar chosen




Група: Li gurus
Мнения: 1489
Регистриран: Април 2005

Оценка: 5

Offline
има една дребна разлика в начините на инсталиране на пакети - когато инсталирате програмата Х в бинарен вид и тя изреве че липсва някой пакет трябва да го намерите и инсталирате - до тук нещата са прости - но когато се опитвате да компилирате нещо и configure (или make) изревът че липсва пакет тогава трябва да инсталирате изходният код на пакетът (ОСВЕН бинарният - просто трябва да ги имате и двата пакета) - изходният код (по точно хедър файловете) се ползват за "физчическото" изграждане на програмата Х (затова по големите пакети като QT библиотеките имат "орязана" версия съдържаща само хедър файловете)
Контакти:  mcwolf

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #8 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Януари 07 2006, 07:41
scarface

No avatar chosen




Група: Li fans
Мнения: 40
Регистриран: Декември 2005

Оценка: няма

Offline
pffff, mcwolf ne sym probval tova koeto kazvash,no vchera se porazrovih iz directory-ite i vidiah,che v /usr/lib ima dir glib2.0, koeto pone na 1 pogled smiatam,che shte oznachava,che triabva oshte ot install-a na linux-a da ima vyprosnia glib2.0,koito predpolagam e po-nov ot 1.2.2 - iziskvan ot xmms-a, za da se instalira:(
ima li niakakva ulovka tuk ili da probvam,kakto ti kazvash /i vprochem tova koeto ti kazvash za koe shte vaji v moia sluchai,za xmms-a ili za GLIB-a?/

P.S.
Sigurno izglejdam riadko-nekadyren ekzempliar,no niama i koi da mi pokaje daje:)


Редактирано от scarface на Януари 07 2006, 07:42
Контакти:  scarface
WEB  
Мнение #9 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Януари 07 2006, 16:21
Drakula

Avatar




Група: Li fans
Мнения: 240
Регистриран: Август 2005

Оценка: няма

Offline
Ако почнеш да пишеш на кирилица, може и да ти дам някои идеи...
Контакти:  Drakula
WEB  
Мнение #10
Skip to the previous post in this topic. Написано на: Януари 07 2006, 16:46
scarface

No avatar chosen




Група: Li fans
Мнения: 40
Регистриран: Декември 2005

Оценка: няма

Offline
Drakula,drakone,ne misli,che ne sym ot podryjnicite na kirilicata,problema e ,che za momenta u doma niamam net,pisha ot rabota,a kakto moje bi se doseshtash OS tuk e Windows i to nezabravimia 98 :D  => za da si kacha kirilica mi triabva ili CD-ROM /a takyv niama,niama dori floppy/ ili pone flextype,a licenz za poslednoto niamam otkyde da vzema,a rabotnoto mi miasto ne pozvoliava da se "mandahercam" s nelicenziran software:(
Nadiavam se pri4inite mi da sa osnovatelni i da polucha pomosht,Blagodaria:)
Контакти:  scarface
WEB  
Общо 14 отговор(а) от Декември 21 2005, 17:38 до сега

© 2014 Linux Index Project
Powered by iF 1.0.0 © 2006 ikonForums