Запомняне

» Здравейте
[ Вход :: Регистриране ]
Тема: From .rpm to .deb?
Мнение #1 Skip to the next post in this topic.
Написано на: Април 06 2006, 14:32
NetCutter

Avatar


Warn 5

Група: Li fans
Мнения: 171
Регистриран: Март 2006

Оценка: няма

Offline
Цитат:

Въпрос: Как да конвертирам .rpm файл в .deb файл?
Код: 
sudo alien package_file.rpm

Това го пише в ubuntuguide.hit.bg,ама не става,щото ми пише
Код: 
sudo:alien -Comand Not Found

Да поясна на Убунту съм и пак в тоя сайт намерих как да се инсталиран .deb пакети,а нз как се инсталват .rpm(и дали въобще е възможно под Убунту)
Помагайте :60;
Контакти:  NetCutter

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #2 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Април 06 2006, 15:10
mcwolf

No avatar chosen




Група: Li gurus
Мнения: 1489
Регистриран: Април 2005

Оценка: 5

Offline
точно така се прави НО трябва да инсталираш все пак alien преди това (sudo apt-get install alien)
Контакти:  mcwolf

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #3 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Април 06 2006, 15:28
NetCutter

Avatar


Warn 5

Група: Li fans
Мнения: 171
Регистриран: Март 2006

Оценка: няма

Offline
Опитах:
Код: 
a@ubuntu:~$ sudo apt-get install alien
Reading package lists... Done
Building dependency tree... Done
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
 alien: Depends: debhelper (>= 3) but it is not going to be installed
        Depends: rpm (>= 2.4.4-2) but it is not going to be installed
 skype: Depends: libqt3-mt but it is not going to be installed or
                 libqt3c102-mt (>= 3:3.3.3.2) but it is not installable
        Depends: libstdc++5 (>= 1:3.3.4-1) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
Контакти:  NetCutter

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #4 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Април 06 2006, 15:29
mcwolf

No avatar chosen




Група: Li gurus
Мнения: 1489
Регистриран: Април 2005

Оценка: 5

Offline
You might want to run `apt-get -f install' to correct these
Контакти:  mcwolf

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #5 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Април 06 2006, 16:22
NetCutter

Avatar


Warn 5

Група: Li fans
Мнения: 171
Регистриран: Март 2006

Оценка: няма

Offline
Еййй мерси много :24;
Контакти:  NetCutter

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #6 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Април 09 2006, 10:06
bg_talibana

Avatar




Група: Li fans
Мнения: 78
Регистриран: Януари 2006

Оценка: няма

Offline
А може ли да се разчита на този метод, че повечето пакети работят?

Goa, a treasured part of the world... A reflection of the beauty and tranquility of the Indian continent. A paradise for many, and much more than that for others.... A place where music is a second language and where people come together.
Контакти:  bg_talibana
WEB  
Мнение #7 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Април 09 2006, 10:49
yasnv

No avatar chosen




Група: Li fans
Мнения: 141
Регистриран: Август 2005

Оценка: няма

Offline
общо взето да,
но пак е на яве проблема с зависимостите от .рпм,но не винаги.

ако ти изпише че не може да намери някои библиотеки инсталираш ги и това е.

...иначе не е интересно.
have-tried list: Slax Slackware Mandriva SuSe Knoppix Debian Mepis PCLinuxOS Vector.Linux Ubuntu Kubuntu Tilix Xandros PC-BSD Frugalware rPath VLOS Fedora Gentoo
next-to-try:Korooa
Контакти:  yasnv
WEB  
Мнение #8 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Април 09 2006, 13:15
mcwolf

No avatar chosen




Група: Li gurus
Мнения: 1489
Регистриран: Април 2005

Оценка: 5

Offline
rpm, deb и всякакви подобни щуротий най грубо представляват "архиви" - затова конвертирането от един формат в друг запазва 100% цялостта и логиката на програмата
Контакти:  mcwolf

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #9 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Април 09 2006, 14:58
bg_talibana

Avatar




Група: Li fans
Мнения: 78
Регистриран: Януари 2006

Оценка: няма

Offline
Питам, защото преди пробвах с valknut на knoppix 3.9, ама искаше да тръгне (;

Goa, a treasured part of the world... A reflection of the beauty and tranquility of the Indian continent. A paradise for many, and much more than that for others.... A place where music is a second language and where people come together.
Контакти:  bg_talibana
WEB  
Мнение #10
Skip to the previous post in this topic. Написано на: Април 09 2006, 15:21
mcwolf

No avatar chosen




Група: Li gurus
Мнения: 1489
Регистриран: Април 2005

Оценка: 5

Offline
поринцип когато разпакетираш на ръка пакетът прескачаш проверката на зависимостите (можеш дори да я разкараш или промениш и да си направиш пакетът отново) това вече не ти гарантира наличието на всички библиотеки от който зависи приложението - но когато го пуснеш в конзола то ще си каже какво не е наред - проблемът ти не е бил в конвертирането а в  нещо друго
Контакти:  mcwolf

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Общо 9 отговор(а) от Април 06 2006, 14:32 до сега

© 2014 Linux Index Project
Powered by iF 1.0.0 © 2006 ikonForums