Запомняне

» Здравейте
[ Вход :: Регистриране ]
Тема: Skype, slackware 11, KDE 3.5
Мнение #1 Skip to the next post in this topic.
Написано на: Април 22 2007, 22:33
liubeto

No avatar chosen




Група: Li fans
Мнения: 58
Регистриран: Декември 2005

Оценка: няма

Offline
Здравейте на всички имам проблем с една до болка позната програмка - skype. Няма да се оплаквам, че нямам звук простото, защото това е доста дискутирано, а и е най-малкия ми проблем. Проблемия е следния инсталирам си skype-а, той си се свързва показва, че съм онлайн, но е дотук, ако реша да изпратя някакво суобщение на някои почвам да пиша и след около минута се изписва "Съобщението още не е доставено" и нищо не става. Най ме дразни при опит да се изключи "забива" ,самата програма се прецаква, знака в системния панел или неизчезва напълно, или просто остава празно място, а той си върви като процес ("ps aux"), пусках го и през конзола с надежда да изплюе няква грешка, но не няма нищо. Как ли не се опитвах да го кача като готов пакет за слак (linuxpackages.net), от сайта на skype и двете версии пробвах не и не същото винаги се получава, стигнах до състояние да се чудя дали трябва не само да се разархивира, но и да се инсталира....   :29;  Ако някои има идея как може да го излъжа да проработи много ще съм му благодарен. За съжеление единственото, което прочетох е предложение да си компилирам едно 2.6 ядро а не това by default (2.4.33.3). Аиде поздрави!

Once you go slack, you never turn back :)
Контакти:  liubeto
WEB  
Мнение #2 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Април 23 2007, 00:06
delafer

Avatar




Група: Li fans
Мнения: 398
Регистриран: Март 2006

Оценка: няма

Offline
Цитат:  (liubeto @ Април 22 2007,22:33)

За съжеление единственото, което прочетох е предложение да си компилирам едно 2.6 ядро а не това by default (2.4.33.3). Аиде поздрави!

... а може ли скромно да попитам - при инсталирането защо не си написал след boot: huge26.s за да ти инсталира ядро 2.6.17.13   :P

 Напълно поправимо - пакетите за ядрото и модулите са на диска в директория /extra/linux-2.6.17.13 - може и да те излъжа за името... Нататък няма да те учиме как се инсталират пакети в слака... Не помня дали самото ядро се инсталираше само като vmlinuz в /boot или си имаше и номер отзад: в тоя случай да не пропуснеш да си настроиш lilo да ти зарежда новото ядро...  :8;


Редактирано от delafer на Април 23 2007, 00:19

"Imagination is more important than knoledge" A.Einstein
Контакти:  delafer
Мнение #3 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Април 23 2007, 22:13
liubeto

No avatar chosen




Група: Li fans
Мнения: 58
Регистриран: Декември 2005

Оценка: няма

Offline
Така какво стана качих си пакета с новото ядро, качих си и пакета с модулите и сорса, реших да променя /etc/lilo.conf :
Код: 

# LILO configuration file
# generated by 'liloconfig'
#
# Start LILO global section
boot = /dev/hdb
#compact        # faster, but won't work on all systems.
prompt
timeout = 300
# VESA framebuffer console @ 1024x768x256
vga = 773
# Normal VGA console
# vga = normal
# VESA framebuffer console @ 1024x768x64k
# vga=791
# VESA framebuffer console @ 1024x768x32k
# vga=790
# VESA framebuffer console @ 1024x768x256
# vga=773
# VESA framebuffer console @ 800x600x64k
# vga=788
# VESA framebuffer console @ 800x600x32k
# vga=787
# VESA framebuffer console @ 800x600x256
# vga=771
# VESA framebuffer console @ 640x480x64k
# vga=785
# VESA framebuffer console @ 640x480x32k
# vga=784
# VESA framebuffer console @ 640x480x256
# vga=769
# ramdisk = 0     # paranoia setting
# End LILO global section
# Windows bootable partition config begins
other = /dev/hda1
 label = Windows
 table = /dev/hda
# Windows bootable partition config ends
# Linux bootable partition config begins
image = /boot/vmlinuz
 root = /dev/hdb2
 label = Linux-2.4.33.3
 read-only # Non-UMSDOS filesystems should be mounted read-only for checking
# Linux bootable partition config ends

#Tova as sym go dobavil:
image = /boot/vmlinuz-generic-2.6.17.13
 root = /dev/hdb2
 label = Linux - 2.6.17.3
 read-only

И при стартиране няма промяна, реших да разгледам /boot директорията и там забелязах, че vmlinuz сочи вече към новото ядро, но не се стартира то. Въпроса е как да направя, че да мога да си избирам кое от двете да боот-вам. Сега се сетих за един сайт и там прочетох че трябва да се изпълни тази команда:
Код: 
mkinitrd -k 2.6.10 -o /boot/initrd-2.6.10.gz -m reiserfs:eepro100

На верен път ли съм  :14;  :)
delafer, както винаги благодаря ти за помоща!

Once you go slack, you never turn back :)
Контакти:  liubeto
WEB  
Мнение #4 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Април 23 2007, 22:23
liubeto

No avatar chosen




Група: Li fans
Мнения: 58
Регистриран: Декември 2005

Оценка: няма

Offline
Съжелявам, че пак пиша, но искам да добавя само че тая команда дето я драснах не е съвсем така и вместо 2.6.10 (така я взех от сайта) е моито ядро 2.6.17.3. Въпреки това не стаа нищо с нея.   :6;

Once you go slack, you never turn back :)
Контакти:  liubeto
WEB  
Мнение #5 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Април 23 2007, 23:09
delafer

Avatar




Група: Li fans
Мнения: 398
Регистриран: Март 2006

Оценка: няма

Offline
Еми пропуснал си да изпълниш /sbin/lilo ...
Ако vmlinuz сочи към новото ядро - можело да не променяш нищо, но може и така - показвам ти само съществената част от текста на /etc/lilo.conf
Код: 
# Windows bootable partition config begins
other = /dev/hda1
label = Windows
table = /dev/hda
# Windows bootable partition config ends
# Linux bootable partition config begins
image = /boot/vmlinuz
root = /dev/hdb2
label = Linux-2.4.33.3
read-only # Non-UMSDOS filesystems should be mounted read-only for checking
# Linux bootable partition config ends

#Tova as sym go dobavil:
label = Linux-2.6.17.13
image = /boot/vmlinuz-generic-2.6.17.13
root = /dev/hdb2
read-only


И ЗАДЪЛЖИТЕЛНО след пипане по lilo.conf изпълняваш /sbin/lilo !

p.s. и обезателно си инсталирай, ако не си, пакета с модулите на ядрото, че ще се видиш в приключение...
initrd си го оправи с точното име на ядрото, че иначе все едно го няма... Всъщност с reiserfs ли си ? Щото ако си с ext2 или ext3 не ти трябва. И си го добави в lilo.conf в секцията за ядрото :
Код: 
initrd = /boot/initrd...блабла.gz

 И имай предвид, че за новото ядро ще трябва да си прконфигурираш някои работи... поне alsaconf... а ако си с графична карта с 3D ще си преинсталираш и драйвера.


Редактирано от delafer на Април 23 2007, 23:36

"Imagination is more important than knoledge" A.Einstein
Контакти:  delafer
Мнение #6
Skip to the previous post in this topic. Написано на: Април 23 2007, 23:37
liubeto

No avatar chosen




Група: Li fans
Мнения: 58
Регистриран: Декември 2005

Оценка: няма

Offline
То работи, не мога да повярвам..... :33;  :33;
delafer, винаги ми помагаш, никога не си ми казал нещо скапано, голям съм ти длъжник.... :60;

Once you go slack, you never turn back :)
Контакти:  liubeto
WEB  
Общо 5 отговор(а) от Април 22 2007, 22:33 до сега

© 2014 Linux Index Project
Powered by iF 1.0.0 © 2006 ikonForums