Запомняне

» Здравейте
[ Вход :: Регистриране ]
 » Начало » Li Форуми » Help & Support » Applications » Debian: проблем с инсталиране на Skype
Тема: Debian: проблем с инсталиране на Skype
Мнение #1 Skip to the next post in this topic.
Написано на: Юли 03 2007, 15:18

No avatar chosen




Група: Li fans
Мнения: 28
Регистриран: Юли 2007

Оценка: няма

Offline
Значи, логвам се през конзолата като root:

su

след това се опитвам да го инсталирам скайпа за Debian Etch, с командата
Код: 
dpkg -i името_на_пакета.deb


и получавам това:

Код: 
debian:/home/azsamwe# dpkg -i skype-1.4.0.74.deb
tar: ./control: записано е време 2007-06-12 12:00:08, което е 108150011.878826182 сек. в бъдещето
tar: ./md5sums: записано е време 2007-06-12 12:00:08, което е 108150011.878006762 сек. в бъдещето
tar: ./conffiles: записано е време 2007-06-12 12:00:08, което е 108150011.877710172 сек. в бъдещето
tar: .: записано е време 2007-06-12 11:51:14, което е 108149477.877480309 сек. в бъдещето
Selecting previously deselected package skype.
(Reading database ... 83025 files and directories currently installed.)
Unpacking skype (from skype-1.4.0.74.deb) ...
dpkg: dependency problems prevent configuration of skype:
skype depends on libqt4-core (>= 4.2.1); however:
 Package libqt4-core is not installed.
skype depends on libqt4-gui (>= 4.2.1); however:
 Package libqt4-gui is not installed.
dpkg: error processing skype (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
skype
debian:/home/azsamwe#


Какво да направя за да го инсталирам ?

благодаря предварително. :)


Редактирано от djsf на Юли 03 2007, 15:22
Контакти:  djsf
WEB  
Мнение #2 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Юли 03 2007, 15:34
quintessence

Avatar




Група: Li psychos
Мнения: 813
Регистриран: Август 2005

Offline
Иска depends - libqt4-core (версия 4.2.1 или по-горна)и libqt4-gui (версия 4.2.1 или по-горна) . Инсталирай ги
Контакти:  quintessence

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #3 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Юли 03 2007, 15:39

No avatar chosen




Група: Li fans
Мнения: 28
Регистриран: Юли 2007

Оценка: няма

Offline
На прав път ли съм ?

Код: 
debian:/home/azsamwe# apt-get -f install
Четене на списъците с пакети... Готово
Изграждане на дървото със зависимости... Готово
Коригиране на зависимостите... Готово
Следните допълнителни пакети ще бъдат инсталирани:
 gcc-4.2-base libc6 libc6-i686 libdbus-1-3 libgcc1 libglib2.0-0 libqt4-core
 libqt4-gui libstdc++6 libxrandr2 locales zlib1g
Предложени пакети:
 glibc-doc
Препоръчвани пакети:
 libglib2.0-data qt4-qtconfig
Следните пакети ще бъдат ПРЕМАХНАТИ:
 tzdata util-linux
Следните НОВИ пакети ще бъдат инсталирани:
 gcc-4.2-base libqt4-core libqt4-gui
Следните пакети ще бъдат актуализирани:
 libc6 libc6-i686 libdbus-1-3 libgcc1 libglib2.0-0 libstdc++6 libxrandr2
 locales zlib1g
ПРЕДУПРЕЖДЕНИЕ: Следните необходими пакети ще бъдат премахнати.
Това НЕ би трябвало да става освен ако знаете точно какво правите!
 util-linux tzdata (поради util-linux)
9 актуализирани, 3 нови инсталирани, 2 за премахване и 695 без промяна.
2 не са напълно инсталирани или премахнати.
Необходимо е да се изтеглят 17,5MB архиви.
След разпакетирането ще бъде използвано 10,8MB дисково пространство.
На път сте да направите нещо потенциално опасно.
За да продължите, въведете фразата „Да, прави каквото казвам!“
?]
Контакти:  djsf
WEB  
Мнение #4 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Юли 03 2007, 15:58
tolostoi

Avatar




Група: Li maniacs
Мнения: 869
Регистриран: Юли 2006

Оценка: 5

Offline
Правият път е
Код: 
apt-get update
apt-get upgrade
apt-get install gdebi
после с десен бутон в-у пакета на скайп, отваряш го с gdebi (трябва да ти се е появил там) той проверява за зависимости и ги тегли и инсталира.
И за всеки случай
Код: 
apt-get install build-essential


Редактирано от tolostoi на Юли 03 2007, 15:59

Мнение #5 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Юли 03 2007, 16:19

No avatar chosen




Група: Li fans
Мнения: 28
Регистриран: Юли 2007

Оценка: няма

Offline
Цитат:  (tolostoi @ July 03 2007,15:58)

Правият път е
Код: 
apt-get update
apt-get upgrade
apt-get install gdebi
после с десен бутон в-у пакета на скайп, отваряш го с gdebi (трябва да ти се е появил там) той проверява за зависимости и ги тегли и инсталира.
И за всеки случай
Код: 
apt-get install build-essential

Ок, но можеш ли да ми дадеш някфи добри хранилища, защото в момента ми дава error и т.н.

много ще съм ти благодарен ,ако можеш да дадеш някфи хранилища да има skype, mysql, apache ...

мерси предварително. :)
Контакти:  djsf
WEB  
Мнение #6 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Юли 03 2007, 16:32
tolostoi

Avatar




Група: Li maniacs
Мнения: 869
Регистриран: Юли 2006

Оценка: 5

Offline
За скайп има хранилище ама не знам защо ти е инсталирай го от .deb пакета. Ето ти хранилища
Код: 
deb ftp://ftp.bg.debian.org/debian/ stable main contrib non-free
deb-src ftp://ftp.bg.debian.org/debian/ stable main contrib non-free
#Debian multimedia
deb http://www.debian-multimedia.org/ etch main
изпълни
Код: 
apt-get update
apt-get install debian-multimedia-keyring
apache си го има търси в sinaptic

Мнение #7 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Юли 03 2007, 16:34

No avatar chosen




Група: Li fans
Мнения: 28
Регистриран: Юли 2007

Оценка: няма

Offline
Ти ми отговори в датата, ама нека тука пишем там няма да влизам сега ...

значи ето пак същия проблем с тези хранилища където ми даде :14; от какво може да е ???

Код: 
debian:/home/azsamwe# apt-get update
E: Неуспех при достъпа до заключване /var/lib/apt/lists/lock - open (11 Resource temporarily unavailable)
E: Неуспех при заключването на директорията със списъка на пакетите
debian:/home/azsamwe#


Редактирано от djsf на Юли 03 2007, 16:34
Контакти:  djsf
WEB  
Мнение #8 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Юли 03 2007, 16:42
tolostoi

Avatar




Група: Li maniacs
Мнения: 869
Регистриран: Юли 2006

Оценка: 5

Offline
Пиши тук какво е станало, затвори си synaptic само един може да работи (synaptic е графичен фронтенд на apt един вид същото)

Редактирано от tolostoi на Юли 03 2007, 16:43

Мнение #9 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Юли 03 2007, 16:44

No avatar chosen




Група: Li fans
Мнения: 28
Регистриран: Юли 2007

Оценка: няма

Offline
Ми аз мисля, че го нямам имам само KPackage Package Manager ...

Извинявам се, но съм нов много в тея неща и не разбирам и извинявам се ако подразня някого с ламерските си въпроси.

мерси, та ккаво да направя сега, ако може по-подробно да обесните, с команди кфо да пиша и т.н. мерси

Ако може да ми кажеш как да го затвора synaptic-а ?
Контакти:  djsf
WEB  
Мнение #10
Skip to the previous post in this topic. Написано на: Юли 03 2007, 16:52
tolostoi

Avatar




Група: Li maniacs
Мнения: 869
Регистриран: Юли 2006

Оценка: 5

Offline
АА ти си с КДЕ тогава затвори него, ако незнаеш какво си отварял, направо рестартирай машината и ако вече си сложил хранилищата изпълни това
Код: 
apt-get update
apt-get install debian-multimedia-keyring
после това
Код: 
apt-get update
apt-get upgrade
apt-get install gdebi
apt-get install build-essential
и отвори скайп с gdebi. Копи и пейст на командите докато се научиш да ги пишеш (малка и голяма буква са от знаечение, имай го предвид) и се изпълняват една по една(ред по ред както съм ги написал)

Общо 23 отговор(а) от Юли 03 2007, 15:18 до сега
 » Начало » Li Форуми » Help & Support » Applications » Debian: проблем с инсталиране на Skype

© 2014 Linux Index Project
Powered by iF 1.0.0 © 2006 ikonForums