Запомняне

» Здравейте
[ Вход :: Регистриране ]
 » Начало » Li Форуми » Help & Support » Applications » ADEPT - управление на пакети
Тема: ADEPT - управление на пакети, "ar" - липсва
Мнение #1 Skip to the next post in this topic.
Написано на: Юли 24 2007, 14:36
hwarang

No avatar chosen




Група: Li fans
Мнения: 18
Регистриран: Юли 2007

Оценка: няма

Offline
Свалям си пакети *.деб  , като ги включа ми изписва ето това


Какво да правя  :6;

П.С. Като дам от системното меню "Добавяне/Премахване на пакети" , ми зарежда около 20тина секунди и след тва не се пуска програмата , а изчезва и неще да се пусне , тва от кво може да е?

Когато тръгвам да компилирам някоя програма през конзолата всеки път ми изписва това:

Код: 
root@hwarang-desktop:/home/hwarang# cd /home/hwarang/Programki/xmms-1.2.7/
root@hwarang-desktop:/home/hwarang/Programki/xmms-1.2.7# ./configure
creating cache ./config.cache
checking host system type... i686-pc-linux-gnuoldld
checking for a BSD compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking whether make sets ${MAKE}... no
checking for working aclocal... missing
checking for working autoconf... missing
checking for working automake... missing
checking for working autoheader... missing
checking for working makeinfo... missing
checking for prefix by checking for xmms... no
checking for gcc... no
checking for cc... no
configure: error: no acceptable cc found in $PATH
root@hwarang-desktop:/home/hwarang/Programki/xmms-1.2.7# make
bash: make: command not found
root@hwarang-desktop:/home/hwarang/Programki/xmms-1.2.7# make install
bash: make: command not found
root@hwarang-desktop:/home/hwarang/Programki/xmms-1.2.7#


Редактирано от hwarang на Юли 24 2007, 15:30
Контакти:  hwarang
WEB  
Мнение #2 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Юли 24 2007, 21:42
tonitochev

No avatar chosen




Група: Li fans
Мнения: 269
Регистриран: Април 2006

Оценка: няма

Offline
Дистро?

Debian Lenny http://mylinuxtoni.site88.net/
Home Linux вестник за GNU/Linux http://vestnik.hbcom.info/news.php
Debian за българи http://debianhome.wordpress.com/
Мнение #3 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Юли 24 2007, 22:39
hwarang

No avatar chosen




Група: Li fans
Мнения: 18
Регистриран: Юли 2007

Оценка: няма

Offline
Tilix 2.0 (Ubuntu)
Контакти:  hwarang
WEB  
Мнение #4 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Юли 25 2007, 08:42
mcwolf

No avatar chosen




Група: Li gurus
Мнения: 1489
Регистриран: Април 2005

Оценка: 5

Offline
като начало трябва да инсталираш build-essential
Код: 
sudo apt-get install build-essential
Контакти:  mcwolf

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #5 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Юли 25 2007, 08:57
hwarang

No avatar chosen




Група: Li fans
Мнения: 18
Регистриран: Юли 2007

Оценка: няма

Offline
root@hwarang-desktop:/home/hwarang# sudo apt-get install build-essential
Reading package lists... Done
Building dependency tree... Done
E: Couldn't find package build-essential
Контакти:  hwarang
WEB  
Мнение #6 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Юли 25 2007, 09:10
mcwolf

No avatar chosen




Група: Li gurus
Мнения: 1489
Регистриран: Април 2005

Оценка: 5

Offline
сложи cd-то после изпълни
Код: 
sudo apt-get update

и след това пробвай пак да инсталираш пакетът - да се надяваме че го има на дискът

освен това дай да видиме какво имаш в /etc/apt/source.list
Код: 
cat /etc/apt/sources.list

аааа и още нещо - НЕ работи като root когато ти трябват root права слагай по едно sudo пред командата


Редактирано от mcwolf на Юли 25 2007, 09:11
Контакти:  mcwolf

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #7 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Юли 25 2007, 09:55
hwarang

No avatar chosen




Група: Li fans
Мнения: 18
Регистриран: Юли 2007

Оценка: няма

Offline
Започнах да им инсталирам зависимостите обаче стигнах до едно място откъдето няма мърдане и незнам как да продължа ?

root@hwarang-desktop:/home/hwarang#  dpkg  -i /home/hwarang/Desktop/fontconfig-config_2.4.2-1ubuntu1_all.deb
dpkg: considering removing fontconfig in favour of fontconfig-config ...
dpkg: no, cannot remove fontconfig (--auto-deconfigure will help):
firefox depends on fontconfig
 fontconfig is to be removed.
dpkg: regarding .../fontconfig-config_2.4.2-1ubuntu1_all.deb containing fontconfig-config:
fontconfig-config conflicts with fontconfig (<< 2.3.2-2)
 fontconfig (version 2.3.2-1.1ubuntu12) is installed.
dpkg: error processing /home/hwarang/Desktop/fontconfig-config_2.4.2-1ubuntu1_all.deb (--install):
conflicting packages - not installing fontconfig-config
Errors were encountered while processing:
/home/hwarang/Desktop/fontconfig-config_2.4.2-1ubuntu1_all.deb
root@hwarang-desktop:/home/hwarang#

Код: 
hwarang@hwarang-desktop:~$ sudo apt-get install build-essential
Reading package lists... Done
Building dependency tree... Done
build-essential is already the newest version.
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
 build-essential: Depends: gcc (>= 4:4.1.1) but it is not installable
                  Depends: g++ (>= 4:4.1.1) but it is not installable
                  Depends: make but it is not installable
                  Depends: dpkg-dev (>= 1.13.5) but it is not installable
 gcc-4.1: Depends: gcc-4.1-base (= 4.1.1-19) but 4.1.2-0ubuntu4 is to be instal                                                              led
          Depends: cpp-4.1 (= 4.1.1-19) but it is not installable
          Depends: binutils (>= 2.16.1cvs20051214) but it is not installable
          Depends: libssp0 but it is not installable
 libc6-i686: PreDepends: libc6 (= 2.3.6-0ubuntu20) but 2.5-0ubuntu14 is to be i                                                              nstalled
 libfontconfig1: Depends: fontconfig-config (= 2.4.2-1ubuntu1) but it is not in                                                              stallable
 skype: Depends: libqt4-gui (>= 4.2.1) but it is not installable
 smplayer: Depends: libqt4-gui (>= 4.2.3) but it is not installable
           Depends: libqt4-qt3support (>= 4.2.3) but it is not installable
           Depends: mplayer but it is not installable or
                    mplayer-nogui but it is not installable
 wine: Depends: libgphoto2-2 (>= 2.3.0) but 2.1.6-5.2ubuntu8 is to be installed
       Depends: libgphoto2-port0 (>= 2.3.0) but 2.1.6-5.2ubuntu8 is to be insta                                                              lled
       Depends: libxml2 (>= 2.6.27) but 2.6.24.dfsg-1ubuntu1 is to be installed
       Depends: libxslt1.1 (>= 1.1.20) but 1.1.15-1ubuntu1 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a s                                                              olution).



Код: 
cat /etc/apt/sources.list
# Line commented out by installer because it failed to verify:
#deb [URL=http://bg.archive.ubuntu.com/ubuntu/]http://bg.archive.ubuntu.com/ubuntu/[/URL] dapper main restricted
# Line commented out by installer because it failed to verify:
#deb-src [URL=http://bg.archive.ubuntu.com/ubuntu/]http://bg.archive.ubuntu.com/ubuntu/[/URL] dapper main restricted

## Major bug fix updates produced after the final release of the
## distribution.
# Line commented out by installer because it failed to verify:
#deb [URL=http://bg.archive.ubuntu.com/ubuntu/]http://bg.archive.ubuntu.com/ubuntu/[/URL] dapper-updates main restricted
# Line commented out by installer because it failed to verify:
#deb-src [URL=http://bg.archive.ubuntu.com/ubuntu/]http://bg.archive.ubuntu.com/ubuntu/[/URL] dapper-updates main restricted

## Uncomment the following two lines to add software from the 'universe'
## repository.
## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## universe WILL NOT receive any review or updates from the Ubuntu security
## team.
# deb [URL=http://bg.archive.ubuntu.com/ubuntu/]http://bg.archive.ubuntu.com/ubuntu/[/URL] dapper universe
# deb-src [URL=http://bg.archive.ubuntu.com/ubuntu/]http://bg.archive.ubuntu.com/ubuntu/[/URL] dapper universe

## Uncomment the following two lines to add software from the 'backports'
## repository.
## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
# deb [URL=http://bg.archive.ubuntu.com/ubuntu/]http://bg.archive.ubuntu.com/ubuntu/[/URL] dapper-backports main restricted universe multiverse
# deb-src [URL=http://bg.archive.ubuntu.com/ubuntu/]http://bg.archive.ubuntu.com/ubuntu/[/URL] dapper-backports main restricted universe multiverse

# Line commented out by installer because it failed to verify:
#deb [URL=http://security.ubuntu.com/ubuntu]http://security.ubuntu.com/ubuntu[/URL] dapper-security main
# Line commented out by installer because it failed to verify:
#deb-src [URL=http://security.ubuntu.com/ubuntu]http://security.ubuntu.com/ubuntu[/URL] dapper-security main
# deb [URL=http://security.ubuntu.com/ubuntu]http://security.ubuntu.com/ubuntu[/URL] dapper-security universe
# deb-src [URL=http://security.ubuntu.com/ubuntu]http://security.ubuntu.com/ubuntu[/URL] dapper-security universe


Редактирано от hwarang на Юли 25 2007, 10:01
Контакти:  hwarang
WEB  
Мнение #8 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Юли 25 2007, 11:14
phantomlord
Phantom Lord
Avatar




Група: Li maniacs
Мнения: 665
Регистриран: Август 2005

Оценка: няма

Offline
Оправи си хранилищата. Избери за твоята дистрибуция от тук.
Не забравяй после да дадеш apt-get update.

Debian lenny/sid, 2.6.24-phantomlord, KDE 3.5.9
http://myfreesoft.net/phpBB2/index.php?c=7
The knowledge is to be shared...
Помогни си сам, за да ти помогне и Господ
Контакти:  phantomlord

  • AOL  AOL:
  • ICQ  ICQ: 322393169
  • MSN  MSN:
  • YIM  Yahoo IM:
Мнение #9 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Юли 25 2007, 12:38
hwarang

No avatar chosen




Група: Li fans
Мнения: 18
Регистриран: Юли 2007

Оценка: няма

Offline
Е как се оправят тия хранилища  :14;

Такам значи написах echo "от онзи сайт които им даде намерих за Тиликс 2 и го копнах тука"> /etc/apt/sources.list

после sudo apt-get update , започна да сваля някакви работи и даде накрая Done..

, но това все още не иска да се оправи немога да инсталирам fontconfig-config , щото било в конфлитк с некво друго дето ми трябвало за Мозилата и още куп програми , и така немога да инсталирам нищо... щото тряя да инсталирам тоза да мога да инстална libqt4-core и т.н....

:29;  :29;  :29;  :14;  :14;


one more thing:


Редактирано от hwarang на Юли 25 2007, 13:36
Контакти:  hwarang
WEB  
Мнение #10
Skip to the previous post in this topic. Написано на: Юли 25 2007, 18:37
tonitochev

No avatar chosen




Група: Li fans
Мнения: 269
Регистриран: Април 2006

Оценка: няма

Offline
Пич,фани прочети това:
http://debian-book-bg.openfmi.net/src/htmlsplit/debian-book.html
и по-подробно това:
http://debian-book-bg.openfmi.net/src/htmlsplit/node79.html
След това виж си инсталирай synaptic и си инсталирай на воля.
А за такива единични пакети,дето си ги теглил поединично кой знае защо има една много сладка програмка gdebi.

Debian Lenny http://mylinuxtoni.site88.net/
Home Linux вестник за GNU/Linux http://vestnik.hbcom.info/news.php
Debian за българи http://debianhome.wordpress.com/
Общо 11 отговор(а) от Юли 24 2007, 14:36 до сега
 » Начало » Li Форуми » Help & Support » Applications » ADEPT - управление на пакети

© 2014 Linux Index Project
Powered by iF 1.0.0 © 2006 ikonForums