Запомняне

» Здравейте
[ Вход :: Регистриране ]
 » Начало » Li Форуми » Help & Support » Applications » Проблем с eclipse
Тема: Проблем с eclipse
Мнение #1 Skip to the next post in this topic.
Написано на: Септември 20 2007, 13:13
DVDsMenta

Avatar




Група: Li fans
Мнения: 65
Регистриран: Април 2007

Оценка: няма

Offline
Аз съм на сусе 64 битово 10.2 и има съотвенто исталирана джава платформа 1.6 за 64 бита и като се опитам да си инсталирам еclipse IDE C/C++ и ми се появява следното:
Код: 
JVM terminated. Exit code=13
/usr/java/jdk1.6.0_02/bin/java
-Xms40m
-Xmx512m
-Dosgi.bundlefile.limit=100
-jar /home/kiril/Desktop/eclipse/plugins/org.eclipse.equinox.launcher_1.0.0.v20070606.jar
-os linux
-ws gtk
-arch x86
-showsplash
-launcher /home/kiril/Desktop/eclipse/eclipse
-name Eclipse
--launcher.library /home/kiril/Desktop/eclipse/plugins/org.eclipse.equinox.launcher.gtk.linux.x86_1.0.0.v20070606/eclipse_1017a.so
-startup /home/kiril/Desktop/eclipse/plugins/org.eclipse.equinox.launcher_1.0.0.v20070606.jar
-exitdata 358009
-vm /usr/java/jdk1.6.0_02/bin/java
-vmargs
-Xms40m
-Xmx512m
-Dosgi.bundlefile.limit=100
-jar /home/kiril/Desktop/eclipse/plugins/org.eclipse.equinox.launcher_1.0.0.v20070606.jar  

Ще съм благодарен, ако някой ми обясни от какво се появява това и най-вече как да инсталирам любимия едитор....
10х предварително на всички писали по темата !  :43;
Контакти:  DVDsMenta
WEB  
Мнение #2 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Септември 20 2007, 18:39
nikolavp

Avatar




Група: Li maniacs
Мнения: 560
Регистриран: Юли 2006

Оценка: 4

Offline
hmm не съм много запознат с rpm технологията, но ще се опитам да ти помогна все пак де :).
Код: 
rpm -l "java-та"| grep '/bin/java'
намираш си къде ти се намира изпълнимия файл за джавата. Пример
Код: 
qlist sun-jdk-1.6.0.02 | grep '/bin/java'
/opt/sun-jdk-1.6.0.02/bin/java
/opt/sun-jdk-1.6.0.02/bin/java-rmi.cgi
/opt/sun-jdk-1.6.0.02/bin/javac
/opt/sun-jdk-1.6.0.02/bin/javadoc
/opt/sun-jdk-1.6.0.02/bin/javah
/opt/sun-jdk-1.6.0.02/bin/javap
/opt/sun-jdk-1.6.0.02/bin/javaws
/opt/sun-jdk-1.6.0.02/jre/bin/java
/opt/sun-jdk-1.6.0.02/jre/bin/java_vm
/opt/sun-jdk-1.6.0.02/jre/bin/javaws
Nikolavp nikolavp #
Този ред те интересува /opt/sun-jdk-1.6.0.02/bin/java. Сега отиваш до директорията с еклипса и пишеш ./eclipse -vm  /opt/sun-jdk-1.6.0.02/bin/java, като заменяш съотетния път. Потребителите на Гентоо могат да ползват java-config( не знам дали я има в Сусето). Нещо от рода на ./eclipse -vm $(java-config --java) трябва да ви свърши работа :)
Успех и пиши ако е станало(ако не е ти ще пишеш  :28; )

Контакти:  nikolavp

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #3 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Септември 20 2007, 20:46
DVDsMenta

Avatar




Група: Li fans
Мнения: 65
Регистриран: Април 2007

Оценка: няма

Offline
Мерси за помоща, но нещо не става след като напиша
Код: 
./eclipse -vm /usr/java/jdk1.6.0_02/bin/java

Отново ми се появявя гадното съобщение, като въведа и другото ти предложение става страшно:
Код: 
kiril@2072565957:~/bin/eclipse> ./eclipse -vm$(java-config--java)
bash: java-config--java: command not found

*** glibc detected *** /home/kiril/bin/eclipse/eclipse: double free or corruption (out): 0x080709b0 ***
======= Backtrace: =========
/lib/libc.so.6[0xf7a806e1]
/lib/libc.so.6(cfree+0x89)[0xf7a81d79]
/home/kiril/bin/eclipse/plugins/org.eclipse.equinox.launcher.gtk.linux.x86_1.0.0.v20070606/eclipse_1017a.so(run+0x81d)[0xf7f97665]
/home/kiril/bin/eclipse/eclipse[0x80492e7]
/lib/libc.so.6(__libc_start_main+0xdc)[0xf7a31f9c]
/home/kiril/bin/eclipse/eclipse[0x8048f61]
======= Memory map: ========
08048000-0804b000 r-xp 00000000 08:07 235782127                          /home/kiril/bin/eclipse/eclipse
0804b000-0804c000 rw-p 00002000 08:07 235782127                          /home/kiril/bin/eclipse/eclipse
0804c000-08150000 rw-p 0804c000 00:00 0                                  [heap]
f7100000-f7121000 rw-p f7100000 00:00 0
f7121000-f7200000 ---p f7121000 00:00 0
f72d7000-f72e1000 r-xp 00000000 08:05 112072                             /lib/libgcc_s.so.1
f72e1000-f72e3000 rw-p 00009000 08:05 112072                             /lib/libgcc_s.so.1
f7313000-f7373000 rw-s 00000000 00:08 3375128                            /SYSV00000000 (deleted)
f7373000-f739d000 r--p 00000000 08:08 1626630                            /usr/share/fonts/truetype/albw.ttf
f739d000-f739f000 r-xp 00000000 08:05 628203                             /opt/gnome/lib/pango/1.5.0/modules/pango-basic-fc.so
f739f000-f73a1000 rw-p 00001000 08:05 628203                             /opt/gnome/lib/pango/1.5.0/modules/pango-basic-fc.so
f73a1000-f73a8000 r--s 00000000 08:09 485816                             /var/cache/fontconfig/77e41c5059666d75f92e318d4be8c21e-x86.cache-2
f73a8000-f73a9000 r--s 00000000 08:09 485824                             /var/cache/fontconfig/b6bbb9f898b73777cfe763014a8c08d3-x86.cache-2
f73a9000-f73ab000 r--s 00000000 08:09 485810                             /var/cache/fontconfig/d458be102e54cf534d1eef0dcbb02d07-x86.cache-2
f73ab000-f73d2000 r--s 00000000 08:09 485820                             /var/cache/fontconfig/8d4af663993b81a124ee82e610bb31f9-x86.cache-2
f73d2000-f73d7000 r--s 00000000 08:09 485815                             /var/cache/fontconfig/d62e99ef547d1d24cdb1bd22ec1a2976-x86.cache-2
f73d7000-f741d000 r--s 00000000 08:09 485812                             /var/cache/fontconfig/df311e82a1a24c41a75c2c930223552e-x86.cache-2
f741d000-f7463000 r--s 00000000 08:09 485813                             /var/cache/fontconfig/17090aa38d5c6f09fb8c5c354938f1d7-x86.cache-2
f7463000-f747e000 r--s 00000000 08:09 485821                             /var/cache/fontconfig/7ef2298fde41cc6eeb7af42e48b7d293-x86.cache-2
f747e000-f749c000 r-xp 00000000 08:05 628311                             /opt/gnome/lib/gtk-2.0/2.10.0/engines/libqtcurve.so
f749c000-f749e000 rw-p 0001d000 08:05 628311                             /opt/gnome/lib/gtk-2.0/2.10.0/engines/libqtcurve.so
f749e000-f749f000 rw-p f749e000 00:00 0
f749f000-f74d4000 r--s 00000000 08:09 550531                             /var/run/nscd/passwd
f74d4000-f750f000 r--p 00000000 08:08 147167                             /usr/lib/locale/en_US.utf8/LC_CTYPE
f750f000-f75e6000 r--p 00000000 08:08 147168                             /usr/lib/locale/en_US.utf8/LC_COLLATE
f75e6000-f75e8000 rw-p f75e6000 00:00 0
f75e8000-f7612000 r-xp 00000000 08:05 628194                             /opt/gnome/lib/libpangoft2-1.0.so.0.1400.5
f7612000-f7614000 rw-p 00029000 08:05 628194                             /opt/gnome/lib/libpangoft2-1.0.so.0.1400.5
f7614000-f7615000 rw-p f7614000 00:00 0
f7615000-f7619000 r-xp 00000000 08:08 132544                             /usr/lib/libXfixes.so.3.1.0
f7619000-f761b000 rw-p 00003000 08:08 132544                             /usr/lib/libXfixes.so.3.1.0
f761b000-f7623000 r-xp 00000000 08:08 132652                             /usr/lib/libXcursor.so.1.0.2
f7623000-f7625000 rw-p 00007000 08:08 132652                             /usr/lib/libXcursor.so.1.0.2
f7625000-f7632000 r-xp 00000000 08:08 132542                             /usr/lib/libXext.so.6.4.0
f7632000-f7634000 rw-p 0000c000 08:08 132542                             /usr/lib/libXext.so.6.4.0
f7634000-f7637000 r-xp 00000000 08:08 132672                             /usr/lib/libXrandr.so.2.0.0
f7637000-f7639000 rw-p 00002000 08:08 132672                             /usr/lib/libXrandr.so.2.0.0
f7639000-f7640000 r-xp 00000000 08:08 132666                             /usr/lib/libXi.so.6.0.0
f7640000-f7642000 rw-p 00006000 08:08 132666                             /usr/lib/libXi.so.6.0.0
f764Aborted

Какти вече си забелязал от първия ред тази команда е за дентуууу в сусето я няма, а после вече не знам какво става.....  :6;
Контакти:  DVDsMenta
WEB  
Мнение #4 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Септември 20 2007, 22:20
nikolavp

Avatar




Група: Li maniacs
Мнения: 560
Регистриран: Юли 2006

Оценка: 4

Offline
Леко стрелям на посоки, но не съм сигурен дали тия версии на еклипс за официално сваляне стават за 64 битова джава. Защо не пробваш тия тука http://download.eclipse.org/eclipse....dex.php
(64 битовите разбира се ). Вярно, че са SDK, ама нямам друго обяснение и пробвай това за сега.


Редактирано от nikolavp на Септември 20 2007, 22:21

Контакти:  nikolavp

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #5 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Септември 20 2007, 23:15
DVDsMenta

Avatar




Група: Li fans
Мнения: 65
Регистриран: Април 2007

Оценка: няма

Offline
Да ти кажа за Java ide работи, но на мен ми трябва с/с++ и май започвам да си мисля, че не се подържа версия за 64 архитектури  :14;
Контакти:  DVDsMenta
WEB  
Мнение #6 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Септември 21 2007, 19:48
nikolavp

Avatar




Група: Li maniacs
Мнения: 560
Регистриран: Юли 2006

Оценка: 4

Offline
Цитат:  (DVDsMenta @ Септември 20 2007,23:15)

Да ти кажа за Java ide работи, но на мен ми трябва с/с++ и май започвам да си мисля, че не се подържа версия за 64 архитектури  :14;

Сложи си CDT, то и без това повечето плъгини като mylyn искат SDT-тo :)

Контакти:  nikolavp

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #7 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Септември 21 2007, 21:02
Zero_effect

Avatar




Група: Li maniacs
Мнения: 489
Регистриран: Юли 2005

Оценка: 5

Offline
Аз ти препоръчвам да ползваш code::blocks за C++, а не eclipse, иначе аз ползвам gedit с някои по-специални настройки, защото повечето IDE-та ми се виждат прекалено тежки.
Контакти:  Zero_effect

  • AOL  AOL:
  • ICQ  ICQ: 94584818
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #8 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Септември 22 2007, 15:40
nikolavp

Avatar




Група: Li maniacs
Мнения: 560
Регистриран: Юли 2006

Оценка: 4

Offline
Ако нямаш много памет и аз бих ти препоръчал това, но ако имаш повече от 1 GB, или пък толкова, няма смисъл да се лишаваш от по - доброто :). Успех ти желая.

Контакти:  nikolavp

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #9 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Септември 22 2007, 20:22
Zero_effect

Avatar




Група: Li maniacs
Мнения: 489
Регистриран: Юли 2005

Оценка: 5

Offline
На мен основния ми проблем е процесора, защото почти постоянно е на 100% (kdevelop) или става на 100%, докато пиша(code::blocks). Предпочитам да ги ползвам тия проценти за компилиране(въпреки че ползвам двете машини вкъщи за компилиране с distcc), като ползвам нещо, което не е чак такова швейцарско ножче.

Редактирано от Zero_effect на Септември 22 2007, 20:25
Контакти:  Zero_effect

  • AOL  AOL:
  • ICQ  ICQ: 94584818
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #10
Skip to the previous post in this topic. Написано на: Септември 22 2007, 20:56
nikolavp

Avatar




Група: Li maniacs
Мнения: 560
Регистриран: Юли 2006

Оценка: 4

Offline
Цитат:  (Zero_effect @ Септември 22 2007,20:22)

На мен основния ми проблем е процесора, защото почти постоянно е на 100% (kdevelop) или става на 100%, докато пиша(code::blocks). Предпочитам да ги ползвам тия проценти за компилиране(въпреки че ползвам двете машини вкъщи за компилиране с distcc), като ползвам нещо, което не е чак такова швейцарско ножче.

Наистина го има момента с малко по - бавната компилация, но аз и без това не прекомпилирам много често ;). Все пак опитай eclipse определено мога да кажа, че се държи доста добре последната версия(миналите бяха боза). Какъв ти е процесора ?

Контакти:  nikolavp

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Общо 14 отговор(а) от Септември 20 2007, 13:13 до сега
 » Начало » Li Форуми » Help & Support » Applications » Проблем с eclipse

© 2014 Linux Index Project
Powered by iF 1.0.0 © 2006 ikonForums