Запомняне

» Здравейте
[ Вход :: Регистриране ]
 » Начало » Li Форуми » Help & Support » Applications » Проблем със Slackware 12
Тема: Проблем със Slackware 12
Мнение #1 Skip to the next post in this topic.
Написано на: Октомври 18 2007, 22:05
emagi

Avatar


Warn 2

Група: Li fans
Мнения: 134
Регистриран: Декември 2006

Оценка: няма

Offline
Досега бях със Slackware 11 и нямах следния проблем:
инсталирам 12-ката,стартирам графична среда startx и съответно искам да вляза в дяла където е инсталиран слака,и ми изписва следното съобщение:
ERROR - Konqueror

A security policy in place prevents this sender from sending this message to this recipient,see message bus configuration file(rejected message haed interface "org.freedesktop.Hal.Device.Volume" member "Mount error name"(unset)" destination "org.freedesktop.Hal")


Досега този проблем не ми е правил слака,и не знам на какво се дължи това!Като дам OK няма нищо в дяла!Инсталирах го 2 пъти,но все същата работа!
Пътя към дяла е съответно system:/media/hda6
Предварително Ви благодаря@
Контакти:  emagi
WEB  
Мнение #2 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Октомври 18 2007, 22:13
Drakula

Avatar




Група: Li fans
Мнения: 240
Регистриран: Август 2005

Оценка: няма

Offline
Тука дискутирахме  подобен проблем.
Контакти:  Drakula
WEB  
Мнение #3 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Октомври 18 2007, 22:53
emagi

Avatar


Warn 2

Група: Li fans
Мнения: 134
Регистриран: Декември 2006

Оценка: няма

Offline
Доколкото виждам трябва да добавя root към plugdev и cdrom групи!Но как става това?
Контакти:  emagi
WEB  
Мнение #4 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Октомври 18 2007, 23:27
nikolavp

Avatar




Група: Li maniacs
Мнения: 560
Регистриран: Юли 2006

Оценка: 4

Offline
Цитат:  (emagi @ Октомври 18 2007,22:53)

Доколкото виждам трябва да добавя root към plugdev и cdrom групи!Но как става това?

Да не би да не си се релогнал ? :) Сложи си нормалния user в plugdev и cdrom групата и после рестартирай X-a(релогни се) и да изход от
Код: 
groups

Контакти:  nikolavp

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #5 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Октомври 19 2007, 11:49
emagi

Avatar


Warn 2

Група: Li fans
Мнения: 134
Регистриран: Декември 2006

Оценка: няма

Offline
ПОсъветваха ме да пробвам чрез монтиране с fstab:
Ето как стоят при мен нещата:
/etc/fstab/
Код: 


/dev/hda5        swap               swap             defaults         0      0
/dev/hda6           /                  ext2             defaults         1       1
/dev/hda7           /home            ext2            defaults         1       2
/dev/cdrom        /mnt/cdrom      auto           noauto,owner,ro      0      0
/dev/fd0            /mnt/floppy      auto           noauto,owner         0       0
devpts              /dev/pts          devpts         gid=5, mode=620        0       0
proc                  /proc             proc             defaults                    0         0
Контакти:  emagi
WEB  
Мнение #6 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Ноември 03 2007, 16:24
emagi

Avatar


Warn 2

Група: Li fans
Мнения: 134
Регистриран: Декември 2006

Оценка: няма

Offline
Здравейте!
Днес отново инсталирах Slackware 12,и да видя няма ли да оправя този проблем!Така,ето го и файла fstab,който в момента е на Слака!:
Код: 

/dev/hda5        swap             swap        defaults         0   0
/dev/hda6        /                ext3        defaults         1   1
/dev/hda7        /home            ext3        defaults         1   2
/dev/hda1        /windows  ntfs ro             1   0
/dev/cdrom      /mnt/cdrom       auto        noauto,owner,ro  0   0
/dev/fd0         /mnt/floppy      auto        noauto,owner     0   0
devpts           /dev/pts         devpts      gid=5,mode=620   0   0
proc             /proc            proc        defaults         0   0

Добавих и root в cdrom,plugdev групи!Сега като съм се логнал като руут,въведа ли groups:
Код: 

root@moon:/etc# groups
cdrom plugdev

Добавям руут с командата usermod -g plugdev примерно,но да принадлежи само на две групи??? ???
Та проблема е в това,че в графична среда(KDE) не мога да вляза в hda6(дяла където е инсталиран Слака)
КАто натисна върху иконата,ми дава Permissions denied
Няма икона и на CD-ROM и на Floopy!
Не ми дава да маунтна hda6 в /
А дяла е unmount-нат!
Независимо,че го има описан във файла fstab,пробвах с mount /dev/hda6  /
Код: 

root@moon:/etc# mount /dev/hda6 /
mount: /dev/hda6 already mounted or / busy
mount: according to mtab, /dev/hda6 is already mounted on /

Моля,помагайте!!!!  :)  :)  :)
Контакти:  emagi
WEB  
Мнение #7 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Ноември 03 2007, 17:33
delafer

Avatar




Група: Li fans
Мнения: 398
Регистриран: Март 2006

Оценка: няма

Offline
Би ли прочел материала от ТОЗИ блог. Мисля, че ще ти свърши работа, нищо че разисква страничен "проблем" - важно е да схванеш принципа. А за автора им... мисля, че не е нужно да пояснявам кой е...

Редактирано от delafer на Ноември 03 2007, 17:43

"Imagination is more important than knoledge" A.Einstein
Контакти:  delafer
Мнение #8 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Ноември 03 2007, 20:14
emagi

Avatar


Warn 2

Група: Li fans
Мнения: 134
Регистриран: Декември 2006

Оценка: няма

Offline
Много интересно,като няма диск в cdrom-aняма и икона в KDE контрол мениджъра,сложа ли диск излиза икона,дава че cdrom-a е unmount!Автоматично монтиране ли става!Немога да разбера!
Контакти:  emagi
WEB  
Мнение #9 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Ноември 03 2007, 20:34
Drakula

Avatar




Група: Li fans
Мнения: 240
Регистриран: Август 2005

Оценка: няма

Offline
Цитат:  (Drakula @ Октомври 18 2007,22:13)

Тука дискутирахме  подобен проблем.

Направи ли си труда да последваш линка, който ти посочих? Така като гледам не - все още не си добавил опцията "user" като параметър в fstab.
Контакти:  Drakula
WEB  
Мнение #10
Skip to the previous post in this topic. Написано на: Ноември 03 2007, 20:48
emagi

Avatar


Warn 2

Група: Li fans
Мнения: 134
Регистриран: Декември 2006

Оценка: няма

Offline
Добре,а защо ми дава "Permission denied",когато се опитвам да вляза под графична среда в дял hda6,там където е слака!И за CD-to ми прави същата глупост!
Добавих root към група plugdev!Сега като дам команда groups,ми дава следното:
[code]
root@moon:~#groups
cdrom floppy audio video plugdev
[/b]
Мен ме сумнява,че липсва групата users,нали?


Редактирано от emagi на Ноември 03 2007, 20:50
Контакти:  emagi
WEB  
Общо 13 отговор(а) от Октомври 18 2007, 22:05 до сега
 » Начало » Li Форуми » Help & Support » Applications » Проблем със Slackware 12

© 2014 Linux Index Project
Powered by iF 1.0.0 © 2006 ikonForums