Запомняне

» Здравейте
[ Вход :: Регистриране ]
 » Начало » Li Форуми » Help & Support » Applications » iSeries Access for Linux
Тема: iSeries Access for Linux, rpm dependencies failed
Мнение #1 Skip to the next post in this topic.
Написано на: Ноември 03 2007, 20:42
sleepwalker

Avatar




Група: Li fans
Мнения: 30
Регистриран: Август 2006

Оценка: няма

Offline
Здравейте приятели,

налага ми се да инсталирам iSeries Access for Linux.

От сайта на IBM свалих iSeriesAccess-5.4.0-1.2.i386.rpm
# rpm -ivh iSeriesAccess-5.4.0-1.2.i386.rpm

казва, че иска libXm.so.3

Доколкото четох това се съдържа в openmotif, който вече бях инсталирала, версия 2.3.0.0 ( работя с Fedora Core 5)

# locate libXm.so
/usr/lib/libXm.so.4
/usr/lib/libXm.so.4.0.0

като първото е символна връзка към второто. Има и още една символна връзка към второто с име libXm.so

Направих символна връзка, наречена libXm.so.3, първо сочеща към libXm.so.4, но инсталирането на пакета отново даде същата грешка.
След това направих наново тази символна връзка, но я насочих към libXm.so.4.0.0, но пак без резултат.
Имам инсталирани libtiff и libXP.
Деинсталирах openmotif, никаква индикация или промяна в резултата след опит да инсталирам пакета.

Според вас откъде може да идва проблемът и как да се справя с него?

Предварително благодаря!

Never sigh for better world
It's already composed, played and told
Контакти:  sleepwalker
WEB  
Мнение #2
Skip to the previous post in this topic. Написано на: Ноември 03 2007, 23:13
saejoh

Avatar




Група: Li maniacs
Мнения: 449
Регистриран: Септември 2005

Оценка: няма

Offline
Цитат:  (sleepwalker @ Ноември 03 2007,20:42)

...
казва, че иска libXm.so.3

Доколкото четох това се съдържа в openmotif, който вече бях инсталирала, версия 2.3.0.0 ( работя с Fedora Core 5)

# locate libXm.so
/usr/lib/libXm.so.4
/usr/lib/libXm.so.4.0.0

...

Правилно си се ориентирал, остава само да потърсиш пакет, който съдържа точно libXm.so.3 (в най-добрия случай за Fedora 5). Гимнастиките с правене на символни връзки към нещо, което не върши работа, ги зарежи.

Ath XP 1700+, NVidia, Biostar M7NCG, Повече тук и тук
Контакти:  saejoh

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Общо 1 отговор(а) от Ноември 03 2007, 20:42 до сега
 » Начало » Li Форуми » Help & Support » Applications » iSeries Access for Linux

© 2014 Linux Index Project
Powered by iF 1.0.0 © 2006 ikonForums