Запомняне

» Здравейте
[ Вход :: Регистриране ]
 » Начало » Li Форуми » Help & Support » Applications » субититри с mplayer
Тема: субититри с mplayer, вече се побърках направо
Мнение #1 Skip to the next post in this topic.
Написано на: Ноември 16 2007, 16:10
phidelio

No avatar chosen




Група: Li fans
Мнения: 28
Регистриран: Май 2007

Оценка: няма

Offline
опитвах какво ли не, четох всякакви ръководства из знайни и незнайни български форуми, но така и не успях да подкарам субтитри на кирилица с mplayer. ubuntu 7.10 съм и съм инсталирал пакета mplayer-fonts.
Контакти:  phidelio
WEB  
Мнение #2 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Ноември 16 2007, 17:24
gosheto

Avatar




Група: Li fans
Мнения: 162
Регистриран: Април 2005

Оценка: 5

Offline
Виж тук
Контакти:  gosheto
WEB  
Мнение #3 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Ноември 16 2007, 17:49
tolostoi

Avatar




Група: Li maniacs
Мнения: 869
Регистриран: Юли 2006

Оценка: 5

Offline
Код: 
apt-get install mplayer
след което е добре да си оправим кирилицата от конфиг файлът който се намира в нашата директория (не са ви нужни root права за да го направите, ползвате си вашият потребител) този файл се създава след първото стартиране на мплеър, така, че по добре първо го стартирайте веднъж тогава, пристъпете към промянта на конфиг файла :)
Код: 
nano ~/.mplayer/config
когато се отвори допълнете си това
Код: 
# Write your default config options here!
fontconfig = yes
subfont-text-scale = 2.7
subcp = cp1251
subfont-encoding=unicode
#vf=expand=0:-80:0
този ред
subfont-text-scale = 2.7
показва големината на шрифта, в примера е 2.7 можете да си го направите 3,4,5,2 колкото си искате, както на вас ви харесва на мен 2.7 ми е добре за телевизора. Редът
#vf=expand=0:-80:0
е за местене на субтитрите по вертикала на екрана за мен -80 е добре, пробвайте до -120 (така ще ви бъдат на черните лини субтитрите ако е широкоекранен филма)той започва с # (диез) отпред и се пропуска от интерпретатора, един вид все едно го няма, ако искате да не го пропуска а да го чете и изпълнява просто триете символа #, тогава зададените опции в този ред ще се изпълняват.
Ето още трикове за мплеър http://forums.debian.net/viewtopic.php?t=17783

Мнение #4
Skip to the previous post in this topic. Написано на: Ноември 20 2007, 08:35
didoriginal

Avatar




Група: Li fans
Мнения: 8
Регистриран: Януари 2007

Оценка: няма

Offline
И аз вчера се борих с проблема, но слава Богу го разреших (по някаква случайност сам :) ). Та, отиваш на Preferences -> Fonts. Шрифтовете се пазят в следната папка: /usr/share/fonts/truetype/msttcorefonts/ . Аз лично си избрах Вердана -> /usr/share/fonts/truetype/msttcorefonts/verdana.ttf. След това оставяш encoding-a в секция Fonts на Unicode. След това отдиди на Sibtitles & OSD и избери като encoding Cyrillic Windows (CP1251).

Дано проработи при теб! :)

Контакти:  didoriginal
WEB  
Общо 3 отговор(а) от Ноември 16 2007, 16:10 до сега
 » Начало » Li Форуми » Help & Support » Applications » субититри с mplayer

© 2014 Linux Index Project
Powered by iF 1.0.0 © 2006 ikonForums