Запомняне

» Здравейте
[ Вход :: Регистриране ]
 » Начало » Li Форуми » Help & Support » Applications » Проблемче с mplayer.
Тема: Проблемче с mplayer.
Мнение #1 Skip to the next post in this topic.
Написано на: Февруари 07 2008, 22:48

No avatar chosen




Група: Li fans
Мнения: 258
Регистриран: Януари 2008

Оценка: няма

Offline
Имам проблем с инсталацията на mplayer.Дистрото ми е Ubuntu версия 6.06.Изтеглих пакета MPlayer-0.90.tar.bz2 и го разархивирах,но не мога да го инсталирам.Първо стартирам файла configure ,но при командата make започват да се появяват съобщения за грешки.Нямам gcc компилатор и мисля че в това се корени проблема. Някой знае ли нещо по въпроса или някакъв по-лесен начин за инсталация на mplayer?
Контакти:  AZ ZERGA
WEB  
Мнение #2 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Февруари 07 2008, 23:13

Avatar




Група: Li fans
Мнения: 102
Регистриран: Декември 2006

Оценка: няма

Offline
Вероятно не ти е инсталиран пакета build-essential напиши в конзолата

Код: 
sudo apt-get install build-essential
или го инстални от синаптик ако ти е по удобно
Мнение #3 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Февруари 08 2008, 00:34

No avatar chosen




Група: Li fans
Мнения: 258
Регистриран: Януари 2008

Оценка: няма

Offline
============ Checking for gcc version ============
Result is: 4.0.3, bad
##########################################

============ Checking for gcc-3.1 version ============
Result is: not found
##########################################

============ Checking for gcc3 version ============
Result is: not found
##########################################

============ Checking for gcc-3.0 version ============
Result is: not found
##########################################

============ Checking for cc version ============
Result is: 4.0.3, bad
##########################################

Това е съдържанието на файла configure.log ,затова си мисля че си имам проблем с това ,че нямам инсталиран C компилатор.Иначе си инсталирах както ми каза build-essential,но все още ми иска gcc или поне аз така го разбирам.
Контакти:  AZ ZERGA
WEB  
Мнение #4 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Февруари 08 2008, 10:38

Avatar




Група: Li psychos
Мнения: 1311
Регистриран: Април 2005

Offline
Ами хайде сега да инсталираме и gcc:
Код: 
sudo apt-get install gcc


btw, защо просто не използваш synaptic, за да инсталираш Mplayer като преди това си намерил и сложил подходящите хранилища в '/etc/apt/sources.list' ?

Два месеца работа с компютъра спестява два часа четене на документация

Бизнесът на Microsoft е бизнес за трима: Един пише вируси, друг прави антивирусни, а третият продава (псевдо)операционна система за тях.
Контакти:  stumps

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
Мнение #5 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Февруари 08 2008, 17:02

No avatar chosen




Група: Li fans
Мнения: 258
Регистриран: Януари 2008

Оценка: няма

Offline
Инсталирах си gcc и... пак същият проблем.Не желая да използвам графичен потребителски интерфейс и затова не инсталирам със синаптик.В момента използвам твоят съвет ,като дърпам от хранилищата използвайки apt-get.
Контакти:  AZ ZERGA
WEB  
Мнение #6 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Февруари 08 2008, 17:09

Avatar




Група: Li maniacs
Мнения: 560
Регистриран: Юли 2006

Оценка: 4

Offline
Цитат: (AZ ZERGA @ Февруари 08 2008, 00:34)

============ Checking for gcc version ============
Result is: 4.0.3, bad
##########################################

============ Checking for gcc-3.1 version ============
Result is: not found
##########################################

============ Checking for gcc3 version ============
Result is: not found
##########################################

============ Checking for gcc-3.0 version ============
Result is: not found
##########################################

============ Checking for cc version ============
Result is: 4.0.3, bad
##########################################

Това е съдържанието на файла configure.log ,затова си мисля че си имам проблем с това ,че нямам инсталиран C компилатор.Иначе си инсталирах както ми каза build-essential,но все още ми иска gcc или поне аз така го разбирам.

Ако искаш да ползваш тази версия на gcc ще трябва да ползваш svn дървото :). При мен например работи с gcc 4.2.2, ма версията е някаква странна :)

Цитат: 

Installed versions:  1.0_rc2_p24929-r3


Редактирано от nikolavp на Февруари 08 2008, 17:09

Контакти:  nikolavp

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #7 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Февруари 08 2008, 22:25

No avatar chosen




Група: Li fans
Мнения: 269
Регистриран: Април 2006

Оценка: няма

Offline
Еми идеята е да си провериш кое хранилище да включиш и след това:
apt-get install mplayer
щото ще станеш луд по време на компилацията - ./configure не ти изкарва всички пакети, дето липсват накуп, а еди по един. А те са наистина много. Ако ги намериш някъде описани точните зависимости, може и да се ускорят нещата, ама ...
Ако си нямаш друга работа, компилирай.
Абе винаги съм се чудел, що новаците се хвърлят да компилират без нужда...

Debian Lenny http://mylinuxtoni.site88.net/
Home Linux вестник за GNU/Linux http://vestnik.hbcom.info/news.php
Debian за българи http://debianhome.wordpress.com/
Мнение #8 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Февруари 08 2008, 23:35

No avatar chosen




Група: Li fans
Мнения: 258
Регистриран: Януари 2008

Оценка: няма

Offline
Цитат: (tonitochev @ Февруари 08 2008, 22:25)

Еми идеята е да си провериш кое хранилище да включиш и след това:
apt-get install mplayer
щото ще станеш луд по време на компилацията - ./configure не ти изкарва всички пакети, дето липсват накуп, а еди по един. А те са наистина много. Ако ги намериш някъде описани точните зависимости, може и да се ускорят нещата, ама ...
Ако си нямаш друга работа, компилирай.
Абе винаги съм се чудел, що новаците се хвърлят да компилират без нужда...

Да ти кажа честно вече наистина станах луд.Ако знаех по-лесен начин за инсталация на mplayer въобще нямаше да си губя времето с напразни опити.Първото нещо което пробвах е с apt-get,но явно не разполагам с подходящите хранилища.Ако някой каже някое хранилище ще съм му много благодарен.Ще ми спести наистина много време.
:14;
Контакти:  AZ ZERGA
WEB  
Мнение #9 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Февруари 23 2008, 21:59

No avatar chosen




Група: Li fans
Мнения: 258
Регистриран: Януари 2008

Оценка: няма

Offline
Срам не срам пак ще ви занимая с mplayer.Вече съм си го инсталирал но не мога да намеря информация за плеъра на български език.Някой знае ли някакъв сайт с упътване на български,че не мога да си го подкарам.
Контакти:  AZ ZERGA
WEB  
Мнение #10
Skip to the previous post in this topic. Написано на: Февруари 24 2008, 08:04

No avatar chosen




Група: Li fans
Мнения: 269
Регистриран: Април 2006

Оценка: няма

Offline
Използвам Debian и хранилището за мултимедия го знам. За Ubuntu - не , но просто включи всички налични, а , справка мисля че имаше в linux-bg.org секция идеи. Има тема за хранилищата на дебиан базирани дистрибуции.
Като включиш подходящите хранилища, като не искаш сунаптик, става и конзолно с apt-get или aptitude ...
За МПлаера няма преведено на български. В Дебиан с apt-get install mplayer ти се инсталира каквото е нужно, появява се иконка в менюто, само трябва да си го настроиш да показва бг субтитрите - просто и лесно.

Debian Lenny http://mylinuxtoni.site88.net/
Home Linux вестник за GNU/Linux http://vestnik.hbcom.info/news.php
Debian за българи http://debianhome.wordpress.com/
Общо 11 отговор(а) от Февруари 07 2008, 22:48 до сега
 » Начало » Li Форуми » Help & Support » Applications » Проблемче с mplayer.

© 2014 Linux Index Project
Powered by iF 1.0.0 © 2006 ikonForums