Запомняне

» Здравейте
[ Вход :: Регистриране ]
 » Начало » Li Форуми » Help & Support » Applications » Пръщене от колонките по врме на play-ване
Тема: Пръщене от колонките по врме на play-ване, след преинсталация на ALSA драйверите
Мнение #1 Skip to the next post in this topic.
Написано на: Август 17 2009, 17:21

Avatar




Група: Li fans
Мнения: 105
Регистриран: Юли 2008

Оценка: няма

Offline
Здравейте LI форумци.
Малко предистория. Доста често срещано явление е да има проблеми със звука под Линукс (поне до колкото аз съм запознат). Аз не че нямах звук, имах си, но когато имам пусната програма изпълняваша музика и всички други звуци спират, дори и да е спряла музиката от програмата. Например слушам си музика от Rhythmbox и искам да видя някое клипче във YouTube, спирам музиката пускам клипчето и няма звук  :14; Чак когато затворя Rhythmbox получавам звук от YouTube, но след като свърши клипчето трябва да затворя FireFox-a за да имам звук обратно на Rhythmbox когато го пусна. Доста тъпичко  :29;
 Реших че трябва да си преинстална ALSA драйверите. За жалост не помня точно от кой сайт (или форум) гледах какво точно да изпълня за да ги преинсталирам :6;  :6; , но от тогава на сам вече наистина имам проблеми със звука.

 А самите проблеми са, че когато някоя програма иска да плейва звук, звукът е съпроводен от бръмчене, което дори може да е по-силно от това което свири.

с Ubuntu 8.04 съм на лаптоп Acer Aspire 5315

От System->Preferences->Sound Устройствата които мога да избирам са:
Код: 
pcsp
ALC268 Analog
ALSA - Advanced Linux Sound Architecture
OSS - Open Sound System
PulceAudio Sound Server


като дам lspci това което дава за звуковата ми карта е
Код: 
Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)


П.П. Ако съм избрал ALC268 Analog за устройство по подразбиране, програмите които го използват имат нормален звук, но скайп и дори звуците от самото убунту пръщят.

И в крайна сметка да попитам дали някой е имал подобен проблем или може да предложи нещо с което да пробвам за да си върна звука обратно нормален. Благодаря предварително!

Контакти:  doommaster

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
Мнение #2 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Август 17 2009, 18:07

Avatar




Група: Li fans
Мнения: 240
Регистриран: Август 2005

Оценка: няма

Offline
Предполагам вече си видял темата, но да я покажа: http://ubuntuforums.org/showthread.php?t=101125
Гном съм ползвал много малко, но доколкото знам звуковата му система по подразбиране е ESD. Не знам как се държи ESD, но ако е същия боклук като Arts (аналога на ESD под KDE), силно препоръчвам да го изключиш, или по възможност да го разкараш. Сблъсъка на Arts с ALSA обикновено резултира в звукове от едно единствено приоложение в даден момент от време
След като с ALSA чуваш нещо друго освен пращане, бих те посъветвал да си пуснеш един alsamixer в конзолата и да си поиграеш с нивата на PCM. Когато PCM нивото е прекалено високо, звукавата карта (поне моята) силно изкривява звука и създава впечатление за пращене.
Контакти:  Drakula
WEB  
Мнение #3 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Август 17 2009, 21:53

Avatar




Група: Li fans
Мнения: 105
Регистриран: Юли 2008

Оценка: няма

Offline
Тази статия не я бях видял. Мерси че ми я показа, сега май като гледам имам звук от две приложения, въпросът с пръщенето остава. Ти каза че при теб кривяло и създавало илюзия че пръщи, но при мен си пръщи дори и да е тихо, даже да не издава звук в този момент. а иначе от system->preferences->sound ако избера ALSA и ми пръщи, само на ALC268 Analog не ми пръщи, но както казах не всички програми го използват, въпреки че съм го задал да е то

Контакти:  doommaster

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
Мнение #4 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Август 17 2009, 22:56

Avatar




Група: Li fans
Мнения: 240
Регистриран: Август 2005

Оценка: няма

Offline
Хмм... това не е ли като твоя случай? И там се говори за alsamixer. Дай му шанс :) Може даже да пуснеш "alsamixer -c0 -V all" за да видиш всички канали. Поразцъкай ги, но освен да намаляш нивата на каналите, пробвай да ги изключваш и включваш (с копчето "M"). Имай предвид, че изкривяването може да се получи от калпав усилвател на самата карта и дори да намалиш изходното ниво до минимум без да намалиш "коефициента на усилване", пак може да криви.
Също така, бих споменал, че преди много години на едно FreeBsd на един стар компютър имах пращене като си местех мишката. Интересно, че то мистериозно изчезна като изключих PC Speaker-a, пак от alsamixer :)
Не съм много сигурен какво е ALC268 Analog. Тъй като гледам с Google, изглежда да е някаква Realtek звукова карта. Но пък от друга страна, изглежда си имаш и Интел-ска такава...
Огледай и тази страница - http://www.sabi.co.uk/Notes/linuxSoundALSA.html. Има доста писано, може и да видиш решението.

Редактирано от Drakula на Август 17 2009, 22:57
Контакти:  Drakula
WEB  
Мнение #5 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Август 18 2009, 11:32

Avatar




Група: Li fans
Мнения: 763
Регистриран: Февруари 2008

Оценка: 5

Offline
проблема ти е в pulseaudio, а не в alsa.

Контакти:  altoas

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
Мнение #6 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Август 18 2009, 12:01

Avatar




Група: Li fans
Мнения: 105
Регистриран: Юли 2008

Оценка: няма

Offline
Drakula Играх си с всички възможни канали на alsamixer-a, успях почти да сведа бръмченето до минимум, но и звука беше толкова силен  :D Като намаля допълнително звука от програмата мога да стигна до случай да е почти чист (поне в сравнение с каквото беше) но е адски тих, усиля ли и започва да криви. Все едно предусилвателя на картата е на макс, а крайното стъпало намалено. И когато бутам настройките на звука през алса миксера все едно не усилвам и намалям крайното стъпало, а предусилвателя.

Цитат: 

altoas | Написано на Август 18 2009, 11:32
проблема ти е в pulseaudio, а не в alsa.

И на мен ми се върти нещо такова понеже както написах в началото като си избера звука ми да излиза през PulseAudio и пак бръмчи. Би ли дал някаква идея кое може да човръкна за да стигна до заветната цел.

Контакти:  doommaster

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
Мнение #7 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Август 18 2009, 14:11

Avatar




Група: Li fans
Мнения: 105
Регистриран: Юли 2008

Оценка: няма

Offline
След като стартирах PulseAudio Manager видях че там имам две устройства за изход
Код: 
Name: alsa_output.platform_pcspkr_sound_card_0_alsa_playback_0
Description: ALSA PCM on hw:0 (pcsp) via DMA

Name: alsa_output.pci_8086_284b_sound_card_0_alsa_playback_0
Description: ALSA PCM on front:1 (ALC268 Analog) via DMA


Ако звукът излиза през второто всичко е ок, но ако излиза през първото пръщи.
От настройките на PulseAudio се вижда че Default Sink e alsa_output.platform_pcspkr_sound_card_0_alsa_playback_0, a на мен ми трябва другото.

Как да ги сменя и даже ако може да махна първото изобщо да не се вижда?

Контакти:  doommaster

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
Мнение #8 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Август 18 2009, 19:37

Avatar




Група: Li fans
Мнения: 105
Регистриран: Юли 2008

Оценка: няма

Offline
Няма предложения от никой  :14; , но аз продължавам с човъркането.

Попаднах на
https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/204809
и там пробвах с ръчно зареждането на модулите във /etc/pulse/default.pa но за мое съжаление пак не стана. Оставих само да задам устройствата по подразбиране
Код: 
### Make some devices default
set-default-sink intel-hda_out
set-default-source intel-hda_in


До тук добре ALSA-та ми проработи вече без пръщене  :33; , но PulseAudio-то и OSS-a продължаваt да пръщят, а ALC268 Analog, на което ми работеха по-рано някой програми вече дава грешка ако се play-не звук през него.
На пръв поглед всички програми си имат звук без пръщене (явно използват ALSA-та без проблем)  :24; .
Обаче началния звук на Login екрана вече го няма по незнайна причина  :14; - айде това не е фатално, но за много кратко се появява едно пукане малко преди да започне звука когато се е логнал вече потребител. :12;

Ако все пак някой се е занимавал с настроойка на PulseAudio може да предложи нещо, което съм пропуснал да напише някой ред ;)

Контакти:  doommaster

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
Мнение #9 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Август 19 2009, 23:06

Avatar




Група: Li fans
Мнения: 763
Регистриран: Февруари 2008

Оценка: 5

Offline
pulseaudio при мен правеше големи проблеми, въпреки отчаяните ми опити. накрая махнах изцяло Ubuntu и Gnome. чиста инсталация на Kubuntu 9.04 и за сега нямам спиране на звука, борба м/у приложения и т.н. знам, че не е решение в стил linux, но вкъщи е място за entertainment.

Контакти:  altoas

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
Мнение #10
Skip to the previous post in this topic. Написано на: Август 24 2009, 04:02

Avatar




Група: Li fans
Мнения: 105
Регистриран: Юли 2008

Оценка: няма

Offline
Щом ти не си успял да се справиш със PulseAudio-то... едва ли има смисъл да се мъча много. Малко хич не ми се преинсталира сега, доста си играх и човърках да си подредя разни нещица както ми хрумне, ама.... май може накрая и до там да се стигне да ми е на чисто и да си сложа нещата само които ще ползвам, без другите глупости които слагах и махах само за да ги пробвам. И както каза вкъщи си е вкъщи трябва всичко да работи лесно и безотказно без да се налага сума време в настройки. Щом при чиста инсталация ми работи, значи следващия път трябва да внимавам. :6;  :6;  :6;

Контакти:  doommaster

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
Общо 11 отговор(а) от Август 17 2009, 17:21 до сега
 » Начало » Li Форуми » Help & Support » Applications » Пръщене от колонките по врме на play-ване

© 2014 Linux Index Project
Powered by iF 1.0.0 © 2006 ikonForums