Запомняне

» Здравейте
[ Вход :: Регистриране ]
 » Начало » Li Форуми » Help & Support » Applications » apt-get install linux-headers-2.6.15-1-586tsc
Тема: apt-get install linux-headers-2.6.15-1-586tsc, НЕ СТАВА И ТОВА СИ Е  !!!!!!!!
Мнение #1 Skip to the next post in this topic.
Написано на: Март 02 2006, 20:45
Leftfield

Avatar




Група: Li fans
Мнения: 20
Регистриран: Февруари 2006

Оценка: няма

Offline
Здравейте реших и тук да попитам как да си инсталирам linux-headers-2.6.15-1-586tsc  Пробвах по няколко начина и не стана :

root@1[kernel]#  apt-get install linux-headers-2.6.15-1-586tsc
Reading package lists... Done
Building dependency tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 linux-headers-2.6.15-1-586tsc: Depends: linux-headers-2.6.15-1 (= 2.6.15-3.ww1) but 2.6.15-7 is to be installed

пробвах и през Synaptic и там същата работа , а много ми трябва да го имам инсталиран този пакет щото ми го търси VMWare при инсталацията .... но това е друг въпрос :)

пс: със Simply Mepis 3.4-3 , linux 2.6.15-1-586tsc  съм

Безкрайно ще съм благодарен ако някой може да помогне по някакъв начин
Контакти:  Leftfield
WEB  
Мнение #2 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Март 02 2006, 21:32
stumps

Avatar




Група: Li psychos
Мнения: 1311
Регистриран: Април 2005

Offline
Опитай просто с командата:
Код: 
apt-get install linux-headers

Два месеца работа с компютъра спестява два часа четене на документация

Бизнесът на Microsoft е бизнес за трима: Един пише вируси, друг прави антивирусни, а третият продава (псевдо)операционна система за тях.
Контакти:  stumps

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
Мнение #3 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Март 02 2006, 21:37
Leftfield

Avatar




Група: Li fans
Мнения: 20
Регистриран: Февруари 2006

Оценка: няма

Offline
Опитах ама и така не стана изписвами че трябва да избера точно какво да сваля
root@1[kernel]# apt-get install linux-headers
Reading package lists... Done
Building dependency tree... Done
Package linux-headers is a virtual package provided by:
 linux-headers-2.6.15-1-586tsc 2.6.15-3.ww1
 linux-headers-2.6.12-1-p4-smp 2.6.12-10.dcc3.0
 linux-headers-2.6.12-1-k7-smp 2.6.12-10.dcc3.0
 linux-headers-2.6.12-1-586tsc 2.6.12-10.dcc3.0
 linux-headers-2.6.12-1 2.6.12-10.dcc3.0
 linux-headers-2.6-p4-smp 2.6.12-10.dcc3.0
 linux-headers-2.6-586tsc 2.6.12-10.dcc3.0
 linux-headers-2.6.15-1-k7-smp 2.6.15-7
 linux-headers-2.6.15-1-k7 2.6.15-7
 linux-headers-2.6.15-1-686-smp 2.6.15-7
 linux-headers-2.6.15-1-686 2.6.15-7
 linux-headers-2.6.15-1-486 2.6.15-7
 linux-headers-2.6.15-1 2.6.15-7
 linux-headers-2.6-k7-smp 2.6.15-7
 linux-headers-2.6-k7 2.6.15-7
 linux-headers-2.6-686-smp 2.6.15-7
 linux-headers-2.6-686 2.6.15-7
 linux-headers-2.6-486 2.6.15-7
You should explicitly select one to install.
Контакти:  Leftfield
WEB  
Мнение #4 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Март 04 2006, 02:36
yasnv

No avatar chosen




Група: Li fans
Мнения: 141
Регистриран: Август 2005

Оценка: няма

Offline
сега съм на градус,но ще се опитам да ти обясня проблема.

в файла /etc/apt/sources.list трябва да добавиш хранилище,което да има нужните пакети за да инсталираш това което искаш.

Код: 
The following packages have unmet dependencies:

в линукса има зависимости,апт-гет до голяма степен ги заличава,но за да инсталираш тоя пакет ти трябват още други,които апт-гет не може да ги намери,за това трябва да добавиш тези пакети(които linux-headers-2.6.15-1-586tsc изисква)чрез добавяне на някое хранилище под формата на http или ftp ред с командата

Код: 
kdesu kwrite /etc/apt/sources.list
(командата е за КДЕ)

...иначе не е интересно.
have-tried list: Slax Slackware Mandriva SuSe Knoppix Debian Mepis PCLinuxOS Vector.Linux Ubuntu Kubuntu Tilix Xandros PC-BSD Frugalware rPath VLOS Fedora Gentoo
next-to-try:Korooa
Контакти:  yasnv
WEB  
Мнение #5 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Март 04 2006, 21:41
phantomlord
Phantom Lord
Avatar




Група: Li maniacs
Мнения: 665
Регистриран: Август 2005

Оценка: няма

Offline
Цитат:

Depends: linux-headers-2.6.15-1 (= 2.6.15-3.ww1) but 2.6.15-7 is to be installed

Предполагам, че linux-headers-2.6.15-1-586tsc е в testing хранилищата и за да се инсталира той, е необходимо да се инсталира и пакета на linux-headers. apt-get си избира по-новата версия "but 2.6.15-7 is to be installed", която пък е несъвместима с 2.6.15-1. Пробвай да изключиш (коментираш) unstable репотата. Остави само stable и testing хранилищата. После: apt-get update и отново пробваш с инсталацията.

Debian lenny/sid, 2.6.24-phantomlord, KDE 3.5.9
http://myfreesoft.net/phpBB2/index.php?c=7
The knowledge is to be shared...
Помогни си сам, за да ти помогне и Господ
Контакти:  phantomlord

  • AOL  AOL:
  • ICQ  ICQ: 322393169
  • MSN  MSN:
  • YIM  Yahoo IM:
Мнение #6
Skip to the previous post in this topic. Написано на: Април 17 2006, 15:47

Avatar


Warn 3

Група: Li fans
Мнения: 384
Регистриран: Април 2006

Оценка: няма

Offline
Еми аз май отговорих на тази тема тука !

red@debian:~$ sudo apt-build world
-----> Rebuilding the world! <-----
-----> Building package list <-----
Please read README.Debian first.
red@debian:~$
Контакти:  Red

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Общо 5 отговор(а) от Март 02 2006, 20:45 до сега
 » Начало » Li Форуми » Help & Support » Applications » apt-get install linux-headers-2.6.15-1-586tsc

© 2014 Linux Index Project
Powered by iF 1.0.0 © 2006 ikonForums