Запомняне

» Здравейте
[ Вход :: Регистриране ]
 » Начало » Li Форуми » Help & Support » Kernels & Drivers » Ari Radeon 9550 под Suse 10.1
Тема: Ari Radeon 9550 под Suse 10.1, Въпрос
Мнение #1 Skip to the next post in this topic.
Написано на: Февруари 02 2007, 16:25
Centrino

Avatar




Група: Li fans
Мнения: 31
Регистриран: Януари 2007

Оценка: няма

Offline
Здравейте
искам да помоля някой да ми каже къде бъркам при инсталирането на драйварите за Видеото ми.


Примерен код
 ip-181-175:~/bin # ati-driver-installer-8.33.6-x86.x86_64.run --listpkg
Creating directory fglrx-install
Verifying archive integrity... All good.
Uncompressing ATI Proprietary Linux Driver-8.33.6.............................................................................


..........................................................................................


..........................................................................................


..........................................................................................


..........................................................................................


..........................................................................................


....................................................
==================================================
ATI Technologies Linux Driver Installer/Packager
==================================================
List of generatable packages:

Package Maintainer(s): Aric Cyr <aric.cyr@ati.com>
Status: *UNVERIFIED*
Debian Packages:
       Debian/sarge
       Debian/stable
       Debian/sid
       Debian/unstable
       Debian/etch
       Debian/testing
       Debian/experimental

Package Maintainer(s): Niko Mirthes <nmirthes@gmail.com>
                      Michael Larabel <michael@phoronix.com>
Status: Verified
Fedora Packages:
       Fedora/FC3
       Fedora/FC4
       Fedora/FC5
       Fedora/FC6
       Fedora/RHEL3
       Fedora/RHEL4

Package Maintainer(s): Arnaud Patard <apatard@mandriva.com>
Status: *UNVERIFIED*
Mandriva Packages:
       Mandriva/2006
       Mandriva/2007

Package Maintainer(s): Bowen Zhu <bwzhu@redflag-linux.com>
Status: *UNVERIFIED*
RedFlag Packages:
       RedFlag/RF50

Package Maintainer(s): ATI
Status: Verified
RedHat Packages:
       RedHat/RHEL3
       RedHat/RHEL3_64a
       RedHat/RHEL4
       RedHat/RHEL4_64a

Package Maintainer(s): Stefan Dirsch <sdirsch@suse.de>
Status: Verified
SuSE Packages:
       SuSE/NLD9-IA32
       SuSE/SLES9-IA32
       SuSE/SUSE91-IA32
       SuSE/NLD9-AMD64
       SuSE/SLES9-AMD64
       SuSE/SUSE91-AMD64
       SuSE/SUSE100-IA32
       SuSE/SUSE92-IA32
       SuSE/SUSE93-IA32
       SuSE/SUSE100-AMD64
       SuSE/SUSE92-AMD64
       SuSE/SUSE93-AMD64
       SuSE/SLED10-IA32
       SuSE/SLES10-IA32
       SuSE/SUSE101-IA32
       SuSE/SLED10-AMD64
       SuSE/SLES10-AMD64
       SuSE/SUSE101-AMD64
       SuSE/SUSE102-IA32
       SuSE/SUSE102-AMD64

Package Maintainer(s): Aric Cyr <aric.cyr@gmail.com>
Status: *UNVERIFIED*
Ubuntu Packages:
       Ubuntu/warty
       Ubuntu/4.10
       Ubuntu/hoary
       Ubuntu/5.04
       Ubuntu/breezy
       Ubuntu/5.10
       Ubuntu/dapper
       Ubuntu/6.06
       Ubuntu/edgy
       Ubuntu/6.10

For example, to build a Debian Etch package, run the following:
% ./ati-driver-installer-<version>-<architecture>.run --buildpkg Debian/etch

Removing temporary directory: fglrx-install
ip-181-175:~/bin # ./ati-driver-installer-8.33.6-x86.x86_64.run --buildpkg SuSe/SUSE101-IA32
Creating directory fglrx-install
Verifying archive integrity... All good.
Uncompressing ATI Proprietary Linux Driver-8.33.6.............................................................................


..........................................................................................


..........................................................................................


..........................................................................................


..........................................................................................


..........................................................................................


....................................................
==================================================
ATI Technologies Linux Driver Installer/Packager
==================================================
The distribution 'SuSe' is not supported
Removing temporary directory: fglrx-install
ip-181-175:~/bin # ./ati-driver-installer-8.33.6-x86.x86_64.run --buildpkg SuSE/SUSE101-IA32
Creating directory fglrx-install
Verifying archive integrity... All good.
Uncompressing ATI Proprietary Linux Driver-8.33.6.............................................................................


..........................................................................................


..........................................................................................


..........................................................................................


..........................................................................................


..........................................................................................


....................................................
==================================================
ATI Technologies Linux Driver Installer/Packager
==================================================
Generating package: SuSE/SUSE101-IA32
/tmp/ati.Q25973
rpm -Package /root/bin/fglrx_6_9_0_SUSE101-8.33.6-1.i386.rpm has been successfully generated
Removing temporary directory: fglrx-install
ip-181-175:~/bin # rpm -Uhv fglrx_6_9_0_SUSE101-8.33.6-1.i386.rpm
Preparing...                ########################################### [100%]
  1:fglrx_6_9_0_SUSE101    ########################################### [100%]

*************************************************************
Package "kernel-source" needs to be installed by YaST2 first!
*************************************************************


**************************************************************
Building/installation of fglrx kernel module failed! Try again
by calling "/usr/X11R6/bin/fglrx-kernel-build.sh" manually.
**************************************************************


*************************************************************
Please read "/usr/share/doc/packages/fglrx/README.SuSE" for
configuration details when using SaX2.
*************************************************************

ip-181-175:~/bin # rpm -Uhv fglrx_6_9_0_SUSE101-8.33.6-1.i386.rpm
Preparing...                ########################################### [100%]
       package fglrx_6_9_0_SUSE101-8.33.6-1 is already installed
ip-181-175:~/bin # /usr/X11/bin/fglrx-kernel-build.sh
/usr/src/kernel-modules/fglrx ~/bin
rm: cannot remove `Modules.symvers': No such file or directory
rm: cannot remove `*.o': No such file or directory
rm: cannot remove `*.ko': No such file or directory
rm: cannot remove `*.mod.*': No such file or directory
make: Entering directory `/usr/src/linux-2.6.16.13-4-obj/i386/default'
make -C ../../../linux-2.6.16.13-4 O=../linux-2.6.16.13-4-obj/i386/default
 LD      /usr/src/kernel-modules/fglrx/built-in.o
 CC [M]  /usr/src/kernel-modules/fglrx/firegl_public.o
/usr/src/kernel-modules/fglrx/firegl_public.c:468: warning: initialization from incompatible pointer type
/usr/src/kernel-modules/fglrx/firegl_public.c: In function ‘KAS_ExecuteAtLevel’:
/usr/src/kernel-modules/fglrx/firegl_public.c:4449: warning: ‘flags’ may be used uninitialized in this function
 LD [M]  /usr/src/kernel-modules/fglrx/fglrx.o
 Building modules, stage 2.
 MODPOST
WARNING: could not find /usr/src/kernel-modules/fglrx/.libfglrx_ip.a.GCC4.cmd for /usr/src/kernel-modules/fglrx/libfglrx_ip.a.GCC4
 CC      /usr/src/kernel-modules/fglrx/fglrx.mod.o
 LD [M]  /usr/src/kernel-modules/fglrx/fglrx.ko
make: Leaving directory `/usr/src/linux-2.6.16.13-4-obj/i386/default'
make: Entering directory `/usr/src/linux-2.6.16.13-4-obj/i386/default'
make -C ../../../linux-2.6.16.13-4 O=../linux-2.6.16.13-4-obj/i386/default modules_install
 INSTALL /usr/src/kernel-modules/fglrx/fglrx.ko
 DEPMOD  2.6.16.13-4-default
make: Leaving directory `/usr/src/linux-2.6.16.13-4-obj/i386/default'
~/bin
ip-181-175:~/bin #



 Според мене проблема е ето в това
Примерен код

 Package "kernel-source" needs to be installed by YaST2 first!


 но после се усетих че този пакет трябва да бъде инсталиран. Инсталирах го от дисковете с Suse-a  и изпълних още веднъж командата но тогава ми показа че вече са инсталирани. И така аз реших че всичко е ок и тръгнах да иснталирам 3D - то.  Четох насам натам и разбрах че се инсталира с командата
Sax2 -r -m 0=fglrx -b /usr/share/doc/packages/fglrx/sax-profile
изпулних я... но нищо все още нямам 3D

Моля Ви Помогнете ми. За първи път сядам на PC с такъв вид операционна система

п.с Четох и много други статии за инсталиране на драйвъри на Ати но и с тях не можах. Само можах да съсипя системата и се наложи да преинсталирам.
Контакти:  Centrino
WEB  
Мнение #2 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Февруари 02 2007, 17:29
liubeto

No avatar chosen




Група: Li fans
Мнения: 58
Регистриран: Декември 2005

Оценка: няма

Offline
Здрасти аз съм с същата видео карта, обаче не съм с Suse, а с Slackware, незнам откъде си го дърпал този драйвъра, но при инсталацията на моя всичко мина в графичен режим, нямаше никъкъв проблем, чел съм и съм свалял от страницата на ATI, единственото кофти беше че дори след инсталацията трябваше да си задам чрез командата aticonfig, хоризонтална и вертикална честота на монитора и резолюция на екрана. Ръчно от файлът xorg.conf неставаше.Сега пак преглеждам инструкциите и не съм работил много на Suse (даже хич), но защо пишеш тая команда след като инсталацията се стартира с  
Код: 
sh ./ati-driver-installer-8.33.6.run

А и в официалните инструкции пише, че драйвърът е направен специално за Red hat destrubutions. Не би трябвало да има проблеми.

Once you go slack, you never turn back :)
Контакти:  liubeto
WEB  
Мнение #3 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Февруари 02 2007, 17:45
hollow

Avatar




Група: Li fans
Мнения: 65
Регистриран: Януари 2006

Оценка: няма

Offline
ами в yast  като напишеш да ти търси ati те ти ли изкарва някакви драйвери?май на сусе съм слагал но ако не ги слагаш през yast трябва X  да не ти върви по време на инсталацията(така поне беше с драйверите на nvidia) .иначе казано първо init 3  и чак тогава sh ./ati-driver-installer-8.33.6.run

Контакти:  hollow
WEB  
Мнение #4 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Февруари 02 2007, 19:23
nikolavp

Avatar




Група: Li maniacs
Мнения: 560
Регистриран: Юли 2006

Оценка: 4

Offline
От линка, който ти дадох в другата тема и който не си прочел внимателно.Първо не прави нови тема за същите неща и второ чети по внимателно
Цитат:

You still need to configure the driver with SaX2. Details can be found
in /usr/share/doc/packages/fglrx/README.SuSE.

Unfortunately you need to recompile the "fglrx" kernel module right
after any kernel (security) update. Use "fglrx-kernel-build.sh" for
this.
Sега виж какво точно пише в /usr/share/doc/packages/fglrx/README.SuSE и виж дали отговаря на това, което пишеш в конзолата за Sax после да те питам как позна, че нямаш 3d какво ти дава
Код: 
glxinof | grep render
ако това ти дава блаблабла:: No .Значи не ти е пуснато и пробвай да махнеш пакета(тук вече ще трябва да погледнеш нещата, които ти дадох, защото честно казано съм забравил как се работи си rpm :) и после пак да го "rebuild-неш" и инсталираш с rpm -Uhv пакета.

Контакти:  nikolavp

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #5 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Февруари 02 2007, 20:13
liubeto

No avatar chosen




Група: Li fans
Мнения: 58
Регистриран: Декември 2005

Оценка: няма

Offline
С риск да те объркам окончателно хвърли едно око на това
:6;

Once you go slack, you never turn back :)
Контакти:  liubeto
WEB  
Мнение #6 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Февруари 02 2007, 20:49
Centrino

Avatar




Група: Li fans
Мнения: 31
Регистриран: Януари 2007

Оценка: няма

Offline
Така....... Здравейте. Мерси че се опитахте да ми помогнете, но явно аз съм куха лейка. Драйвърите съм ги инсталирал. Поеви ми се в менюто иконка от която да конфигурирам "уж".
но проблема идва в друго. Графиката много ми насича(невъзможно е на windows компа ми вървеше по добре) и като пусна my computer ми пише някакъв друг модел на видео картата и показва 3d not supported :14; А колкото до документа който nikolavp ми даде много му благодаря. Но направих всичко от там. Чел съм го много пъти дори още продължавам да го чета защото нещо при мене не се получава ето това
Код: 
You still need to configure the driver with SaX2. Details can be found
in /usr/share/doc/packages/fglrx/README.SuSE.

Unfortunately you need to recompile the "fglrx" kernel module right
after any kernel (security) update. Use "fglrx-kernel-build.sh" for
this.


или аз не си го превеждам както трябва или и аз не знам вече :(  
главно не можах да разбера какво трябва да правя с тоя sax2 стартирам го. От там мога да настроивам резолюция и  пр.
също  /usr/share/doc/packages/fglrx/README.SuSE влизам тука ама... Като ми се пусне sux2 то и там не ми показва правилния модел на видео картата. Вади ми като модел  Model:  RV350 AS О_о и аз не знам . Но не мисля да се откажа ако трябва ще сменя дистрибуцията. Но напълно съм решил да си остана на linux.оффф и аз не знам  :28;  работата стана много мацана
Контакти:  Centrino
WEB  
Мнение #7 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Февруари 02 2007, 21:33
nikolavp

Avatar




Група: Li maniacs
Мнения: 560
Регистриран: Юли 2006

Оценка: 4

Offline
Я да видиме как си е свършил работата Sax :).Дай изход от
Код: 
cat /etc/X11/xorg.conf | grep Driver
и от
Код: 
rpm -q kernel-headers
(дано не ме лъже паметта за това ;))

EDIT:Ако второто не стане добави и параметър -а
Код: 
rpm -qa kernel-headers


Редактирано от nikolavp на Февруари 02 2007, 21:35

Контакти:  nikolavp

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #8 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Февруари 02 2007, 21:58
liubeto

No avatar chosen




Група: Li fans
Мнения: 58
Регистриран: Декември 2005

Оценка: няма

Offline
Колкото и странно да ти звучи това е драйверът, който ти трябва (за твоита карта), при мене самата карта я разпознава като RV350 AS [Radeon 9550], (цялото название след lspci, което ми излиза за видео картата е
Цитат:

VGA compatible controller: ATI Technologies Inc RV350 AS [Radeon 9550]

За конфигурация на самата карта пишеш и четеш (при мене не стана с редакция на xorg.conf):
Код: 
aticonfig --help

Once you go slack, you never turn back :)
Контакти:  liubeto
WEB  
Мнение #9 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Февруари 02 2007, 22:41
Centrino

Avatar




Група: Li fans
Мнения: 31
Регистриран: Януари 2007

Оценка: няма

Offline
Здравейте,
Работата при мене стана много умацана. Линукса нещо му стана. :))) т.е аз му напраих нещо ще се наложи да го реинсталирам защото като го пусна и.. опаа не стига до графична среда  :14;  бързо действам а ? Имам линукс от 2 дена а съм го реинсталвал 3 пъти  :8; а пък неска не ми се занимава повече с компютри. Просто нервите ми с ана ркаен предел отивам да релаксирам малко. Утре ще видя какво ще правя дано всичко да мине по мед и масло ( което малко ме съмнява де :) ) а пък ако имам проблеми пак ще се обръщам към вас :))) Хората  са казали " надеждата умира последна"

Лека вечер на всички!!! и благодатя за помоща

п.с Не пиша от моето pc
Контакти:  Centrino
WEB  
Мнение #10
Skip to the previous post in this topic. Написано на: Февруари 03 2007, 20:21
Centrino

Avatar




Група: Li fans
Мнения: 31
Регистриран: Януари 2007

Оценка: няма

Offline
Здравейте отново съм аз. Преинсталирах линукса и сложих на ново драйвърите точно както беше написано в туторитала който nikolavp беше да. Но стиганах до стъпката
Код: 
You still need to configure the driver with SaX2. Details can be found
in /usr/share/doc/packages/fglrx/README.SuSE.

Unfortunately you need to recompile the "fglrx" kernel module right
after any kernel (security) update. Use "fglrx-kernel-build.sh" for
this.
и зациклих. Не знам какво да правя не можах да го разбера. А не ми работи все още 3d-то(а как разбрах ли много просто пробвах да стартирам една проста 3d игричка която върви с дистрибуцията. И като се пробвах да я стартирам ми изписа че нямам 3D)
@nikolavp При изпълнението на командата
Цитат:

rpm -q kernel-headers

се полевява ето това
Код: 
ip-181-175:~ # rpm -q kernel-headers
package kernel-headers is not installed


При изпълнението на командата
Цитат:

cat grep driver

нищо не става
Код: 
ip-181-175:/etc/X11 # cat xorg.conf | Grep Driver
bash: Grep: command not found

помогнете.. На път съм да се откажа от линукс :(( и да мина пак на бозавия Виндоус
Контакти:  Centrino
WEB  
Общо 26 отговор(а) от Февруари 02 2007, 16:25 до сега
 » Начало » Li Форуми » Help & Support » Kernels & Drivers » Ari Radeon 9550 под Suse 10.1

© 2014 Linux Index Project
Powered by iF 1.0.0 © 2006 ikonForums