Запомняне

» Здравейте
[ Вход :: Регистриране ]
 » Начало » Li Форуми » Help & Support » Kernels & Drivers » Проблем с Nvidia драйвър
Тема: Проблем с Nvidia драйвър
Мнение #1 Skip to the next post in this topic.
Написано на: Септември 21 2007, 20:07
makrosxxx

Avatar




Група: Li fans
Мнения: 79
Регистриран: Октомври 2006

Оценка: няма

Offline
Като пусна да гледам филм и по някое време компа зацикля тотално и само твърд рестарт го оправя.
Пробвах с различни плеари и различни филми, ала  ефекта е един и същ. Редактирах
Цитат:

Section "Device"
Identifier "nVidia Corporation NV34 [GeForce FX 5200]"
Driver "nv"
BusID "PCI:1:0:0"

и проблема изчезна .
При инсталацията на драйвърите всичко мина нормално, без да извежда никакви грешки.
Дистрото е Debian stable
Контакти:  makrosxxx
WEB  
Мнение #2 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Септември 21 2007, 23:50
tolostoi
Нерегистриран










Махни драйвера от нвидиа и го инсталирай наново, понякога се получват такива неща когато има упдейти по приложения свързани с Х-а, а то скоро имаше (абе и на КДЕ-то днес ъпдейти и то доста, нещо се съживи тоя стабилният :) )
Контакти:  tolostoi

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #3 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Септември 22 2007, 20:27
makrosxxx

Avatar




Група: Li fans
Мнения: 79
Регистриран: Октомври 2006

Оценка: няма

Offline
Преинсталирах драйвърите, ала пак продължаваше да забива.
Преинсталирах Debiana , изпълних :
Цитат:

#apt-get update
#apt-get dist-upgrade


след това :
Цитат:

1. Добавяте следното хранилище в /etc/apt/sources.list:
Цитат:
deb http://sidux.com/debian/ sid main contrib non-free firmware fix.main fix.contrib fix.non-free


2. Изпълнявате:
Код:
apt-get update
apt-get install sidux-scripts


3. Излизате от Х-а като изпълнявате:
Код:
/etc/init.d/gdm stop #ако ползвате gdm
/etc/init.d/kdm stop #ако ползвате kdm


4. Логвате се като root и изпълнявате:
Код:
sgfxi

Първите няколко часа всичко беше ОК, ала в един момент заби тотално. Под линдоус нямам тези проблеми!?
Контакти:  makrosxxx
WEB  
Мнение #4 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Септември 23 2007, 11:18
tonitochev

No avatar chosen




Група: Li fans
Мнения: 269
Регистриран: Април 2006

Оценка: няма

Offline
Еми като гледам, ти от stable си скочил директно на unstable. А това е версия на Debian, където пакетите са на ръба, така да се каже. И при тея чести обновявания е нормално от време на време да се получават проблеми.
Най-благоприятният вариант си е Debian test, където сорса е сравнително нов и достатъчно стабилен.
В случая просто си ползвай драйвера nv и толкоз.
При мен с Nvidia 400  и използване на драйвер 9639 на nvidia всичко работи два дена и после почва рестартът на X сървъра когато му хареса.
Е същото го прави , но много рядко, под Уиндоус. Така че сигурно проблема ми е чисто хардуерен. Скоро ще разбера, като си сменя видеокартата.

Debian Lenny http://mylinuxtoni.site88.net/
Home Linux вестник за GNU/Linux http://vestnik.hbcom.info/news.php
Debian за българи http://debianhome.wordpress.com/
Мнение #5 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Септември 23 2007, 13:47
makrosxxx

Avatar




Група: Li fans
Мнения: 79
Регистриран: Октомври 2006

Оценка: няма

Offline
При разрешени само stable хранилища, без използването на скрипта по горе, инсталиране на драйвъра по следния начин
Цитат:

apt-get install module-assistant nvidia-kernel-common
m-a prepare
m-a auto-install nvidia
apt-get install nvidia-glx

Пак се получава същия проблем !?
Контакти:  makrosxxx
WEB  
Мнение #6 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Септември 23 2007, 14:13
tolostoi

Avatar




Група: Li maniacs
Мнения: 869
Регистриран: Юли 2006

Оценка: 5

Offline
Драйвера в стабилното хранилище е много "стабилен" 77 нещо май беше, махни всичко което си сложил от хранилищата (с aptitude purge imeto_na_paketa ще разчистиш по-бързо) и пробвай така http://forums.linux-index.org/ikonboa....;t=2352

Мнение #7 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Септември 23 2007, 15:04

No avatar chosen




Група: Li fans
Мнения: 34
Регистриран: Февруари 2007

Оценка: няма

Offline
Махни драйвърите както ти е казал Tolostoi или в конзола nvidia-installer --uninstall и следвай следната статия:
http://myfreesoft.net/phpBB2/viewtopic.php?t=596
Моята / GF 5500 / вчера изгоря и сега съм временно с по - стара - MX 440 и инсталирах драйвърите без проблем, следвайки въпросната статия.
Дистрото ми е като твоето! Успех! :28;
Контакти:  deke
WEB  
Мнение #8 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Септември 23 2007, 23:24
makrosxxx

Avatar




Група: Li fans
Мнения: 79
Регистриран: Октомври 2006

Оценка: няма

Offline
Деинсталирах, свалих драйвъра от сайта на Nvidia, инсталирах по описания от Tolostoi метод. Всичко премина без грешки, ала на края пак същата работа !? Като си пусна 3D скринсървър (Еуфория) и почти веднага следва рестарт на Х или тотално забиване, със филмите е същата работа. Взех да се съмнявам вече дали картата ми не е взела да сдава багажа. Минах под линдоус и пуснах 4 филма наведнъж(нямам инсталирани игри), никакви забивани, никакви рестарти и т.н..
Не знам вече какво да правя  :14;

Ето и част от грешката която ми изписа :

Цитат:

EFLAGS: 00213097 (2.6.18-5-486 #1)
Eip is at 0xdc91292f
..........................................................................................
..........................
Process xorg(pid:2964, ti=dd3aa000 task=dfeae570 tast.ti=dd3aa000)
..........................................................................................
..........................
call trace:
[<c01114ed>]wake_up+0x11/0x1a
[<co1ec155>]release-dev+0x20d/0x5a1
[<c01b5188>]proc_bus-pci-open+0x585/0x620
..........................................................................................
...........................


Редактирано от makrosxxx на Септември 24 2007, 08:47
Контакти:  makrosxxx
WEB  
Мнение #9 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Септември 24 2007, 09:51
tolostoi

Avatar




Група: Li maniacs
Мнения: 869
Регистриран: Юли 2006

Оценка: 5

Offline
Казано честно от тези грешки нищо не ми става ясно, но за първи път чувам за такъв проблем, може наистина да е нещо хардуеърно. Ти кой драйвер инсталира?
С част от грешките в гугъл нищо ли не излиза?

Мнение #10
Skip to the previous post in this topic. Написано на: Септември 24 2007, 11:09
makrosxxx

Avatar




Група: Li fans
Мнения: 79
Регистриран: Октомври 2006

Оценка: няма

Offline
NVIDIA-Linux-x86-100.14.19-pkg1.run
Това е драйвъра който инсталирах.
Ако беше хардуерен проблем би трябвало и под линдоус да имам същите проблеми. До скоро там съм играл игри които искат доста ресурси(процесор, рам, видео) и не съм имал никакви проблеми, хем съм с Windows 2003 Enterprise Server .
Смених пак nvidia с nv в xorg.conf, пуснах няколко филма наведнъж и ги оставих тако поне 30 мин., няма зацикляне няма никакви проблеми.
Ползвал съм и др. дистрибуции(Kubuntu, Tilix, Mandriva, Suse, Slackware ) но такива проблеми до сега не съм имал.
Контакти:  makrosxxx
WEB  
Общо 10 отговор(а) от Септември 21 2007, 20:07 до сега
 » Начало » Li Форуми » Help & Support » Kernels & Drivers » Проблем с Nvidia драйвър

© 2014 Linux Index Project
Powered by iF 1.0.0 © 2006 ikonForums