Запомняне

» Здравейте
[ Вход :: Регистриране ]
 » Начало » Li Форуми » Help & Support » Kernels & Drivers » Драйвър за звукова карта Intel ICH7
Тема: Драйвър за звукова карта Intel ICH7
Мнение #1 Skip to the next post in this topic.
Написано на: Ноември 03 2007, 22:32
hellkiller

Avatar




Група: Li fans
Мнения: 63
Регистриран: Юли 2006

Оценка: няма

Offline
Диструбиция: Kubuntu 7.10. Проблемът е следният - доста често се губи звукът. Смисъл като се стартира повечето пъти има звук и след малко изчезва. Дори някой път като го намаля или увелича отново изчезва напълно. Налага се рестарт на системата, но някой път и тои не помага. Идеи как да се оправи проблема. Звуковата карта е вградена.
Контакти:  hellkiller
WEB  
Мнение #2 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Ноември 03 2007, 23:07
delafer

Avatar




Група: Li fans
Мнения: 398
Регистриран: Март 2006

Оценка: няма

Offline
Не даваш подробности... Прегледай ТОЗИ линк, надявам се да ти свърши работа.

Редактирано от delafer на Ноември 03 2007, 23:10

"Imagination is more important than knoledge" A.Einstein
Контакти:  delafer
Мнение #3 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Ноември 03 2007, 23:37
hellkiller

Avatar




Група: Li fans
Мнения: 63
Регистриран: Юли 2006

Оценка: няма

Offline
Като дам да инсталирам alsa-utils казва, че е инсталирана най-новата версия, а като напиша "sudo alsaconf" и ми казва "command not found". Идеи?
Контакти:  hellkiller
WEB  
Мнение #4 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Ноември 03 2007, 23:59
saejoh

Avatar




Група: Li maniacs
Мнения: 449
Регистриран: Септември 2005

Оценка: няма

Offline
Този линк може да ти даде още идеи, но май общо взето пак опира до alsa-та.
Най-долу се говори и за pciutils, виж дали ги имаш в твойто дистро.


Редактирано от saejoh на Ноември 04 2007, 00:10

Ath XP 1700+, NVidia, Biostar M7NCG, Повече тук и тук
Контакти:  saejoh

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #5 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Ноември 04 2007, 04:31
delafer

Avatar




Група: Li fans
Мнения: 398
Регистриран: Март 2006

Оценка: няма

Offline
Не съм в час с UBUNTU... пробвай да стартираш командата с пълния и път - трябва да е в /usr/sbin/alsaconf.

По принцип пакетите са 2 - alsa-libs и alsa-utils - или нещо подобно като име - провери през пакетния мениджър дали са ти инсталирани наистина. Alsaconf е част от втория.

Друга идея мога да ти дам - пишеш
Код: 
sudo alsa[и тук натискаш TAB]
и ще видиш какви възможности ще ти предложи.

И още - контролния център на KDE си настрой да ползува за звука ALSA, ако не си...


Редактирано от delafer на Ноември 04 2007, 04:47

"Imagination is more important than knoledge" A.Einstein
Контакти:  delafer
Мнение #6 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Ноември 04 2007, 10:54
hellkiller

Avatar




Група: Li fans
Мнения: 63
Регистриран: Юли 2006

Оценка: няма

Offline
Ето какво дава:

rahnev@Slack:~$ sudo apt-get install alsa
alsa                   alsaplayer-common      alsaplayer-output
alsa-base              alsaplayer-daemon      alsaplayer-text
alsa-firmware-loaders  alsaplayer-esd         alsaplayer-xosd
alsa-headers           alsaplayer-gtk         alsa-source
alsamixergui           alsaplayer-interface   alsa-tools
alsa-oss               alsaplayer-jack        alsa-tools-gui
alsaplayer             alsaplayer-nas         alsa-utils
alsaplayer-alsa        alsaplayer-oss

Иначе през пакетния мениджър дава, че alsa-utils е инсталиран. Но не намира пакет alsa-libs
Контакти:  hellkiller
WEB  
Мнение #7 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Ноември 04 2007, 13:16
delafer

Avatar




Група: Li fans
Мнения: 398
Регистриран: Март 2006

Оценка: няма

Offline
Това което ме дразни в Linux (btw единственото) липсата на унификация поне на основните неща !!! Командата е
Код: 
sudo asoundconf


справка -> ТУК

Иначе процедурата би трябвало да е следната, само ще си я преведеш на "езика" на убунту :
- alsaconf ( при теб asoundconf) - за настройка на модула за картата
- alsamixer ( при теб ...?) - тук си от-mute-ваш колкото се може повече канали, по-нататък ще видиш кое няма да ти трябва
- alsactl store ( при теб...?) - за да си запомни настройките и да не си прави каквото му хрумне при следващо рестартиране.

След това, както ти казах по-горе в контролния център на KDE - alsa...
И кажи дали сме го излъгали да проработи като хората...  ;)


Редактирано от delafer на Ноември 04 2007, 13:27

"Imagination is more important than knoledge" A.Einstein
Контакти:  delafer
Мнение #8 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Ноември 04 2007, 14:40
hellkiller

Avatar




Група: Li fans
Мнения: 63
Регистриран: Юли 2006

Оценка: няма

Offline
Пак не е нещо като хората, т.е. е същото. Когато се опитам да намаля или увелича звука и той изчезва напълно. Иначе останалите 2 команди са същите. Какъв му е проблема?  :29;

Редактирано от hellkiller на Ноември 04 2007, 16:11
Контакти:  hellkiller
WEB  
Мнение #9 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Ноември 04 2007, 16:14
delafer

Avatar




Група: Li fans
Мнения: 398
Регистриран: Март 2006

Оценка: няма

Offline
Май попаднах на нещо - прегледай ТОВА. Не съм много сигурен, ама ми намирисва на твоя проблем...
ТОВА е и самото ръководство за настройка. Това за най-новата версия на alsa го пропусни - ти така или иначе имаш най-новата. Обърни внимание на секцията за настройка на параметрите на модула и накрая - за настройката на kmix.


Редактирано от delafer на Ноември 04 2007, 16:21

"Imagination is more important than knoledge" A.Einstein
Контакти:  delafer
Мнение #10
Skip to the previous post in this topic. Написано на: Ноември 04 2007, 16:58
hellkiller

Avatar




Група: Li fans
Мнения: 63
Регистриран: Юли 2006

Оценка: няма

Offline
Мисля, че този път го излъгах :) Сега уж върви както трябва. Добавих този ред "options snd-hda-intel model=laptop" в края на файла "/etc/modprobe.d/alsa-base" и се получи. Благодаря много ;)
Контакти:  hellkiller
WEB  
Общо 10 отговор(а) от Ноември 03 2007, 22:32 до сега
 » Начало » Li Форуми » Help & Support » Kernels & Drivers » Драйвър за звукова карта Intel ICH7

© 2014 Linux Index Project
Powered by iF 1.0.0 © 2006 ikonForums