Запомняне

» Здравейте
[ Вход :: Регистриране ]
 » Начало » Li Форуми » Help & Support » Kernels & Drivers » Проблем с видео драйверите
Тема: Проблем с видео драйверите
Мнение #1 Skip to the next post in this topic.
Написано на: Ноември 08 2007, 20:08
bostko

No avatar chosen




Група: Li fans
Мнения: 35
Регистриран: Юли 2006

Оценка: няма

Offline
Вече трети ден се мъча да инсталирам видео драйвери на един компютър. Видео картата е АТИ 9600. Пробвах на убунту 7.10 и на ПСЛинуксОС 2007 да ги сложа обаче без успех :( Сега последно съм на ПСЛинуксОС 2007. Инсталирал съм ати 8.40.4 от synaptic. [rumen@localhost ~]$ glxinfo
name of display: :0.0
display: :0  screen: 0
direct rendering: No
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
   GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
   GLX_EXT_import_context, GLX_EXT_texture_from_pixmap, GLX_OML_swap_method,
   GLX_SGI_make_current_read, GLX_SGIS_multisample, GLX_SGIX_hyperpipe,
   GLX_SGIX_swap_barrier, GLX_SGIX_fbconfig, GLX_MESA_copy_sub_buffer
client glx vendor string: ATI
client glx version string: 1.3
client glx extensions:
   GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
   GLX_ARB_get_proc_address, GLX_SGI_video_sync, GLX_ARB_multisample,
   GLX_ATI_pixel_format_float, GLX_ATI_render_texture
GLX version: 1.2
GLX extensions:
   GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
   GLX_ARB_multisample
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.5)
OpenGL extensions:
   GL_ARB_imaging, GL_ARB_multitexture, GL_ARB_texture_border_clamp,
   GL_ARB_texture_cube_map, GL_ARB_texture_env_add,
   GL_ARB_texture_env_combine, GL_ARB_texture_env_dot3,
   GL_ARB_transpose_matrix, GL_EXT_abgr, GL_EXT_blend_color,
   GL_EXT_blend_minmax, GL_EXT_blend_subtract, GL_EXT_texture_env_add,
   GL_EXT_texture_env_combine, GL_EXT_texture_env_dot3,
   GL_EXT_texture_lod_bias
glu version: 1.3
glu extensions:
   GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess

  visual  x  bf lv rg d st colorbuffer ax dp st accumbuffer  ms  cav
id dep cl sp sz l  ci b ro  r  g  b  a bf th cl  r  g  b  a ns b eat
----------------------------------------------------------------------
0x23 24 tc  0 24  0 r  y  .  8  8  8  0  0 16  0  0  0  0  0  1 0 None
0x24 24 tc  0 24  0 r  y  .  8  8  8  0  0 16  8 16 16 16  0  1 0 None
0x25 24 tc  0 32  0 r  y  .  8  8  8  8  0 16  8 16 16 16 16  1 0 None
0x26 24 tc  0 32  0 r  .  .  8  8  8  8  0 16  8 16 16 16 16  1 0 None
0x27 24 dc  0 24  0 r  y  .  8  8  8  0  0 16  0  0  0  0  0  1 0 None
0x28 24 dc  0 24  0 r  y  .  8  8  8  0  0 16  8 16 16 16  0  1 0 None
0x29 24 dc  0 32  0 r  y  .  8  8  8  8  0 16  8 16 16 16 16  1 0 None
0x2a 24 dc  0 32  0 r  .  .  8  8  8  8  0 16  8 16 16 16 16  1 0 None
0x3c 32 tc  1  0  0 c  .  .  0  0  0  0  0  0  0  0  0  0  0  0 0 None
[QUOTE]

# File generated by XFdrake (rev 57713)
# **********************************************************************
# Refer to the xorg.conf man page for details about the format of
# this file.
# **********************************************************************

Section "ServerLayout"
Identifier     "layout1"
Screen      0  "aticonfig-Screen[0]" 0 0
InputDevice    "Keyboard1" "CoreKeyboard"
InputDevice    "Mouse1" "CorePointer"
EndSection

Section "Files"

   # font server independent of the X server to render fonts.
   # minimal fonts to allow X to run without xfs
FontPath     "unix/:-1"
FontPath     "/usr/share/fonts/misc:unscaled"
EndSection

Section "Module"
Load  "dbe" # Double-Buffering Extension
Load  "v4l" # Video for Linux
Load  "extmod"
Load  "type1"
Load  "freetype"
Load  "glx" # 3D layer
Load  "dri" # direct rendering
EndSection

Section "ServerFlags"

   #DontZap # disable <Crtl><Alt><BS> (server abort)
# allows the server to start up even if the mouse does not work
   #DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
Option    "allowmouseopenfail"
EndSection

Section "InputDevice"
Identifier  "Keyboard1"
Driver      "kbd"
Option    "XkbModel" "pc105"
Option    "XkbLayout" "us"
Option    "XkbOptions" "compose:rwin"
EndSection

Section "InputDevice"
Identifier  "Mouse1"
Driver      "mouse"
Option    "Protocol" "ExplorerPS/2"
Option    "Device" "/dev/mouse"
EndSection

Section "Monitor"

   # TV fullscreen mode or DVD fullscreen output.
   # 768x576 @ 79 Hz, 50 kHz hsync
Identifier   "monitor1"
VendorName   "Generic"
ModelName    "1024x768 @ 60 Hz"
HorizSync    31.5 - 48.5
VertRefresh  50.0 - 70.0
ModeLine     "768x576" 50.0 768 832 846 1000 576 590 595 630
ModeLine     "768x576" 63.1 768 800 960 1024 576 578 590 616
EndSection

Section "Monitor"
Identifier   "aticonfig-Monitor[0]"
Option    "VendorName" "ATI Proprietary Driver"
Option    "ModelName" "Generic Autodetecting Monitor"
Option    "DPMS" "true"
EndSection

Section "Device"
Identifier  "device1"
Driver      "fglrx"
VendorName  "ATI Technologies Inc."
BoardName   "ATI Radeon"
Option    "DPMS" "false"
Option    "XaaNoOffscreenPixmaps" "1"
EndSection

Section "Device"
Identifier  "aticonfig-Device[0]"
Driver      "fglrx"
EndSection

Section "Screen"
Identifier "screen1"
Device     "device1"
Monitor    "monitor1"
DefaultDepth     16
SubSection "Display"
Depth     8
Modes    "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
EndSubSection
SubSection "Display"
Depth     15
Modes    "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
EndSubSection
SubSection "Display"
Depth     16
Modes    "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
EndSubSection
SubSection "Display"
Depth     24
Modes    "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
EndSubSection
EndSection

Section "Screen"
Identifier "aticonfig-Screen[0]"
Device     "aticonfig-Device[0]"
Monitor    "aticonfig-Monitor[0]"
DefaultDepth     24
SubSection "Display"
Viewport   0 0
Depth     24
EndSubSection
EndSection

Section "Extensions"
Option    "Composite"
EndSection



[QUOTE]
Pls някой да помогне щото вече откачам :@
Контакти:  bostko
WEB  
Мнение #2
Skip to the previous post in this topic. Написано на: Ноември 08 2007, 22:29
todir

Avatar




Група: Li fans
Мнения: 105
Регистриран: Ноември 2007

Оценка: няма

Offline
Код: 
Section "Extensions"
Option    "Composite"
EndSection

Това така ли ти е наистина или е грешка като си го пайстнал? С тази версия на драйвера трябва да е  
Код: 
Option    "Composite" "Disable"
Освен това коментирай модула dri.
Виж какви грешки има в /var/log/Xorg.0.log
Най-добре се помъчи да инсталираш 8.42.3
Добри ръководства за различни дистрибуции има тук
Контакти:  todir
WEB  
Общо 1 отговор(а) от Ноември 08 2007, 20:08 до сега
 » Начало » Li Форуми » Help & Support » Kernels & Drivers » Проблем с видео драйверите

© 2014 Linux Index Project
Powered by iF 1.0.0 © 2006 ikonForums