Запомняне

» Здравейте
[ Вход :: Регистриране ]
 » Начало » Li Форуми » Help & Support » Kernels & Drivers » Webcam settings
Тема: Webcam settings
Мнение #1 Skip to the next post in this topic.
Написано на: Февруари 23 2008, 09:29

Avatar




Група: Li fans
Мнения: 79
Регистриран: Октомври 2006

Оценка: няма

Offline
Дистро: debian-40r3-i386-kde
Камера: Trust WB-1100G
Използван драйвер: gspca-modules-2.6.18-6-486
Използван цензор: Sonix sn9c10x + Pas106 sensor

Проблема е че през деня изображението е толкова светло че нищо не се вижда почти, а през ноща обратното. Трябва да насоча някъкво осветление към лицето ми та да може да се вижда нещо.

Възникна и нов проблем, след като пусна филм и се опитам след това да провера камерата в skype, ми изписва че няма намерено устройство и :
Quote: 

Tasks:  89 total,   1 running,  88 sleeping,   0 stopped,   0 zombie
Cpu(s): 25.3%us, 57.3%sy,  0.0%ni,  0.0%id,  0.0%wa,  0.0%hi, 17.3%si,  0.0%st
Mem:    517016k total,   341068k used,   175948k free,    10332k buffers
Swap:   538168k total,        0k used,   538168k free,   190056k cached

 PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND
3507 xxx       15   0 93224  44m  13m S 95.5  8.7   1:23.83 skype
3208 root      15   0 34752  21m 4408 S  2.0  4.3   0:06.52 Xorg
3697 xxx       15   0 31076  14m  12m S  1.7  2.9   0:00.67 konsole
3506 xxx       15   0  151m  42m  18m S  0.7  8.4   0:13.73 firefox-bin
3715 xxx       15   0  2228 1128  856 R  0.3  0.2   0:00.05 top
   1 root      15   0  1940  644  552 S  0.0  0.1   0:01.06 init
   2 root      34  19     0    0    0 S  0.0  0.0   0:00.00 ksoftirqd/0
   3 root      10  -5     0    0    0 S  0.0  0.0   0:00.02 events/0
   4 root      12  -5     0    0    0 S  0.0  0.0   0:00.00 khelper
   5 root      13  -5     0    0    0 S  0.0  0.0   0:00.00 kthread
   8 root      10  -5     0    0    0 S  0.0  0.0   0:00.00 kblockd/0
   9 root      20  -5     0    0    0 S  0.0  0.0   0:00.00 kacpid
 100 root      10  -5     0    0    0 S  0.0  0.0   0:00.00 kseriod
 142 root      25   0     0    0    0 S  0.0  0.0   0:00.00 pdflush
 143 root      15   0     0    0    0 S  0.0  0.0   0:00.00 pdflush
 144 root      20  -5     0    0    0 S  0.0  0.0   0:00.00 kswapd0
 145 root      20  -5     0    0    0 S  0.0  0.0   0:00.00 aio/0
xxx@xxx:~$        
 


Драйвера съм го инсталирал чрез синаптик.
След това изпълних следните указания :
Quote: 

                                                 2 - edit with vi or gedit the file "/etc/modprobe.d/blacklist" with the command "sudo vi /etc/modprobe.d/blacklist " and add the following line:
blacklist sn9c102

3- plug your webcam to an USB port and reboot the system

4- now do the command : su chmod a+rw /dev/video0


Рестартирам и всичко е наред докато не пусна филм  :14;  :12;

Ето и малко инфо:
Quote: 

xxx@xxx:~$ lsusb
Bus 005 Device 001: ID 0000:0000
Bus 003 Device 001: ID 0000:0000
Bus 004 Device 001: ID 0000:0000
Bus 002 Device 003: ID 0c45:600d Microdia
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 001: ID 0000:0000




xxx@xxx:~$ lsmod
Module                  Size  Used by
nvidia               4545108  12
ppdev                   8708  0
lp                     10948  0
button                  6800  0
ac                      5252  0
battery                 9732  0
ipv6                  213984  8
ipt_TTL                 2432  1
ipt_MASQUERADE          3584  1
xt_limit                2816  3
xt_pkttype              2048  1
xt_tcpudp               3200  17
xt_state                2304  7
ipt_LOG                 6016  13
iptable_mangle          2944  1
iptable_nat             7044  1
iptable_filter          3200  1
ip_conntrack_irc        6896  0
ip_nat_ftp              3456  0
ip_nat                 16428  3 ipt_MASQUERADE,iptable_nat,ip_nat_ftp
ip_conntrack_ftp        7536  1 ip_nat_ftp
ip_conntrack           47156  7 ipt_MASQUERADE,xt_state,iptable_nat,ip_conntrack_irc,ip_nat_ftp,ip_nat,ip_conntrack_ftp
nfnetlink               6680  2 ip_nat,ip_conntrack
ip_tables              12104  3 iptable_mangle,iptable_nat,iptable_filter
x_tables               12932  9 ipt_TTL,ipt_MASQUERADE,xt_limit,xt_pkttype,xt_tcpudp,xt_state,ipt_LOG,iptable_nat,ip_table

s
nls_iso8859_1           4352  1
ntfs                  184084  1
dm_snapshot            15644  0
dm_mirror              18000  0
dm_mod                 48952  2 dm_snapshot,dm_mirror
loop                   14216  0
tsdev                   7616  0
snd_via82xx            25368  0
snd_mpu401_uart         7552  1 snd_via82xx
snd_seq_dummy           3972  0
snd_seq_oss            27648  0
snd_seq_midi            8352  0
snd_seq_midi_event      6784  2 snd_seq_oss,snd_seq_midi
snd_via82xx_modem      13832  0
snd_ac97_codec         82848  2 snd_via82xx,snd_via82xx_modem
snd_ac97_bus            2432  1 snd_ac97_codec
snd_seq                42192  6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
gspca                 598992  0
snd_pcm_oss            38048  0
snd_mixer_oss          15232  1 snd_pcm_oss
analog                 10528  0
serio_raw               6532  0
videodev               21120  1 gspca
v4l1_compat            12164  1 videodev
snd_pcm                65928  4 snd_via82xx,snd_via82xx_modem,snd_ac97_codec,snd_pcm_oss
snd_timer              19972  2 snd_seq,snd_pcm
snd_rawmidi            22048  2 snd_mpu401_uart,snd_seq_midi
snd_seq_device          7820  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq,snd_rawmidi
psmouse                34568  0
snd                    45412  12 snd_via82xx,snd_mpu401_uart,snd_seq_oss,snd_via82xx_modem,snd_ac97_codec,snd_seq,snd_pcm_o

ss,snd_mixer_oss,snd_pcm,snd_timer,snd_rawmidi,snd_seq_device
parport_pc             31524  1
parport                32200  3 ppdev,lp,parport_pc
gameport               13832  2 snd_via82xx,analog
rtc                    11572  0
v4l2_common            20480  1 videodev
soundcore               8928  1 snd
snd_page_alloc         10248  3 snd_via82xx,snd_via82xx_modem,snd_pcm
floppy                 52004  0
i2c_viapro              8340  0
i2c_core               19472  2 nvidia,i2c_viapro
pcspkr                  2816  0
shpchp                 32796  0
pci_hotplug            28088  1 shpchp
via_agp                 9728  1
agpgart                29360  2 nvidia,via_agp
evdev                   9088  1
ext3                  116488  2
jbd                    47272  1 ext3
sd_mod                 19088  5
ide_cd                 35616  0
cdrom                  32416  1 ide_cd
ehci_hcd               27144  0
sata_via               10116  4
uhci_hcd               20236  0
usbcore               109444  4 gspca,ehci_hcd,uhci_hcd
via82cxxx               8452  0 [permanent]
generic                 4996  0 [permanent]
ide_core              107760  3 ide_cd,via82cxxx,generic
libata                 87700  1 sata_via
scsi_mod              121992  2 sd_mod,libata
8139cp                 20736  0
8139too                24192  0
mii                     5376  2 8139cp,8139too
skge                   33936  0
thermal                13576  0
processor              23724  1 thermal
fan                     4868  0


[QUOTE]
sion 4.1.2 20061115 (prerelease) (Debian 4.1.1-21)) #1 Sun Feb 10 22:06:33 UTC 2008
BIOS-provided physical RAM map:
BIOS-e820: 0000000000000000 - 000000000009d800 (usable)
BIOS-e820: 000000000009d800 - 00000000000a0000 (reserved)
BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
BIOS-e820: 0000000000100000 - 000000001fffb000 (usable)
BIOS-e820: 000000001fffb000 - 000000001ffff000 (ACPI data)
BIOS-e820: 000000001ffff000 - 0000000020000000 (ACPI NVS)
BIOS-e820: 00000000fec00000 - 00000000fec01000 (reserved)
BIOS-e820: 00000000fee00000 - 00000000fee01000 (reserved)
BIOS-e820: 00000000ffff0000 - 0000000100000000 (reserved)
511MB LOWMEM available.
On node 0 totalpages: 131067
 DMA zone: 4096 pages, LIFO batch:0
 Normal zone: 126971 pages, LIFO batch:31
DMI 2.3 present.
ACPI: RSDP (v000 ASUS                                  ) @ 0x000f5e20
ACPI: RSDT (v001 ASUS   A7V600   0x42302e31 MSFT 0x31313031) @ 0x1fffb000
ACPI: FADT (v001 ASUS   A7V600   0x42302e31 MSFT 0x31313031) @ 0x1fffb0b2
ACPI: BOOT (v001 ASUS   A7V600   0x42302e31 MSFT 0x31313031) @ 0x1fffb030
ACPI: MADT (v001 ASUS   A7V600   0x42302e31 MSFT 0x31313031) @ 0x1fffb058
ACPI: DSDT (v001   ASUS A7V600   0x00001000 MSFT 0x0100000b) @ 0x00000000
ACPI: PM-Timer IO Port: 0xe408
ACPI: Local APIC address 0xfee00000
ACPI: LAPIC (acpi_id[0x00] lapic_id[0x00] enabled)
Processor #0 6:10 APIC version 16
ACPI: LAPIC_NMI (acpi_id[0x00] high edge lint[0x1])
ACPI: IOAPIC (id[0x02] address[0xfec00000] gsi_base[0])
IOAPIC[0]: apic_id 2, version 3, address 0xfec00000, GSI 0-23
ACPI: INT_SRC_OVR (bus 0 bus_irq 0 global_irq 2 dfl edge)
ACPI: INT_SRC_OVR (bus 0 bus_irq 9 global_irq 9 low level)
ACPI: IRQ0 used by override.
ACPI: IRQ2 used by override.
ACPI: IRQ9 used by override.
Enabling APIC mode:  Flat.  Using 1 I/O APICs
Using ACPI (MADT) for SMP configuration information
Allocating PCI resources starting at 30000000 (gap: 20000000:dec00000)
Detected 1500.192 MHz processor.
Built 1 zonelists.  Total pages: 131067
Kernel command line: root=/dev/sda4 ro
mapped APIC to ffffd000 (fee00000)
mapped IOAPIC to ffffc000 (fec00000)
Enabling fast FPU save and restore... done.
Enabling unmasked SIMD FPU exception support... done.
Initializing CPU#0
PID hash table entries: 2048 (order: 11, 8192 bytes)
Console: colour VGA+ 80x25
Dentry cache hash table entries: 65536 (order: 6, 262144 bytes)
Inode-cache hash table entries: 32768 (order: 5, 131072 bytes)
Memory: 511944k/524268k available (1499k kernel code, 11752k reserved, 599k data, 256k init, 0k highmem)
Checking if this processor honours the WP bit even in supervisor mode... Ok.
Calibrating delay using timer specific routine.. 3002.86 BogoMIPS (lpj=6005722)
Security Framework v1.0.0 initialized
SELinux:  Disabled at boot.
Capability LSM initialized
Mount-cache hash table entries: 512
CPU: After generic identify, caps: 0383fbff c1c3fbff 00000000 00000000 00000000 00000000 00000000
CPU: After vendor identify, caps: 0383fbff c1c3fbff 00000000 00000000 00000000 00000000 00000000
CPU: L1 I Cache: 64K (64 bytes/line), D cache 64K (64 bytes/line)
CPU: L2 Cache: 256K (64 bytes/line)
CPU: After all inits, caps: 0383fbff c1c3fbff 00000000 00000420 00000000 00000000 00000000
Compat vDSO mapped to ffffe000.
CPU: AMD Athlon™ XP 2400+ stepping 00
Checking 'hlt' instruction... OK.
ACPI: Core revision 20060707
ENABLING IO-APIC IRQs
..TIMER: vector=0x31 apic1=0 pin1=2 apic2=-1 pin2=-1
checking if image is initramfs... it is
Freeing initrd memory: 4636k freed
NET: Registered protocol family 16
EISA bus registered
ACPI: bus type pci registered
PCI: PCI BIOS revision 2.10 entry at 0xf1970, last bus=1
PCI: Using configuration type 1
Setting up standard PCI resources
ACPI: Interpreter enabled
ACPI: Using IOAPIC for interrupt routing
ACPI: PCI Interrupt Link [LNKA] (IRQs 3 4 5 6 7 9 10 *11 12)
ACPI: PCI Interrupt Link [LNKB] (IRQs 3 4 5 6 7 9 10 11 12) *0, disabled.
ACPI: PCI Interrupt Link [LNKC] (IRQs 3 4 5 6 7 9 *10 11 12)
ACPI: PCI Interrupt Link [LNKD] (IRQs 3 4 *5 6 7 9 10 11 12)
ACPI: PCI Interrupt Link [LNKE] (IRQs 3 4 5 6 7 9 10 *11 12)
ACPI: PCI Interrupt Link [LNKF] (IRQs 3 4 5 6 7 9 10 *11 12)
ACPI: PCI Interrupt Link [LNKG] (IRQs 3 4 5 6 7 9 *10 11 12)
ACPI: PCI Interrupt Link [LNKH] (IRQs 3 4 5 6 7 9 10 11 12) *15, disabled.
ACPI: PCI Root Bridge [PCI0] (0000:00)
PCI: Probing PCI hardware (bus 00)
ACPI: Assume root bridge [\_SB_.PCI0] bus is 0
PCI: enabled onboard AC97/MC97 devices
Boot video device is 0000:01:00.0
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0._PRT]
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.PCI1._PRT]
Linux Plug and Play Support v0.97 © Adam Belay
pnp: PnP ACPI init
pnp: PnP ACPI: found 16 devices
PnPBIOS: Disabled by ACPI PNP
PCI: Using ACPI for IRQ routing
PCI: If a device doesn't work, try "pci=routeirq".  If it helps, post a report
pnp: 00:02: ioport range 0xe400-0xe47f could not be reserved
pnp: 00:02: ioport range 0xe800-0xe81f has been reserved
pnp: 00:0f: ioport range 0x290-0x297 has been reserved
pnp: 00:0f: ioport range 0x370-0x375 has been reserved
PCI: Bridge: 0000:00:01.0
 IO window: disabled.
 MEM window: ee000000-efdfffff
 PREFETCH window: eff00000-f7ffffff
PCI: Setting latency timer of device 0000:00:01.0 to 64
NET: Registered protocol family 2
IP route cache hash table entries: 4096 (order: 2, 16384 bytes)
TCP established hash table entries: 16384 (order: 4, 65536 bytes)
TCP bind hash table entries: 8192 (order: 3, 32768 bytes)
TCP: Hash tables configured (established 16384 bind 8192)
TCP reno registered
Simple Boot Flag at 0x3a set to 0x1
audit: initializing netlink socket (disabled)
audit(1203870269.944:1): initialized
VFS: Disk quotas dquot_6.5.1
Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
Initializing Cryptographic API
io scheduler noop registered
io scheduler anticipatory registered
io scheduler deadline registered
io scheduler cfq registered (default)
PCI: Bypassing VIA 8237 APIC De-Assert Message
isapnp: Scanning for PnP cards...
isapnp: No Plug & Play device found
Serial: 8250/16550 driver $Revision: 1.90 $ 4 ports, IRQ sharing enabled
serial8250: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
serial8250: ttyS1 at I/O 0x2f8 (irq = 3) is a 16550A
00:0a: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
00:0b: ttyS1 at I/O 0x2f8 (irq = 3) is a 16550A
RAMDISK driver initialized: 16 RAM disks of 8192K size 1024 blocksize
PNP: PS/2 Controller [PNP0303:PS2K,PNP0f03:PS2M] at 0x60,0x64 irq 1,12
serio: i8042 AUX port at 0x60,0x64 irq 12
serio: i8042 KBD port at 0x60,0x64 irq 1
mice: PS/2 mouse device common for all mice
EISA: Probing bus 0 at eisa.0
Cannot allocate resource for EISA slot 8
EISA: Detected 0 cards.
TCP bic registered
NET: Registered protocol family 1
NET: Registered protocol family 17
NET: Registered protocol family 8
NET: Registered protocol family 20
Using IPI Shortcut mode
ACPI: (supports S0 S1 S4 S5)
Freeing unused kernel memory: 256k freed
Time: tsc clocksource has been installed.
input: AT Translated Set 2 keyboard as /class/input/input0
ACPI: PCI Interrupt 0000:00:09.0[A] -> GSI 18 (level, low) -> IRQ 169
skge 1.6 addr 0xed800000 irq 169 chip Yukon rev 1
skge eth0: addr 00:11:2f:11:64:ff
8139too Fast Ethernet driver 0.9.27
ACPI: PCI Interrupt 0000:00:0b.0[A] -> GSI 19 (level, low) -> IRQ 177
eth1: RealTek RTL8139 at 0xd400, 4c:00:10:50:44:3f, IRQ 177
eth1:  Identified 8139 chip type 'RTL-8100B/8139D'
8139cp: 10/100 PCI Ethernet driver v1.2 (Mar 22, 2004)
SCSI subsystem initialized
usbcore: registered new driver usbfs
usbcore: registered new driver hub
USB Universal Host Controller Interface driver v3.0
ACPI: PCI Interrupt 0000:00:10.0[A] -> GSI 21 (level, low) -> IRQ 185
PCI: VIA IRQ fixup for 0000:00:10.0, from 0 to 9
uhci_hcd 0000:00:10.0: UHCI Host Controller
uhci_hcd 0000:00:10.0: new USB bus registered, assigned bus number 1
uhci_hcd 0000:00:10.0: irq 185, io base 0x00009800
usb usb1: configuration #1 chosen from 1 choice
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 2 ports detected
libata version 2.00 loaded.
Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
ACPI: PCI Interrupt 0000:00:10.1[A] -> GSI 21 (level, low) -> IRQ 185
PCI: VIA IRQ fixup for 0000:00:10.1, from 0 to 9
uhci_hcd 0000:00:10.1: UHCI Host Controller
uhci_hcd 0000:00:10.1: new USB bus registered, assigned bus number 2
uhci_hcd 0000:00:10.1: irq 185, io base 0x00009400
usb usb2: configuration #1 chosen from 1 choice
hub 2-0:1.0: USB hub found
hub 2-0:1.0: 2 ports detected
ACPI: PCI Interrupt 0000:00:10.2[B] -> GSI 21 (level, low) -> IRQ 185
PCI: VIA IRQ fixup for 0000:00:10.2, from 0 to 9
uhci_hcd 0000:00:10.2: UHCI Host Controller
uhci_hcd 0000:00:10.2: new USB bus registered, assigned bus number 3
uhci_hcd 0000:00:10.2: irq 185, io base 0x00009000
usb usb3: configuration #1 chosen from 1 choice
hub 3-0:1.0: USB hub found
hub 3-0:1.0: 2 ports detected
ACPI: PCI Interrupt 0000:00:10.3[B] -> GSI 21 (level, low) -> IRQ 185
PCI: VIA IRQ fixup for 0000:00:10.3, from 0 to 9
uhci_hcd 0000:00:10.3: UHCI Host Controller
uhci_hcd 0000:00:10.3: new USB bus registered, assigned bus number 4
uhci_hcd 0000:00:10.3: irq 185, io base 0x00008800
usb usb4: configuration #1 chosen from 1 choice
hub 4-0:1.0: USB hub found
hub 4-0:1.0: 2 ports detected
sata_via 0000:00:0f.0: version 2.0
ACPI: PCI Interrupt 0000:00:0f.0[B] -> GSI 20 (level, low) -> IRQ 193
sata_via 0000:00:0f.0: routed to hard irq line 0
ata1: SATA max UDMA/133 cmd 0xD000 ctl 0xB802 bmdma 0xA800 irq 193
ata2: SATA max UDMA/133 cmd 0xB400 ctl 0xB002 bmdma 0xA808 irq 193
scsi0 : sata_via
usb 2-1: new full speed USB device using uhci_hcd and address 2
ata1: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
usb 2-1: configuration #1 chosen from 1 choice
ata1.00: ATA-6, max UDMA/133, 156301488 sectors: LBA48
ata1.00: ata1: dev 0 multi count 16
ata1.00: configured for UDMA/133
scsi1 : sata_via
ata2: SATA link down 1.5 Gbps (SStatus 0 SControl 300)
ATA: abnormal status 0x7F on port 0xB407
 Vendor: ATA       Model: ST380013AS        Rev: 3.18
 Type:   Direct-Access                      ANSI SCSI revision: 05
ACPI: PCI Interrupt 0000:00:10.4[C] -> GSI 21 (level, low) -> IRQ 185
PCI: VIA IRQ fixup for 0000:00:10.4, from 0 to 9
ehci_hcd 0000:00:10.4: EHCI Host Controller
ehci_hcd 0000:00:10.4: new USB bus registered, assigned bus number 5
ehci_hcd 0000:00:10.4: irq 185, io mem 0xec800000
ehci_hcd 0000:00:10.4: USB 2.0 started, EHCI 1.00, driver 10 Dec 2004
usb usb5: configuration #1 chosen from 1 choice
hub 5-0:1.0: USB hub found
hub 5-0:1.0: 8 ports detected
SCSI device sda: 156301488 512-byte hdwr sectors (80026 MB)
sda: Write Protect is off
sda: Mode Sense: 00 3a 00 00
SCSI device sda: drive cache: write back
SCSI device sda: 156301488 512-byte hdwr sectors (80026 MB)
sda: Write Protect is off
sda: Mode Sense: 00 3a 00 00
SCSI device sda: drive cache: write back
sda: sda1 sda2 < sda5 > sda3 sda4
sd 0:0:0:0: Attached scsi disk sda
VP_IDE: IDE controller at PCI slot 0000:00:0f.1
ACPI: PCI Interrupt 0000:00:0f.1[A] -> GSI 20 (level, low) -> IRQ 193
PCI: VIA IRQ fixup for 0000:00:0f.1, from 14 to 1
VP_IDE: chipset revision 6
VP_IDE: not 100% native mode: will probe irqs later
VP_IDE: VIA vt8237 (rev 00) IDE UDMA133 controller on pci0000:00:0f.1
   ide0: BM-DMA at 0xa000-0xa007, BIOS settings: hda:pio, hdb:pio
   ide1: BM-DMA at 0xa008-0xa00f, BIOS settings: hdc:DMA, hdd:pio
Probing IDE interface ide0...
usb 2-1: USB disconnect, address 2
Probing IDE interface ide1...
usb 2-1: new full speed USB device using uhci_hcd and address 3
usb 2-1: configuration #1 chosen from 1 choice
hdc: HL-DT-ST CD-RW GCE-8524B, ATAPI CD/DVD-ROM drive
ide1 at 0x170-0x177,0x376 on irq 15
hdc: ATAPI 52X CD-ROM CD-R/RW drive, 2048kB Cache, UDMA(33)
Uniform CD-ROM driver Revision: 3.20
Attempting manual resume
kjournald starting.  Commit interval 5 seconds
EXT3-fs: mounted filesystem with ordered data mode.
Linux agpgart interface v0.101 © Dave Jones
pci_hotplug: PCI Hot Plug PCI Core version: 0.5
shpchp: Standard Hot Plug PCI Controller Driver version: 0.4
agpgart: Detected VIA KT400/KT400A/KT600 chipset
agpgart: AGP aperture is 64M @ 0xf8000000
input: PC Speaker as /class/input/input1
Linux video capture interface: v2.00
/tmp/buildd/linux-modules-extra-2.6-2.6.18/debian/build/build_i386_none_486_gspca/gspca_core.c: USB SPCA5XX camera found. SONIX sn9c10[1 2]
/tmp/buildd/linux-modules-extra-2.6-2.6.18/debian/build/build_i386_none_486_gspca/gspca_core.c: [spca5xx_probe:3887] Camera type SN9C
/tmp/buildd/linux-modules-extra-2.6-2.6.18/debian/build/build_i386_none_486_gspca/gspca_core.c: [spca5xx_getcapability:1165] maxw 352 maxh 288 minw 160 minh 120
usbcore: registered new driver gspca
/tmp/buildd/linux-modules-extra-2.6-2.6.18/debian/build/build_i386_none_486_gspca/gspca_core.c: gspca driver 2.6.18 registered
Real Time Clock Driver v1.12ac
parport: PnPBIOS parport detected.
parport0: PC-style at 0x378 (0x778), irq 7, dma 3 [PCSPP,TRISTATE,COMPAT,ECP,DMA]
Floppy drive(s): fd0 is 1.44M
FDC 0 is a post-1991 82077
PCI: Enabling device 0000:00:11.6 (0000 -> 0001)
ACPI: PCI Interrupt 0000:00:11.6[C] -> GSI 22 (level, low) -> IRQ 201
input: ImPS/2 Generic Wheel Mouse as /class/input/input2
ts: Compaq touchscreen protocol output
PCI: Setting latency timer of device 0000:00:11.6 to 64
ACPI: PCI interrupt for device 0000:00:11.6 disabled
VIA 82xx Modem: probe of 0000:00:11.6 failed with error -13
ACPI: PCI Interrupt 0000:00:11.5[C] -> GSI 22 (level, low) -> IRQ 201
PCI: Setting latency timer of device 0000:00:11.5 to 64
codec_read: codec 0 is not valid [0xfe0000]
codec_read: codec 0 is not valid [0xfe0000]
codec_read: codec 0 is not valid [0xfe0000]
codec_read: codec 0 is not valid [0xfe0000]
Adding 538168k swap on /dev/sda3.  Priority:-1 extents:1 across:538168k
EXT3 FS on sda4, internal journal
loop: loaded (max 8 devices)
device-mapper: ioctl: 4.7.0-ioctl (2006-06-24) initialised: dm-devel@redhat.com
kjournald starting.  Commit interval 5 seconds
EXT3 FS on sda5, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
NTFS driver 2.1.27 [Flags: R/W MODULE].
NTFS volume version 3.1.
NTFS-fs warning (device sda1): load_system_files(): Unsupported volume flags 0x4000 encountered.
NTFS-fs error (device sda1): load_system_files(): Volume has unsupported flags set.  Mounting read-only.  Run chkdsk and mount in Windows.
skge eth0: enabling interface
skge eth0: Link is up at 100 Mbps, full duplex, flow control tx and rx
ACPI: Power Button (FF) [PWRF]
ACPI: Power Button (CM) [PWRB]
lp0: using parport0 (interrupt-driven).
ppdev: user-space parallel port driver
NET: Registered protocol family 10
lo: Disabled Privacy Extensions
IPv6 over IPv4 tunneling driver
cdrom: This disc doesn't have any tracks I recognize!
eth1: link down
ADDRCONF(NETDEV_UP): eth1: link is not ready
nvidia: module license 'NVIDIA' taints kernel.
ACPI: PCI Interrupt 0000:01:00.0[A] -> GSI 16 (level, low) -> IRQ 209
NVRM: loading NVIDIA Linux x86 Kernel Module  1.0-8776  Mon Oct 16 21:56:04 PDT 2006
agpgart: Found an AGP 3.5 compliant device at 0000:00:00.0.
agpgart: Putting AGP V3 device at 0000:00:00.0 into 8x mode
agpgart: Putting AGP V3 device at 0000:01:00.0 into 8x mode
ip_tables: © 2000-2006 Netfilter Core Team
Netfilter messages via NETLINK v0.30.
ip_conntrack version 2.4 (4095 buckets, 32760 max) - 224 bytes per conntrack
eth0: no IPv6 routers present
[QUOTE]


http://img.data.bg/i.php?show=827416&ctrl_id=g7kxjv#img

http://img.data.bg/i.php?show=827417&ctrl_id=u3xz8e#img

Редактирано от makrosxxx на Февруари 25 2008, 12:41
Контакти:  makrosxxx
WEB  
Мнение #2 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Февруари 26 2008, 10:01

Avatar




Група: Li fans
Мнения: 79
Регистриран: Октомври 2006

Оценка: няма

Offline
Промених използвания от mplayer драйвер от xv(X11/Xv) на X11(OpenGL) и проблема с намиране на камерата в skype изчезна, засега.
За проблема с гамата използвах :
Quote: 

nano /etc/modprobe.d/options
options gspca gamma=6

от тази статия : http://mirolm.blogspot.com/2008/01/skype-linux.html
ала без ефект. Някъкви идеи как да стане промяната на гамата и настройките на картината от камерата ?  :21;
Контакти:  makrosxxx
WEB  
Мнение #3 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Февруари 26 2008, 11:10

Avatar




Група: Li maniacs
Мнения: 869
Регистриран: Юли 2006

Оценка: 5

Offline
Оф, тоя тъпия чип microdia се радвай, че си го подкарал, съвсем профилактично, сложи последният драйвер gspca, проблеми от подобен тип се оправят с по-добър драйвер, дано имаш късмет.
Махаш този gspca модул който си инсталирал(не е зле да рестираш машината след като го разкараш), след това теглиш от нестабилният дебиан сорса на gspca ето от тук примерно http://packages.debian.org/sid/gspca-source и го инсталираш.
След това
Код: 
apt-get update
apt-get upgrade
apt-get install module-assistant
m-a prepare
m-a a-i gspca
ще ти компилира модула и ще ти го инсталира, може да пробваш как работи вече  :17;

Мнение #4 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Февруари 26 2008, 11:58

Avatar




Група: Li fans
Мнения: 79
Регистриран: Октомври 2006

Оценка: няма

Offline
Изпълних по горе описаните съвети ала без ефект. Дори и с новия драйвер положението е същото.
Използвах и camstream за тестване. Първоначално и там беше така със светлината ала след малки корекции нещата се нормализираха. Няма ли възможност да се задават  стойности на контраст,осветеност, гама директно чрез драйвера ?  :12;
Контакти:  makrosxxx
WEB  
Мнение #5 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Февруари 26 2008, 14:43

Avatar




Група: Li maniacs
Мнения: 869
Регистриран: Юли 2006

Оценка: 5

Offline
Нямам идея дали може това което питаш, дай да видим какво говори dmesg
Код: 
dmesg | grep gsp

Мнение #6 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Февруари 26 2008, 23:00

Avatar




Група: Li fans
Мнения: 79
Регистриран: Октомври 2006

Оценка: няма

Offline
Quote: 

xxx@xxx:~$ dmesg | grep gsp
/usr/src/modules/gspca/gspca_core.c: USB GSPCA camera found. SONIX sn9c10[1 2]
/usr/src/modules/gspca/gspca_core.c: [spca5xx_probe:4275] Camera type SN9C
/usr/src/modules/gspca/gspca_core.c: [spca5xx_getcapability:1249] maxw 352 maxh 288 minw 160 minh 120
usbcore: registered new driver gspca
/usr/src/modules/gspca/gspca_core.c: gspca driver 01.00.20 registered
/usr/src/modules/gspca/gspca_core.c: [gspca_set_isoc_ep:945] ISO EndPoint found 0x81 AlternateSet 8
/usr/src/modules/gspca/gspca_core.c: [gspca_set_isoc_ep:945] ISO EndPoint found 0x81 AlternateSet 8
/usr/src/modules/gspca/gspca_core.c: [gspca_set_isoc_ep:945] ISO EndPoint found 0x81 AlternateSet 8
/usr/src/modules/gspca/gspca_core.c: [gspca_set_isoc_ep:945] ISO EndPoint found 0x81 AlternateSet 8
Контакти:  makrosxxx
WEB  
Мнение #7 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Февруари 29 2008, 10:55

Avatar




Група: Li fans
Мнения: 79
Регистриран: Октомври 2006

Оценка: няма

Offline
Quote: 

Go to the the Linux Video settings directory:
CODE
cd /sys/module/gspca/parameters/


EVERY FOLLOWING COMMAND MUST BE RUN AS ROOT! (sudo doesn't handle the ">" redirection stuff elegantly without weird escaping, which I haven't mastered yet)


And echo new values to the gamma and color files:
CODE
echo 4 > /sys/module/gspca/parameters/gamma
OR
echo 290 > /sys/module/gspca/parameters/GRed
OR
echo 310 > /sys/module/gspca/parameters/GGreen
OR
echo 315 > /sys/module/gspca/parameters/GBlue

After tweaking with these, right click the skype systray icon, and chose "Options", then "Video Devices", then click the video "Test" button to check it out. You'll need to close and reopen the options window after each change.

Once you've tweaked to the best config possible, save the module settings permanently to /etc/modprobe.d/options:

Add these lines (with your values) to the "/etc/modprobe.d/options" file:
CODE
options gspca gamma=4
options gspca GRed=290
options gspca GGreen=310
options gspca GBlue=315


http://forum.skype.com/index.php?showtopic=106357&st=0
Контакти:  makrosxxx
WEB  
Мнение #8 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Февруари 29 2008, 13:07

Avatar




Група: Li maniacs
Мнения: 869
Регистриран: Юли 2006

Оценка: 5

Offline
damn, makrosxxx ще вземеш да го измислиш тоя драйвер  ;) Работи ли?

Мнение #9 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Февруари 29 2008, 22:43

Avatar




Група: Li fans
Мнения: 398
Регистриран: Март 2006

Оценка: няма

Offline
При него не знам, ама при мен проработи и то много добре !!! Поздравлевия !!! :28;

"Imagination is more important than knoledge" A.Einstein
Контакти:  delafer
Мнение #10
Skip to the previous post in this topic. Написано на: Март 01 2008, 00:20

Avatar




Група: Li fans
Мнения: 79
Регистриран: Октомври 2006

Оценка: няма

Offline
При мен също работи.
Контакти:  makrosxxx
WEB  
Общо 11 отговор(а) от Февруари 23 2008, 09:29 до сега
 » Начало » Li Форуми » Help & Support » Kernels & Drivers » Webcam settings

© 2014 Linux Index Project
Powered by iF 1.0.0 © 2006 ikonForums