Запомняне

» Здравейте
[ Вход :: Регистриране ]
 » Начало » Li Форуми » Help & Support » Kernels & Drivers » Проблеми с драйвъри.
Тема: Проблеми с драйвъри.
Мнение #1 Skip to the next post in this topic.
Написано на: Юли 02 2008, 12:53

Avatar




Група: Li fans
Мнения: 3
Регистриран: Юли 2008

Оценка: няма

Offline
Аре и тука да го пусна и тук да дискусираме по моя проблемос.
@theevilsite - с ctrl+alt+backspace ресваш X-а - нормално да те "изхвърля пак на прозореца с името и паролата". Very Happy

Но не разбирам какво искаш да направиш сега? Инсталирал ли си драйвърите?
Ако си, замисли се над следния ред: "run nvidia-xconfig` as root"

@cleaver
Ненененене! Бягай, тва ще му омаже X-a! Smile

Отвори този файл
/etc/X11/xorg.conf и дай тук съдържанието му.
В момента драйверът ти казва, че ядрото не използва неговия модул за комуникация с видеочипа. Така че трябва да го накараме да го използва. Това се описва в xorg.conf
Дай да го видим. Smile

____
Е тва е :
# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by failsafeDexconf, using
# values from the debconf database and some overrides to use vesa mode.
#
# You should use dexconf or another such tool for creating a "real" xorg.conf
# For example:
# sudo dpkg-reconfigure -phigh xserver-xorg
Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us,bg"
Option "XkbVariant" ","
Option "XkbOptions" "grp:alt_shift_toggle,lv3:ralt_switch"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
EndSection

Section "Device"
Identifier "Configured Video Device"
Driver "vesa"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Configured Video Device"
Monitor "Configured Monitor"
SubSection "Display"
Modes "800x600"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
screen 0 "screen1" 0 0
EndSection
Section "Module"
Load "glx"
Load "GLcore"
Load "v4l"
EndSection
Section "device" #
Identifier "device1"
Boardname "NVIDIA GeForce 7 Series"
Busid "PCI:4:0:0"
Driver "nv"
Screen 0
Vendorname "NVIDIA"
EndSection
Section "screen" #
Identifier "screen1"
Device "device1"
Defaultdepth 24
Monitor "monitor1"
SubSection "Display"
Depth 24
Modes "1024x768@60" "800x600@60" "800x600@56" "640x480@60"
EndSubSection
EndSection
Section "monitor" #
Identifier "monitor1"
Vendorname "Generic LCD Display"
Modelname "LCD Panel 1024x768"
Horizsync 31.5-48.0
Vertrefresh 56.0 - 65.0
modeline "640x480@60" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync
modeline "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
modeline "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
modeline "1024x768@60" 65.0 1024 1048 1184 1344 768 771 777 806 -vsync -hsync
Gamma 1.0
EndSection
Section "device" #
Identifier "device2"
Boardname "NVIDIA GeForce 7 Series"
Busid "PCI:5:0:0"
Driver "nv"
Screen 0
Vendorname "NVIDIA"
EndSection
Section "screen" #
Identifier "screen2"
Device "device2"
Defaultdepth 24
Monitor "monitor2"
EndSection
Section "monitor" #
Identifier "monitor2"
Gamma 1.0
EndSection
Section "ServerFlags"
EndSection

Само да добавя че от Апп>Систем тоолс>и там ми излиза Нвидиа Х сеттингс и като го натисна ми казва че трябва да пусна 'nvidia-xconfig' и да ресна Х-а.Като пусна команда sudo nvidia-xconfig ми казва че достъпът е отказан.Нали с със sudo пускам команда като root.

Ей го на : You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run `nvidia-xconfig` as root), and restart the X server.

А ето и след командата
theevilsite@theevilsite:~$ sudo nvidia-xconfig

Using X configuration file: "/etc/X11/xorg.conf".

VALIDATION ERROR: Data incomplete in file /etc/X11/xorg.conf.
Device section "Configured Video Device" must have a Driver
line.

Backed up file '/etc/X11/xorg.conf' as '/etc/X11/xorg.conf.backup'
New X configuration file written to '/etc/X11/xorg.conf'
:6;

Xperia Silver 16GB MicroSDHC
Контакти:  theevilsite

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #2 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Юли 02 2008, 15:49

No avatar chosen




Група: Li maniacs
Мнения: 153
Регистриран: Февруари 2007

Оценка: няма

Offline
Не използвам Убунту, нито видеокарта на Nvidia. Би било хубаво още някой да даде мнение, преди да опиташ нещата, описани по - долу. Също, добре би било, преди да опитваш каквото и да е от нещата, които съм написал по-долу, да си направиш копие на файла xorg.conf:
Код: 
sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf_copie

и в случай, че нещо не проработи както трябва, да можеш да си върнеш сегашните настройки на файла с
Код: 
sudo cp /etc/X11/xorg.conf_copie /etc/X11/xorg.conf

================================================================
============== Инсталиране на драйвери =========================
================================================================

От този ред:
Код: 
Boardname "NVIDIA GeForce 7 Series"

ми се струва, че картата ти е от серия 7. Оттук ( https://help.ubuntu.com/community/BinaryDriverHowto/Nvidia#Ubuntu 7.04 using 'Restricted Devices Manager' ) ми се струва, че пакетът:
-> nvidia-glx-legacy съответства на драйвер 71хх
-> nvidia-glx съответства на драйвер 96xx
-> nvidia-glx-new съответства на драйвер 97xx
Мисля, че като цъкнеш на Restricted Devices Manager, програмата се опитва автоматично да определи каква ти е картата и да  инсталира един от тези пакети. Можеш да провериш дали някой от  горните пакети е инсталиран с командата:
Код: 
dpkg -l | grep nvidia
или просто да потърсиш в Synaptic дали са инсталирани. Ако от горната команда не се покаже нищо, няма инсталиран такъв пакет.
Ако никой от тях не е инсталиран, явно ще трябва да го инсталираш ти. За да видиш точно каква ти е картата (т.е., да не инсталираш на сляпо), опитай с командата:
Код: 
lspci | grep VGA

Това ще ти подскаже точно каква ти е видеокартата и точно кой пакет ти трябва.
Можеш да инсталираш някой от горните пакети с командата
Код: 
sudo apt-get install името_на_пакета
или да намериш пакета по име в Synaptic и да го инсталираш.
Гледайки от това HowTo ( http://wiki.debian.org/NvidiaGraphicsDrivers#Libraries ), от това HowTo ( https://help.ubuntu.com/community/NvidiaManual ) и от описанието на пакетите за Убунту (например, за http://packages.ubuntu.com/feisty/nvidia-kernel-source пише, че няма нужда от този пакет, защото linux-restricted-modules идва с прекомпилиран пакет), ми се струва, че би трябвало това:
Код: 
sudo apt-get install linux-restricted-modules-$(uname -r)
да инсталира нужният за ядрото пакет.

Толкова за това дали си инсталирал драйверите.

================================================================
==================== Променяне на xorg =========================
================================================================

Съобщението за грешка ти казва, че не може да намери драйвера на Nvidia; в твоя xorg.conf се използва драйвера vesa вместо драйвера nvidia.
Код: 
Section "Device"
Identifier "Configured Video Device"
Driver "vesa"
EndSection

Според мен, би трябвало да замениш реда
Код: 
Driver "vesa"
с  
Код: 
Driver "nvidia"

За да редактираш xorg.conf, можеш да използваш следната команда:
Код: 
gksu gedit /etc/X11/xorg.conf

След промяната запазваш файла xorg.conf.
Мисля, че трябва също да се зареди модулът nvidia. Можеш да провериш дали е зареден с командата:
Код: 
lsmod | grep nvidia
Ако не ти покаже нищо, значи модулът не е зареден в ядрото. Можеш да го заредиш с командата
Код: 
sudo modprobe nvidia
След което рестартираш Х-сървъра:
Код: 
sudo /etc/init.d/gdm restart

================================================================
======================= Проверка ===============================
================================================================

Тук вече ще видиш, дали сме омазали системата напълно.
Ако всичко е наред след рестартирането, би трябвало командата
Код: 
glxinfo | grep rendering
да ти изкара ред, в който пише нещо като "Direct rendering: Yes". Т.е., вече ще имаш 3Д ускорение на видеокартата. Вече можеш да пуснеш командата
Код: 
gksu gedit /etc/modules
и най-отдолу, на нов ред, да напишеш
Код: 
nvidia
за да се зарежда модулът на nvidia в ядрото ти всеки път при рестартиране на системата, вместо всеки път да го зареждаш с modprobe.

Редактирано от cdiem на Юли 02 2008, 20:15
Контакти:  cdiem

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #3 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Юли 02 2008, 23:27

Avatar




Група: Li fans
Мнения: 240
Регистриран: Август 2005

Оценка: няма

Offline
Честно казано въобще не чаткам какъв е принципно проблема с nVidia драйверите, при положение, че от nVidia са се постарали да си напишат супер детайлно ръководство. Това ръководство даже и описва как да се редактира xorg.conf (например цък1 и цък2)
Да не говорим, че вероятно за всяка дистрибуция има писания покриващи спецификите на дистрибуцията (пример за Ubuntu)

Специално за твоя проблем - не знам как работи nvidia-xconfig, но грешката е пределно ясна:
Цитат: 

VALIDATION ERROR: Data incomplete in file /etc/X11/xorg.conf.
Device section "Configured Video Device" must have a Driver
line.

Демек, в секция "Configured Video Device" трябва да имаш ред (параметър) с име Driver. В горния линк с кодово наименование "цък2" имаш пример как би трябвало той да изглежда.
Контакти:  Drakula
WEB  
Мнение #4 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Юли 03 2008, 14:16

Avatar




Група: Li fans
Мнения: 7
Регистриран: Юни 2008

Оценка: няма

Offline
Здравейте.Тъй като наскоро ми дойдоха дисковета с Ubuntu реших да го инсталирам в лаптопа на един приятел (Samsung R60).Той не беше виждал даже Линукс досега и му бях обещал да му сложа и да му пусна онези ефекти на Compiz това онова и се зарадва много.Ама проблем.Инсталирах го през Wubi всичко си мина нормално,след рестарт като пуснах да буутне Ubuntu стигна до едно място и ми каза че не може да зареди графичната среда и си остана с командната линия.Прочетох из форуми че трябвало с apt-get да инсталирам ATI драйверите на неговата видео карта (x1250).Но проблема е там че незнам как да конфигурирам Wireless-а му под командната линия за да сваля драйветите.Има ли начин да инсталирам тези драйвери http://ati.amd.com/support/drivers/linux/linux-radeon.html без интернет например ако са във USB флашката или CD-то?Ако има как с какви команди?Един приятел ми каза че мога да го конфигурирам да използва VGA драйвери че да ми пусне графичната среда колкото да конфигурирам безжичната мрежа и да сваля драйверите но това как става също незнам.Погледнах из xorg.conf и видях че  секцията

Section "Device"
Identifier "Configured Video Device"
EndSection

беще така в смисъл помня че трябваше да има една линия Driver под Identifier.Моля ако някой може да ми помогне ще съм много благодарен тъй като се изложих пред момчето бях му обещал да го запозная с Linux а нещата не станаха :(

God is a Dj and House is my Religion.
Контакти:  Bavarian

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #5 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Юли 03 2008, 18:36

Avatar




Група: Li fans
Мнения: 621
Регистриран: Декември 2006

Оценка: 5

Offline
Ами намушкай един кабел в лаптопа отвори в конзола ifconfig и му дай адресите от доставчика.Под текстов режим няма да можеш да инсталираш АТИ карта защото инсталатора е графичен.През apt-get също.Или сложи диска на убунту /предполагам че е лайф цд/ и свали каквото ти трябва.А най-вероятното да омаже Х-а е компиз - според мен първо настрой всичко в убунту /+ мрежата/,направи си копие на xorg и после се занимавай с ефектите на десктопа.
Контакти:  devik
WEB  
Мнение #6 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Юли 04 2008, 09:01

Avatar




Група: Li fans
Мнения: 105
Регистриран: Ноември 2007

Оценка: няма

Offline
Айде бе нямало да може! И без това почти никой не ползва графичния инсталер. Ето линк с вики как става http://wiki.cchtml.com/index.p...._8.6.29
Все пак трябва нет за да се изтеглят някой зависимости.
Контакти:  todir
WEB  
Мнение #7
Skip to the previous post in this topic. Написано на: Юли 04 2008, 12:27

Avatar




Група: Li fans
Мнения: 7
Регистриран: Юни 2008

Оценка: няма

Offline
Справих се с драйвърите.След инсталация с Wubi понеже зарежда Ubuntu като LiveCD инсталирах драйверите под конзолата.След това без рестарт пуснах графичната среда и инсталирах Ubuntu на емулирания дял в C: на Windows.След инсталация на Ubuntu и рестарт пак под конзолата инсталирах драйверите но тъй като системата беше вече инсталирана след рестарт драйверите не се изгубиха.Дотук всичко перфектно четох как да го правя в една статия специално за Samsung R60 във форумите.Но след като пуснах графичната среда на инсталираната система се и се логвам с моя акаунт чува се звука на Gnome като зареди но само един бял екран...Във форумите четох че е възможно по много причини,от драйвърите,от лаптопа или от ментелива флашка.Както и да е така и не можах да го оправя.Явно тоя Samsung R60 е много проблемен с Ubuntu.Е той така или иначе след няколко месеца ще си вземе нов лаптоп и на него вече :) Все пак благодаря за помощта.

God is a Dj and House is my Religion.
Контакти:  Bavarian

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Общо 6 отговор(а) от Юли 02 2008, 12:53 до сега
 » Начало » Li Форуми » Help & Support » Kernels & Drivers » Проблеми с драйвъри.

© 2014 Linux Index Project
Powered by iF 1.0.0 © 2006 ikonForums