Запомняне

» Здравейте
[ Вход :: Регистриране ]
 » Начало » Li Форуми » Help & Support » Kernels & Drivers » Fdora 11 Проблем с Nvidia
Тема: Fdora 11 Проблем с Nvidia
Мнение #1 Skip to the next post in this topic.
Написано на: Юли 31 2009, 11:25

Avatar




Група: Li fans
Мнения: 134
Регистриран: Ноември 2006

Оценка: няма

Offline
След инсталирането на драйвера на NVIDIA GeForce 7900 gs не се стартира Х. Влезнах като root в терминал и се опитах да го стартирам с командата startx но ми да следната грешка.


X.Org X Server 1.6.1.901 (1.6.2 RC 1)
Release Date: 2009-5-8
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.18-128.1.6.el5 i686
Current Operating System: Linux ip-163-155.powernet.bg 2.6.29.4-167.fc11.i586 #1 SMP Wed May 27 17:14:37 EDT 2009 i686
Kernel command line: ro root=UUID=1ca86f05-7391-48d7-8cc4-d9d713c343ec rhgb quiet
Build Date: 18 May 2009  02:47:59PM
Build ID: xorg-x11-server 1.6.1.901-1.fc11
  Before reporting problems, check http://wiki.x.org
  to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
  (++) from command line, (!!) notice, (II) informational,
  (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Fri Jul 31 10:38:19 2009
(==) Using config file: "/etc/X11/xorg.conf"
(==) ServerLayout "Layout0"
(**) |-->Screen "Screen0" (0)
(**) |   |-->Monitor "Monitor0"
(**) |   |-->Device "Device0"
(**) |-->Input Device "Keyboard0"
(**) |-->Input Device "Mouse0"
(**) Option "Xinerama" "0"
(==) Automatically adding devices
(==) Automatically enabling devices
(**) FontPath set to:
  /usr/share/fonts/default/Type1,
  catalogue:/etc/X11/fontpath.d,
  built-ins
(==) ModulePath set to "/usr/lib/xorg/modules"
(WW) AllowEmptyInput is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
(WW) Disabling Keyboard0
(WW) Disabling Mouse0
(II) Loader magic: 0x640
(II) Module ABI versions:
  X.Org ANSI C Emulation: 0.4
  X.Org Video Driver: 5.0
  X.Org XInput driver : 4.0
  X.Org Server Extension : 2.0
(II) Loader running on linux
(--) using VT number 7

(--) PCI:*(0@7:0:0) nVidia Corporation G71 [GeForce 7900 GS] rev 161, Mem @ 0xfa000000/16777216, 0xe0000000/268435456, 0xfb000000/16777216, I/O @ 0x00009c00/128, BIOS @ 0x????????/131072
(II) No APM support in BIOS or kernel
(II) System resource ranges:
 

   * -1   0   0xffffffff - 0xffffffff (0x1) MX
     [1] -1   0   0x000f0000 - 0x000fffff (0x10000) MX


  [2] -1   0   0x000c0000 - 0x000effff (0x30000) MX
  [3] -1   0   0x00000000 - 0x0009ffff (0xa0000) MX
  [4] -1   0   0xffffffff - 0xffffffff (0x1) MX
  [5] -1   0   0x000f0000 - 0x000fffff (0x10000) MX
  [6] -1   0   0x000c0000 - 0x000effff (0x30000) MX
  [7] -1   0   0x00000000 - 0x0009ffff (0xa0000) MX
  [8] -1   0   0xffffffff - 0xffffffff (0x1) MX
  [9] -1   0   0x000f0000 - 0x000fffff (0x10000) MX
  [10] -1   0   0x000c0000 - 0x000effff (0x30000) MX
  [11] -1   0   0x00000000 - 0x0009ffff (0xa0000) MX
  [12] -1   0   0xffffffff - 0xffffffff (0x1) MX
  [13] -1   0   0x000f0000 - 0x000fffff (0x10000) MX
  [14] -1   0   0x000c0000 - 0x000effff (0x30000) MX
  [15] -1   0   0x00000000 - 0x0009ffff (0xa0000) MX
  [16] -1   0   0x0000ffff - 0x0000ffff (0x1) IX
  [17] -1   0   0x00000000 - 0x00000000 (0x1) IX
  [18] -1   0   0x0000ffff - 0x0000ffff (0x1) IX
  [19] -1   0   0x00000000 - 0x00000000 (0x1) IX
  [20] -1   0   0x0000ffff - 0x0000ffff (0x1) IX
  [21] -1   0   0x00000000 - 0x00000000 (0x1) IX
  [22] -1   0   0x0000ffff - 0x0000ffff (0x1) IX
  [23] -1   0   0x00000000 - 0x00000000 (0x1) IX
(II) LoadModule: "extmod"
(II) Loading /usr/lib/xorg/modules/extensions//libextmod.so
(II) Module extmod: vendor="X.Org Foundation"
  compiled for 1.6.1.901, module version = 1.0.0
  Module class: X.Org Server Extension
  ABI class: X.Org Server Extension, version 2.0
(II) Loading extension SELinux
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "dbe"
(II) Loading /usr/lib/xorg/modules/extensions//libdbe.so
(II) Module dbe: vendor="X.Org Foundation"
  compiled for 1.6.1.901, module version = 1.0.0
  Module class: X.Org Server Extension
  ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "glx"
(II) Loading /usr/lib/xorg/modules/extensions//libglx.so
(II) Module glx: vendor="NVIDIA Corporation"
  compiled for 4.0.2, module version = 1.0.0
  Module class: X.Org Server Extension
(II) NVIDIA GLX Module  185.18.29  Thu Jul 23 05:48:22 PDT 2009
(II) Loading extension GLX
(II) LoadModule: "record"
(II) Loading /usr/lib/xorg/modules/extensions//librecord.so
(II) Module record: vendor="X.Org Foundation"
  compiled for 1.6.1.901, module version = 1.13.0
  Module class: X.Org Server Extension
  ABI class: X.Org Server Extension, version 2.0
(II) Loading extension RECORD
(II) LoadModule: "dri"
(II) Loading /usr/lib/xorg/modules/extensions//libdri.so
(II) Module dri: vendor="X.Org Foundation"
  compiled for 1.6.1.901, module version = 1.0.0
  ABI class: X.Org Server Extension, version 2.0
(II) Loading extension XFree86-DRI
(II) LoadModule: "dri2"
(II) Loading /usr/lib/xorg/modules/extensions//libdri2.so
(II) Module dri2: vendor="X.Org Foundation"
  compiled for 1.6.1.901, module version = 1.0.0
  ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DRI2
(II) LoadModule: "nvidia"
(II) Loading /usr/lib/xorg/modules/drivers//nvidia_drv.so
(II) Module nvidia: vendor="NVIDIA Corporation"
  compiled for 4.0.2, module version = 1.0.0
  Module class: X.Org Video Driver
(EE) NVIDIA: Failed to load the NVIDIA kernel module. Please check your
(EE) NVIDIA:     system's kernel log for additional error messages.
(II) UnloadModule: "nvidia"
(II) Unloading /usr/lib/xorg/modules/drivers//nvidia_drv.so
(EE) Failed to load module "nvidia" (module-specific error, 0)
(EE) No drivers available.

Fatal server error:
no screens found

Please consult the The X.Org Foundation support
   at http://wiki.x.org
for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

-  P C  -
MB-ASUS M2N-E/NF570/s.AM2
CPU-AMD ATHLON 3800+/64bit/x2/s.AM2
V.C.-GeForce 7900GS DDR3 PCI-E 256MB HDTV
RAM-KINGSTON 2x1GB /DDR2/667
Контакти:  alkor
WEB  
Мнение #2
Skip to the previous post in this topic. Написано на: Юли 31 2009, 18:08

Avatar




Група: Li maniacs
Мнения: 449
Регистриран: Септември 2005

Оценка: няма

Offline
system's kernel log разгледай и дай допълнително инфо за грешката от него.
nvidia-settings пробвай.
Изтеглил си 185.18.29-драйвер? Сигурен ли си, че е подходящият? Лаптоп - Десктоп? Архитектура на процесора? Как го инсталира?
Деинсталира ли предишен драйвер, ако си имал такъв?

Редактирано от saejoh на Юли 31 2009, 18:11

Ath XP 1700+, NVidia, Biostar M7NCG, Повече тук и тук
Контакти:  saejoh

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Общо 1 отговор(а) от Юли 31 2009, 11:25 до сега
 » Начало » Li Форуми » Help & Support » Kernels & Drivers » Fdora 11 Проблем с Nvidia

© 2014 Linux Index Project
Powered by iF 1.0.0 © 2006 ikonForums