Запомняне

» Здравейте
[ Вход :: Регистриране ]
 » Начало » Li Форуми » Help & Support » Kernels & Drivers » Проблем в USB WiFi Адаптер
Тема: Проблем в USB WiFi Адаптер, Zyxel NWD-270N
Мнение #1 Skip to the next post in this topic.
Написано на: Февруари 27 2010, 11:04

No avatar chosen




Група: Li fans
Мнения: 21
Регистриран: Януари 2008

Оценка: няма

Offline
Здравейте,
Имам USB WiFi адаптер Zyxel NWD-270N. Когато го купих, веднага след plug-ването в PC-то, беше детекнато и с ifconfig се виждаше като wlan0. Всичко беше ОК, до момента в който случайно извадих устройството, докато компютъра работеше - след това PC-то заби и трябваше да се рестартира. След рестарт вече нямах wlan0 :). Отначало помислих, че проблема е хардуаерен, но не е, защото при boot от Live CD устройството се вижда. Операционната система (Ubuntu 9.10) вижда адаптера като usb устройство, когато включено, но нямам wlan0:
Код: 

dani@dani-desktop:~$ lsusb
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
[U]Bus 001 Device 006: ID 0586:341a ZyXEL Communications Corp.[/U]
Bus 001 Device 005: ID 04f2:a142 Chicony Electronics Co., Ltd
Bus 001 Device 004: ID 09da:000a A4 Tech Co., Ltd Port Mouse
Bus 001 Device 003: ID 0409:005a NEC Corp. HighSpeed Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Използвах ndiswrapper за да кача win драйвери - адаптера също се вижда като активен и от там:
Код: 

dani@dani-desktop:~$ ndiswrapper -l
WARNING: All config files need .conf: /etc/modprobe.d/ndiswrapper, it will be ignored in a future release.
rt2870 : driver installed
device (0586:341A) present (alternate driver: rt2800usb)

Обаче wifi интерфейс все още нямам:

Код: 

dani@dani-desktop:~$ iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

vboxnet0  no wireless extensions.


Това е информацията, която мога да предоставя, ако имате нужда от нещо допълнително или имате идеи, моля пишете ;)
Контакти:  Sett

  • AOL  AOL:
  • ICQ  ICQ: 323700122
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #2 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Февруари 28 2010, 09:05

No avatar chosen




Група: Li fans
Мнения: 258
Регистриран: Януари 2008

Оценка: няма

Offline
Хм, :21; .Всъщност ако първо поставиш устройството и след това заредиш Убунту,би трябвало да го види.Препоръчвам ти да си инсталираш операционната система на твърдият диск за да нямаш проблеми.След което:
sudo apt-get install dnsmasq и си готов.Мисля че от Убунту 9.04 до сега пакета си го има в самата дистрибуция и няма нужда от инсталиране ама не съм много сигурен.Това лесно можеш да го провериш с някоя команда.Ако го има буташ устройството в USB гнездото,рестартираш и трябва да стане.
Контакти:  AZ ZERGA
WEB  
Мнение #3 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Февруари 28 2010, 10:15

No avatar chosen




Група: Li fans
Мнения: 21
Регистриран: Януари 2008

Оценка: няма

Offline
Явно не съм се изразил добре - операционната система е инсталирана на твърдят диск, заредих Live CD-то само за да тествам дали ще открие устройството  и да - през Live CD-то работи. Пробвал съм и първо да бутна USB-то и да рестартирам, и да го закача при вече зареден ОС, както и да изключа PC-то, да бутна устройството и да включа отново - не става.
dnsmasq е инсталиран по default, но не виждам с какво това би помогналo.

Нещо се е обозило, когато издършах апатера в работещо състояние, но не мога разбера какво. Ако преинсталирам ОС-а, най-вероятно ще работи, но както се сещате, не искам да го правя :)
Контакти:  Sett

  • AOL  AOL:
  • ICQ  ICQ: 323700122
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #4 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Февруари 28 2010, 22:07

No avatar chosen




Група: Li fans
Мнения: 258
Регистриран: Януари 2008

Оценка: няма

Offline
Аз редовно си издърпвам адаптера ама проблеми до сега не съм имал.Винаги си инсталирам предпоследното Убунту защото е стабилно,а към последната версия винаги има какво да се очаква.Ако имаш друго USB гнездо на компа ти препоръчвам да поставиш адаптера там и пак да пробваш.Ако не стане,с Убунту 9.04 не смятам че ще имаш проблеми.
Контакти:  AZ ZERGA
WEB  
Мнение #5 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Март 04 2010, 15:39

No avatar chosen




Група: Li fans
Мнения: 5
Регистриран: Септември 2009

Оценка: няма

Offline
С какво ядро си? Аз имах също подобен проблем...
Я пробвай следното да видим какво ще се получи:

sudo echo blacklist rt2800usb > /etc/modprobe.d/blacklist.conf


sudo modprobe rt2870sta

Предполагам проблема е в blacklist...
Контакти:  ApucTokpaT

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #6 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Март 04 2010, 22:32

No avatar chosen




Група: Li fans
Мнения: 21
Регистриран: Януари 2008

Оценка: няма

Offline
Благодаря, ApucTokpaT :)

2.6.31-20-generic
Горното  нямаше резултат. Пробвах с modprobe rt2800usb и устройството изгря - сега имам wlan0, но проблема е, че не се виждат никакви ssid-та - нито с iwlist, нито с WiFi radar (някакво GUI tool-че). Не съм сигурен, че преди са се виждали мрежи (всъщност никога не съм използвал на практика usb-то), но сега със сигурност около мен има мрежи, които си broadcast-ват ssid-то, а когато пробвам да се закача към работеща скрита мрежа, пак не става. Все пак, предполагам, че е напрадък това, че вече имам wifi интерфейс, но ще може ли да се измисли и нещо за новият проблем?

Редактирано от Sett на Март 04 2010, 22:33
Контакти:  Sett

  • AOL  AOL:
  • ICQ  ICQ: 323700122
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #7 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Март 05 2010, 16:22

No avatar chosen




Група: Li fans
Мнения: 5
Регистриран: Септември 2009

Оценка: няма

Offline
Чакай да видим ( впрочем аз също съм начинаещ в тази област) ,това което разбрах досега ,е че инсталирания драйвър не го подкарва ,но за сметка на това подкарва този който идва с ядрото,но пък не ти върши работа, защото устройството работи с RT2870usb...Това което бих могъл да ти предложа е да си сложиш ядро като моето 2.6.32 и да го компилираш ръчно с localmodconfig (дравъра в него е включен и ще ти подкара нета без проблеми),но това е все едно да трепеш мухи с базука...Ако все пак решиш да направиш тази крайна стъпка това ще ти помогне: http://it-light.net/linux....id.html
В противен случай можеш отново да опиташ да  прочетеш README файла на драйвъра за линукс,аз използвах нещо подобно на този туториал за да го подкарам,важно е да  изпълниш следната команда за да не си пречат двата драйвъра:
sudo gedit /etc/modprobe.d/blacklist.conf
и добавяш в края
blacklist rt2x00usb
blacklist rt2x00lib
blacklist rt2800usb
Ако си изтеглил драйвъра на десктопа правиш следното:
cd ~/Desktop
tar -xvf ~/Desktop/RT2870_LinuxSTA*.tgz
cd ~/Desktop/*2870*
натройваш ID на устройството с :
gedit ~/Desktop/*2870*/common/rtusb_dev_id.c
и добавяш :{USB_DEVICE(0586:341A)}
после за да го съгласуваш с network-manager правиш следното :
gedit ~/Desktop/*2870*/os/linux/config.mk
и променяш на "yes" там където пише wpasyplicant=no
влизаш си в директорията където ти е разархивиран драйвъра и: make
sudo make install
като свършиш го зареждаш заедно при стартиране на системата с:
sudo modprobe -r rt2870sta
sudo insmod /lib/modules/`uname -r`/kernel/drivers/net/wireless/rt2870sta.ko
sudo /etc/init.d/networking restart
sudo restart network-manager
МАХАШ СТАРИЯ ДРАЙВЪР КОЙТО СИ СЛОЖИЛ (в убунтуто ти е инсталиран също заедно с дистрибуцията) с команда:
sudo rm -rf /lib/modules/`uname -r`/kernel/drivers/staging/rt2870
и това е!

Редактирано от ApucTokpaT на Март 05 2010, 16:24
Контакти:  ApucTokpaT

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #8
Skip to the previous post in this topic. Написано на: Март 07 2010, 00:10

No avatar chosen




Група: Li fans
Мнения: 258
Регистриран: Януари 2008

Оценка: няма

Offline
Добре ама не можах да разбера какво точно трябваше да правим(да приемаш или да споделяш интернет),не за друго ами щото ако искаш да споделяш net първо ще ти трябва DHCP сървър,а мисля че точно там е проблема.Смятам че първо трябва да изпълниш ifconfig.Успех!
Контакти:  AZ ZERGA
WEB  
Общо 7 отговор(а) от Февруари 27 2010, 11:04 до сега
 » Начало » Li Форуми » Help & Support » Kernels & Drivers » Проблем в USB WiFi Адаптер

© 2014 Linux Index Project
Powered by iF 1.0.0 © 2006 ikonForums