Запомняне

» Здравейте
[ Вход :: Регистриране ]
 » Начало » Li Форуми » Help & Support » Kernels & Drivers » Ati драйвери
Тема: Ati драйвери
Мнение #11 Skip to the next post in this topic.
Написано на: Април 13 2005, 13:22
mcwolf

No avatar chosen




Група: Li gurus
Мнения: 1489
Регистриран: Април 2005

Оценка: 5

Offline
това с Х-а ми се вижда странно, но щом е станало е добре - при инсталацията на драйверът е хубаво да е изключен - и да не забравиш да кажеш как е минала одисеята  :)

Редактирано от mcwolf на Април 13 2005, 13:22
Контакти:  mcwolf

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #12 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Април 13 2005, 13:35
PinkFloyd

Avatar




Група: Li fans
Мнения: 116
Регистриран: Април 2005

Оценка: няма

Offline
Имаше и други странности.След startx мишката замръзна на място.Alt+Ctrl+Del ,от там отново конзола и при опит за reboot,shutdown,halt ми обявяваше че няма такава команда.При man reboot всичко е както трябва.Абе чудя се дали да не си сложа едно истинско Slackware макар че Вектора е като истребител.
Контакти:  PinkFloyd
WEB  
Мнение #13 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Април 13 2005, 13:53
mcwolf

No avatar chosen




Група: Li gurus
Мнения: 1489
Регистриран: Април 2005

Оценка: 5

Offline
след като си ровчил по настройките на Х-а ли замръзва мишката (дефакто при инсталацията на драйверът) - ако е така значи нещо се е омазало файлчето - отвори си архивът и си прехвърли настройката на мишокът - а иначе нали знаеш - скоростта е за сметка на функционалността - инсталирай едно KDE да видиш колко бавно ще работи и векторът
Контакти:  mcwolf

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #14 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Април 13 2005, 14:05
PinkFloyd

Avatar




Група: Li fans
Мнения: 116
Регистриран: Април 2005

Оценка: няма

Offline
Мишката замръзна веднага след стартирането на Х последвало конвертирането на rpm в tgz.След превключване между Х със замръзнала мишка и конзола която не приема каманди за рестартиране ,изключих от конзолата с Alt+Itrl+Del.Сега всичко е ОК.Инсталацията съм я оставил за довечера.Аз съм с KDE при това всички екстри са на максимум.Работи два пъти по бързо от Mandrake с icewm,да не говорим за "стария" на 4 месеца WinXP
Контакти:  PinkFloyd
WEB  
Мнение #15 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Април 13 2005, 18:36
PinkFloyd

Avatar




Група: Li fans
Мнения: 116
Регистриран: Април 2005

Оценка: няма

Offline
Моля за извинение но се налага да бъда подробен.
В конзола без Х изпълних installpkg fglrx......и след секунда ми даде съобщението PACKAGE DESCRIPTION:Рестартирах(незнам дали е нужно,аз за всеки случай) и всичко нормално без видими разлики,KDE кото KDE.Отворих терминал с намерение да търся има ли инсталирани драйвери и вместо да търся стартирах fglrxkonfig.Отговорих на въпросите като на няколкото които не ми бяха съвсем ясни отбелязах това което ми се предлага.Рестнах и вместо автоматично влизане в Х излезе съобщениеWARNING:Recent X-Window was respawned too short.Да проверя X-Window и да опитам отново.
Пуснах fglrxconfig няколко пъти като намалих стойностите за монитора,след това махнах екстри от сорта на TV-out,но Х йок.
След това пуснах xorgconfig и пак нищо.Накрая с вградения за конфигуриране инструмент VASM върнах нещата до толкова че имам Х но настройките които съм правил на ръка в xorg.conf ги няма.Например при първоначална инсталация няма modeline и аз си дописвах.В Х11 сега имам десетина файла започващи с xorg и един XFree86.В /lib/modules имам директория fglrx и в нея някакъв скрипт make instal.sh
Е, това е с малко думи.
Контакти:  PinkFloyd
WEB  
Мнение #16 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Април 14 2005, 13:04
mcwolf

No avatar chosen




Група: Li gurus
Мнения: 1489
Регистриран: Април 2005

Оценка: 5

Offline
пробвай така:
# cd /lib/modules/fglrx/build_mod/
# sh make.sh
# cd ..
# sh make_install.sh
# modprobe fglrx
и чак селед това fglrxconfig

и дай съдържанието на X11 да ги видиме тия файлове (най-вероятно са архивни файлове) - когато решиш да връщаш системата в изходно състояние (след като Х-а неще да тръгне) просто си копирай архивчето на xorg.conf върху това с което се дъни - а ако проблемът е с неработещ модул копирай направо директорията с модулите (дето ти казах да и направиш резервно копие)

Редактирано от mcwolf на Април 14 2005, 13:05
Контакти:  mcwolf

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #17 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Април 14 2005, 20:44
PinkFloyd

Avatar




Група: Li fans
Мнения: 116
Регистриран: Април 2005

Оценка: няма

Offline
Абе добри хора,днес цял ден нямах достъп до сайта ви.Помислих си че от завис някой го е пр....л.Не мога да се възползвам от последния ти съвет защото след доста опити върнах архива.С find обаче намирам доста файлове fglrx,но няма да ги чистя.Xorg файловете наистина са архиви,но първия го няма,така че в момента са пообъркани.Днес и утре съм почивка и ще взема да преинсталирам и ще видя какво ще стане.Home директорията ми е на друг дял,инсталацията протича бързо,е язък за настройкитеИ понеже мокър от дъжд не се бои използвах да поекспериментирам с други неща за който по рано не събирах смелост.Успях да се убедя че това животно Linux е доста дуракоустойчиво след като още работи и си чатя с вас в момента.
Контакти:  PinkFloyd
WEB  
Мнение #18 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Април 14 2005, 20:52
PinkFloyd

Avatar




Група: Li fans
Мнения: 116
Регистриран: Април 2005

Оценка: няма

Offline
Забравих да спомена нещо което ми направи впечатление додето търсех и разглеждах файловете съдържащи fglrx  Никъде не присъстваше номера на мойто 2.4.29 ядро,а навсякъде беше 2.6.
Контакти:  PinkFloyd
WEB  
Мнение #19 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Април 14 2005, 22:17
mcwolf

No avatar chosen




Група: Li gurus
Мнения: 1489
Регистриран: Април 2005

Оценка: 5

Offline
щом така или иначе си решил да преинсталираш преди това си поиграй с тоя глупав драйвер :) да видиш дали ще тръгне - и един съвет за архивите - направи си една директорийка и си ги трупай в нея - така дори и да преинсталираш (нещо което не те съветвам да правиш за ремонт на системата) ще можеш да си върнеш всичко както си е било бързо и лесно
Контакти:  mcwolf

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #20
Skip to the previous post in this topic. Написано на: Април 16 2005, 20:37
PinkFloyd

Avatar




Група: Li fans
Мнения: 116
Регистриран: Април 2005

Оценка: няма

Offline
След    sh make.sh  даде съобщение че е компилирало нещо си направило е още нещо си и ми даде инструкции които съвпадат с твоите.Дадох му   sh make_install.sh  и ми излезе съобщение че ПЕРМИСИОН ДЕНИЕД.Явно че драйверите са за ядро 2.6 защото кото разгледах файловете в архива никъде не видях2.4,а само 2.6.На сайта на Ати мисля че видях нещо от сорта че трябва да е по ново от 2.4.Не съжалявам за мъките,то така можеш да научиш нещо.
Контакти:  PinkFloyd
WEB  
Общо 27 отговор(а) от Април 11 2005, 21:24 до сега
 » Начало » Li Форуми » Help & Support » Kernels & Drivers » Ati драйвери

© 2014 Linux Index Project
Powered by iF 1.0.0 © 2006 ikonForums