Запомняне

» Здравейте
[ Вход :: Регистриране ]
 » Начало » Li Форуми » Help & Support » Kernels & Drivers » Проблем с AC'97-драйвери - Debian
Тема: Проблем с AC'97-драйвери - Debian
Мнение #1 Skip to the next post in this topic.
Написано на: Март 05 2006, 16:54
templar

No avatar chosen




Група: Li fans
Мнения: 3
Регистриран: Март 2006

Оценка: няма

Offline
Става дума за Debian Linux с ядро 2.6.15. Дъното ми е Gigabyte GA-7ZM и е с вградена sound-карта AC'97. Когато се зарежда KDE-то ми изкарва съобщение:

Код: 

Sound server informational message:
Error while initializing the sound driver:
device /dev/dsp can't be opened (No such file or directory)
The sound server will continue, using the null output device.


Изглежда трябва да си инсталирам sound driver. Някой може ли да ми каже от къде и как?
Контакти:  templar
WEB  
Мнение #2 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Март 05 2006, 23:08
quintessence

Avatar




Група: Li psychos
Мнения: 813
Регистриран: Август 2005

Offline
Код: 
apt-get install alsa-base alsa-source alsa-utils
...след това конфигурираш ALSA-та с помощта на alsaconf .. като супер потребител /т.е root/ изпълняваш
Код: 
alsaconf
 :)
Контакти:  quintessence

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #3 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Март 08 2006, 21:51
templar

No avatar chosen




Група: Li fans
Мнения: 3
Регистриран: Март 2006

Оценка: няма

Offline
Накрая на изпълнението на alsaconf ми дава:

Код: 

FATAL: Error running install command for snd_seq
FATAL: Error running install command for snd_via82xx


Редактирано от templar на Март 08 2006, 22:03
Контакти:  templar
WEB  
Мнение #4 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Март 09 2006, 01:18
quintessence

Avatar




Група: Li psychos
Мнения: 813
Регистриран: Август 2005

Offline
инсталирай също така /явну пакетите липсват :) / alsa-driver , alsa-lib , alsa-oss ..  :)
Контакти:  quintessence

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #5 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Март 09 2006, 01:55
Leftfield

Avatar




Група: Li fans
Мнения: 20
Регистриран: Февруари 2006

Оценка: няма

Offline
аз имах същия проблем и го реших като си свалих и съответно инсталирах alsa-modules , http://apt.mepis.org/3.4/pool/linux-2.6/ избери си алса модул за твоето ядро
Контакти:  Leftfield
WEB  
Мнение #6 Skip to the next post in this topic.
Skip to the previous post in this topic. Написано на: Март 12 2006, 20:20
templar

No avatar chosen




Група: Li fans
Мнения: 3
Регистриран: Март 2006

Оценка: няма

Offline
Пробвах да инсталирам alsa-driver, alsa-lib и alsa-oss с apt-get. Само третия беше открит и само него инсталирах нормално. alsa-lib си го намерих от tar.bz пакет и го инсталирах, но alsa-driver не стана по този начин - дава ми някаква грешка при компилацията.

alsa-modules си го свалих за k7. Като пробвам да го инсталирам ми дава:
Код: 
# dpkg -i alsa-modules-2.6.15-1-k7-smp_1.0.10+1.0.11rc2-2+2.6.15-3.ww1_i386.deb
(Reading database ...   107869 files and directories currently installed.)
Preparing to replace alsa-modules-2.6.15-1-k7-smp 1.0.10+1.0.11rc2-2+2.6.15-3.ww1 (using alsa-modules-2.6.15-1-k7-smp_1.0.10+1.0.11rc2-2+2.6.15-3.ww1_i386.deb) ...
Unpacking replacement alsa-modules-2.6.15-1-k7-smp ...
Setting up alsa-modules-2.6.15-1-k7-smp (1.0.10+1.0.11rc2-2+2.6.15-3.ww1) ...
FATAL: Could not open '/boot/System.map-2.6.15-1-k7-smp': No such file or directory


System.map-файлът на ядрото ми е /boot/System.map-2.6.15


Редактирано от templar на Март 12 2006, 20:22
Контакти:  templar
WEB  
Мнение #7
Skip to the previous post in this topic. Написано на: Април 15 2006, 23:50
kalin

Avatar




Група: Li fans
Мнения: 29
Регистриран: Април 2006

Оценка: няма

Offline
Цитат:  (templar @ Март 05 2006,16:54)

Става дума за Debian Linux с ядро 2.6.15. Дъното ми е Gigabyte GA-7ZM и е с вградена sound-карта AC'97. Когато се зарежда KDE-то ми изкарва съобщение:

Код: 

Sound server informational message:
Error while initializing the sound driver:
device /dev/dsp can't be opened (No such file or directory)
The sound server will continue, using the null output device.


Изглежда трябва да си инсталирам sound driver. Някой може ли да ми каже от къде и как?

ще paste-неш ли какво ти дава lsmod
Контакти:  kalin
WEB  
Общо 6 отговор(а) от Март 05 2006, 16:54 до сега
 » Начало » Li Форуми » Help & Support » Kernels & Drivers » Проблем с AC'97-драйвери - Debian

© 2014 Linux Index Project
Powered by iF 1.0.0 © 2006 ikonForums