Запомняне

» Здравейте
[ Вход :: Регистриране ]
 » Начало » Li Форуми » Help & Support » Servers & Services » Mysql проблем
Тема: Mysql проблем, socket is not correctly configured
Мнение #1 Skip to the next post in this topic.
Написано на: Февруари 23 2008, 13:44

No avatar chosen




Група: Li fans
Мнения: 1
Регистриран: Август 2007

Оценка: няма

Offline
Значи обърнах се към някои ваши колеги, но мисля да се обърна и към останалите значи проблема ми следен :6; вчера по някакъв странен начин съм прецакал mysql сървъра на Debian 6 (исках да инсталирам cpanel,но не стана и го манах и след това ми дава това)
Код: 
#2002 - Няма отговор от сървъра (or the local MySQL server's socket is not correctly configured)

Това на phpmyadmin..
Код: 
Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)

По точно изобщо не може да се свърже към mysqla никое приложение или сайт  :14;
Някакви идеи?
Това са командите които са ми казали да покажа какво изписва.. (да спомена сървъра е отдалечен и ползвам Putty)
Код: 

root@goebbels:/# ps -e | grep mysql
27992 ?        00:00:00 mysqld_safe
28013 ?        00:00:00 mysqld
root@goebbels:/# netstat -tap | grep mysql
tcp        0      0 *:mysql                 *:*                     LISTEN     28013/mysqld
root@goebbels:/# /etc/init.d/mysql restart
Shutting down MySQL
Starting MySQL
root@goebbels:/#


my.cnf

Код: 

#
# The MySQL database server configuration file.
#
# You can copy this to one of:
# - "/etc/mysql/my.cnf" to set global options,
# - "~/.my.cnf" to set user-specific options.
#
# One can use all long options that the program supports.
# Run program with --help to get a list of available options and with
# --print-defaults to see which it would actually understand and use.
#
# For explanations see
# http://dev.mysql.com/doc/mysql/en/server-system-variables.html

# This will be passed to all mysql clients
# It has been reported that passwords should be enclosed with ticks/quotes
# escpecially if they contain "#" chars...
# Remember to edit /etc/mysql/debian.cnf when changing the socket location.
[client]
port = 3306
socket = /var/run/mysqld/mysqld.sock

# Here is entries for some specific programs
# The following values assume you have at least 32M ram

# This was formally known as [safe_mysqld]. Both versions are currently parsed.
[mysqld_safe]
socket = /var/run/mysqld/mysqld.sock
nice = 0

[mysqld]
#
# * Basic Settings
#
user = mysql
pid-file = /var/run/mysqld/mysqld.pid
socket = /var/run/mysqld/mysqld.sock
port = 3306
basedir = /usr
datadir = /var/lib/mysql
tmpdir = /tmp
language = /usr/share/mysql/english
skip-external-locking
#
# Instead of skip-networking the default is now to listen only on
# localhost which is more compatible and is not less secure.
bind-address = 127.0.0.1
#
# * Fine Tuning
#
key_buffer = 16M
max_allowed_packet = 16M
thread_stack = 128K
thread_cache_size = 8
#max_connections        = 100
#table_cache            = 64
#thread_concurrency     = 10
#
# * Query Cache Configuration
#
query_cache_limit       = 1M
query_cache_size        = 16M
#
# * Logging and Replication
#
# Both location gets rotated by the cronjob.
# Be aware that this log type is a performance killer.
#log = /var/log/mysql/mysql.log
#
# Error logging goes to syslog. This is a Debian improvement :)
#
# Here you can see queries with especially long duration
#log_slow_queries = /var/log/mysql/mysql-slow.log
#long_query_time = 2
#log-queries-not-using-indexes
#
# The following can be used as easy to replay backup logs or for replication.
#server-id = 1
log_bin = /var/log/mysql/mysql-bin.log
# WARNING: Using expire_logs_days without bin_log crashes the server! See README.Debian!
expire_logs_days = 10
max_binlog_size         = 100M
#binlog_do_db = include_database_name
#binlog_ignore_db = include_database_name
#
# * BerkeleyDB
#
# Using BerkeleyDB is now discouraged as its support will cease in 5.1.12.
skip-bdb
#
# * InnoDB
#
# InnoDB is enabled by default with a 10MB datafile in /var/lib/mysql/.
# Read the manual for more InnoDB related options. There are many!
# You might want to disable InnoDB to shrink the mysqld process by circa 100MB.
#skip-innodb
#
# * Security Features
#
# Read the manual, too, if you want chroot!
# chroot = /var/lib/mysql/
#
# For generating SSL certificates I recommend the OpenSSL GUI "tinyca".
#
# ssl-ca=/etc/mysql/cacert.pem
# ssl-cert=/etc/mysql/server-cert.pem
# ssl-key=/etc/mysql/server-key.pem



[mysqldump]
quick
quote-names
max_allowed_packet = 16M

[mysql]
#no-auto-rehash # faster start of mysql but no tab completition

[isamchk]
key_buffer = 16M

#
# * NDB Cluster
#
# See /usr/share/doc/mysql-server-*/README.Debian for more information.
#
# The following configuration is read by the NDB Data Nodes (ndbd processes)
# not from the NDB Management Nodes (ndb_mgmd processes).
#
# [MYSQL_CLUSTER]
# ndb-connectstring=127.0.0.1


#
# * IMPORTANT: Additional settings that can override those from this file!
#
!includedir /etc/mysql/conf.d/




Ако знаете за какво става дума ви моля за помощ :(  :12;
Контакти:  mavpa
WEB  
Мнение #2
Skip to the previous post in this topic. Написано на: Март 13 2008, 17:49

No avatar chosen




Група: Li gurus
Мнения: 1489
Регистриран: Април 2005

Оценка: 5

Offline
как точно го махна ?
Контакти:  mcwolf

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Общо 1 отговор(а) от Февруари 23 2008, 13:44 до сега
 » Начало » Li Форуми » Help & Support » Servers & Services » Mysql проблем

© 2014 Linux Index Project
Powered by iF 1.0.0 © 2006 ikonForums