Запомняне

» Здравейте
[ Вход :: Регистриране ]
 » Начало » Li Форуми » Help & Support » Servers & Services » Проблем с апаче и пхп5
Тема: Проблем с апаче и пхп5
Мнение #1 Skip to the next post in this topic.
Написано на: Декември 30 2008, 10:53

No avatar chosen




Група: Li fans
Мнения: 23
Регистриран: Юли 2008

Оценка: няма

Offline
Здравейте.
След многобройните ми опити да направя ... и аз не знам какво точно ... се получи следния гаф. От нищото (е предполагам си има логично обяснение  :14; ) се появиха едни проблеми в стандартния изход на апт-гет.
Това е изхода на apt-get upgrade изпълнена от root:
Код: 

root@server:/etc/apache2# apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages have been kept back:
 libsasl2 libsasl2-modules-sql
0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.
11 not fully installed or removed.
After this operation, 0B of additional disk space will be used.
Do you want to continue [Y/n]?

това ме пита всеки път без значение дали давам Y или N
след това:
Код: 

Setting up libapache2-mod-php5 (5.2.4-2ubuntu5.4) ...
dpkg: error processing libapache2-mod-php5 (--configure):
subprocess post-installation ****** returned error exit status 10
Setting up php5-cli (5.2.4-2ubuntu5.4) ...
dpkg: error processing php5-cli (--configure):
subprocess post-installation ****** returned error exit status 10
dpkg: dependency problems prevent configuration of php-pear:
php-pear depends on php5-cli | php4-cli; however:
 Package php5-cli is not configured yet.
 Package php4-cli is not installed.
dpkg: error processing php-pear (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of php5:
php5 depends on libapache2-mod-php5 (>= 5.2.4-2ubuntu5.4) | php5-cgi (>= 5.2.4-2ubuntu5.4); however:
 Package libapache2-mod-php5 is not configured yet.
 Package php5-cgi is not installed.
dpkg: error processing php5 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of php5-curl:
php5-curl depends on phpapi-20060613; however:
 Package phpapi-20060613 is not installed.
 Package libapache2-mod-php5 which provides phpapi-20060613 is not configured yet.
 Package php5-cli which provides phpapi-20060613 is not configured yet.
 Package php5-cgi which provides phpapi-20060613 is not installed.
dpkg: error processing php5-curl (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of php5-gd:
php5-gd depends on phpapi-20060613; however:
 Package phpapi-20060613 is not installed.
 Package libapache2-mod-php5 which provides phpapi-20060613 is not configured yet.
 Package php5-cli which provides phpapi-20060613 is not configured yet.
 Package php5-cgi which provides phpapi-20060613 is not installed.
dpkg: error processing php5-gd (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of php5-imap:
php5-imap depends on phpapi-20060613; however:
 Package phpapi-20060613 is not installed.
 Package libapache2-mod-php5 which provides phpapi-20060613 is not configured yet.
 Package php5-cli which provides phpapi-20060613 is not configured yet.
 Package php5-cgi which provides phpapi-20060613 is not installed.
dpkg: error processing php5-imap (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of php5-ldap:
php5-ldap depends on phpapi-20060613; however:
 Package phpapi-20060613 is not installed.
 Package libapache2-mod-php5 which provides phpapi-20060613 is not configured yet.
 Package php5-cli which provides phpapi-20060613 is not configured yet.
 Package php5-cgi which provides phpapi-20060613 is not installed.
dpkg: error processing php5-ldap (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of php5-mcrypt:
php5-mcrypt depends on phpapi-20060613; however:
 Package phpapi-20060613 is not installed.
 Package libapache2-mod-php5 which provides phpapi-20060613 is not configured yet.
 Package php5-cli which provides phpapi-20060613 is not configured yet.
 Package php5-cgi which provides phpapi-20060613 is not installed.
dpkg: error processing php5-mcrypt (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of php5-mhash:
php5-mhash depends on phpapi-20060613; however:
 Package phpapi-20060613 is not installed.
 Package libapache2-mod-php5 which provides phpapi-20060613 is not configured yet.
 Package php5-cli which provides phpapi-20060613 is not configured yet.
 Package php5-cgi which provides phpapi-20060613 is not installed.
dpkg: error processing php5-mhash (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of php5-pspell:
php5-pspell depends on phpapi-20060613; however:
 Package phpapi-20060613 is not installed.
 Package libapache2-mod-php5 which provides phpapi-20060613 is not configured yet.
 Package php5-cli which provides phpapi-20060613 is not configured yet.
 Package php5-cgi which provides phpapi-20060613 is not installed.
dpkg: error processing php5-pspell (--configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
libapache2-mod-php5
php5-cli
php-pear
php5
php5-curl
php5-gd
php5-imap
php5-ldap
php5-mcrypt
php5-mhash
php5-pspell
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@server:/etc/apache2#


Проблема е, че не мога да накарам апаче да отваря php файлове а като направя заявка към някой .php файл браузера се опитва да го запази, а не да го изпълни.
Добавил съм DirectoryIndex bla, bla, index.php, bla

Моля за помощ, че след малко ще прецакам сигурно и апачето :)

А някой да ми предложи готова сглобена и най-вече сигурна (доколкото може да бъде) LAMP конфигурация? Защото се оказа, че това нещо е по-силно от мене...

Благодаря предварително за помоща и весели празници.


Н. Христов


Edit - използвам Ubuntu 8.10, Apache2 и трябва да използвам php5.

Редактирано от nedko на Декември 30 2008, 11:50
Контакти:  nedko

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Мнение #2
Skip to the previous post in this topic. Написано на: Декември 30 2008, 14:36

No avatar chosen




Група: Li fans
Мнения: 23
Регистриран: Юли 2008

Оценка: няма

Offline
Че съм кух :)

Проблема е бил, че в sources.list съм нашибал стари хранилища. С много четене и още повече нерви и се оправих :)

Благодаря все пак.
Контакти:  nedko

  • AOL  AOL:
  • ICQ  ICQ:
  • MSN  MSN:
  • YIM  Yahoo IM:
WEB  
Общо 1 отговор(а) от Декември 30 2008, 10:53 до сега
 » Начало » Li Форуми » Help & Support » Servers & Services » Проблем с апаче и пхп5

© 2014 Linux Index Project
Powered by iF 1.0.0 © 2006 ikonForums